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日本語訳版まえがき  
 

Ocean Data View (ODV) は、様々な海洋データを簡単に解析・可視化できるソフトウェアで、 アルフレッ

ド・ヴェゲナー極域海洋研究所 (AWI) から無償で公開されています。 

ODV ユ ー ザ ー ズ マ ニ ュ ア ル 日 本 語 訳 版 は 作 者 の 了 解 を 得 て 、 日 本 海 洋 デ ー タ セ ン タ ー (Japan 

Oceanographic Data Center; JODC)が翻訳を、 (一財)日本水路協会海洋情報研究センター(Marine 

Information Research Center; MIRC)が監修を担当いたしました。 

 

本ユーザーズガイドが皆様にお役立ていただければ幸いです。  

 

ウィンドウやダイアログボックスのタイトルや項目名などは原文のまま表記しています。 

 

メインメニューやポップアップメニューなどに表示される選択可能なメニューはイタリック体で表記して い

ます。  

 

Ocean Data View に関するオフィシャルサイト 

 http://odv.awi.de/  

 

日本語訳版に関するお問い合わせ先  

日本海洋データセンター  
〒100-8932 東京都千代田区霞が関 3-1-1  

  https://www1.kaiho.mlit.go.jp/JODC/SODAN/annai.html 

     

海洋情報研究センター  
〒140-0001 東京都品川区北品川 4-7-35 御殿山トラストタワー16F 一般財団法人日本水路協会  
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使用許諾契約 (License Agreement) 
ODV を使用する前に使用許諾契約書をお読みください（訳注：原文では別文書ですが日本語訳版では以下に

記載します）。 

 

Ocean Data View 使用許諾契約（Ocean Data View License Agreement） 
Ocean Data View (ODV)のダウンロードおよび／または使用によって、あなたはアルフレッド・ヴェゲナー極地海洋研

究所ヘルムホルツセンター(AWI) との間に次の法的な合意に従うことに同意したことになります。この合意項目に同意

できない場合は、本ソフトウェアをダウンロードおよび／または使用しないでください。 

 

1.科学および教育での利用（SCIENTIFIC USE AND TEACHING） 

Ocean Data View は非商用、非軍事研究、および教育目的の場合に無償で使用することができます。科学的な作業で本

ソフトウェアを使用する場合、あなたの出版物において Ocean Data View を次のように引用してください： 
Schlitzer, Reiner, Ocean Data View, https://odv.awi.de, 2024. 

 

2.商用利用（COMMERCIAL USE） 

商用または製品のために、Ocean Data View またはその如何なる部分をも使用する場合には、特別な書面のソフトウェ

ア・ライセンスが必要です。詳細は下記のアドレスにお問い合わせください。 

そういった意味で出版社は非商用ユーザーなので、例えば受理した原稿の図といった執筆者が作成した ODV アイテムの

複製／出版のためにライセンスを購入する必要はありません。 

 

3. 軍事利用（MILITARY USE） 
AWI は、その活動を民間の目的に集中させています。 軍事目的に Ocean Data View ソフトウェアのライセンスを付与

するのは、ケースバイケースの評価判断を受けた場合のみです。 詳細は下記のアドレスにお問い合わせください。 

 

4. 再配布 (REDISTRIBUTION) 
CD-ROM、DVD または他の電子媒体またはインターネットによる Ocean Data View の再配布には、AWI による事前の

書面での許可が必要です。詳細は下記のアドレスにお問い合わせください。 

 

5. 保証の放棄 (WARRANTY DISCLAIMER) 
ODV ソフトウェアは、明示の如何にかかわらず、いかなる種類の保証なしにあるがまま提供されるものです。商用利用

や特定目的に関する利用の適合性に関する暗黙の保証もありません。ソフトウェアの品質や性能に関する全てのリスクは、

利用者が負うものであり、ソフトウェアに欠陥があった場合、全ての必要なサービス、復旧あるいは修正にかかる費用は、

利用者の負担となります。 

AWI, ODV の協力者ならびにその著作権保有者のいずれも、利用者に対し、あらゆる直接的、間接的、一般的、特殊的、

典型的、偶発的あるいは必然的な損害がどのように生じたとしても、また、ソフトウェアの利用による、あるいは利用で

きないことによる責任（データあるいは誤って提出されたデータの損失、利用者あるいは第三者が被った損失、他のソフ
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トウェアと同時に利用したために生じたソフトウェアの被害や営業の中断を含み、尚且つそれだけに留まらない損失）を

一切負いません。 

 
Alfred Wegener Institute, Am Handelshafen 12, 27570 Bremenhaven, Germany, 
E-Mail: odv_license at awi.de 
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1 概要（General Overview） 
Ocean Data View(ODV)は、海洋学および他のジオリファレンスを与えられた(空間的位置情報が付加され

た)プロファイル、軌跡、時系列データを対話的に探究しグラフ化するアプリケーションソフトウェアです。

このソフトウェアは、Windows、macOS、Linux、および UNIX システムで使用できます。 ODV データと

設定ファイルはプラットフォームに依存せず、サポートされている全てのシステム間で交換することができ

ます。ODV を使用すると、安価でポータブルなハードウェア上で非常に大きなデータセットを保存し分析す

ることができます。高品質な測点図、一つ以上の測点の一般的な成分間プロット、選択された測点の散布図、

任意の航跡に沿った鉛直断面図、一般的な等値面上の成分分布など、さまざまな種類のグラフィックス出力

を簡単に作成する事が出来ます。 
 
ODV はオリジナルのスカラーデータやベクトルデータをカラー点、数値データ、または矢符で表示すること

ができます。さらに、自動的に生成される格子上での推定値を提供し、断面に沿った、あるいは等値面上の

カラー彩色および等値線を描画するための、三つの異なる格子化アルゴリズムがあります。多くの派生量を

ソフトウェア実行中に計算できます。これらの変数は、ディスクに保存されている基本変数と同じ方法で表

示および分析する事ができます。 
 
ODV 4 はオブジェクト指向の C ++ソフトウェアコードに基づいており、以前の ODV バージョンの多くの

制限を克服しました。下位互換性を確保するため、ODV は ODV3 で作成された既存のデータコレクション

と構成ファイル（現在ではビューと呼ばれる）をサポートし続けています。ただし、新しく作成される全て

のコレクションでは、新しい一般的なデータモデルと内部記憶フォーマットが使用されるようになっていま

す。以前のように、ODV データコレクションはプラットフォームへの非依存性を維持しているので、サポー

トされるシステム間で移動することができます。新しいデータモデルの新機能には、より柔軟なメタデー

タ・スキーム、無制限の数のデータ変数のサポート、ユーザー指定のデータタイプ、メタデータとデータ変

数のための特別な品質フラグスキームがあります。 
 
1.1 使いやすさ（Ease of Use） 
ODV は柔軟性に富んで使いやすく設計されています。ユーザーは内部のデータ記憶フォーマットの詳細を知

る必要がなく、プログラミングの経験も不要です。ODV は利用可能な測点分布図を常に画面上に表示するの

で、ユーザーはマウスで測点、サンプル、断面、等値面を選んで簡単にデータを操作できます。測点図と

ODV 描画キャンバスのデータウィンドウのレイアウトは、他の多くのビュー設定と同様に容易に修正でき、

後で使用するために好みの設定をビューファイルの中に記憶できます。 

ODV は比較的安価でポータブルなハードウェア上で何百万もの測点を含む非常に大きなデータコレクション

を処理することができ、新しいデータが利用可能になると既存のデータコレクションを拡張することができ

ます。ODV の広範囲なプロットの種類と柔軟な対話的制御によりデータの品質管理がとても容易になり、訓

練や教育にも役立ちます。 
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1.2 高密度データフォーマット（Dense Data Format） 
ODV データフォーマットは、可変長で不等間隔なプロファイル、軌跡、および時系列データを最適化します。

非常に大きなデータコレクションであっても、高密度記憶を提供し、任意の測点のデータへの即時アクセス

を可能にします。データフォーマットは柔軟性があり、測点数、サンプル数、変数の数は事実上無制限です。

ODV コレクションのメタデータおよびデータ変数のリストは、コレクション作成時にユーザーによって定義

されます。プロファイル、軌跡、または時系列の様に非常に異なるデータタイプのデータを格納するために、

異なる ODV コレクションが作成されます。 

 

ODV はまた、実際のデータ値に加えて全ての個々の値について品質フラグを維持します。これらの品質フラ

グは、例えば不良または疑わしいデータを解析から除外するときのデータ品質フィルタリングに使用されま

す。数値および品質フラグは編集および変更することができます。全ての変更は記録されるので、必要に応

じて意図しない変更を元に戻すことが可能になります。 

 

1.3 拡張性 (Extensibility) 
ODV はコレクションへの新しいデータのインポートおよびコレクションからデータのエクスポートも容易で

す。広く使用されている以下のフォーマットの海洋データを ODV システムに直接読み込むことができます： 

• ASCII スプレッドシート・データ 

• Argo プロファイルと軌跡データ 

• GTSPP データ 

• SeaDataNet データ 

• Sea-Bird データ(.cnv format)  

• WOCE と CLIVAR の WHP 交換フォーマットによるデータ 

• World Ocean Database データ 

 

1.4 派生変数（Derived Variables） 
データファイルに格納された基本的な測定変数に加えて、ODV は多数の派生変数を計算して表示することが

できます。これらの派生変数のアルゴリズムは、ODV ソフトウェアにコード化されているか(ポテンシャル

水温、ポテンシャル密度、力学高度(いずれも基準層は任意)、中立密度、Brunt-Väisälä Frequency (ブラ

ントーバイサラ振動数)、音速、酸素飽和度、他多数)、もしくはユーザーのマクロファイルまたは数式で定

義されます。新しい派生変量に数式やマクロファイルが使えることによって ODV の適用範囲は一層広がり、
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科学分野では未だ確立されていない新しい数量に関する実験が容易に行えます。ODV にはマクロエディタが

組み込まれているので、ODV マクロの作成および修正は簡単にできます。 
 
1.5 プロットの種類 (Plot Types) 
任意の基本変数または派生変数を一つまたは複数のデータウィンドウに表示することができます。 さらに、

任意の変数を使用して等深面、等密度面、等温面、または等塩分面などの様な等値面を定義することができ

ます。例えば中層水における塩分極小層のような、ある成分の極小もしくは極大層は、その成分の鉛直微分

がゼロの等値面として選択することができます。 

 

ODV はデータを次の二つの基本的な方法：（1）データの位置にオリジナルデータをユーザー定義サイズの

カラー点（図 1-1a 参照）、数値、または矢符（図 1-2 参照）で；または（2）オリジナルデータを等距離ま

たは可変解像度の矩形格子の格子領域に投影して表示します（図 1-1b 参照）。方法１は最も基本的で、デ

ータの「ありのまま」の分布を瞬時に描くので、不良データやサンプリングが粗な領域を明らかにできます。

これに対して方法２は見た目が「美しく」、方法１で見られるようなカラーの、特にサイズの大きな点が重

なりあう状態を回避することができます。ただし方法 2 の格子領域は、実際には加工されたデータを表わし

ているので、格子化の結果としてデータの小規模スケールまたは顕著な特徴が変更または失われる可能性が

あることに注意してください。どちらの表示モードでも ODV はウィンドウデータと格子領域を ASCII ファ

イルまたはクリップボードにエクスポートできるので、ODV を離れて事後利用できます。 

 

スカラー成分フィールドに加えて、ODV は X および Y ベクトル成分を別個の変数として提供するデータセ

ットのベクトル場の表示もサポートしています。(図 1-2 参照)。 

 

 
図 1-1：(a)カラー点および(b)格子領域として表示されるデータ 

 

1.6 ウィンドウスコープ（Window Scopes） 
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ODV アプリケーションウィンドウは、常に利用可能な測点のマップを表示します。さらに、ユーザーは実デ

ータの表示のために無制限の数の他のウィンドウを定義することが出来ます。これら各々のデータウィンド

ウは、次の画面のうちの一つを有することができます： STATION、SCATTER、SECTION、SURFACE。各

ウィンドウは独自の画面を有し、異なるデータウィンドウの画面には違いがあります。 

 

図 1-2：歴史的風応力場の矢符プロット 

 
1.6.1 STATIONスコープ（STATION Scope） 

STATION スコープウィンドウ(図 1-3 参照)は、マップのピックリスト内にある測点のデータのみを示す

X/Y プロットを提供します。+ (プラス)ボタンを押すと現在の測点をピックリストに追加するでき、- (マイ

ナス)ボタンを押すと削除できます。マップポップアップメニューの Manage Pick List > Edit Pick List オプショ

ンを使用して測点ピックリストの編集が出来ます。とりわけ、これによって個々の選んだ測点ごとにグラフ

ィックススタイルを調整することが可能になります。他の全てのデータウィンドウのタイプに関して、

STATION ウィンドウでは、X 軸と Y 軸に任意の(基本または派生)データ変数を割り当てることができます。

識別を容易にするために、選んだ測点はデータウィンドウと同じ記号および色を用いてマップ内に印づけら

れます。マップの注釈スイッチが on になっていれば、選んだ測点の位置に測点ラベルとともに表示されます。 

 

1.6.2 SCATTERスコープ（SCATTER Scope） 
SCATTER スコープウィンドウ（図 1-4 を参照）は、マップに現在表示されている全ての測点のデータを表

示するので、潜在的に非常に大きなデータセットの概要を表します。SCATTER ウィンドウは、特にデータ

品質管理に役立ちます。以降の全てのスコープと同様に、SCATTER ウィンドウでは X と Y の変数に加えて

Z 変数がサポートされています。Z 変数の値は、指定された X/Y データ位置に描画される色を決定します。Z 

変数のプロットには（SECTION モードおよび SURFACE モードと同様に)次の二つの方法：(1) X/Y の位置
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にカラー点または実際のデータ値を表示(初期設定)、または(2)観測データに基づいて推定した連続的な格子

領域として表示します。格子領域にはカラーの陰影や等値線で描画できます。 

 

SCATTER ウィンドウは、データ点の制限を超えたらデータを読み込まないことに注意してください。既定

の最大データ数は 250,000,000 ですが、General Settings ダイアログの View > Data Count Limit ページで増減

できます。 

 
 

 
図 1-3：STATIONスコープを使用した正射図および六つのデータウィンドウによるウィンドウレ

イアウト例。測点ピックリストは識別を容易にするためにマップ内に印付けられる。 
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図 1-4：SCATTERスコープを使用した二つのデータウィンドウでのウィンドウレイアウト例。一測

点のデータは、記号セット・グラフィックスオブジェクトを使用して強調表示されていま

す。 

 

1.6.3 SECTIONスコープ（SECTION Scope） 
SECTION スコープウィンドウ（図 1-5 を参照）は、地図に現在定義されている断面に属する全ての測点、

例えば赤い断面帯の内側にある全測点のデータを表示します。断面図はマップポップアップメニューの

Manage Section オプションを使用して定義または変更します。 SECTION ウィンドウはまた、Z 変数とオ

リジナルデータまたは格子領域の表示もサポートしています。SECTION ウィンドウは、航跡に沿った成分分

布や所定の軌道に沿った調査の測点に関する成分間プロットの表示をするのに最も有用なウィンドウです。 
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図 1-5：二つの SECTIONスコープ（1と 2）と一つの SCATTERデータウィンドウ（3）のウィンド

ウレイアウト例。 SCATTERウィンドウ 3はマップ内の全測点の全データを表示しているのに対し、

SECTIONウィンドウ 1と 2は断面帯内の測点データのみを表示している。 

 

1.6.4 SURFACEスコープ（SURFACE Scope） 
ODV はメタデータとデータ変数に加えて、第三の変数セット isosurface variables（等値面変数）を定義でき

ます。 等値面変数は特定の等値面上の所定のデータ変数の値（例えば図 1-6 の水温または深度）を提供しま

す。等値面は一定の深度または密度の層のような別のデータ変数が一定値である層です。 

 

SURFACE スコープウィンドウはマップ内の全ての測点の等値面の値を表示します。SURFACE ウィンドウは

X, Y, Z の等値面変数をサポートしています。 経度と緯度が等値面変数として X 軸と Y 軸に割り当てられて

いる場合、ウィンドウは選択された Z 変数を表示するマップになります（図 1-6 を参照）。このようなマッ

プデータウィンドウは、測点図の投影法およびレイヤー設定を使用します。SURFACE データウィンドウの

X 軸と Y 軸に他の等値面変数を割り当てることもできるので、Z 変数として別の等値面変数を使用して色付

けすることにより、一般的な等値面変数の相関プロットになります。 
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図 1-6：等値面上の成分分布を示す SURFACEスコープの二つのデータウィンドウのレイアウト例 

 
 
1.7 グラフィックスの出力（Graphics Output） 
メインメニューのオプションの File > Save Canvas As を使用してキャンバス、マップ、および個々のデータウ

ィンドウのイメージファイルを gif, png, jpg,および tif で作ることが出来ます。または、キャンバス、マップお

よびデータウィンドウの各々の Save Canvas As, Save Map As, Save Plot As コンテキストメニューオプションも

使用できます。あるいは、キャンバス、マップまたはデータウィンドウ上にマウスを移動させて Ctrl-S ショ

ートカットキーを押すとこれらと同じオプションが即座に起動されます。 

 

ファイル保存ダイアログが表示されますので、ターゲットイメージのパス、ファイル名、タイプを指定して

ください。続いて Image Properties ダイアログでイメージの解像度を指定し、display style では normal か

pure を、背景では透明か不透明かを選んでください。 

 

 
図 1-7: Image properties ダイアログ 

 

GeoTIFF 

Tiff イメージフォーマットを選ぶと測点図もしくはいずれかのマップデータウィンドウの座標系が定義され

た GeoTIFF イメージが作成されます。これらの GeoTIFF イメージは GIS のレイヤーとして使うことができ

ます。最良の結果を得るには、display style で pure を選択し（軸ラベル、カラーバーまたはグラフィックオ
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ブジェクトは描画せず）、Transparent background ボックスをチェックしてください。以下に GIS アプリケ

ーションでの表示例を示します。 

 

 
図 1-8: σ0=27.0の等密度面の等深線および色付けされた同じ等密度面上でのリン酸塩濃度の GISでの表示

例 

断裂投影図（Interrupted Maps） 

測点図およびマップデータウィンドウ（X 軸と Y 軸が経度と緯度のデータウィンドウ）のコンテキストメニ

ューには Save As Interrupted Map オプションがあります。Interrupted Map Properties ダイアログでは、タ

イトル、著作権表示、および北極および南極のサブウィンドウを含むかどうか、といったプロパティを指定

します。彩色および等値線のプロパティは親ウィンドウから引き継がれます。 
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図 1-9: 断裂投影図法で表示された 500ｍ深の酸素分布。断裂投影図はプロットコンテキストメニューの

"Save As Interrupted Map"を介して作成される。 

 

1.8 データ統計（Data Statistics） 
データウィンドウ内の X, Y, Z データ、またはマップ内の測点の位置と日付/時刻メタデータの統計情報は、

マウスがそれぞれのデータウィンドウまたはマップ上にあるときに F4 キーを押すと簡単に得られます。平均

値、標準偏差、データ点数は X, Y, Z 変数の各々の最小値と最大値と同様にダイアログに表示されます。加

えて X, Y, Z データの柱状グラフは X/Y データ分布図と同様に単純にボタンをクリックするだけで得られま

す。マップについては時間または季節(訳注: 1 月 1 日からの経過日)に対する測点数の柱状グラフも得られま

す。 

 

1.9 推定と平均化（Estimation and Averaging） 
ODV は任意の緯度-経度-深度における基本変数もしくは派生変数の値の推定に使えます(3D estimation (三

次元推定))。三次元推定には高速加重平均処理が実装されていて、ユーザーが指定した経度、緯度、深度の

平均の長さスケールおよびその時点で有効な測点とサンプルとのセットが使用されます。推定の座標は

ASCII ファイルで提供されます。これらの点は不規則に配置されているか、あるいは均一または不均一な矩

形または曲線状の格子上にあります。メインメニューから Tools > 3D Estimation を選択して三次元推定を呼

び出します。 
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Z 変数を持つデータウィンドウの場合、別の方法である二次元推定を使用して、任意の X/Y 点の Z 値を推定

することができます。三次元推定の場合、X/Y 座標は ASCII ファイルで提供されます。これらの点は不規則

に配置されているか、あるいは均一または不均一な矩形または曲線状の格子上にあります。 各々のデータウ

ィンドウのポップアップメニューから Extras > 2D Estimation を選択して二次元推定を呼び出します。 

 
第三の推定方法である一次元推定は、X 軸または Y 軸のどちらか一方に主要変数を持つデータプロットに対

して使用できます。このオプションは，プロット中のデータ点に適用した最上自乗推定を用いて基本変数の

指定した値に対する他の変数を推定します。ユーザーが指定する座標は（一行につき一座標の）ASCII ファ

イルで与えるか、一次元等距離グリッドとして対話的に指定できます。推定結果は ASCII ファイルに書き込

まれます。1D Estimation オプションを使用すると、例えばコレクションに格納されている変数の標準層

（圧力）プロファイルが得られます。それぞれのデータプロットポップアップメニューから Extras > 1D 

Estimation を選択して一次元推定を呼び出します。 

 

上述した様々な推定方法に加えて、ODV はユーザー指定の緯度／経度／深度ボックス内の平均と標準偏差を

計算できます。指定されたボックス内のその時点で有効な全てのサンプルが計算に使用されます。 
 

1.10 NetCDF サポート（NetCDF Support）  
ネイティブな ODV データコレクションに加えて、ODV はモデル出力のようなグリッドデータのプラットフ

ォーム非依存保管に広く使われている、ローカルまたはリモート netCDF ファイルにアクセスしてデータを

可視化することもできます。ODV は netCDF ファイルの中の重要な次元数と変数を四段階の netCDF セット

アップウィザードを介してユーザーに問い合わせます。それによって netCDF ファイルの内容は netCDF フ

ァイルがネイティブの ODV コレクションであるかのようにユーザーに提示されます。全ての ODV 解析およ

び可視化オプションは、netCDF ファイル内のデータの探索に使用できます。 NetCDF ファイルはプラット

フォーム非依存なので、全ての ODV 対応システムで使用できます。 
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2 ファースト・ステップ（First Steps） 
2.1 Ocean Data Viewのインストール（Installing Ocean Data View） 
ソフトウェアを使用する前に、コンピュータに ODV をインストールする必要があります。Windows, 

macOS, お よ び Linux 用 の 最 新 の ODV イ ン ス ト ー ル フ ァ イ ル は 、

https://odv.awi.de/ja/software/download/からダウンロードできます。 ダウンロードページにアクセス

するには個人ログインデータを登録して使用する必要があります。詳しいインストール手順は INSTALL.txt

ファイルで提供されています。ODV 使用規則の使用許諾契約書を参照してください。 
 
サポートされるプラットフォーム：ODV は以下のプラットフォームで動作します：Windows（全てのバー

ジョン）;  macOS 10.5 以降; カーネルバージョン 2.6.15 以降で 2006 年 6 月以降にリリースされた

Linux 配布パッケージ。ODV は Debian 8, 11 および 12, Ubuntu 18.0.4, 20.04 および 22.0.4, および

CentOS 7 上で動作確認されています。 

 

ユーザーのドキュメントディレクトリ内のサブディレクトリ ODV は ODV ユーザーディレクトリとして機能

します。 このディレクトリは ODV のインストール時に自動的に作成され、マップリソースのみならずパレ

ット、マクロ、地名辞典、コマンド、またはグラフィックスオブジェクトファイルが、インストールパッケ

ージからこのディレクトリにコピーされます。ユーザーは、これらのファイルのカスタマイズバージョンを

ODV ユーザーディレクトリに作成することができます。 ここで重要なことは、カスタマイズしたファイル

を新しい名前で保存することです。 さもなければ、変更されたバージョンは次の新しい ODV ソフトウェア

バージョンがインストールされたときに上書きされて失われます。ユーザーディレクトリの絶対パスのみな

らず他の ODV インストール設定は Help > About ODV またはmacOS では odv > About odv で取得できます。 
 
補足的な高解像度の海岸線と地形のパッケージは View > Settings（macOS では ODV > Preferences）オプショ

ンを使用してインストールできます。 詳細は 2.12 節以降を参照してください。 

 

ODV ユーザーディレクトリは View > Settings > System > User Directory でシステムディスク上の別の場所に移

動できます。 パフォーマンス上の理由からユーザーディレクトリをネットワークドライブには移動しないで

ください。 

 
2.2 Ocean Data Viewの起動（Running Ocean Data View） 
ODV がシステムにインストールされると、さまざまな方法でソフトウェアを起動できます。 

 

https://odv.awi.de/ja/software/download/
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Windows では、インストール手順によってデスクトップ上に ODV アイコンが作成され、.odv および.var コ

レクションファイルタイプが ODV アプリケーションに自動的に関連付けられます。 ODV を起動するに

は、.odv または.var ファイルをダブルクリックするか、ODV デスクトップアイコンをダブルクリックします。 
 
ODV でサポートされているファイルを ODV アイコンにドラッグ・アンド・ドロップすることもできます。 

これにより ODV が起動してドロップされたファイルが開きます。すでに ODV が実行されている場合は、任

意の ODV サポートファイルを ODV ウィンドウにドラッグ・アンド・ドロップしてこのファイルを開くこと

ができます。 サポートされているファイルタイプには、ODV コレクション（.odv および.var）、netCDF フ

ァイル（* .nc、*. cdf）および ODV スプレッドシートファイル（.txt）があります。 
 
macOS、Linux、およびUNIXシステムでは、オペレーティングシステム固有のメソッドを使用してODV実

行可能ファイルodvまたはODV起動スクリプトファイルrun_odvのエイリアスまたはアイコンを作成できます。

ODV実行可能ファイルodvは、ODVをインストールしたbin_...ディレクトリにあります（例えばmacOS Xでは

bin_macx、Linuxシステムではbin_linux-i386など）。 デスクトップまたはタスクバー/ドックアイコンが作成

されたら、ODVアイコンをダブルクリックするかシングルクリックしてODVを起動できます。 ほとんどのシ

ステムではODVコレクション.odvおよび.varファイル、netCDFファイル、またはサポートされているデータ

インポートファイルをODVアイコンにドラッグ・アンド・ドロップすることもできます。 
 
ODV は DOS ボックスやターミナルウィンドウからパス名を伴った実行可能ファイルと（オプションの）引

数を共に入力して起動することもできます。 いくつかのシステムでは、スクリプトファイル run_odv を使用

してコマンドラインから ODV を起動できます。 コマンドラインから ODV を起動すると以下の引数がサポー

トされます。ファイルとパス名に空白が含まれる場合には、それらを引用符""で囲む必要があることに注意

してください。 

 

コマンドラインから ODV を起動する方法は二つあります： 
odv file [-access accessMode] [-view view_file] [-setting_file settings_file] 
または 
odv -x cmd_file [-q]  
 
最初のケースでは、アクセスモード accessMode を使用して ODV コレクション（.odv または..var コレクショ

ンファイル）または netCDF .nc または.cdf ファイルを開き（可能な値は ReadOnly または ReadWrite で、デ

フォルトは ReadWrite）、ビューファイル view_file からビューを読み込みます。-access および-view 引数はオ

プションです。 

 

View_file は.xview または.cfg ファイルパス、あるいは$FullScreenMap$または$TowPickWin$のようなテンプレ

ートビュー指示子となります(注：Windows PowerShell では`$FullScreenMap`$のように“`” (バッククォー

ト ) エ ス ケ ー プ キ ャ ラ ク タ ー を ビ ュ ー 指 示 子 の 前 に 入 れ る 必 要 が あ り 、 Linux や macOS で は 
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\$FullScreenMap\$ の様に\(バックスラッシュ)をエスケープキャラクターとして使用します。) もし

view_file が空もしくはファイルが存在しない場合は親コレクションの最後のビューファイルが読み込まれま

す。 

 

ODV バイナリディレクトリが環境変数 PATH にない場合、例えば Windows の場合は"c:¥Program 

Files¥Ocean Data View¥bin_w64¥odv"、 macOS の場合は"/Applications/Ocean Data View"のように

ODV 実行可能ファイルを絶対パス名で指定しなければなりません。 file は絶対パス名またはカレントディレ

クトリからの相対パスでなければなりません。view_file は絶対パス名または file を含むディレクトリからの相

対パスでなければなりません。 

 

Setting_file オプションで代わりの ODV アプリケーション設定ファイルを指定します。このオプションは内容

を理解できるユーザーのみ使用してください。 
 
上の二番目のコマンドラインは、ODV コマンドファイル cmd_file を開いてファイルに含まれるコマンドを実

行します。 オプション引数-q が指定されていれば、全てのコマンドが処理された後に ODV は自動的にシャ

ットダウンします。 cmd_file は絶対パス名または現在のディレクトリからの相対パスでなければなりません。 
 
ODV が起動したら、File > Open オプションを使用してデータコレクション、netCDF ファイル、またはサポ

ートされている任意のインポートデータファイルを開きます。標準の「ファイルを開く」ダイアログが表示

され、開きたいファイルの種類とファイル名を選択できます。サポートされているインポートデータファイ

ルを開くと、選択したファイルのディレクトリに新しいコレクションが自動的に作成され、ファイルからデ

ータがインポートされ、新しく作成されたデータコレクションが開きます。 
 
コレクションを開いた後、ODV はコレクションの最新のビュー設定を読み込むことに注意してください。 

これらのビュー設定には、測点およびサンプル選択フィルタが含まれています。指定したフィルタ設定に依

存して、コレクション内の測点とデータ値のサブセットのみがマップおよびデータウィンドウに表示されま

す。View > Station Filter > Rleax を使用して測点フィルタの設定を解除し，View > Station Filter > Customize を

使用して測点フィルタの設定を変更してください。 
 
ビューバーの「+」(plus）ボタンを右クリックするか、View > Load Views を使用して、以前に保存した他の

ビューを読み込むことができます。View > Layout あるいはキャンバス、マップおよびデータウィンドウのコ

ンテキストメニューにある Layout オプションを介してウィンドウレイアウトを変更できます。View > 

Layout Templates  > ...を介して、定義済みのレイアウトテンプレートのいずれかを読み込めます。View メニ

ューオプション、あるいはキャンバス領域、マップ、またはデータウィンドウの一つの上で右クリックする

と表示される context-specific ポップアップメニューを使用して、さまざまなビュー設定を対話形式に変更

できます。 

Suzuki Toru
以前はフルパス=絶対パスでしたが，昨今では区別する場合もあるようですので，「絶対」パスとしました。
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2.3 ヘルプの取得（Getting Help） 
F1 キーを押すか、Help > User’s Guide オプションを使用すると、ODV ユーザーズガイド（本書）が開きます。

ユーザーズガイドの pdf 版は ODV のウェブサイトから入手できます。多くの ODV ダイアログで help ボタ

ンを押すと、状況依存ヘルプが提供されます。これは View > Settings > Program Locations（macOS の場

合：odv > Preferences > Program Locations）で指定された Web ブラウザが起動し、ブラウザはユーザーズガ

イドの特定の章にジャンプします。Windows の状況依存ヘルプは Chrome と Firefox で最も効果的です。 

macOS および一部の Linux システムでは、ODV 状況依存ヘルプが表示される前に実行中の web ブラウザ

を閉じる必要があります。 

 

2.4 アプリケーションウィンドウ（Application Window） 
ODV アプリケーションウィンドウは次の要素で構成されています（図 2-1 を参照）： 

Menu Bar: メニューバーからメインメニューにアクセスできます。 

Views Bar: ビューバーには、開いているビューごとにクリック可能なタブと、（1）さらにビューを開く

（「＋」(plus)ボタン）、（2）ビューを元に戻す/やり直す（history ボタン）、（3）変更ビュー

を保存する（save ボタン）のセットがあります。 

Canvas: グラフィックスキャンバスはマップ（常に表示されます）と無制限のデータウィンドウを含みます。 

キャンバス、マップ、およびデータウィンドウは、注釈テキスト、記号、またはユーザー定義図形

といった、無制限の数のグラフィックスオブジェクトを含みます。 
Status Bar: 別々の区画で（1）ステータス情報、（2）現在のマウス位置の座標または進行状況バー、（3）

現在選択されている測点数、コレクション内の測点の総数、および現在のビューの名前等を提供し

ます。 

Current Station Window: 現在の測点のメタデータ値（マップ上に赤い十字印で示されます）。 

Current Sample Window: 現在のサンプルのデータ値と品質フラグ（データウィンドウ上に赤い十字印で示さ

れます）。現在のサンプルフィルタ設定を満足するデータのみが示されます。 

Isosurface Data Window: 現在の測点の等値面の値。 

Suzuki Toru
原文にピリオドはありませんが，おそらく忘れたものと思われます。
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図 2-1：ODVアプリケーションウィンドウの要素 

 

ビューバーには、それぞれの開いているビューにクリック可能なタブと次のボタンのセットがあります：（1）

さらにビューを開く（「＋」(plus)ボタン）、（2）ビューの変更を元に戻す（アンドゥボタン）、（3）ビ

ューの変更をやり直す（リドゥボタン）、（5）変更したビューの保存（セーブボタン）。 

 
マップまたは任意のデータウィンドウに示された測点またはデータを左クリックすると、それぞれの測点ま

たはサンプルが選択されます。ほとんどのウィンドウ要素を右クリックすると、要素固有のさまざまなオプ

ションを持つコンテキストメニューが表示されます。データリスト項目の上にマウスを置くと、詳細なデー

タ情報を含むポップアップウィンドウが表示されます。 

 
マップには現在の測点フィルタ設定を満たす測点が表示されます。それは pick station list を保持し section を

持ちます。データウィンドウは次のスコープのいずれかを持ちます：（1）STATION：選択した測点の X/Y

データを表示し、選択した測点はデータウィンドウと同じマークでマップに示されます；（2）SCATTER：マ

ップに表示している全ての選択した測点の X/Y/Z データを表示します；（3）SECTION：断面帯内の全測点

の X/Y/Z データを示します；（4）SURFACE：マップに示された全ての選択した測点の等値面 X/Y/Z データ

を表示します。現在のウィンドウレイアウトとパラメータ設定はまとめてビューと呼ばれます。ビューは後

で使用するためにファイルに保存できます。 

 

ODV ウィンドウ要素およびポップアップメニューのいくつかは以降で詳細を説明します。 

Suzuki Toru
RelaxではなくResetの方が英語っぽいですね。
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2.5 メニューバー（Menu Bar） 
メインメニューには基本的な機能があります： 

File: コレクションを開くまたは作成；netCDF ファイルを開く； ODV でサポートされているデータファイル

を開く；バッチモードでの ODV コマンドの実行；現在の ODV グラフィックスキャンバスの gif, 

png, jpg,または tiff イメージの生成； ODV の終了。 

Collection: コレクションのコピー、名前の変更、削除；データコレクションの並び替えおよび圧縮；現在の測

点または有効な測点のサブセットの削除；コレクション情報、目録、およびログファイルの閲覧。

コレクションログファイルへのコメントの追加；主要変数の特定；良好なカバレッジ基準の定義；

コレクションのプロパティと変数の表示または編集。 

View: 測点とサンプルフィルタの設定；派生変数の定義；等値面変数の定義；マップとデータウィンドウのレ

イアウト変更；変数ラベル、数値形式、リスト表示ウィンドウの表示順序の変更；直近のビュー変

更を元に戻す/やり直す; ビュー設定を読み込んで保存し、一般的な ODV 設定を定義します。 

Import: 現在のコレクションへのデータのインポート（サポートしているフォーマットには、さまざまなスプ

レッドシートフォーマット、Argo、MedAtlas、World Ocean Database、WOCE が含まれます）。 

Export: 現在選択されている測点データを ASCII ファイル、ODV コレクションまたは netCDF ファイルにエ

クスポート；ウィンドウの X, Y, Z データを ASCII ファイルにエクスポート；参照データセットと

してウィンドウ X, Y, Z データをエクスポート；等値面値を ASCII ファイルにエクスポート。 

Tools: 地衡流の計算; 三次元推定; ボックス平均値の計算; 異常値と重複測点の特定；マクロエディタ; カラ

ーパレットエディタ（Windows のみ）。リストファイルの生成；海洋計算。 

Help: ODV ヘルプシステムの起動；ODV ウェブページの参照；バグレポートの送信; ODV のバージョンとイ

ンストールの詳細を表示。 

 

2.6 ビューバー（Views Bar） 

データコレクションを開くと ODV は最後に使用したビューを読み込んで表示します。このビューはメニュー

バーのすぐ下にあるビューバーのタブで表されます。 

 

 

図 2-2：三つの開いたビューのタブが付いたバーと、プラス（「＋」）、アンドゥ、リドゥ、およ

び保存ボタンのビューバーの例 

 

「＋」(plus)ボタンを右クリックすると現れる「ファイルを開く」ダイアログから一つ以上のビューファイル

を選んで既存のビューを追加できます。「＋」(plus)ボタンを左クリックして現れるリストからテンプレート

を選んで有効なテンプレートビューの中から一つを新しいビューとして選択できます。それぞれのタブをク
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リックしてビューを切り替えると、それが現在のビューになります。 タブ内の「×」ボタンをクリックする

と、開いているビューを閉じることができます。 最後の開いているビューを閉じると、データコレクション

が閉じられるので注意してください。 

 

Save ボタンを左クリックすると現在のビューが保存されます。save ボタンを右クリックすると現在のビュー

を新しい名前で保存することができます（名前を付けて保存）。赤色の save ボタンは現在のビューに保存さ

れていない変更があることを示しています。Undo または Redo ボタンをクリックすると最後のビューの変更

を元に戻す、またはやり直せます。Undo または redo ボタンを右クリックすると、元に戻す/やり直す操作が

可能な直近の動作リストが表示されます。測点図の移動やサイズ変更、またはデータウィンドウの作成、削

除，サイズ変更には、キャンバス、マップ、およびデータウィンドウのコンテキストメニューの Layout オプ

ションを使います。 

 

2.7 メタデータとデータリスト・ウィンドウ（Metadata and Data List Windows） 
Current Station Window では（地図上に赤い十字印で示されている）現在の測点のメタデータ値が含まれ、

Current Sample Window には（データウィンドウ上に赤い十字印で示されている）現在のサンプルのデータ値

とそれに関連付けられた品質フラグが含まれ、Isosurface Data Window には現在の測点の等値面の値が含まれ

ています。データ値は、値の品質がすぐわかるように異なる色で表示されます。また Current Sample Window

にはまた、データエラーおよび／またはデータ情報が実データと共に提供されている場合、1-σ データエラ

ー（訳注：サンプル群が正規分布 N(μ, σ2) (ここでμは平均、σ２は分散)であるとき、そのサンプルがμ±1σ

を超えた場合）および／またはⓘ記号が表示されます。データ情報の値を見るにはⓘの上にマウスを置いて

ください。もし情報の値が URL もしくはコレクション内の情報ファイルへの参照（lf で始まる値）の場合、

（青色の）ⓘ記号を左クリックすると、Web ブラウザにそれぞれの文書が表示されます。スプレッドシート

ファイルにデータエラーとデータ情報の値を含める方法の詳細については汎用 ODV スプレッドシートフォー

マットの説明を参照してください。 

 

Current Sample Window リスト項目の一つにマウスを置くと、完全な変数ラベル、データ値、関連付けられた

データエラー（利用可能な場合）、品質フラグテキスト、データ情報値（利用可能な場合）を含むツールチ

ップメッセージが自動的に表示されます 。 

 

リストウィンドウの一つをマウスで右クリックすると、ウィンドウ固有のポップアップメニューが表示され

ます。Current Sample Window では、一列目の変数ラベル、二列目および三列目のデータ値と品質フラグ、ま

たはデータ情報が利用可能な場合はⓘ記号を含む四列目を右クリックすると、別々のメニューが表示されま

す。これらのメニューでは、派生変数の定義、変数の表示順序の変更、変数のプロパティ（ラベルと数値形
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式）の変更、またはデータ可用性情報の表示（一列目）、データ値、データエラーまたは品質フラグの編集

（二列目または三列目） またはデータ情報値の編集（一列目）ができます。Sample .. / ..見出しを右クリッ

クすると、新しいサンプルの追加、現在のサンプルの削除、または別のサンプルを現在のサンプルとして選

択できます。 

 

2.8 グラフィックスキャンバス（Graphics Canvas） 
キャンバスは ODV の描画エリアで、測点図と 0 個以上のデータウィンドウが含まれます。View > Settings > 

Canvas（macOS の場合：odv > Preferences > Canvas）でキャンバスのサイズを調整できます。 

 

2.9 ポップアップメニュー（Popup Menus） 

キャンバス、マップ、データウィンドウ、グラフィックスオブジェクト、または任意のリストウィンドウ上

でマウスの右ボタンをクリックすると、クリックされた要素に固有のオプションを提供する別々のポップア

ップが呼び出されます。ほとんどの ODV 機能は、これらのコンテキスト依存のポップアップメニューを介し

て利用できます。頻繁に使うオプションもまた特定のショートカットキーで直接呼び出せます。 

オーバーレイウィンドウ（下記参照）上で右クリックするとオーバーレイウィンドウのコンテキストメニュ

ーが表示されます。アンダーレイの親ウィンドウのコンテキストメニューを表示するには Alt+右クリック

（「Alt」キーを押しながら右クリック）してください。Extras や Layout のような頻繁に使うコンテキスト

メニューのサブメニューは、右クリックと同時に修飾キーを押してください（下表参照）。 

 

表 2-1: 右クリック＋修飾キーで表示されるポップアップメニュー 

Shift Ctrl Alt ポップアップメニュー 

X   マップおよびデータウィンドウの Extra メニュー 

 X  キャンバス、マップおよびデータウィンドウの Layout メニュー 

  X オーバーレイウィンドウ上でクリックしたとき親アンダーレイのコンテキ

ストメニュー 

X  X オーバーレイウィンドウ上でクリックしたとき親データウィンドウの Extra

メニュー 

 X X オーバーレイウィンドウ上でクリックしたとき親データウィンドウの

Layout メニュー 

Suzuki Toru
原文にはviewmchangesとありますが，そんな単語ありません!? view changesのtypoかと思われます。
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2.10 ステータスバー（Status Bar） 
ODV のステータスバーには、ヘルプ、ステータス、進行状況の情報が表示されます。 ステータスバーの一

番右の区画には、マップに現在表示されている測点の数、コレクション内の測点の総数、および現在のビュ

ーファイルの名前が表示されます。 この区画の上にマウスを置くと、現在のビューに関するより詳細な情報

を含むポップアップウィンドウが表示されます。 

 

測点フィルタ区画の S は測点選択フィルタが有効であり、コレクション内の使用可能な測点のサブセットの

みが現在のマップに表示されていることを示しています。測点フィルタが有効でない場合、測点フィルタ区

画は空です。測点フィルタの設定は View > Station Filter で解除または変更できます。 

 

サンプルフィルタ区画は、品質(Q)、範囲(R)およびポリゴン(P)の各サンプルフィルタのいずれかが（マウス

を個々のデータウィンドウ上に移動させた）データウィンドウの一つ、あるいは（マウスを等値面データウ

ィンドウ上に移動させた）等値面変数値の計算に対して有効かどうかを示しています。（データウィンドウ

または等値面データウィンドウの）項目を右クリックして Sample Filter オプションを選択すると、サンプル

フィルタ設定を解除または変更できます。 

 

アクセス表示区画には現在のコレクションのアクセスモードが表示されます。RW は Read-Write アクセスを

示し、R は ReadOnly を示します。ReadOnly モードでコレクションを開くとメタデータとデータは編集できず、

追加データをインポートできないことに注意してください。全ての編集およびインポートオプションは無効

になります。あるコレクションを ODV の第一インスタンスで開き、同じコレクションを第二インスタンスで

開くと、第二インスタンスは ReadOnly アクセスになります。さらに、第二インスタンスがコレクションの使

用を開始すると、第一インスタンスの ReadWrite アクセスモードは、第二インスタンスがシャットダウンす

るまで ReadOnly に格下げされます。一時的に格下げされた ReadOnly アクセスは R-として示されます。 その

コレクションを使用する他の全ての ODV インスタンスが終了すると、第一インスタンスは自動的に

ReadWrite アクセスに完全復帰します。 ここで記述したアクセス管理戦略は、ある ODV インスタンスが現

在そのコレクションを使用している唯一のインスタンスである場合のみ、コレクションに対する変更を保証

するものです。 
 

アクセス管理は ODVCF6 および ODVCF5 .odv コレクションでのみ利用可能であることに注意してください。 

NetCDF ファイルはデフォルトでは ReadOnly モードで読み込まれます。 

 

2.11 現在の測点とサンプル（Current Station and Sample） 
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ODV は常に現在の測点を示しています。この測点は赤い十字印でマップに表示され、そのメタデータは

Current Station Window に表示されます。新しい（別の）現在の測点を選択するには、マップ内の測点をマウ

スの左ボタンでクリックします。例えば、同じ海域での繰り返し観測など、同一地点に一つ以上の測点があ

ると思われる場合には、SHIFT キーを押しながらその測点の位置をクリックすると、クリックした位置に実

際に複数の測点がある場合は、これらの測点のリストが表示されるので、リストから新しい現在の測点を選

択できます。キーボードのキーを使って新しい現在の測点を選択することもできます：右矢印キーで次の測

点を選択でき（コレクション内の測点の順番に従います）、左矢印キーで前の測点を選択できます。 

 

マップポップアップメニューから Current Station by Name を選択すると、特定のクルーズラベル、測点ラベ

ル、および測点のタイプに合致した測点を現在の測点にできます。 マップポップアップメニューから

Current Station by ID を選択して（またはマウスがマップ上にあるときに＃キーを押して）内部 ID 番号を入

力すると新しい現在の測点を選択できます（測点ラベルと混同しないでください）。 

 

現在の測点のサンプルの一つが現在のサンプルです。現在のサンプルはデータウィンドウに赤い十字印で表

示され、そのデータ値と品質フラグが Current Sample Window に表示されます。新しい現在のサンプル（およ

び場合によっては新しい現在の測点）を選択するには、データウィンドウの任意のデータポイント上でマウ

スを左クリックします。下矢印キーで次のサンプルを（主要変数値の昇順で）選択し、上矢印キーで前のサ

ンプルを選択します。PgUp または PgDn キーを押すと、現在のサンプルが何ステップか前方または後方に移

動します。 Pos 1（訳注：日本語/US キーボードでは HOME キー）または End を押すと、測点の最初または

最後のサンプルに移動します。 

 
2.12 マップおよびデータウィンドウの描画（Map and Data Window Drawing） 
マップウィンドウとデータウィンドウは、プログラムの開始時に、またはビューが読み込まれたり、多数の

レイアウトまたは表示プロパティのいずれかが変更されたりするたびに、自動的に描画または再描画されま

す。 選択された測点のリストが空で、現在のセクションが定義されていない場合、STATION または SECTION

スコープのデータウィンドウは空のままです。 

 

選択リストに測点を追加するには、マップ内の特定の測点マークをダブルクリックするか、マークをクリッ

クして測点を現在の測点にしてから ENTER を押します。選択リストに追加する他の測点にもこの手順を繰り

返します。選択リストには無制限に測点を収容できます。選択リストから測点を削除するには、現在の測点

にして（例えば STATION ウィンドウでデータ点の一つをクリックして）Delete ボタンを押します。選択リス

ト・エントリのプロパティは、マップポップアップメニューの Manage Pick List > Edit Pick List オプションを

使用して編集できます。 
 

Toru Suzuki
文中はShftですが訳版ではShiftに統一しました。以降も同様です。
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セクションを定義する、またはセクション・プロパティを変更するには、マップポップアップメニューの

Manage Section メニューのオプションを使用します。セクションが定義されるとセクションに沿った座標を

派生変数として使用できます。これはセクション座標の選択に応じて Section Longitude, Section Latitude また

は Section Distance にすることができます。 セクションに沿った成分分布を作成する場合は、セクション座標

をプロットの X 軸に配置します。 

 

2.13 設定（Settings） 
オプション View > Settings（macOS の場合は odv > Preferences ）を使用してグラフィックスやテキストフォ

ント、キャンバスのサイズ、ブラウザやテキストファイルの表示コマンドなど、一般的な ODV 設定をカスタ

マイズできます。 

 

キャンバスサイズ（Canvas Size:） 

ODV グラフィックスキャンバスの幅と高さ、例えばマップウィンドウとデータウィンドウが描画される白い

領域を調整します。 現在の画面に最適な設定を確立するには Fit to screen をクリックします。 キャンバスサ

イズを大幅に変更した際は Font タブで Graphics Font Size を調整する必要があるでしょう。 

 

フォント（Fonts:） 

フォントファミリーとさまざまなフォントプロパティを選択し、グローバルフォントスケールファクタの

Size を設定します。 グラフィックステキストと軸の注釈を大きくする場合は Size の値を大きくし、そうでな

い場合は小さくします。キャンバスサイズを大きく変更した後は Graphics Font Size の調整が必要になる場合

があります（下記参照）。 

テキストフォント Size エントリは、メニュー、ダイアログ、および現在の測点とサンプルリストウィンドウ

に使用されるフォントサイズを決定します。 

 

ハイライト（Highlighting:） 

マップ内の現在の測点の位置と、データウィンドウ内の現在の測点の現在のサンプルとデータを強調表示す

るために使用する色を選択します。 
 
軸同期（Axis Synchronization:） 

異なるデータウィンドウ間の範囲同期は現在は view のプロパティです。 View > View Properties オプション

を使って機能のオン・オフを切り替えてください。 

 

グリッド海底地形リソース（Gridded Bathymetry Resources:） 
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%H オペランドを使用したマクロおよび数式と同様に DIVA ドメインの設定において、セクションの海底地

形として使用されるオプションの全球または地域グリッド海底地形リソースをインストールまたはアンイン

ストールします。インターネット接続が必要です。 

 

マップリソース（Map Resources:）  

全世界または特定の地域用のオプションの高解像度の海岸線および等深線のリソースをインストールまたは

アンインストールします。 等深線リソースは ODV マップで使用されます。 インターネット接続が必要です。 

 

次のマップリソースのダウンロードおよびインストールによって利用可能になります：（1）2'x2'および

6'x6'の解像度の Amante and Eakins (2009)の ETOPO1 global relief data, (2)2'x2'および 6'x6'の解像度の

GEBCO_2014 global elevation data (version 2014-11-12, http://www.gebco.net/)、(3)30”x30”の解像度

で北緯 60 度以北における IBCAO V3 bathymetric data（http://www.ngdc.noaa.gov/mgg/） （ETOPO1

（2009）のリソースより取得）、(4)1’x1’, 2’x2’, 6’x6’の解像度で南緯 45 度以南における Timmermann 

et al. (2010)の RTOPO gridded relief data, (5）バルト海、北海、地中海、およびケルゲレン諸島海域に

関する地域シリーズ。 

 

 
 

図 2-6：フラム海峡周辺のサンプル地図(左から(a)GlobHR、(b)ETOPO1_6min、(c)ETOPO1_2min) 

 

これらの追加リソースは、ODV 内からいつでも View > Settings > Map > Resources (macOS では、odv > 

Preferences > Map > Resources）オプションを使用してインストール（またはアンインストール）出来ます。

マニュアルダウンロードとオプションパッケージのインストールは不要になりました。 

 

ETOPO1、GEBCO_2014、IBCAO、RTOPO のマップデータはタイル表示されます。これらのリソースは二つの

方法でインストールできます：(1)完全、または(2)オンデマンド（必要に応じてダウンロードする; 

download-on-demand）パッケージです。 (1)の場合、Install ボタンを押すと完全パッケージのダウンロード

と展開が始まります。この作業には数分かかるでしょう。その後、全領域の地図データがシステム上で即座

に利用可能になり、地図の描画が直ちに実行されます。 (2)のインストールはすぐに終わります。 ただし測

点図を描画するとき、描画を開始する前に ODV は現在のマップに必要な全てのタイルデータをシステムにダ

http://www.gebco.net/
Suzuki Toru
原文のミススペルと思われます。
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ウンロードします。 ダウンロードされたタイルはあなたのシステムにキャッシュされるので、二回目以降は

ダウンロードされません。 

 

ディスク容量が制限されない場合は、完全な ETOPO1 または GEBCO_2014 の 6min および 2min パッケージの

インストールをお勧めします。 複数の ODV ユーザーが使用するシステムの管理者は、ダウンロードした地

図データを ODV ユーザーディレクトリ<ODV user directory>/coast/*_?min から ODV インストールディレクト

リ<ODV installation directory>/coast/*_?min に移動させるべきです。 そうすることでマップリソースはシステ

ム上の全ての ODV ユーザーが利用できるようになり、ユーザー毎に ODV ユーザーディレクトリへ複数イン

ストールされることを回避できます。 

パッケージ領域が関心のある地域をカバーしている場合は、地域パッケージをインストールしたほうがよい

でしょう。繰り返しますが、マルチ ODV ユーザー・システムの管理者はリソースを ODV ユーザーディレク

トリから ODV インストールディレクトリに移動させるべきです。 

 

ETOPO1 および GEBCO_2014 2min パッケージは、既存の地域別オプションパッケージの多くを置き換え、同

等またはそれ以上の品質を提供します。 
 
特定の小さな領域に対してのみ高解像度マップが必要な場合は、ダウンロード時間とストレージ容量を減ら

すために、完全パッケージの代わりに ETOPO1 または GEBCO_2014_2min のオンデマンド（download-on-

demand）パッケージのインストールをお勧めします。 
 

インターネット接続はマップレイヤシリーズ・インストールのいずれかを実行するために必須です。自動ま

たは手動モードでマップリソースを使用する方法に関する情報は 9.1 章にあります。 

 

リソースプライオリティ（Resource Priorities） 

マップレイヤの Automatic selection が有効で、現在のマップ領域で複数のインストール済みマップリソース

が利用可能な場合、デフォルトでは中程度の描画コストで高い解像度を提供する特定のリソースが選択され

ます。Resource Priorities ページでマップリソースの優先順位を指定し優先順位を明示できます。リストの一

番上にあるリソースは下のものよりも優先されます。 
 

スプレッドシートのインポート（ Spreadsheet Import） 

測点間の位置（度単位での経度または緯度）と時間（時単位）の差の制限を指定します。これらの制限を超

えた場合、たとえ測点ラベルがあって両測点でそれが同じでも測点は常に分割されます。インポートファイ



ODV User’s Guide 
 

 

ルに測点ラベルが指定されていない場合は、位置および／または日付時刻が異なれば常に測点は分割されま

す。 

 

SDN (SeaDataNet)のインポート（SDN Import） 

SeaDataNet データのインポートの際の出力親ディレクトリを指定します。 実際の SDN インポートは親ディ

レクトリのサブディレクトリ yyyy-mm-ddThh-mm-ss にあります（ここで yyyy-mm-ddThh-mm-ss はインポート

が行われたときの日付時刻を表します）。 
 
Sea-Bird CNV のインポート（Sea-Bird CNV Import） 

アップキャストとダウンキャストを別々の測点に分割するか、または圧力毎に値を平均化するかどうかを指

定します。 
 
WOD (World Ocean Database)のインポート（WOD Import） 

WOD 識別子と二文字の国コードのみで構成される WOD13_GR などの短い航海ラベルか、OCL 航海番号も含

む長い航海ラベル（例：WOD13_US014887）のどちらかを選択します。長い航海ラベルを選択すると大量の

データをインポートする際に非常に多数のクルーズが発生するのでお勧めしません。 
 
プログラムロケーション（Program Locations） 

Web ブラウザ（ODV ヘルプに必要）とテキストビューア（テキストファイルの表示に必要）の絶対パスを

指定します。 

 

macOS、Linux、および UNIX プラットフォームでは、テキストビューアコマンドは 0 個以上の引数をスペ

ースで区切って指定できます。 テキストビューアと引数のパスにスペースが含まれる場合は、スペースをバ

ックスラッシュ(\)でエスケープしてください。 
 
例：テキストビューアとして "/usr/local/My editor path"にインストールした emacs を使用する際に、すで

に開かれている emacs エディタを再利用するために emacs クライアントを呼び出す。 

 
/usr/local/ My\ editor\ path/emacsclient -a /usr/local/My\ editor\ path/emacs 
 

macOS では Web ブラウザを指定することはできません。 ODV は代わりにシステムデフォルトブラウザを

呼び出します。 

 

サイドバーフォルダー（Sidebar Folders） 

ODV の「ファイルを開く」ダイアログと「ファイルを保存する」ダイアログでは、ダイアログの左側のサイ

ドバーに一覧表示されているいくつかのディレクトリにすばやくアクセスできます。サイドバーリストの一
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部になるように、よく使用するディレクトリを二つまで指定できます（macOS システムでは使用できませ

ん）。 
 
ユーザーディレクトリ（User Directory） 

ODV ユーザーディレクトリの絶対パスを指定します。ODV はこのディレクトリをカスタムデータコレクショ

ン、パレット、マクロ、およびコマンドファイル、地図および海底地形リソースのために使用します。 

 

ODV ユーザーディレクトリを変更するには Change User Directory ボタンを押して新しい ODV ユーザーディ

レクトリの親ディレクトリを選択します。最高のパフォーマンスを得るには高速のローカルディスク上のデ

ィレクトリを選択し、ネットワークおよび USB ドライブは避けてください。 

 

注：このオプションはコレクションが開いていないときにのみ使用可能です。他の ODV インスタンスが実行

されていないことを確認してください。以前のユーザーディレクトリの内容は、手動で新しい場所に移動す

る必要があります。その後 ODV を終了して再起動します。 
 
ウェブリンク（Web Links） 

ODV Web サイトの URL、ODV Web サイトからファイルをダウンロードするためのルート URL、および

NERC vocabulary server のルート URL を指定します。 
 

DIVA（DIVA） 

新しいデータウィンドウに最初に適用される DIVA 設定を指定します。ユーザーは Properties > DIVA Settings 

ページから何時でもデータウィンドウの DIVA 設定を個々にカスタマイズできます。 

 

Threads ページでは DIVA 実行時の並列スレッドの最大数を指定できます。いくつかの並行スレッドを使うと

読み込みと複数のデータウィンドウ表示が著しく高速化されます。もしあなたのシステムに 4 論理 CPU コア

と 8GB 以上の RAM が搭載されていれば、4 並列スレッドを、8 以上の論理 CPU コアと 16GB 以上の RAM

が搭載されていれば 8 並列スレッドを試してみてください。もし一つ以上のデータウィンドウが空のままな

ら最小スレッド数に戻してください。 
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3 ODVコレクション（ODV Collections） 

ODV は非常に大きなデータセットを効率的に処理できる特別なデータ保存形式を使用しています。 このフ

ォーマットは不等間隔の可変長データ用に最適化されており、高密度の記憶域と高速データアクセスを提供

します。ある意味で ODV データストレージモデルは、格子データ用に最適化された netCDF データフォー

マットを補完するものです。 
 
ODV コレクションフォーマットは、プロファイル、航跡、時系列など、広範囲な環境データをサポートして

います。 当初 ODV の開発は海洋データに焦点を合わせていましたが、コレクションフォーマットの一般的

な設計により、大気、堆積物、氷床など他のさまざまな分野のデータも同様に扱うことができます。 通常

ODV によって処理される観測データは空間的にも時間的にも不規則に分布しています。 さらに ODV は格子

データと数値モデル出力も維持できます。 
 
ODV は、以前のバージョンの ODV で使用されていた以前の形式の ODVCF5 および ODVGENERIC よりも強力

な新しいコレクションデータ形式（ODVCF6）をサポートし、以前の形式の多くの制限を克服しています。現

在、事実上無制限のメタデータとデータ変数のセット、およびコレクション内の事実上無制限の数の測点と

サンプルがサポートされています。ODVCF6 はメタデータとデータ変数のデータ品質フラグをサポートしてお

り、ユーザーは 16 の一般的な海洋学的スキームのセットからカスタム品質フラグスキームを選択できます。

メタデータおよびデータ変数は、数値（値ごとに 1 から 8 バイト）、あるいはユーザー指定の固定最大長

（TEXT 型）または任意の長さ（INDEXED_TEXT）のテキストを含むこともできます。 
 
ODV は下位互換性があり、ODVCF5 および ODVGENERIC コレクション、および以前のバージョンの ODV で

作成されたビューまたは構成ファイルを完全にサポートしています。 新しいコレクションを作成するとき、

ODV は常に ODVCF6 フォーマットを使用して、全ての新機能を提供し、メタデータとデータ変数のより柔軟

な定義を可能にします。 

 

特に ODVCF6 は以下の機能を提供します： 

1. コレクション内の全ての測点に対して固有で変更不可能な識別子を提供する新しい Accession 

Number メタデータ変数。測点の Accession Number は測点がコレクションに追加されたときに（通

常はインポート中に）割り当てられ、Sort および Condense 操作中は保持されます。これは、コレク

ション内のステーションの順序が変わると連携して変更される Station IDs とは対照的です。 

2. メタデータおよびデータ変数の新しい型：SIGNED_BYTE、UNSIGNED_SHORT、UNSIGNED_INTEGER、

INDEXED_TEXT（下記の表を参照）。 INDEXED_TEXT は任意の長さの UNICODE 文字列をサポート

しています。 何度も発生する文字列（クルーズラベルなど）は非常に効率的に処理されます。 
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3. 測点ごとの履歴記録。全てのインポートおよびデータ編集操作は所定の測点の履歴に記憶されます。 

履歴情報はデータをコレクションまたは ODV スプレッドシートファイルにエクスポートするとき

に維持されます。 

4. 全てのデータ変数は、実データ値と品質フラグに加えてデータエラー値とデータ情報文字列を保持

できるようになりました。データエラーと情報文字列は STANDARD_DEV 列と INFOS 列を使用して

スプレッドシートファイルに提供されます。 

5. 適切な ReadWrite または ReadOnly アクセス管理。コレクションへの ReadWrite アクセスは、現在そ

のコレクションを処理している唯一のアプリケーションである場合にのみ許可されます。同じコレ

クションを開く二番目のアプリケーションは ReadOnly アクセスのみになります。コレクションが複

数のアプリケーションで開かれると、最初のアプリケーションのアクセス権は動的に ReadOnly にな

ります。コレクションを使用している他の全てのアプリケーションが終了すると、元の ReadWrite

アクセスは動的に復元されます。 

6. コレクションのパスワード保護。不正使用を防止するために ODVCF6 コレクションをパスワードで

保護できるようになりました。 

 

3.1 データモデル（Data Model） 
ODV はプロファイル（海洋、大気、湖沼、海洋および湖成堆積物、氷床など）、航跡（航走データ）、海洋、

流氷、陸上の漂流点や固定点での時系列など、非常に広範囲のデータタイプを処理できます。 
 
ODV によって維持されている基本的なデータ実体は station で、所定の地理的位置および日付/時刻で得られ

たデータの二次元の表で示されます。ODV は、ODV データコレクション内の潜在的に非常に多数の測点デ

ータを照合します。通常ユーザーはデータコレクションを開き、このコレクション内の測点データを操作し

ます。 コレクションは拡張可能であり、新しい測点データは逐次追加できます。測点は、航海や測点の名前、

時空間座標など、さまざまなメタデータ変数によって記述されます。下記の必須メタデータ変数のセットに

加えて、ODV コレクションは無制限の数の他のメタ変数を持つことができます。メタ変数には数値またはテ

キストを含みます。 
 
メタデータに加えて、各測点には一行以上かつ二列以上で構成される二次元データ表も含まれています（表

3-2）。各行は所定のサンプルのデータを保持し、各列はコレクションに格納されているデータ変数の一つを

表します。データ変数の数と型はユーザー定義であり、コレクションごとに異なります。データ変数の一つ

である primary variable は特殊で、測点のサンプルの順序変数として機能します。 必ずというわけではあ

りませんが、通常これが最初のデータ変数です。メタデータとデータ変数のセットはコレクションの作成時

に定義されますが、後からいつでも変更できます。 
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どの測点についても、ODV は全てのメタ変数、さらに全てのデータ変数と全てのサンプルのデータ値を保持

します。さらに ODV は個々のメタデータとデータ値に関連する quality flag values も保持します。一つの

測点（station quality flag）と個々のサンプル（sample quality flags）の総合的な品質を記述する追加の品

質フラグがあります。品質フラグの値はデータに対する信頼度を反映しており、データセットの中で非常に

有益な部分です。 
 
ODV は海洋学界で広く使用されている 15 の品質フラグスキームをサポートしており、また海洋学や他の種

類の環境データに適用できる独自のシンプルで一般的な品質フラグスキームも定義しています。ODV はデー

タのフィルタリングにデータ品質フラグの値を活用しています。データ変数のデータ品質フラグ値は品質フ

ラグ派生変数を用いて作図や他の目的にも使用されます。 

 

個々のメタデータおよびデータ変数は、異なる品質フラグスキームを使用しています。サンプルデータ値の

みならずメタデータ（経度と緯度を除く）が欠落している可能性があります。 

 

3.1.1 メタ変数（Meta-Variables） 
ODV は、航海名と測点名、および与えられた測点の地理的位置と日時に関する情報を含む必須のメタ変数の

セットを定義しています（表 3-1 参照）。全ての ODV コレクションには必須のメタ変数が含まれていて、

コレクションに格納されている測点を記述するために、全ての値を指定することが望まれます。観測の日付

と時刻または測点名とそれが属する航海（または探査）名は測点を完全に識別し、強力な測点選択フィルタ

を適用させるために必要です。それらがデータセットに与えられていない場合は、経度と緯度を除く全ての

メタデータが空になります。 経度と緯度は常に与えられなければならず、この情報がない測点は ODV コレ

クションに読み込まれません。 

 

必須のメタ変数に加えて、ODV コレクションは数値型またはテキスト型の追加のメタ変数を無制限に持つこ

とができます。必須メタ変数の型は変更できませんが、バイトサイズは変更できます。一例として、ユーザ

ーが経度および緯度のメタ変数型を８バイトの倍精度(実数)に設定すると数センチメートル以下の高解像度

な位置情報を設定できます。 [0 から 255]または[-32,768 から 32,767]の範囲内のメタ変数は、必要なデ

ィスク記憶領域を減らすためにそれぞれ 1 または 2 バイトの整数として表すことができます。 

 

表 3-1：必須およびオプションの ODVメタ変数 

メタ変数 推奨ラベル 
 
必須 
航海ラベル(テキスト) Cruise  
測点ラベル(テキスト) Station 
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測点タイプ(テキスト) Type  

観測日付・時刻(年、月、日、時、分、秒の数値) yyyy-mm-ddThh:mm:ss.sss 
経度(数値; 東経(度)) Longitude [degrees_east] 
緯度(数値; 北緯(度)) Latitude [degrees_north] 

 
オプション 
SeaDataNet測点識別子(テキスト) LOCAL_CDI_ID 
SeaDataNet機関識別子(数値) EDMO_code 
測点の水深または測器深度(数値) Bot. Depth [m] 
...  

ユーザー定義のメタ変数(テキストまたは数値)の追加  

 

3.1.2 データ変数（Data Variables） 
ODV データコレクションは、一般的にデータファイルの全ての測定パラメータ（例えば圧力、水温、塩分、

等）に対して一つのデータ変数を含みます。データ変数の総数とそれらの名前、単位、および値のプロパテ

ィはユーザー定義であり、データコレクションごとに異なります。メタ変数と同様に、データ変数は数値ま

たはテキスト値を持つことができます。データ変数の一つ（Primary variable (主要変数)）は特別で、サンプ

ルを主要変数値の昇順に並び替えるために使用されます。デフォルトでは最初のデータ変数が主要変数とし

て機能しますが、この目的のために他の変数を選択できます。主要変数はコレクションが作成されるときに

定義されます。 

 

3.2 コレクションタイプの例（Example Collection Types）  
上記の ODV データモデルは柔軟性があり、下記の例を含む広範囲の異なるデータタイプをサポートします。 

 

3.2.1 プロファイルデータ（Profile Data）  

このカテゴリは、例えば固定位置、あるいは係留系または漂流機器による操縦されたもしくは受動的な（海

流に乗った）航跡に沿った、または船舶から得られた海洋プロファイルを含む広範囲の観測を取り扱います。

これら全ての場合において表 3-2 のメタデータとデータ変数の割り当てを使用し、それぞれ個々のプロファ

イルは個別の測点として扱う必要があります。大気、氷床または堆積物中のプロファイルデータも同様に取

り扱うことができ、唯一の違いは主要変数の選択（例えば大気中の高度、あるいは氷または堆積物コアの深

さ）です。 
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表 3-2：プロファイルデータの推奨メタデータおよびデータ変数 

メタ変数 値 

Cruise 航海名、探査名、測器名(テキスト) 
Station 固有な測点識別子(テキスト) 
Type Bはボトル採水機、CはCTD、XBT、または250サンプルを超える測点 
yyyy-mm-ddThh:mm:ss.sss 測点（測器の深度）の日付と時刻 
Longitude [degrees_east] 測点（測器の深度）の縦度（東経（度）） 
Latitude [degrees_north] 測点（測器の深度）の緯度（北緯（度）） 
  
Bot. Depth[m] 測点の水深 

無制限の他のメタ変数 （テキストまたは数値） 

データ変数 注釈 

水柱、氷コア、堆積物コア、ま

たは土壌の深度または圧力；大

気中の標高または高度；等 

主要変数として使用 

無制限の他の測定変数または計

算変数 

(テキストまたは数値) 

 

3.2.2 時系列データ (Time Series Data)  
このカテゴリは、時間とともに繰り返される特定の（固定）位置での観測を取り扱います。例としては、係

留された海洋センサー上の海流と海象パラメータの測定、沿岸観測所での海面高度測定、陸上観測所での気

象観測があります。これら全ての場合において、与えられた測器または測点の時系列全体は、十進数の時間

変数を主要変数として使用し、表 3-3 の他のメタデータとデータ変数の割り当てを使用し、個別の測点とし

て扱う必要があります。 

 

表 3-3：時系列データの推奨メタデータとデータ変数 

メタ変数 値 

Cruise 航海名、探査名、測器名(テキスト) 
Station 固有な測点識別子(テキスト) 
Type Bはボトル採水機、CはCTD、XBT、または250サンプルを超える測点 

yyyy-mm-ddThh:mm:ss.sss 測器を配置した日付と時刻 

Longitude [degrees_east] 測器を配置した経度（東経（度）） 
Latitude [degrees_north] 測器を配置した緯度（北緯（度）） 
  
Bot. Depth [m] 測点の水深 
測器とその配置した深度を記述
する、無制限の他のメタ変数 （テキストまたは数字） 
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データ変数 注釈 

連続十進時間変数 

または 

列名がtime_IOS8601である、単

一列のISO8601日付形式2003-

02-17T13:57:12.3 

主要変数として使用 

 

無制限の他の測定変数または計
算変数 

(テキストまたは数値) 

 

3.2.3 軌跡データ（Trajectory Data） 
このカテゴリは、時間とともに繰り返される移動プラットフォーム（例えば、船舶、ドリフター、フロート、

グライダー、飛行機など）で行われる観測を取り扱います。例としては観測航海中、および能動的に移動ま

たは受動的に漂流するラグランジュ型測器から得られる所定の水深における海象パラメータの航走時観測で

す。これら全ての場合において、所定の場所と時間で行われた個々の測定は、測定の深度または標高を主要

変数として、表 3-4 の他のメタデータとデータ変数の割り当てを使用し、個々の測点として扱う必要があり

ます。この形式の軌跡データには、測点ごとに必ず一つのサンプルがあります。測点数は軌跡に沿った観測

数に等しく、通常は多くなります。 

 

表 3-4：軌跡データの推奨メタデータおよびデータ変数 

メタ変数 値 

Cruise 航跡名、探査名、測器名(テキスト) 
Station 固有な測点識別子(テキスト) 
Type B 
yyyy-mm-ddThh:mm:ss.sss 測定日付・時刻 
Longitude [degrees_east] 測定の経度（東経（度）） 
Latitude [degrees_north] 測定の緯度（北緯（度）） 
  
Bot. Depth [m] 測点の水深または標高 

無制限の個々の測定を記述する他のメタ変数 （テキストまたは数字） 

  

データ変数 注釈 

連続十進時間変数 主要変数として使用 

無制限の他の測定変数または計算変数 （テキストまたは数字） 
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3.3 コレクションの作成（Creating Collections） 
新しいODVコレクションは、さまざまな方法で作成できます：（1）File > Newオプションを使用する、（2）

File > Openでスプレッドシートデータファイルを開く、（3）ODVアイコンに（Windowsのみ）またはコレ

クションが開かれていない場合はODVアプリケーションウィンドウにスプレッドシートデータファイルをド

ロップするか、Importメインメニューオプションのいずれかを使用して開きます。 

 

File > Newオプションを使用すると「ファイルを開く」ダイアログが表示されるので、コレクションの名前と

コレクションを作成するディレクトリを指定します。 次の「」内の文字はコレクション名には使用できませ

ん：「\ /：*？ “ <> | スペース」（訳注：日本語環境では「\」も使用できません）。 

 

ODV ではコレクションに格納されるメタデータとデータ変数をユーザーが定義します。どちらの種類の変数

もいくつかの方法で指定できます。サポートされているテンプレートファイル（<.txt>、<.odv>、<.var>、ま

たは任意の拡張子を持つ ASCII スプレッドシートファイル）から取得した変数名を使用するか、手動で変数

ラベルを入力するか、または公開されている様々な海洋データセット（図 3-1 参照）に適した（標準および

ユーザー提供テンプレートの）変数の既定値を使用できます。標準テンプレートのリストには Argo のプロ

ファイルおよび軌跡データ、NOAA NCEI (米国大気海洋庁国立環境情報センター)によって公開されている

World Ocean Database、World Ocean Circulation Experiment（WOCE; 世界海洋循環実験計画）のさま

ざまなデータタイプ、および Medatlas プロジェクトが含まれています。 

図 3-1：Collection template selection ダイアログ 

 

既定標準テンプレートに加えて、ユーザーはカスタムコレクションテンプレートを準備し、それらのテンプ

レートを ODV ユーザーディレクトリの templates/collections サブディレクトリに保存することができます。 
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ユーザーによるコレクションテンプレートファイルの拡張子は<.odv>であり、.odv コレクションファイルの

形式に従います。 

 

3.3.1 テンプレートとしてファイルを使用（Using a File as Template） 
もし.txt、.odv、.varあるいは他のファイルをテンプレートとして使用する場合（図3-1の最初のオプション）、

テンプレートファイルを選択するために「ファイルを開く」ダイアログが表示されます。それからODVは

Metadata and Data Variablesダイアログ（図3-2）が表示されるので、メタデータとデータ変数を変更します。 

 
最初の 11 個のメタ変数（Accession Number まで、およびそれを含む）は必須である事に注意して下さい。

Accession Number を除き、必須のメタ変数のプロパティを変更することはできますが（変数を選択して Edit

を押す）、削除したり並べ替えたりすることはできません。他のメタ変数は並べ替えたり、削除したり、あ

るいはそれらのプロパティを編集したりすることができます。まだ使用されていないスプレッドシートの列

ラベルをメタ変数として追加するには Spreadsheet Column Labels リストからこのラベルを選択して Meta 

Variables >> ボタンを押してください。追加されたメタ変数を追加するには New をクリックして新しいメタ

変数のプロパティを定義します（以下の Properties ダイアログを参照）。メタ変数の総数は無制限です。 

 

図 3-2：Metadata and Data Variables ダイアログ 

 

メタ変数のプロパティを検査または変更するには、変数を選択して Edit を押します。 Properties ダイアロ

グ（図 3-3）が表示されるので、変数のラベルと単位、現在の測点ウィンドウに値を表示するために使用さ
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れる有効桁数（数値の場合）、この変数に使用される品質フラグスキーム、データ型とバイト長（テキスト

の場合）を指定します。 
 
メタ変数のラベルまたは単位を入力するときには書式制御シーケンスを使用して、下付き文字、上付き文字、

および特殊記号を作成できます。ラベルと単位に「;」または「TAB」を含めることはできません。 測点位置

に約 100m 以下の精度が必要な場合は、経度および緯度メタ変数のデータ型が DOUBLE であることを確認

してください。また、経度、緯度、または時間に関わるメタ変数のデータ型に TEXT を使用しないでくださ

い。 サポートされている品質フラグスキームとスキーム間のマッピング（対応表）の説明については、

ODV_QualityFlagSets.pdf を参照してください。 

 

 

図 3-3：メタデータおよびデータ変数のプロパティダイアログ 

 

メタ変数のセットが定義されたら、引き続き変数の追加、削除、並べ替え、またはそれらのプロパティの変

更によるデータ変数を定義します。変数にラベルや単位を入力するときは、書式制御シーケンスを使用して

下付き文字、上付き文字、特殊記号を作成できます。ラベルと単位には「;」または「TAB」を含めることは

できません。サポートされている品質フラグスキームとスキーム間のマッピング（対応表）の説明について

は、ODV_QualityFlagSets.pdf を参照してください。 

 

表 3-5：メタデータおよびデータ変数の ODV データ型 

名前 バイ

ト数 

数値範囲 注釈 

BYTE 1 0～255  

SIGNED_BYTE 1 – 128~127  

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
Suzuki Toru
5.2.0で変更
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表 3-5 に ODV メタデータとデータ変数に使用できる値型の種類をまとめています。数値変数のデフォルト

の型は FLOAT で、ほとんどの場合に十分な精度があります。例えば、非常に正確な経度/緯度を記述するた

めに 7 桁以上が必要な場合は DOUBLE 型を使用してください。 限られた範囲の整数を持つ変数の場合は、

コレクションの格納サイズを減らすために 1 または 2 バイト型のいずれかを使用することを考慮してくださ

い。 

 

テキストを格納するための二つの値型：TEXT と INDEXED_TEXT があります。 
 
次の場合は TEXT を使用してください（最大テキストバイト長を指定; テキスト終端文字に 1 バイトを追加

します）： 

 全てのテキスト値は同じ長さ、 

 最大テキスト長は 10 未満、 

 ほとんどのテキスト値は異なる、 

 テキストには ASCII 文字またはローカル文字セットの拡張部のみが含まれ、コレクションは国際配

布用ではない。 

 

次の場合は INDEXED_TEXT を使用してください： 

 テキスト値は高度な可変長、 

 同じテキスト値が繰り返し使用されている、 

 テキストに ASCII 以外の文字が含まれている。 

 

SHORT 
 

2 – 32,768 ~32,767  

UNSIGNED_SHORT 2 0～65,535  

INTEGER 4 -2,147,483,648～2,147,483,647  

UNSIGNED_INTEGER 4 0～4,294,967,295  

FLOAT 4 3.4E+/-38(7桁) デフォルトの数値型 
DOUBLE 8 1.7E+/-308(15桁)  

TEXT  ASCII+ローカル文字セット ユーザー指定の文字長；文字列終端文

字に1バイトを追加 

INDEXED_TEXT  任意の長さのUTF-8文字符号化形式

の文字列 

メタデータファイルに格納された4バイ

トの文字列インデックス；実際の文字

列はstringpoolファイルに保持される。 
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デフォルトでは、ODV はクルーズラベル（通常は多くの測点で同じクルーズラベルが使用されています）と、

Web サイトまたは Web ドキュメントへのリンクを含む全てのメタデータ変数に INDEXED_TEXT を使用し

ます。 

 

3.3.2 マニュアル入力（Manual Entry） 
変数の手動入力（図 3-1 の二行目のオプション）を選択した場合は、上記のセクション 3.3.1 で説明したも

のと同様の方法でメタ変数とデータ変数を変更する Meta Variables と Data Variables の両ダイアログ（図 3-4）

が表示されます。 

 

3.3.3 既定テンプレートの使用（Using a Pre-defined Template） 
 標準またはユーザー提供のコレクションテンプレートのいずれかを選択した場合、ODV はそのテンプレー

トからメタデータとデータ変数のリストを読み込みます。ユーザーによる変数のプロパティの変更はサポー

トされていません。標準の変数テンプレートを適合させたい場合はカスタムテンプレートを作成し、そのテ

ンプレートを ODV ユーザーディレクトリの templates/collections サブディレクトリに配置する必要がありま

す。ユーザーによるコレクションテンプレートファイルの拡張子は.odv で、.odv コレクションファイルの形

式に従います。 
 
新しいコレクションの定義の最終段階として、ODV は Collection Properties ダイアログ（図 3-5）を表示しま

す。このダイアログで、コレクションに保存するデータのフィールドと種類を指定できます。データの並び

替えに使用される主要変数も選択できます。 

 

     
 図 3-4：メタデータおよびデータ変数の定義に関するダイアログ 
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ODV はコレクションを作成し、キャンバスに全球地図を描画します。 この段階では、そのコレクションは

まだ空っぽで、測点データは一つも含まれていない事に注意して下さい。メニューバーにある Import メニュ

ーのオプションを使用して、データをそのコレクションにインポートしなければなりません。コレクション

の作成中に表示される全てのダイアログには意味のある初期設定が含まれている事に注意して下さい。特別

な要求がなければ、これら全てのダイアログで OK をクリックするだけで、完全に有効なコレクションが生

成されます。 

 

図 3-5：コレクションプロパティの定義ダイアログ 
 

3.4 コレクションファイル（Collection Files） 
このセクションでは、ディレクトリ構造と、それぞれ ODVCF6、ODVCF5、または ODVGENERIC コレクション

を構成するさまざまなファイルの概要を説明します。この情報は熟練したユーザーに向けて提供されており、

問題が発生した場合や予期しない問題が発生した場合に役立つことがあります。 通常ユーザーはコレクショ

ンファイルの構造を気にする必要はありません。 

 

3.4.1 ODVCF6 and ODVCF5 
メタデータとデータ変数に関する情報は、ファイル<col>.odv に保存されています。これはコレクション

<col>の定義ファイルで、コレクションを開くときにはこのファイルを選択する必要があります。Windows

では.odv ファイルタイプは ODV 実行ファイルに関連付けられています。例えば.odv ファイルをダブルクリッ

クすると ODV が起動してコレクションを開きます。.odv ファイルを含むディレクトリは、コレクションのル

ートディレクトリです。 コレクションの他の全てのファイルは<col>.Data という名前のコレクションのル

ートディレクトリのサブディレクトリ（コレクションのベースディレクトリ）に格納されています。 

 

コレクションのベースディレクトリには、コレクションのメタデータとデータファイル、およびビュー、セ

クション、またはグラフィックスオブジェクトファイル用の多数のサブディレクトリが含まれています。サ

ブディレクトリ views には、ユーザーがコレクション内のデータを表示する方法を定義するビューファイル

が格納されています。ビューファイルは、マップ領域、測点およびサンプルフィルタ設定、ウィンドウレイ

アウト、その他多くのパラメータの設定を定義しています。 
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ODVCF6 または ODVCF5 コレクションをコピー、移動、または名前変更するには Collection > Copy または

Collection > Move/Rename オプションを使用します。コレクションを手動でコピーまたは移動する場合は.odv

ファイルと<col>.Data ディレクトリと全てのサブディレクトリをコピーまたは移動してください。ODV コ

レクションファイルは手動で編集しないでください。 

 

表 3-6：ODVCF6 または ODVCF5 コレクションファイルの概要。コレクション名<col>に”/”または”\(訳

注：日本語キーボードでは\)”は含まず、スペースは含めないでください。 

ファイル フォーマット 注釈 

   

Collection file (コレクションファイル) 

<col>.odv ASCII メタデータとデータ変数、コレクションのフィールドとタイプを定義しま
す。 Windowsでは、このファイルタイプはODV実行可能ファイルに関連
付けられています。 .odvファイルをダブルクリックすると、ODVが起動
してコレクションを開きます。 

   

サブディレクトリ<col>.Data 
metadata binary 測点のメタデータ(名前、位置、日付など)を格納する。 
data binary 測点データと品質フラグを格納する。 

   

info ASCII コレクションの説明(自由書式TEXT形式;ファイルはオプション)。 
inventory binary コレクションの航海毎の目録リスト。 
logfile ASCII コレクションのログファイル。データ変更の記録を保存する。 

settings ASCII キー変数の識別子、最後に使用したビューファイルの名前、または直近の

読み込みおよび出力ディレクトリなどの設定が含まれる。 

stringpool binary INDEXED_TEXT文字列および関連するインデックスを含む。 
history binary History string indexesを含む。 
historypool binary History stringsを含む。 

stringpool, history および historypool ファイルは ODVCF6 コレクションにのみ存在します。 
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表 3-7：ODVCF6または ODVCF5のビューおよびセクションファイルの概要。ファイル名<name>は任

意。xviewおよび secファイルのデフォルトの場所はディレクトリ<col>.Data/viewsですが、これらの

ファイルは他の任意のディレクトリに格納することもできます。 

 

3.4.2 ODVGENERIC 
ODVGENERIC コレクション形式は ODV3 以前のソフトウェアで導入されたもので、下位互換性のために引き

続きサポートされています。ODV によって作成された新しいコレクションは全て ODVCF6 コレクションです。 
 
データ変数のリスト、測点メタデータ、および実際の測点データは.var、.hob および.dob ファイルに分けて保

存されます。cfg ファイルにはユーザーがコレクション内のデータを表示する方法を定義するビュー設定が格

納されています。ビュー設定にはマップ領域、測点フィルタ設定、ウィンドウレイアウト、その他多くのパ

ラメータなどの項目が含まれています。コレクションに必要な.var、.hob および.dob ファイルは全て同じディ

レクトリに配置する必要があります（コレクションディレクトリ）。cfg ファイルはディスクのどこにでも保

存できます。 

 

ODV コレクションファイルは手動で編集しないでください。 

 

表 3-8：ODVGENERIC コレクションファイルの概要。コレクション名<col>に“/”または“\(日本語キーボー

ドでは\)”は含まれず、スペースを含んではいけません。全てのファイルは同じディレクトリ(コレクショ

ンディレクトリ)にある必要があります。 

拡張子 フォーマット 注釈 

<name>.xview ASCII レイアウト、値の範囲、派生変数と等値面変数の選択、およびその他
多くの設定を格納しているビューファイル。 親コレクションの名前
は、xviewファイル内に記録されています。 他のコレクションが
xviewファイルを使用すると、派生変数の設定は失われます。 

<name>.sec ASCII セクションの輪郭と特性を格納します。 

ファイル フォーマット 注釈 

   

基本ファイル  必須 
<col>.var ASCII データ変数を定義し、コレクション名と測点数を格納します。Windowsで

は、このファイルタイプは自動的にODV実行ファイルに関連付けられ、例え
ば.varファイルをダブルクリックするとODVが開始し、それぞれのコレクシ
ョンを開きます。 

<col>.hob binary 測点のメタデータ(名前、位置、日付など)を格納します。 
<col>.dob binary 実際の測点データと品質フラグを格納します。 

Suzuki Toru
原文の方が間違っているような気がします。
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表 3-9：ODVGENERIC ビューおよびセクションファイルの概要。ファイル名<name>は任意で、cfg および

sec ファイルは任意のディレクトリに配置することができる。 

 

3.5 プラットフォーム非依存（Platform Independence）  
全ての ODV データコレクションとビューファイルはプラットフォームに依存せず、サポートされている全て

のシステム（Windows、macOS、Linux、および UNIX）で変更なしに使用できます。 

  

   
情報ファイル  オプション 
<col>.info ASCII コレクションの説明(自由書式TEXT形式)。netCDFファイルを開くときに、

自動的にODVは、次元と変数に関する情報を含む.infoを作成します。 
   

補助ファイル  存在しない場合は自動作成 
<col>.inv ASCII コレクションの航海別目録リスト。 
<col>.cid binary 航海ID番号 
<col>.log ASCII コレクションのログファイル。データ変更の記録を保存する。 
<col>.idv ASCII 派生変数の入力に使用されるキー変数(深度、水温、酸素など)のID一覧 
<col>.cfl ASCII 最後に使用した定義ファイルおよび出力ディレクトリの名前を含む。 

拡張子 フォーマット 注釈 

<name>.cfg binary レイアウト、値の範囲、派生変数および等値面変数の選択、および他の多く
の設定を格納する定義ファイル。定義を所有するコレクションの名前はcfgフ
ァイル内に記録されています。別のコレクションがcfgファイルを使用する場
合は一定の制限が適用されます。 

< name >.sec ASCII セクションの輪郭と特性を格納。 



Version 5.8.2 
 

 

 

4 データのインポート（Importing Data） 
ODV は新しいデータをインポートして、インポートしたデータを既存のコレクションに追加したり、自動的

に作成された新しいコレクションにデータを加えたりできます。多くの一般的な海洋データのフォーマット

や幅広い列指向のスプレッドシートファイルを含む多種多様なデータファイルフォーマットのサポートが提

供されています。データのインポートは、一度に一ファイルずつ、もしくは大量のインポートファイルを一

度に処理することによって実行することができます。インポートファイルは、ファイル選択ダイアログを使

用して手動で選択するか、別ファイルに記述したファイル名のリストを使用して選択できます。ファイルリ

ストは組み込みリストファイルジェネレータを使用して簡単に生成できます。インポートファイルのアーカ

イブ（zip、gz、または tar.gz）を指定すると自動的に展開されます。 

 

後述する全てのインポートは二つの方法で実行されます：インポート開始時に（1）コレクションを開くか、

（2）開かないか、です。 

 

(1) コレクションを開く（Collection open） 

インポートが開始された時点でコレクションが開いている場合、ODV は選択された全てのインポートファイ

ルを分析し、そのファイルに含まれる変数の上位集合（ソース変数）を構築します。次に ODV はインポート

ファイル内のメタデータとデータ変数を、現在開いているコレクションの変数（ターゲット変数）に関連付

けることを可能にするダイアログを表示します。その後 ODV は全てのインポートファイルから現在開いてい

るコレクションにデータをインポートします。 

 

(2) コレクションを開かない（No collection open） 

インポート開始時にコレクションが開かれていない場合、ODV は選択された全てのインポートファイルを分

析し、ファイルに含まれるメタデータと変数データ（ソース変数）の上位集合を構築します。次に ODV はイ

ンポートしたデータを受け取るため、自動的に一つ以上の適切なターゲットコレクションを作成します。タ

ーゲットコレクションには、分析中にインポートファイルで見つかった一連の変数が含まれています。ソー

ス変数とターゲット変数間の関連付けは自動的に確立され、インポートはそれ以上のユーザー介入なしに進

行します。 

 

ターゲットコレクションの自動作成を伴うデータのインポート（タイプ 2；インポート開始時にコレクショ

ンを開かない）では、インポートファイルにある全てのメタデータとデータ変数の全てのデータが実際にイ

ンポートされます。これは、インポートしたデータの完全性が主な関心事である場合に好ましいインポート

タイプです。既存のコレクションへの読み込み（タイプ 1；インポート開始時にコレクションを開く）は、

既存のコレクションを新しいデータで拡張することが主な関心事である場合にのみ使用してください。この
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インポートタイプでは、既存のコレクションに含まれていない変数はインポートファイル内のメタデータま

たはデータからインポートされません。 

 

以下の表 4-1 に、さまざまなインポータの概要とデータ読み込みの開始方法を示します。 
 

表 4-1：ODVデータ読み込みとその読み込みの開始方法 
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インポートメニューオプション X X X X X X X X X 
File > Openオプション X - - - - - - - - 
ファイルのドラッグとドロップ X - - - - X - - X 
コマンドファイル X X X X X - - X - 

 

インポートメニュー（Import menu）：これはインポートを開始する通常の方法です。Import メニュー

から適切なエントリを選択してインポートするファイルを選択します。開かれているコレクションにインポ

ートするとき、一部のインポートは互換性のないデータのインポートを防ぐために無効となります。 例えば

時系列データは、プロファイルデータを含むコレクションにはインポートされません。 

File > Open オプション：File > Open メニューからのインポートは、単一のスプレッドシートファイルの

インポートを開始するのに便利な方法です。Open ダイアログが表示されたらタイプフィルタを Data Files に

切り替えてスプレッドシートファイルを選択します。 

ドラッグ・アンド・ドロップ：一部のインポートでは、ファイルブラウザで一つ以上のファイルを選択し、

それらのファイルを ODV ウィンドウにドロップするだけでデータのインポートができます。 ODV は最初に

ドロップされたファイルのファイルタイプに基づいて適切なインポートを選択します。 未知のファイルタイ

プの場合は ODV スプレッドシートのインポートを仮定します。 

コマンドファイル：一部のインポートは、ODV コマンドファイルを呼び出すことによってバッチモードで実

行できます。 詳細については ODV コマンドファイルの章を参照してください。 

マルチファイルインポート：全てのインポートは、インポート毎に複数のファイルを許可します。インポー

トファイルは、ファイル選択ダイアログ、複数ファイルのドラッグ＆ドロップ、または別ファイルに記載さ

れたファイル名のリストを提供することによって手動で選択できます。組み込みリストファイルジェネレー
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タで簡単にファイルリストを生成することができます。これは、複数のディレクトリから多数のファイルを

インポートする場合、または手動で大量のファイル選択を繰り返したくない場合に便利です。 

ファイル固有の変数：全てのインポートでは、インポートファイルを分析し、ファイル内で見つかった変数

の上位集合を収集することによって、インポートメタデータとデータ変数のリストを自動的に構成します。

タイプ 2 のインポート（インポート時にコレクションを開かない）では、インポートファイル内の全ての変

数についてインポートしたデータを受け取るのに適切なターゲットコレクションを自動的に作成します。 

 

4.1 ODV スプレッドシートファイル（ODV Spreadsheet Files）  
ODV は、さまざまなスプレッドシートタイプのファイルからデータを読み取ってインポートします。 イン

ポートファイルの形式が汎用 ODV スプレッドシートフォーマットに準拠している場合、データのインポート

は完全に自動化され、ユーザーは操作の必要がありません。スプレッドシートファイルは、メニューオプシ

ョンの Import > ODV Spreadsheet および File > Open を使用して開いてからインポートするか、あるいはイン

ポートファイルを単に ODV ウィンドウまたはアイコンにドロップすることができます。準拠していないスプ

レッドシートデータファイルもインポートできますが、例えば経度、緯度、日付、時刻のように必須なメタ

データ変数に関するインポートファイル内の列の識別など、ODV はユーザーに操作を求めます。 

 

測点メタデータ情報や列ラベルの有無にかかわらずスプレッドシートファイルのインポートは可能です。

ODV スプレッドシートファイルにはコメントを含めることができ、列区切り文字はタブまたはセミコロンで

す。欠測データは、特別な数値、テキストインジケータまたは空欄で表されます。スプレッドシートファイ

ルは一つ以上のクルーズによる多数の測点データを含んでいます。各測点は無制限の数のサンプル（一行に

つき一サンプル）を含んでいます。測点のサンプルは連続していなければなりませんが、必ずしも並び替え

られている必要はありません。 
 
スプレッドシートファイルを読み込むとき、ODV は Cruise、Station、Type および存在する場合は

LOCAL_CDI_ID の一つ以上のエントリが一行から次の行に変わるたびにデータを測点に分割します。Cruise、

Station、および Type が変わらなくても、日付/時刻、経度および/または緯度が指定された許容範囲を超えて

変わった場合も測点に分割されます。デフォルトの許容値は一時間かつ緯度経度 0.1 度です。これらの値は

View > Settings > Spreadsheet Import オプションで変更できます。 
 
データファイルに Station 情報が与えられていない場合は、Date, Time, Longitude および Latitude の各値がチ

ェックされ、これらの値の一つ以上が変わる毎に測点に分割されます。日付/時刻、経度、緯度のような測点

の全てのメタデータは、インポートファイル内の測点の最初のサンプル行から取得されます。 
 
ファイルからインポートしたデータは、現在開いているデータコレクションに追加されるか、または現在開

いているコレクションがない場合は、新しく作成される適切なコレクションに追加されます。 
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スプレッドシートファイルのデータを現在開いているコレクションにインポートするには、Import > ODV 

Spreadsheet を選択し、標準の「ファイル選択」ダイアログを使用してデータファイルを識別します。インポ

ートオプションを指定して OK を押すとデータのインポートが始まります。 スプレッドシートファイルを

ODV アイコンまたは開いている ODV ウィンドウにドラッグ・アンド・ドロップすることもできます。 

 

 

図 4-1：スプレッドシートファイルのプロパティダイアログ 
 

ファイルが汎用 ODV スプレッドシートファイルではない場合、Spreadsheet File Properties ダイアログボック

スが表示され、列の区切り文字と一つ以上の欠測値の指定が促されます。複数の欠測値は一つ以上のスペー

スで区切る必要があります。インポートファイル内のフィールドが空欄または欠測値の一つを含んでいれば

欠測データと見なされます。最初のデータ行および列ラベルと単位を含む行を指定することもできます。後

者の二つの行番号はラベルと単位が別々の行にある場合にのみ異なるでしょう。ODV は全ての項目に対して

妥当なデフォルト値を提供しているので、ほとんどの場合ほんの少し変更するだけです。Column separator

は Column labels ボックスをクリックすると表示される縦長のラベル一覧から選択します。スプレッドシート

ファイルの全てのプロパティを設定したら OK を押し、インポートを中止する場合は Cancel を押します。 
 
メタデータ列のラベルが汎用 ODV スプレッドシートフォーマット（下記参照）で定義されている推奨ラベル

と異なる場合、Meta Variable Association ダイアログボックスが表示されます。このダイアログでは、入力列
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をコレクションのメタ変数に関連付けるか、入力ファイルで提供されていないメタ変数にデフォルトを設定

することができます。既に関連付けられた変数にはアスタリスク（*）が付いています。 詳細については

「メタ変数関連付けダイアログ（Meta Variable Association Dialog）」の章を参照してください。 
 
4.2 SDNスプレッドシートおよび netCDFファイル（SDN Spreadsheet and netCDF 

Files） 
European SeaDataNet（SDN）プロジェクトは、欧州のデータセンターのネットワークから海洋データを

提供しています（http://www.seadatanet.org）。データ問合せの結果として、SDN は問合せ単一のプロ

ファイル、時系列、または軌跡のデータがそれぞれ格納された潜在的に多数のファイルを含む多数の zip フ

ァイルを配信します。データファイルに含まれるデータ変数に関する情報を格納した

param_decompositions.txt も配信されます。 

SDN は ODV スプレッドシートフォーマットまたは netCDF ファイルを配信します。Import > SeaDataNet 

Formats オプションは両タイプのデータファイルをインポートでき、非常に多数のファイルに対しても簡単

なデータインポート手順を提供しています。選択した個々のインポートファイル（zip、csv、txt、および nc

ファイルは一度のインポートステップに組み合わせることができます）は全て一ステップで処理され、SDN

インポートファイルセットに含まれるデータタイプごとに別々の ODV データコレクションが作成されます。  

 

SDN データの.zip ファイルをダウンロードしたら Import > SeaDataNet Formats を呼び出します。次にダウン

ロードしたファイルが含まれているディレクトリに移動して、インポートするファイルを選択します。

param_decompositions.txt ファイルの選択も確認してください。SDN のインポートを開始するたびに

SDN の親ディレクトリの中にサブディレクトリが作成され、インポートプロセスからの出力がこのサブディ

レクトリに書き込まれます。SDN の親ディレクトリの名前は View > Settings > Import > SDN Import で確認お

よび変更できます。新しいコレクションが書き込まれるサブディレクトリの名前は現在の日時で構成される

ので、実行する全ての SDN インポートに関して固有の名前となります。 
 
ODV は選択された全ての SDN .zip アーカイブファイルを自動的に展開し、抽出された全てのスプレッドシ

ートまたは netCDF ファイルの内容を分析します。これには、そのファイル内の入力ファイルの SDN セマン

ティックヘッダー行と列ヘッダー行の分析、SDN スプレッドシート形式準拠の検査（準拠していないファイ

ルは除かれます）、使用可能な変数に関する情報の収集、ファイル中で見つかった主要変数に関するファイ

ルのグループ化が含まれます。さらに ODV は.csv メタデータファイルを検索し、その内容を追加のメタ変数

に抽出します。//<SDN_REFERENCES>および//<sdn_reference>のコメント行の内容が抽出され、Reference メ

タ変数に提供されます。Reference メタ変数の LOCAL_CDI_ID、EDMO_code、および URL のエントリはクリッ

ク可能であるため、より詳細な情報を含むドキュメントを Web ブラウザで開くことができます。readme.txt

ファイルの内容が抽出され（存在する場合）、作成された全てのコレクションの使用許諾契約ダイアログに

使用されます。 
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ODV は検出されたデータタイプごとに別々のデータコレクションを作成し、一致するファイルのデータを特

定のコレクションに読み込みます。SDN インポートプロセスが完了したら File > Recent Files オプションを使

用して新しく作成されたコレクションを開くことができます。コレクションの別ディレクトリへの移動およ

び／または別名への変更には Collection > Move / Rename を使用します。 

 

以下は、ターゲットコレクションの作成のために ODV によって適用される戦略とそれぞれの変数セットの構

成の詳細な説明です。 

 

最初のステップとして、ODV は全ての SDN インポートファイルのヘッダー列行を解析し、どのファイルで

も使用されている主要変数（メタ変数の後の最初の変数）を検出し、インポートファイルをその主要変数に

従ってグループ化します。 
 
次に、ODV は全てのファイルグループについて、これらのファイル内に存在する変数の上位集合に編集し、

続いて編集済み上位集合の全ての変数からなる ODV コレクションを一つ作成します。グループ内の全てのフ

ァイルからのデータは、最終的にその特定のコレクションにインポートされます。 

 

セマンティックヘッダーの SDN パラメータコードに関係なく、所定のファイルグループの変数の上位集合を

編集している間、ファイルのヘッダー列行に新しい変数ラベルが見つかると、新しい変数が作成されます。

例えば Tempera_sensor1 と Temperature_sensor2（どちらもセマンティックヘッダエントリ SDN：P01 :: 

TEMPPR01 を持つ）の二つのラベルが単一のファイルまたはグループの別々のファイルにある場合、ODV は

タ ー ゲ ッ ト コ レ ク シ ョ ン 内 に Temperature 変 数 の 中 に 別 々 の 変 数 Temperature_sensor1 と

Temperature_sensor2 を作成します。  

 

同じ派生変数名で異なる単位が異なるファイルにある場合は別々の変数が作成されます。例えば Phosphate 

[umol/l]と Phosphate [umol/kg]が二つのファイルで見つかると、二つの別々の変数になります。どのファイル

でもヘッダー行の変数名は固有でなければなりません。一つのファイルで同じ名前を二回以上使用すること

（Phosphate [umol/l]および Phosphate [umol/kg]など）は ODV ではサポートされていません。ある変数の二

つの異形が単一ファイルに表れることはありますが、変数名は異なっている必要があります（例えば

Phosphate_1 と Phosphate_2）。 

 

個 別 の 変 数 を 作 成 す る た め の 上 記 の 規 則 は 、 <install>/include/import デ ィ レ ク ト リ に あ る

sdn_import_settings.xml ファイルの Labels グループにリストされている変数には適用されません。ユーザーは

追加したユーザー指定の設定を含む追加の sdn_import_settings.xml ファイルを<user>/import ディレクトリに

作成できます。競合が発生した場合はユーザー設定が優先されます。 
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SDN インポートファイルで sdn_import_settings.xml ファイルの Labels グループに含まれる変数が見つかると、

SDN インポートファイルのラベルではなく、設定ファイルで指定された変数ラベルが使用されます。例えば

コード SDN:P01 :: PRESPR01、SDN:P01 :: PRESPS01、および SDN:P01 :: PRESPS02 の変数には全てラベル

Pressure が割り当てられ、一つのデータ変数 Pressure のみが作成されます。インポート中に三つの全てのイ

ンポート変数からのデータは単一の Pressure ターゲット変数に割り当てられます。 

 

いくつかの個々の変数を一つのターゲット変数に結合することは、同じ単位を使用する個々の変数に対して

のみ機能します。異なる単位が見つかった場合は別々の変数が作成されます。例えば上記の例で

SDN:P01::PRESPR01 および SDN:P01: PRESPS01 変数が dBar を使用しているのに対し、SDN:P01::PRESPS02 変

数が Bar を使用している場合、二つのターゲット変数 Pressure[dBar]および Pressure[Bar]が作成されます。イ

ン ポ ー ト 中 に SDN:P01 ::PRESPR01 と SDN:P01:: PRESPS01 が Pressure [dBar] に 読 み 込 ま れ 、

SDN:P01::PRESPS02 が Pressure[Bar]に読み込まれます。 

 

二つ以上の SDN パラメータコードのデータを一つのデータ変数に確実に統合するには、ユーザー設定ファイ

ル <user>/import/sdn_import_settings.xml を 作成 して 特定の コー ドの エン ト リを追 加し ます 。例 え ば

SDN:P01::ODSDM021、SDN:P01::PPSUCS01、SDN:P01 ::PSALCC01 などの異なるコードが異なる SDN インポー

トファイルの Salinity に使用されていて、これらの全てのデータを単一の変数 Salinity に統合したい場合は、

ユーザーの sdn_import_settings.xml ファイルの<Labels>タグに次の行を追加する必要があります： 
<Entry code="SDN:P01::ODSDM021" value="Salinity" />  
<Entry code="SDN:P01::PPSUCS01" value="Salinity" />  
<Entry code="SDN:P01::PSALCC01" value="Salinity" /> 

 

上記のように、単一のターゲット変数への統合は、同じ単位を使用している個々の変数に対してのみ機能し

ます。 
 
また、 sdn_import_settings.xml ファイルには、主要変数と知られているコレクションデータタイプ

（ DEPTH_WATER, MINDEPTH_WATER, MAXDEPTH_WATER, PRESS_WATER, PRESS_ATMOSPHERE, 

DEPTH_SEDIMENT, TIME_SERIES および TIMESERIES_CDJ のいずれか一つ）を指定する<PrimaryVarTypes>タグ

も含まれています。 

Bot.Depth メタ変数の値は検証されて、おそらく次の方法で修正されます。ゼロまたは 9999, または 11000

より大きい値、または特定の測点の最大サンプル深度より小さい全ての値は取り除かれます。もし Water 

depth メタ変数値が存在し、かつ最大サンプル深度より大きいか等しい場合は、オリジナルの Bot. Depth 値が

最大サンプル深度より大きくなっていても、この値が Bot.Depth として使用されます。このような修正は

EDITMETADATA メッセージとして測点履歴に記録されます。縦軸が圧力値の場合は Bot. Depth チェックが実

施される前に深度に変換されます。 
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SDN データファイルをインポートしたら、File > Recent Files で新規作成されたコレクションのいずれかを開

くことができ Expor >Data>SDN Aggregated ODV Collection オプションを使用して変数の自動集約を実行できま

す。Export > Data > SDN Harmonized ODV Collection を使うと、混在しているデータを好ましい単位に自動変換

します。Collection > Browse Info File オプションを使うと説明を含むコレクション内のデータ変数のリストを

閲覧できます。 

 

注意：直前の測点からおよそ距離 250m および時間 10 分以内の軌跡点（一測点に一サンプル）は無視され

ます。このルールはデータファイルのサイズが 5KB をこえる場合にのみ適用されます。 

 

4.3 World Ocean Databaseデータ（World Ocean Database Data）  
ODV を使用して、NOAA NCEI（米国大気海洋庁国立環境情報センター；旧 NODC（米国海洋データセンタ

ー））の World Ocean Database (WOD) からオリジナルの海象データを既存または新規のデータコレクシ

ョン内にインポートできます。WOD のインポートはコレクションを開いていなくても実行でき、インポー

トしたデータを受け取る適切なターゲットコレクションが自動的に作成されます。ODV は WOD バージョン

2018 および以降のネイティブ ASCII および不規則配列の netCDF ファイルをサポートしています。それ以

前のバージョンの WOD データファイルは、多くの海洋変数の単位が異なるため受け付けません。例えば

https://www.nodc.noaa.gov/OC5/WOD/datawodgeo.html からダウンロードするなどして WOD native 

ASCII または不規則配列の netCDF フォーマットのデータファイルを入手してください。csv または単一キャ

ストの netCDF フォーマットの WOD データはインポートできません。 

 

WOD データを既存のコレクションにインポートするには、そのコレクションを開きます。 新しいコレクシ

ョンにインポートするには、インポートを呼び出す前に他の開いているコレクションを閉じてください。

Import > NOAA NCEI Formats > World Ocean Database の手順でインポートを呼び出します。標準の「ファイル

を開く」ダイアログを使用してインポートする一つ以上の WOD .gz または .nc データファイルを選択します。

すでに展開されている WODASCII ファイルを選択したい場合にはファイルタイプで All Files (*.*)を選択して

ください。 
 
必要があればインポートオプションを指定して OK を押すとデータのインポートが始まります。ODV は選択

された WOD データファイルを読み、測点フィルタ設定を満たす全ての測点をインポートします。インポー

トした測点のクルーズラベルは WOD18 識別子とそれに続く二文字の NCEI 国コードおよび固有の OCL クル

ーズ番号で構成されています。個々のエントリはアンダースコア “_”で区切られています（注：OCL クルー

ズ番号を除いた簡易クルーズラベルを作成するには View > Settings オプションで Short WOD cruise labels ボッ

クスをチェックして WOD Import 設定を変更してください）。 

 

https://www.nodc.noaa.gov/OC5/WOD/datawodgeo.html
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固有の OCL プロファイル番号は測点番号として ODV によって使用されます。ODV はインポートファイルに

ある WOD データ品質フラグを認識して使用します（下記参照）。データ保有者から提供された品質フラグ

は無視されます。追加のメタデータとして OCL クルーズ番号、データ保有者によるクルーズ名、測点名、お

よび調査員の名前が提供されます。 

 

「ファイルを開く」ダイアログを使用してインポートファイルを手動で選択する代わりに、インポートした

い全てのファイルの名前を含む ASCII ファイルを準備してから、「ファイルを開く」ダイアログでリストフ

ァイルを選択することもできます。これは、複数のディレクトリから多数のファイルをインポートする場合、

または手動で多数のファイルを選択してのインポートを繰り返したくない場合に便利です。リストファイル

内のファイル名は絶対パス名で、一行に一つのファイル名でなければなりません。 ODV リストファイルの

デフォルトの拡張子は.lst です。 組み込みリストファイルジェネレータで簡単にファイルリストを生成する

ことができます。 

 

リストファイルが作成されたら Import > NOAA NCEI Formats > World Ocean Database を選択して事前に作成し

たリストファイルを選択します。 前述のようにインポートオプションを指定して OK を押すとデータのイン

ポートが始まります。ODV はリストファイルにリストされている全てのファイルを読み、現在開いているコ

レクションに全ての測点をインポートします。 

 

WOD データは品質管理されており、データ保有者または NOAA NCEI によって品質が低い、または疑わし

いと判定されたフラグがかなりの量のデータに付与されている場合がある事に注意して下さい。ODV は

WOD ファイル内のデータ品質情報をインポートして維持し、WOD 品質フラグをターゲットデータコレクシ

ョンで使用されている品質フラグスキームに自動的にマッピングします。ターゲットコレクションが World 
Ocean Database variables を使用して作成された場合、データ変数は WOD 品質フラグスキームを使用し、

インポートファイル内の元の WOD 品質フラグは ODV コレクションに維持されます。データを見るときには、

解析から疑わしいデータや不良データを除外するために、オプションの Sample Filter を使用してデータ品質

と範囲フィルタを適用することを検討してください。 

 

個々の品質フラグに加えて、ODV は WOD プロファイルフラグも抽出します。全データ変数に関する連結さ

れたプロファイルフラグ値はメタ変数 WOD profile Flags に保存されます。第一データ変数「深度」はフラグ

値 0 と見なされることに注意してください。View > Station Filter > Customize によって WOD profile Flags を使

用して測点にフィルタをかけることができます。Text Meta Variables の下の Meta Data ページ上で WODprofile 

Flags 変数を選択し、適切なワイルドカード表現を入力してください。例えば ?0* と入力すると第二データ

変数（水温）に関するプロファイルフラグ０（許容されたキャスト）の測点が選択されます。プロファイル

フラグ値の記述を見るには WODprofile Flags 線上にマウスを置いてください。 
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4.4 Argoフロートデータ（Argo Float Data）  
ODV を使用して、単一または複数の Argo core, bio (バージョン 3.1)、および synthetic s-profile (バージ

ョン 1.0) netCDF ファイルから ODV プロファイルまたは軌跡データコレクションにプロファイルおよび軌

跡データをインポートできます。Argo のインポートはコレクションを開いていないときでも実行でき、その

場合はインポートしたデータを受け取る適切なターゲットコレクションが自動的に作成されます。Argo ファ

イ ル は Coriolis お よ び GODAE の デ ー タ セ ン タ ー （ http://www.corio-lis.eu.org/ お よ び 

http://www.usgodae.org/argo/argo.html）からダウンロードできます。ODV は Argo の.nc ファイルのみ

ならず.gz または.zip パッケージも受け付けます。 

 

Argo データは、Argo プロファイルまたは軌跡変数セットを使用してデータコレクションに読み込まなけれ

ばなりません。そのようなコレクションをまだ開いていない場合は File > New オプションを使用して作成し

てください。データ変数を定義するように求められたら、インポートしたいデータの種類に応じて Argo 

Profile または Argo Trajectory を選んでください。Argo 中間パラメータのデータもインポートしたい場合は

Argo Profile ( including intermediate variables)を選択してください。受け取るコレクションが作成されて開かれ

ていたら Import > Argo Formats > Profiles または Import > Argo Formats > Trajectories を選択するとデータのイ

ンポートが始まります。Argo プロファイルまたは軌跡のインポートはコレクションが開かれていなくても呼

び出すことができ、その場合はインポートしたデータを受け取る適切なターゲットコレクションが自動的に

作成されます。その後 ODV は標準の「ファイルを開く」ダイアログを表示するので、所定のディレクトリの

中の一つ以上の Argo netCDF データファイルを選択してください。 あるいは処理対象のファイル名のリス

トを含む ASCII ファイルを選択することもできます。このリストファイルはインポートを始める前に準備す

る必要があります。一行につき一つの絶対ファイルパスのエントリを含める必要があります。リストファイ

ルの拡張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルリストを生

成することができます。 

 

ODV はインポートオプションダイアログを表示します。Argo プロファイルや軌跡データ（上記参照）用に

作成されたコレクションにインポートする場合は単に OK を押すだけでデータのインポートが始まります。 

 

Argo プロファイルまたは軌跡コレクションの変数には圧力、水温、塩分、酸素、および Bio-Argo ファイル

で提供される多くの生物光学変数が含まれます。これらの変数には二つのバージョンがあります：（1）リア

ルタイムまたはオリジナルデータ（第一グループ; 変数ラベルの接尾辞が Original）、および（2）遅延モー

ドまたは補正データ（第二グループ; 接尾辞が adjusted）。ファイルにある補正エラーデータはそれぞれの

補正済み変数の 1-σ エラーデータ（上述訳注参照）として使用されます。リアルタイムデータファイルには

補正済みデータが含まれていないことに注意してください。 
 

http://www.corio-lis.eu.org/
http://www.usgodae.org/argo/argo.html
Suzuki Toru
ODV importに関しては重要な変更点が多々あります。
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NetCDF ファイル内の Argo データ品質フラグは認識され、インポート中にターゲット変数の品質フラグスキ

ームに変換されます。ターゲットコレクションが Argo プロファイルまたは軌跡コレクションの場合はオリ

ジナルの Argo 品質フラグ値が使用され、品質フラグ変換は行われません。 品質フラグマッピングの詳細に

ついては ODV_QualityFlagSets.pdf ファイルを参照してください。 

 

Argo プロファイルデータの場合、ODV 測点名はサイクル数、オプションのサブサイクルインジケータ（a、

b、c など）、データモードインジケータ（R はリアルタイムデータ、D は遅延モードデータ、A は補正済み

リアルタイムデータ）およびプロファイル方向コード（A は昇順、D は降順）で構成されます。Argo 軌跡デ

ータの場合、ODV 測点名は軌跡指標とデータモードインジケータ（R はリアルタイムデータ、D は遅延モー

ドデータ、A は補正済みリアルタイムデータ）で構成されます。データが Bio-Argo ファイルからインポート

した場合、接尾語_bio が測点名に追加されます。一例として、測点ラベル 71a_R_A は、フロートサイクル 71

の第２昇順プロファイルからのリアルタイムデータを含む測点を示します。ラベル 15_D_A は、フロートサイ

クル 15 の第一昇順プロファイルの遅延モードデータ用です。それぞれのプロファイル測定の説明について

は Vertical Sampling Scheme メタ変数の値を参照してください。 
 
全ての場合において Argo プラットフォーム番号が Cruise メタ変数に使用されます。Argo 軌跡ファイルをイ

ンポートするときは有効な地理的位置を持つサイクルのみがインポートされます。 
 
上記の手順に従った Argo プロファイルと軌跡のインポートでは、多くの生物光学および生化学パラメータ

に関して定義された、いくつかの Bio-Argo ファイルに含まれている Argo 中間パラメータ（Argo リファレ

ンス表 3 を参照）は除外されます。最初に File > New で新しいターゲットコレクションを作成し、Argo 

Profile（including intermediate variables）コレクションテンプレートを選ぶと、インポートに中間パラメータ

を含めることができます。このコレクションを開いた状態で Import > Argo Formats > …の順に選択して Argo

のインポートを始めると上述の処理が進行します。 
 
インポートが完了したら View > Sample Filter オプションで適切な品質フラグ選択基準を設定してデータをフ

ィルタリングし、解析から不良データを除外することができます。 

 

4.5 CORA水温・塩分データ（CORA Temperature and Salinity Data） 
ODV を使用して、単一または複合 Coriolis Ocean database for ReAnalysis (CORA, netCDF バージョン

3.0)ファイルから水温・塩分データのプロファイルを ODV プロファイルデータコレクションにインポートで

きます。CORA のインポートはコレクションを開いていなくても実行できます；この場合、インポートした

データを受け取るのに適切なターゲットコレクションが自動的に作成されます。CORA ファイルは Coriolis

データセンター http://www.coriolis.eu.org/Data-Products/Products/CORA からダウンロードできます。ODV

は CORA .tgz パッケージだけでなく.nc ファイルも受け付けます。 
 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.coriolis.eu.org/Data-Products/Products/CORA
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Easy CORA データファイルは現時点ではサポートされていません。 
 
Import > CORA netCDF 3.3 を選択すると CORA のインポートが始まります。ODV は標準の「ファイルを開く」

ダイアログを表示するので、所定のディレクトリから一つ以上のファイル(.nc または.tgz)を選んでください。

もしくは処理対象のファイル名のリストを含む ASCII ファイルを選ぶこともできます。リストファイルの拡

張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルのリストを作成で

きます。 
 
ODV はインポートオプションダイアログを表示します。CORA プロファイルデータのために作られるコレク

ションに読みこむ場合は単に OK を押すだけでデータのインポートが始まります。 
 
CORA プロファイルコレクションの変数には深度、水温および塩分が含まれています。これらの変数には二

つのバージョンが入ります：(1)リアルタイムまたはオリジナルデータ(第一グループ；変数ラベルに接尾語

(original))、(2)遅延モードまたは補正データ(第二グループ；接尾語は(adjusted))。ファイル中に見られる補

正エラーデータは各々の補正変数の 1-σエラーデータが使用されています。リアルタイムデータファイルに

は補正データが含まれていないことに注意してください。 
 
NetCDF ファイル中の CORA データ品質フラグは識別されて、読み込み中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが CORA プロファイルコレクションであれば、オリジナル

CORA 品質フラグ値が使用され、品質フラグ変換は行われません。品質フラグ変換の詳細は ODV品質フラグ

セットを参照してください。 
 
各々のプロファイルの測定法に関する記述は Vertical Sampling Scheme メタ変数の値を参照してください。

CORA プラットフォーム番号は Cruise メタ変数に使用されています。 
 
インポートが完了したら View > Sample Filter オプションで適切な品質フラグ選択基準を設定してデータをフ

ィルタリングし、解析から不良データを除外することができます。 
 

4.6 GTSPP – (全球水温・塩分プロファイルプログラム/Global Temperature-

Salinity Profile Program） 
ODV を使用して GTSPP netCDF バージョン 3.8 および 4.0 形式のファイルから ODV データコレクション

にデータをインポートできます。GTSPP のインポートはコレクションを開いていなくても実行できます。そ

の場合、インポートしたデータを受け取る適切なターゲットコレクションが自動的に作成されます。GTSPP

ファイルは米国海洋データセンター（US National Oceanographic Data Center; 訳注：現 NOAA NCEI（米国大気

海洋庁国立環境情報センター））からダウンロードできます: http://www.nodc.noaa.gov/GTSPP/ 

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.nodc.noaa.gov/GTSPP/
Suzuki Toru
原文ではbioArgoですが，Bio-Argoまたは BGC-Argoが一般的のようです。
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GTSPP データは GTSPP 変数を使用してデータコレクションにインポートしなければなりません。そのよう

なコレクションをまだ開いていない場合は File > New オプションを使用して作成してください。データ変数

を定義するように促されたら GTSPP（Global Temperature-Salinity Pro-file Program）を選択します。データの

インポートを開始するには Import > NOAA NCEI Formats > GTSPP を選んでください。ODV は標準の「ファイ

ルを開く」ダイアログを表示するので、所定のディレクトリから一つ以上の圧縮形式の GTSPP パッケージフ

ァイル（.tgz または.zip）または GTSPP netCDF データファイル（.nc）を選択してください。あるいは処理

対象のファイル名のリストを含む ASCII ファイルを選択することもできます。このリストファイルはインポ

ートを開始する前に準備する必要があります。一行に一つのファイルパスエントリが必要で、ファイルパス

は絶対パス名にする必要があります。リストファイルの拡張子は.lst でなければなりません。組み込みリスト

ファイルジェネレータで簡単にファイルリストを生成することができます。 

 

ODV はインポートオプションダイアログを表示します。GTSPP データ用に作成されたコレクション（上記

参照）にインポートする場合は単に OK を押すだけでインポートが始まります。 

 

GTSPP コレクションの変数は深度、水温、塩分です。GTSPP ファイル内の圧力値は全てインポート中に深

度に変換されます。GTSPP コレクションには Data Type という追加のメタ変数があります。この変数は使用

される IGOSS 無線メッセージの種類または測器の種類に関する情報を保持します。この情報にアクセスする

には ODV バージョン 4.4.2 以降が必要で、それ以前のバージョンではこれらの値は表示されません。 
 
NetCDF ファイル内の GTSPP データ品質フラグは認識され、インポート中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが ODV で作成された GTSPP コレクション（推奨）の場合、

品質フラグ変換は行われずにオリジナルの GTSPP 品質フラグ値がコレクションに格納されます。品質フラグ

マッピングの詳細については ODV_QualityFlagSets.pdf ファイルを参照してください。 
 
インポートが完了したら、適切な品質フラグまたは範囲サンプルフィルタ設定を設定することでデータをフ

ィルタリングし、解析から不良データを除外することができます。 
 

4.7 GOSUD – (全球海洋表層航走データ/Global Temperature-Salinity Underway 

Data) 
ODV を使用して GOSUD netCDF バージョン 3 フォーマットファイルから ODV データコレクションにデー

タをインポートできます。GOSUD のインポートはコレクションを開いていなくても実行できます。この場

合、インポートしたデータを受け取るのに適切なターゲットコレクションが自動的に作成されます。GOSUD

のリアルタイムファイルと遅延モードファイルは http://www.gosud.org/からダウンロードできます。 

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://www.gosud.org/
Suzuki Toru
Ver.5.2.0で追加
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GOSUD データは GOSUD 変数を使用してデータコレクションにインポートしなければなりません。そのよ

うなコレクションをまだ開いていない場合は File > New オプションを使用して作成してください。データ変

数を定義するように促されたら GOSUD（Global Ocean Surface Underway Data）を選択します。データのイン

ポートを開始するには Import > GOSUD netCDF v3.を選んでください。その後 ODV は標準の「ファイルを開く」

ダイアログを表示するので、所定のディレクトリの中から一つ以上の GOSUD netCDF データファイル（.nc）

を選択してください。あるいは処理するファイル名のリストを含む ASCII ファイルを選択することもできま

す。 このリストファイルはインポートを開始する前に準備する必要があります。一行につき一つの nc ファ

イルのパスエントリを含める必要があり、ファイルパスは絶対パス名にする必要があります。リストファイ

ルの拡張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイルリストを生

成することができます。 

 

それから ODV はインポートオプションダイアログを表示します。GOSUD データ用に作成されたコレクショ

ン（上記を参照）にインポートする場合は単に OK を押すだけでデータのインポートが始まります。 
 
GOSUD コレクションの変数は深度、水温、塩分です。 品質管理された遅延モードデータは通常、オリジナ

ルの値に加えて補正水温および塩分のデータも含んでいます。 
 
NetCDF ファイルの GOSUD データ品質フラグは認識され、インポート中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが ODV で作成された GOSUD コレクションの場合（推奨）、

品質フラグの変換は行われずにオリジナルの GOSUD 品質フラグの値がコレクションに格納されます。品質フ

ラグマッピングの詳細については ODV_QualityFlagSets.pdf ファイルを参照してください。 
 
インポートが完了したら、適切な品質フラグまたは範囲サンプルフィルタ設定を設定してデータをフィルタ

リングし、解析から不良データを除外することができます。 
 
4.8 WOCE海洋観測データ (WOCE Hydrographic Data) 
ODV を使用して WHP 交換フォーマットによるオリジナル海洋観測データを既存または新規のデータコレク

ションにインポートができます。WOCE のインポートはコレクションが開かれていなくても実行できます。

この場合、インポートファイルに含まれる変数の上位集合が決定されて適切な受け取りコレクションが自動

的に作成されます。 

 

WHP 交換フォーマットのデータファイルは CLIVAR＆Carbon Hydrographic Data Office（CCHDO）にあ

ります。 
 
データを既存のコレクションにインポートするには、そのコレクションを開いてください。新しいコレクシ

ョンにインポートするには、コレクションを作成する際にコレクションに格納する変数を定義するときに必

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://whpo.ucsd.edu/format.html
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ず WOCE WHP Bottle variables または WOCE WHP CTD variables を選択してください。選択した WOCE インポ

ートファイルの内容に基づいて適切なコレクションを自動的に作成するには、どのコレクションも開かずに

Import > WOCE Formats > ...を使用して適切な WOCE のインポートを開始して、新しい ODV データコレクシ

ョンの名前と場所を指定してください。 

 

WHP 交換フォーマットの採水データを現在開いているコレクションにインポートするには、ODV のメイン

メニューから Import > WOCE Formats > WHP Bottle (exchange format)の順に選択してください。標準のファイ

ル選択ダイアログを使用して WHP データセットを選択します。WHP bottle 交換ファイルのデフォルトの接

尾辞は_hy1.csv です。データファイルの拡張子が異なる場合は、ファイル選択ダイアログのファイルタイプで 

All Files を選択してください。次にインポートオプションを指定して OK を押すとデータのインポートが始ま

ります。ODV はデータファイル内の全ての測点を読んでインポートします。ODV は実データ値に加えて

WOCE データ品質フラグを識別してインポートします。これらの品質フラグは、例えば解析から不良もしく

は疑わしいデータを除外するためのデータのフィルタリングとして後で使用する事ができます。マップポッ

プアップメニュー（Sample Selection タブを選択)から選択基準を選んでデータ品質フィルタを変更できます。 

 
複数の測点を含むファイルをインポートする場合、ODV は航海名または測点番号が変わるたびに測点を分割

します。測点の経度、緯度および占有時間は個々のサンプル値の平均として得られます。無効な経度または

緯度の値を持つサンプルはインポートされません。 

 

WOCE WHP Bottle ファイルの先頭にあるコメントは抽出されてコレクションの一部として別々のテキスト

ファイルに保存されます。これらのファイルへのリンクはメタ変数 Comments に記録されており、その内容

は Comments リンクをクリックするだけで見ることができます。Cruise Information Linke メタ変数はそれ

ぞれの CCHDO 航海ページへのリンクを含んでいます。航海報告へのリンクは CCHDO 航海ページ上にあり

ます。 
 
現在開いているコレクションに CTD データをインポートするには、ODV のメインメニューから Import > 

WOCE Formats > WHP CTD (exchange format) の順に選択してインポートする CTD データが含まれている

_ct1.zip ファイルを選択します。インポートオプションを設定した後、ODV は圧縮ファイルを展開して全て

の CTD 測点を現在開いているコレクションにインポートします。拡張子が異なるインポートファイルは、フ

ァイルタイプフィルタを単一の CTD プロファイルの場合は_ct1.csv に、または All Files に切り替えて選びま

す。 
 
一度のインポート操作で複数の WHP Bottle または CTD 交換ファイルからデータをインポートできます。そ

のための方法の一つは、インポートファイルの名前を含むデフォルトの拡張子.lst を持つ ASCII ファイルを

用意することです。絶対パス名を使用して一行につき一つのファイル名を指定してください。次に WOCE 
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formats > WHP Bottle（exchange format）または WOCE formats > WHP CTD（exchange format）のいずれか

を選択し、ファイルタイプフィルタを.lst に変更してリストファイルを選択し、読み込みオプションを指定し

て OK を押すとデータのインポートが始まります。複数のデータファイルをインポートするもう一つの方法

は、「ファイルを開く」ダイアログで複数の WHP ボトルまたは CTD 交換ファイルを単純に選択することで

す。複数の.lst リストファイルを選択すると最初の一ファイルだけがデータインポート用に認識されます。 
 
4.9 Medatlasフォーマット・データ（Medatlas Format Data） 
地 中 海 と 黒 海 の 海 中 デ ー タ を 含 む MEDAR/Medatlas 2002 デ ー タ 集  (MEDAR Group, 2002 – 

MEDATLAS/2002 database, Mediterranean and Black Sea database of temperature salinity and bio-

chemical parameters. Climatological Atlas. IFREMER Edition (4 CDs)) を作成するために Medatlas フ

ォーマットが使用されました。流速計、サーミスタチェーン、験潮儀、気象ブイ、セジメントトラップによ

る様々な形式の時系列データにも Medatlas フォーマットは使用されています。 
 
ODV はこれらの多様なデータ型を全てインポートできます。 異なるデータ型の変数セットは大きく異なる

ため、受け取るデータコレクションがそれらと一致する変数セットを使用していることが重要となります。

Medatlas ボトルおよび CTD プロファイルデータ用に事前に定義されている変数セットと、二つの時系列デ

ータ用の変数セット（一つはセジメントトラップのデータ、もう一つはその他全ての時系列データ）があり

ます。Medatlas データ用の新しいコレクションを作成するときには適切な変数セットを選んでください（下

記参照）。 

 

Medatlas フォーマットのデータは任意の ODV データコレクションにインポートできますが、Medatlas イ

ンポート変数とコレクションのターゲット変数との手動の関連付けが常に求められます。Medatlas 時系列コ

レクションの Time は、1900-01-01 00:00 からの経過年として提供されています。他の単位（例えば日数）や

別の参照日を使用することはできません。データのインポートを容易にし、手動による変数の関連付けを避

けるためには適切な Medatlas 変数セットを使用してターゲットコレクションを作成してください。そのよう

なコレクションを作成するには File > New オプションを使用してください。データ変数を定義するように求

められたら、Medatlas ボトルデータには Medatlas Bottle variables、Medatlas CTD、XBT または MBT デー

タには Medatlas CTD variables、Medatlas セジメントトラップデータには Medatlas Sediment Trap variables、

その他の Medatlas 時系列データ（例えば流速計、サーミスタチェーン、験潮儀、気象ブイ）には Medatlas 

Time Series variables を選択してください。 

 

Medatlas のインポートはコレクションを開いていなくても実行できます。その場合はインポートしたデータ

を受け取るのに適切なターゲットコレクションが自動的に作成されます。 
 
データのインポートを開始するには、ボトル、CTD、XBT または MBT データの場合は Import > Medatlas 

Formats > Profile Data、または任意の種類の時系列データの場合は Import > Medatlas Formats > Time Series 
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Data を選択してください。どちらのインポートタイプでもインポートする一つ以上の Medatlas データファ

イルを選択できます。あるいは処理するファイル名のリストを含むテキストファイルを選択することもでき

ます。このリストファイルはインポートを開始する前に準備する必要があります。一行に一つのファイルエ

ントリを含める必要があり、ファイル名は絶対パス名とする必要があります。 リストファイルの拡張子は.lst

でなければなりません。組み込みリストファイルジェネレータで使って簡単にファイルリストを生成するこ

とができます。 
 
ODV によって作成された Medatlas の時系列データおよびセジメントトラップのデータコレクションには、

流速計、サーミスタ、海面計、気象ブイ、セジメントトラップといった個々の測器の配置深度を含むメタ変

数 Instrument Depth が含まれます。  

 

Medatlas データファイルの GTSPP 品質フラグは認識され、インポート中にターゲット変数の品質フラグス

キームに変換されます。ターゲットコレクションが ODV で作成された Medatlas プロファイル、時系列、ま

たはセジメントトラップのコレクションの場合、品質フラグ変換は行われずにオリジナルの GTSPP 品質フラ

グ値がコレクションに格納されます。品質フラグマッピングの詳細については ODV_QualityFlagSets.pdf ファ

イルを参照してください。 

 

4.10 MEOP 海洋哺乳類データ（MEOP Marine Mammals Data） 
MEOP 海洋哺乳類プログラム https://www.meop.net/からプロファイルデータをインポートできます。

MEOP netCDF データファイルは https://www.meop.net/database/からダウンロードできます。 

 

MEOP データは MEOP 変数を使ってデータコレクションにインポートしてください。もしそのコレクション

をまだ開いていなければ、File > New オプションを使って作成してください。データ変数の定義を促されたら

MEOP Sea-Mammals Profile を選んでください。データインポートを開始するには Import > MEOP netCDF を選

んでください。ODV は標準の「ファイルを開く」ダイアログを表示するので、そのディレクトリにある一つ

以上の MEOP netCDF データファイル(.nc)を選んでください。もしくは、処理されるファイル名のリストを

含んだ ASCII ファイルを選んでください。このリストファイルはインポートを始める前に用意してください。

一行につき一 nc ファイルパスを記入し、ファイルパスは絶対パス名としてください。リストファイルの拡張

子は.lst でなければなりません。組み込みリストファイル生成機能で簡単にリストファイルを作成できます。 

 

ODV はインポートオプションダイアログを表示します。作成された MEOP データのコレクション（上記参照）

にインポートするには、単に OK を押すだけでデータインポートが始まります。 

 

netCDF ファイルの中の MEOP データ品質フラグはインポート中にターゲット変数の品質フラグスキームに

従って解釈され変換されます。ターゲットコレクションが ODV で作成された MEOP コレクション（推奨）

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
https://www.meop.net/
https://www.meop.net/database/
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であれば、品質フラグは変換されず、元の MEOP 品質フラグ値がコレクションに保存されます。品質フラグ

マッピングの詳細は ODV_QualityFlagSets.pdf を参照してください。 

 

一度インポートすると、適切な品質フラグの設定またはサンプルフィルタ設定によりデータをフィルタリン

グして解析から不良データを除外することができます。 
 
4.11 Sea-Bird CNV ファイル（Sea-Bird CNV Files） 
ODV を使用して Sea-Bird .cnv ファイルから既存のコレクション、またはインポートファイルの特定の内容

に適するよう自動的に作成された新しい ODV データコレクションにデータをインポートできます。Sea-

Bird.cnv ファイルは Sea-Bird 社製 SBE データ処理ソフトウェアを使用して生の Sea-Bird ファイルから作成

されます。そのファイルをインポートするとき、ODV はダウンキャストとアップキャストを別々の測点とし

て分割することができます。ODV はユーザー指定の圧力区間毎にデータを平均することもできます。これら

の機能を有効にする方法は 2.13 節 Sea-Bird CNVのインポートを参照してください。 
 
Sea-Bird.cnv ファイルから既存の ODV データコレクションにデータをインポートするには、まず受け取る

コレクションを ODV で開きます。次に一つ以上の Sea-Bird CNV ファイルを ODV アプリケーションウィン

ドウにドラッグ・アンド・ドロップします。またはメインメニューから Import > Sea-Bird CNV を選んで一つ

以上の Sea-Bird.cnv ファイルを選択します。処理する.cnv ファイル名のリストを含む ASCII ファイルを選択

することもできます。このリストファイルはインポートを開始する前に準備する必要があります。一行につ

き一つのファイルパスエントリを含める必要があり、ファイルパスは絶対パス名である必要があります。リ

ストファイルの拡張子は.lst でなければなりません。組み込みリストファイルジェネレータで簡単にファイル

リストを作成することができます。その後 ODV はインポートオプションダイアログを表示し、承認された場

合は選択した全てのファイルをインポートします。 
 
コレクションが開かれていない場合は Sea-Bird.cnv ファイルを ODV ウィンドウにドロップしたとき、また

は Import > Sea-Bird CNV オプションで Sea-Bird.cnv ファイルを選択したとき、ODV は Sea-Bird ファイル

の内容を分析してインポートファイルに含まれる全ての変数を含むコレクションを自動的に作成します。こ

のコレクションがファイルからデータを受け取ります。ODV は標準の「ファイルを保存する」ダイアログを

表示するので、新しく作成されたデータコレクションの名前とパスを指定します。 

 

名前の一部として次の文字列: depth、pressure、time または julian days のいずれかを含む.cnv ファイルの最

初の変数が、新しく作成されたコレクションの主要変数になります。これはプロファイルの場合は圧力また

は深度であり、時系列の場合は時間変数です。.cnv ファイルの深度、圧力、または時間変数が別の名前を使

用していて自動的に識別されない場合は、インポートが完了した後に手動でコレクションの主要変数を設定

する必要があります。これを行う方法については Changing Collection Properties（コレクションのプロパ

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
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ティの変更）の章を参照し、鉛直プロファイルファイルには圧力または深度を、時系列データには Julian 

Days などの時間変数を選択してください。 
 
ODV はユーザー指定の圧力区間毎に Sea-Bird データの区間平均プロファイルを作成できます。この機能を

有効にする方法は 2.13 節 Sea-Bird CNV インポートを参照してください。ODV はファイルごとに鉛直座標

変数を検索し、必要に応じてデータを圧力に変換し、区間平均を実行します。現在の ODV では指定された順

序で次の Sea-Bird パラメータコードを検索します： 

1. 圧力[db]: prM, prDM, pr50M, prSM, prdM (変換なし)  

2. 圧力[psi]: prE, prDE, pr50E, prSE, prdE (0.0689476 倍)  

3. 圧力、FGP [KPa]: fgp0-fgp7 (0.001 倍)  

4. 深度 Depth [m]: depSM, depFM, dNMEA (TEOS10 変換)  

5. 深度 Depth [ft]: depSF, depFF (0.3048 倍, TEOS10 変換)  

 
圧力データまたは深度データを含むファイルごとに、ODV はファイルにダウンキャストとアップキャストが

含まれるかどうかをチェックし、二つの別々の測点としてデータを保存します。ターゲットコレクションで

は Cast Type メタ変数で up-cast と down-cast 文字列で表されています。アップキャストとダウンキャス

トへの分割は、設定ダイアログにおいてオンまたはオフに切り替えることができます（2.13 節 Sea-Bird 

CNVインポート参照）。 

 

Sea-Bird.cnv ファイルのヘッダーは提供されるメタデータ項目の数と形式においてかなり異なります。次の

規則が満たされる場合、ODV は航海名、測点名、日付と時刻、経度と緯度などのメタデータ項目を認識しま

す： 

1. メタデータ行は「**」（ユーザーメタデータ）または「* NMEA」で始まっていなければなりません。 

2. NMEA メタデータには名前と値を区切るための「=」文字を含める必要があり（例：* NMEA Latitude = 

44 01.58 N）、ユーザーメタデータには区切り文字として「：」を使用する必要があります（例：** 

Latitude: 44 01.58 N） 

3. 次の NMEA メタデータがサポートされています：NMEA Latitude、NMEA Longitude、NMEA UTC (Time） 

4. 航海名には Cruise ラベルを付けなければなりません 

5. 測点名には Station ラベルを付けるか、Station という単語を含める必要があります。 

6. 経度と緯度には Longitude と Latitude のラベルを付ける必要があります。 

7. 経度と緯度の値は「(D)DD MM.mm O」フォーマットに従う必要があります：ここで(D)DD は二桁ま

たは三桁の度を、MM.mm は十進分を、O は方位 N、S、E または W を表します。 

8. 日付と時刻には UTC（Time）ラベルを付けなければなりません。 
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9. 日付と時刻は「MMM dd yyyy hh:mm:ss」フォーマットに従う必要があります：ここで MMM は三文

字の英語の月の省略形（例：May）を表します。 

10. 水深情報には Bottom Depth [m]ラベルを付ける必要があります。 

 

Sea-Bird.cnv ファイルには複数のキャストのデータが含まれています。マルチキャスト.cnv ファイルはファ

イルのヘッダーに特殊なキャスト説明行を含める必要があります。ファイル内のキャストごとに一つのキャ

スト説明行がなければなりません。キャスト説明行は次のフォーマットでなければなりません： 
* cast 4 07 Jul 2015 09:00:29 samples 6415 to 7768, avg = 1, stop = mag switch 
ここで samples エントリはそれぞれのキャストの最初と最後のデータ行インデックスを指定します。* END *

ヘッダー終端子の後の最初のデータ行がデータ行インデックス 1 となります。 
 
Sea-Bird.cnv ファイルのデータは経度または緯度をファイルから取得できないとインポートされません。航

海名および／または測点名が見つからない場合、ODV はそれぞれ unknown とそのファイル名を割り当てま

す。 

 

Sea-Bird.cnv ファイルのインポート中に作成されたコレクションには、コレクションの misc/comments ディ

レクトリに自動的に作成されたコメントファイルの名前を測点毎に保持する Comments メタ変数が追加で含

まれています。コメントファイルには.cnv ファイルの先頭から抽出された全てのヘッダー行が含まれていま

おり、通常はセンサーの識別子やキャリブレーションデータなどの重要な情報が含まれています。Comments

メタデータ値をクリックすると Web ブラウザにコメントファイルの内容が表示されます。ODV は cnv ファ

イルからオペレーターおよび ship/vessel メタデータを抽出し、その値を Operator および Ship メタ変数に

提供します。 
 
4.12 Associate Meta-variablesダイアログ（Associate Meta-variables Dialog） 
データをインポートするとき、ODV は自動的にインポートファイル内から航海名、測点名、観測日、経度、

緯度といった必須のメタデータの位置を突き止めようとします。このメタ変数の自動関連付けに失敗して既

存のコレクションにインポートする場合（インポートタイプ 1）、Associate Meta Variables ダイアログを表示

して（図 4-2 を参照）、ユーザーにメタデータのソースを手動で識別するように求めます。 

 

新しい関連付けを定義するには Source Variables リストと Meta Variables リストから関連付けたい変数を選択

して Associate を押します。インポート中に変換を実行するには Convert を押して使用可能な変換アルゴリズ

ムを一つ選択します。既存の関連付けを削除するには、それぞれの変数を選択して Undo を押します。インポ

ートファイルに所定のメタ変数に関する情報が含まれていない場合は、次の手順でデフォルト値を指定しま

す：（１）それぞれのメタ変数を選択し；（2）Set Default を押して（3）デフォルト値を入力します。指定

したデフォルト設定がファイル内の全てのデータ行に使用されることに注意してください。完了したら OK

を押し、もしくは Cancel を押して読み込みを中止します。Longitude と Latitude のメタ変数は関連付けられ
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ている必要があり（ODV は地理的位置がないと測点を処理できません）、そうでなければ OK ボタンは無効

のままです。 

 

ISO8601 の日付と時刻の仕様 YYYY-MM-DDTHH:MM:SS.SSS のような複合ソース変数の関連付けまたは

変換の際には、複数のターゲットメタ変数（例えば年、月、日、など）が自動的に結合されます。 

 

図 4-2：Associate Meta Variablesダイアログ 

 

4.13 インポートオプションダイアログ （Import Options Dialog） 

既存のコレクションにデータをインポートするとき（インポートタイプ 1）、Import Options ダイアログが表

示されるので、インポートファイルのソースデータ変数とターゲットコレクションのデータ変数を関連付け

てください。インポートモードを選択し、インポートする測点がターゲットコレクションに既に存在するか

どうかを確認するために必要とされるパラメータを指定する事が出来ます（図 4-3 を参照）。 
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図 4-3：インポートオプションダイアログ 

 

インポートモード（Import Mode） 

Add/Replace Station Data：インポートファイルからコレクションにデータを追加する場合はこのオプシ

ョンを選択します。Check for existing stations ボックスがチェックされている場合、ODV はユーザー指定

の基準を適用して一致する測点をターゲットコレクションから検索し、見つかった場合はターゲットコ

レクション内の既存の測点をインポートファイルから新しいデータで置き換える許可を求めます（測点

検索手順の説明については下記 Station and Sample Match-ing Criteria を参照）。 

 

SDN データファイルまたは SDN ターゲットデータコレクションに SDN データコレクションをインポー

トするとき、LOCAL_CDI_ID, データバージョン、および EDMO コードを基に既知の同一測点を検索し

ます。バージョンが下位もしくは同じ既知の同一測点は上書きされます。 
 
Merge Data (selected variables)：一つ以上の変数のデータを追加し（変数の統合）、他の変数の既存のデ

ータを変更しない場合はこのオプションを選択します。あるサンプルの統合変数の統合値は表 4-2 に示

すように既存のデータ値と新しいデータ値に依存します。このモードでは Check for existing stations ボッ

クスのチェックを外すことはできません。データを追加する前に ODV はコレクション内で一致する測点

を検索し（測点検索手順の説明については Station and Sample Matching Criteria を参照）、見つかった場

合そのコレクションからオリジナルの測点を読み取り、選択した変数を追加して更新されたバージョン

でオリジナルの測点を置き換えます。一致する測点が見つからない場合はユーザーに通知します。 
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Merge Data (selected variables)をインポートする場合、ターゲットコレクションの主要変数がソース変数

の一つに関連付けられていることを確認する必要があります。この関連付けはインポートしたデータを

受け取るサンプルを正しく識別するために必要です。主要変数が関連付けられていない場合 Import 

Options ダイアログ（図 4-3 を参照）の OK ボタンは無効になります。コレクションの主要変数を決定す

るにはオプション Collection > Properties > General を使用します。 
 

表 4-2：既存の値と読み込まれた値をマージした結果 

既存値 新値 統合値 

yes yes 既存と新しい値の平均 

yes no 既存値 

no yes 新値 

no no 欠測値 
 

Update Data (selected variables)：一つ以上の変数のデータを更新し（変数の更新）、他の変数の既存のデ

ータを変更しない場合はこのオプションを選択します。あるサンプルの更新変数の更新値は新しいデー

タ値にのみ依存し、既存の値は破棄されます。このモードでは Check for Existing Stations ボックスのチェ

ックを外すことはできません。データを更新する前に ODV はコレクション内で一致する測点を検索し

（測点の検索手順の説明については下記 Station and Sample Matching Criteria を参照）、見つかった場合

はコレクションからオリジナル測点を読み取り、選択された変数のデータを更新し、オリジナル測点を

更新されたバージョンに置き換えます。一致する測点が見つからない場合はユーザーに通知します。 

 

変数の関連付け (Variable Association) 

通常、インポートファイル内の変数の数、順序、および意味はターゲットコレクション内の変数の数、

順序、および意味とは異なり、実際のインポートが行われる前にソース変数とターゲット変数の間の接

続を確立する必要があります。最初に ODV は一致するラベル（名前と単位）を使用して変数を自動的に

接続しようと試み、ダイアログのソース変数リストとターゲット変数リストの中でアスタリスク「*」を

使用して関連付けされた変数に印を付けます。印付けられた変数をクリックすると接続相手の変数を識

別できます。 

 

Import Options ダイアログでは追加の接続を手動で作成するか、既存の接続を元に戻すことができます。 

あるターゲット変数は複数のソース変数と接続する事ができます。 
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ソース/ターゲット変数ペア間の接続を確立するには、それぞれのターゲット変数をクリックしてからタ

ーゲット変数に関連付けるソース変数をクリックして Associate または Convert ボタンのどちらかをクリ

ックします。インポートファイルのデータ値を変更せずにインポートする場合は Associate を使用し、イ

ンポート中に変換を実行する必要がある場合は Convert を使用します。Convert 変換を使用するときは事

前に定義された一般的に使用される変換（例えば単位変換）の中から選択することも、またはその代わ

りに独自の一般的な一次変換式を確立することもできます。 
 

質量当たり（例えば μmol/kg）と体積当たり（例えば μmol/l）との単位間の変換のために一定密度値

ρ=1.025 [kg/l]が使用されます。この特定の密度値は変換に必要な実験室条件（p=0 dbar; T=20°C）にお

ける平均海水密度を表します。サンプルの実際の塩分値を使用しないことによってもたらされる誤差は、

海洋環境では 0.2％未満です。μmol/kg と ml/l との間の酸素単位変換もまた ρ=1.025 [kg/l] の密度値およ

び STP (Standard Temperature and Pressure (標準状態); T=0[℃], p=1[bar] )で 22.391 l における

モル O2 体積を使用します。 深度/圧力変換は適切な TEOS-10 関数を使用します。 
 

あるターゲット変数に対して複数のソース変数を接続できます。これはインポートファイル内の異なる

測点ごとに、あるターゲット変数（例えば Oxygen）のデータが異なる列（そしておそらく異なる単位、

例えば Oxygen [μmol/kg]と Oxygen [ml/l]）にある場合に便利です。 

 
ソース/ターゲット変数接続の代わりに、インポートファイルに対応するソース変数が提供されていない

ターゲット変数にデフォルト値を指定する事ができます。あるターゲット変数にデフォルト値を設定す

るには Target Collection リストでターゲット変数を選択し、Set Default ボタンを押してターゲット変数に

希望するデフォルト値を入力します。デフォルト値を使用するターゲット変数には「+」記号が付きます。

指定された値はこの操作中にインポートした全ての測点の全てのサンプルに使用されます。 

 
ターゲット変数に関連付けられていないソース変数はコレクションにインポートされません。データを

コレクションに統合する場合は、ターゲットコレクションの主要変数とコレクションに追加する必要が

ある変数のセットとの関連付けを確立する必要があります。コレクション内に変更を加えたくないデー

タが既にある場合は変数を関連付けないでください。 
 

Import Options ダイアログの OK ボタンは、ターゲットコレクションの主要変数がいずれかのソース変数

に関連付けられるまで無効のままになります。 
 

測点とサンプルの合致基準（Station and Sample Matching Criteria） 

Check for existing stations ボックスをチェックした場合は Edit Matching Criteria…ボタンをクリックして、

インポートファイルの測点がターゲットコレクションの既存の測点の一つと合致するかどうかを判断し

ます（Station Matching ページ；図 4-4 を参照）。インポートする測点とターゲット測点のサンプルを一
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致させるための基準を変更することもできます（Sample Matching ページ）。サンプルマッチングは

Merge Data (selected variables)および Update Data (selected variables)のインポートにのみ実行されます。 
 

Station Matching ページでは、インポートする測点とターゲット測点の位置、日付/時刻、および名前な

どを比較するさまざまなテストをオンまたはオフにすることができます。要求されたテストが全て成功

した場合、二つの測点は合致すると見なされます。 経度、緯度、および時間の場合、インポート値とタ

ーゲット値が指定された許容範囲内であれば合致となります。 
 

インポートファイル内の航海ラベルがターゲットコレクション内の同じ測点の航海ラベルと異なる場合

は、Target collection cruise label コンボボックスで航海を選択し、Source file cruise label フィールドに別

の航海名を入力して Associate ボタンを押すと別の航海名として確立できます。インポートファイルで見

つかった別の航海名は、測点マッチング手順が開始される前に対応するターゲット航海名に自動的に変

換されます。これはインポートファイルとターゲットコレクションで航海名の異なるバージョンが使用

されている場合に便利です（例えば図 4-4 の ANT XV/4 対 SR04_06AQANTXV_4）。別名が定義されてい

ない場合は正確なクルーズ名の合致が必要です。 

     

図 4-4：合致基準ダイアログの二つのページ 

 

コレクション内で合致するターゲット測点を見つけることに加えて、Merge Data（selected variables）と

Update Data (selected variables)のインポートを実行するとき、インポートする測点とターゲット測点のサ

ンプルも合致している必要があります。サンプルマッチングはインポートサンプルとターゲットサンプ

ルの主要変数値を比較し、最も近い合致を見つけることによって行われます。サンプルMatchingページ

ではインポートサンプルとターゲットサンプルを合致と見なすためにどれだけ近いかを決定するパラメ

ータを指定できます。Add non-matching samples as new samplesボックスがチェックされている場合、不

一致サンプルは新しいサンプルとしてターゲット測点に追加されます。それ以外の場合で一致しないサ

ンプルは無視され、警告メッセージがインポートログファイルに書き込まれます。 
 

4.14 ファイルリストの生成（Generating File Lists） 
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ODV には、複数ファイルのデータをインポートするための.lst ファイルを作成するために利用できる、組み

込みリストファイルジェネレータがあります。これらのリストファイルは大量の Argo、SDN、WOD、また

は WOCE データファイルを一度に ODV にインポートする場合に便利です。リストファイルジェネレータを

呼び出すには Tools > List File Generator オプションを使用します。 

 
これらのファイルを生成するには、目的のファイルまたはディレクトリ全体をダイアログにドラッグ・アン

ド・ドロップするだけです。ディレクトリをドロップすると、そのディレクトリまたはサブディレクトリ内

の全てのファイルがリストに追加されます。ファイル名の先頭または末尾を指定したフィルタを適用すると、

フィルタを満たすファイルだけがリストに追加されます。これらのフィルタはファイルをドロップする前に

適用する必要があります。これにより開始および／または接尾辞が異なるファイルのリストを作成できます。

Case sensitive check ボックスをチェックすると、大文字と小文字を区別するフィルタリングを有効にできます。

ファイルリストが作成されたら重複の除去、または Validate ボタンか Clear ボタンを押して現在の選択内容を

消去することもできます。個々のエントリはリストから直接削除または編集できます。 
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5 データのエクスポート（Exporting Data） 
 

5.1 スプレッドシートファイル（Spreadsheet Files） 
Export> Data> ODV Spreadsheet File を選択して、現在選択されている測点のデータを単一の汎用 ODV スプレ

ッドシートファイルにエクスポートすることができます。対象ディレクトリ、ファイル名、およびファイル

タイプを選択してください。ODV スプレッドシートファイルのヘッダーを含むタブ区切りファイルをエクス

ポートするには Spreadsheet File (*.txt)ファイルタイプ（デフォルト）を、または Excel で簡単に使うた

めに最適なコンマ区切りファイルをエクスポートするには Comma Separated File (*.csv)ファイルタイプ

を選んでください。両ファイルタイプは ODV デスクトップアイコンにファイルをドロップするだけで ODV

に再インポートできます。ODV は列区切り文字の出現をエクスポートされるテキストから探索して、適切な

代替文字に置き換えることに注意してください。例えば csv エクスポートでは、テキスト中のコンマはセミ

コロンに置き換えられます。 

 

次にエクスポートファイルに含める拡張メタ変数およびデータ変数を選択し（デフォルト：全ての拡張メタ

変数および全ての基本変数；実際にデータが含まれているデータ変数を選択する場合は Select Items with Data

ボタンを押してください）、最後にエクスポートファイルのプロパティを指定します。Spreadsheet File 

Properties ダイアログ（図 5-1 参照）では、欠測値を表す文字列（デフォルト：空の文字列）、経度の範囲

（0〜360°E または-180〜180°E）、メタデータ日付形式  (ISO8601 yyyy-mm-ddThh:mm:ss.sss または

mon/day/year)、時系列の日付/時刻値に使用される日付/時刻形式（ISO8601 yyyy-mm-ddThh:mm:ss.sss または

Chronological Julian Days （訳注：CJD; Julian Day に 0.5 を加えてタイムゾーンを考慮したもの）または

Decimal Time in years（十進化年））を指定できます。Data date format エントリは時系列データに対しての

み有効になります。 

 

Data filter エントリでは、全てのデータをエクスポートするか、Spreadsheet File Properties ダイアログに続く

Sample Filter Settings ダイアログで指定できる品質および/または範囲選択基準を満たすサンプルのみをエク

スポートするかを指定できます。Use compact format チェックボックスをチェックすると、測点メタデータは

最初のサンプルにのみエクスポートし、その他の全てのサンプルのメタデータフィールドは空のままになり

ます。このオプションを使用すると、特に CTD、XBT、および多くの種類の時系列データなど、一測点あた

りのサンプル数が多いデータの場合にエクスポートファイルのサイズが大幅に節約できます。メタデータお

よび／またはデータ変数の品質フラグ値を出力したくない場合は Export metadata quality flags または Export 

data quality flags ボックスのチェックを外してください。 
 

Suzuki Toru
とは書いてあるものの，どこにもそれらの航海名が見当たらない…
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Export history ボックスがチェックされている場合、エクスポートした測点の履歴はスプレッドシートファイ

ルに書き出されます。履歴は//<History>のコメント行にまとめられ、所定の測点の履歴はその測点のデータ

の後に書き出されます。 
 
Export>Data ODV Collection を選択して、現在選択されている測点のデータを新しい ODV コレクションにエ

クスポートできます。 次に新しいコレクションに含める変数（デフォルト：全ての変数）を選択し、標準の

ファイル選択ダイアログボックスを使用して保存先ディレクトリとファイル名を指定します。 
 

図 5-1：Spreadsheet File Propertiesダイアログ 
 
5.2 NetCDFファイル (NetCDF Files) 
Export > Data > NetCDF File を選択して、現在選択されている測点のデータを単一の NetCDF ファイルにエク

スポートできます。次にターゲットディレクトリとファイル名を選択し、エクスポートファイルに含める拡

張メタ変数およびデータ変数を選択し（デフォルト：全ての拡張メタ変数および全ての基本データ変数；実

データを含むデータ変数を選択する場合は Select Items with Data ボタンを押してください）、最後にエクス

ポートファイルのプロパティを指定します。NetCDF File Properties ダイアログでは経度の範囲（0〜360°E ま

たは-180〜180°E）と、全てのデータ（サンプル）をエクスポートするか、現在の品質および／または範囲

フィルタを満たすものだけかを指定します。メタデータおよび／またはデータ変数の品質フラグ値をエクス

ポートしたくない場合は Export metadata quality flags および／または Export data quality flags ボックスのチ

ェックを外します。Data filter エントリでは、全てのデータをエクスポートするか、NetCDF File Properties ダ

イアログに続く Sample Filter Settings ダイアログで指定できる品質および／または範囲の選択基準を満たすサ

ンプルのみをエクスポートするかを指定します。 
 
エクスポートした netCDF ファイルの構造は以下の通りです： 

次元： 

 N_STATIONS にはファイルに含まれている測点の数が含まれています。 

 N_SAMPLES には一測点あたりの最大サンプル数が含まれています。 
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 さらに、一次元以上の STRINGi という形式があり、ここで i は整数で、関連するテキスト変数の最

大文字数を表します。 

変数： 

 longitude と latitude には測点の位置が保存されています。 

 date_time には、ある基準日からの測点のグレゴリオ暦の十進化日が含まれ、小数部は一日の端数を

表します。基準日には最も古い測点の年の 1 月 1 月が選択されています。 

 整数値 i を含む変数 metavari は他の ODV メタ変数の値を保存しています。全ての metavari 変数は

longitude, latitude および date_time と同様に N_STATIONS の次元にのみ依存します。 

 Vari 形式の名前を持つ変数は ODV データ変数のデータ値を格納します。これらの変数は

N_STATIONS と N_SAMPLES の次元に依存します。 

 必要があればメタデータおよび/またはデータ変数の品質フラグ値は vari_QC 形式の名前を持つ変数

に格納されます。 

属性（主に標準の NetCDF 属性）： 

 最低限、品質フラグ変数を除く全ての netCDF データ変数は属性 long_name と_FillValue を含みます。

long_name は ODV で使用されている変数の名前を格納します。_FillValue は使用された欠測値を格納

します。一部の変数には属性 units、C_format、FORTRAN_format、valid_min、valid_max、および/ま

たは comment も含まれます。 

 メタ変数 longitude, latitude および date_time はそれぞれ standard_name 属性値である longitudfe, 

latitude および time を格納します。長名 time_ISO8601 または Chronological Julian Date は

standard_name 属性 time を持ちます。Ocean Profiles コレクションの基本変数は属性 positive の値

down を持ちます。 

 NetCDF 品質フラグ変数は使用されている品質フラグスキームを説明する属性 Conventions および

comment を持ちます。 
 
データのソースおよびファイルの作成に使用されたソフトウェアに関する情報はグローバル属性で提供され

ます（表 16-6 を参照）。 

 

追加ファイル<nc filename> _nc_variables.txt が、関連する ODV メタデータおよびデータ変数名、単位、コ

メントとともに NetCDF 変数名のリストを含む出力ディレクトリに作成されます。 
 
ODV の netCDF ファイルはチャンキングと圧縮を使用しているため、読み取りには netCDF4 ベースのツー

ルが必要です。 
 
5.3 WHP 交換フォーマットでのエクスポート (WHP Exchange Format Export) 
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Export > Data > WHP Exchange File を選択して現在選択されている測点データを WHP 交換形式ファイルでエ

クスポートできます。ODV は Description of WHP-Exchange Format for CTD/Hydrographic Data（James H. 

Swift ＆ Stephen C. Diggs; September 2001, updated May 2006 & April 2008; 

http://cchdo.ucsd.edu/format/exchange/index.html）に記載されている Bottle および CTD 出力ファイ

ルの両方をサポートします。 
 
WHP Bottle または CTD エクスポートは次の手順で実行します： 

1. 必要に応じて地図領域を調整してエクスポートしたい測点のセットを選択および／または特別な測

点フィルタ設定を適用します。 

2. ODV のメインメニューから Export > Data > WHP Exchange File > Bottle または Export > Data > WHP 

Exchange File > CTD from の順に選択します。  

3. ODV が重要な変数を自動的に識別できない場合は、これらの変数を識別するように促されます： 
a. WHP ボトルのエクスポート：Pressure in Water Column[db]または Depth in Water Column[m]を

キー変数として特定する必要があります。 

b. WHP CTD のエクスポート：CTD として出力する場合は変数 Temperature [°C]および Pressure 

in Water Column[db]または Depth in Water Column[m]のいずれかが必要です。さらに Salinity 

[psu] と Oxygen を[μmol/ kg]または[ml / l]で識別するよう求められます。 

4. 出力ディレクトリとファイル名を指定します。 

5. WOCE ファイルのヘッダー（ファイルの最初の行）に必要な情報と、出力ファイルの一部にしたい

追加のコメントを指定します。 
 
エクスポートが完了するとファイルは手順 3 で指定した場所に書き込まれます。Bottle データをエクスポー

トした場合、出力ファイルは"_hy1.csv"で終わる単一の CSV テキストファイルになります。CTD としてエクス

ポートした場合、結果のファイルは出力された各測点に対して一つの CSV ファイルを含む接尾辞"_ct1.zip"を

持つ ZIP パッケージになります。 

 

WHP 交換ファイルでのエクスポートは主要変数（プロファイル）として圧力または深度を持つ ODV コレク

ションに対してのみ可能もしくは意味があります。コレクション内の深度値は WHP パラメータ CTDPRS に

書き込む前に圧力に変換されます。 

 

ODV 航海名は WHP パラメータ EXPOCODE、測点名は STNNBR、測点の日時情報は DATE と TIME の下に

エクスポートされます。欠落している時間と日付の情報は出力ファイルではゼロで示されるので、時間が不

明の場合その値は"0000"になります。位置は、緯度の場合は[-90、90]、経度の場合は[-180、180]の範囲

で保存されます。水深が ODV コレクションに存在する場合は、WHP パラメータ DEPTH に対応付けられま

す。 ODV コレクションにメタ変数 SECT_ID が含まれている場合、その値は WHP パラメータ SECT_ID の

下にエクスポートされます。 

http://cchdo.ucsd.edu/format/exchange/index.html
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WOCE WHP Bottle ファイルとしてエクスポートするとき、コレクションは変数 CASTNO、SAMPNO、お

よび BTLNBR についてスキャンされます。CASTNO（キャスト番号）がコレクションに含まれていない場合

はデフォルト値として 1 が使用されます。SAMPLNO（サンプル番号）が欠落している場合、ODV は 1 から

始まる連続サンプル番号を割り当てます。BTLNBR（ボトル番号）がコレクションにない場合、そのような

列は出力ファイルには現れません。他の全ての変数はコレクション内の名前を使用してエクスポートされま

す。エクスポートされる測点セットでデータ値が含まれていない変数は出力ファイルから除外されます。

ODV 派生変数はエクスポートされません。 

 

コレクションが既に WOCE 品質フラグを使用している場合、品質フラグは保持されます。それ以外の場合、

コレクション内の品質フラグはエクスポート前に WOCE スキーマに対応付けられます（対応付けの詳細につ

いては ODV_QualityFlagSets.pdf を参照してください）。WHP CTD としてエクスポートする場合、出力品質

フラグは WOCECTD または GTSPP です（IGOSS と同じ）。WHP ボトルとしてエクスポートする場合、出

力品質フラグは WOCEBOTTLE，または、WOCECTD または GTSPP で使用される CTDSAL 変数または

CTDOXY 変数、 および WOCESAMPLE または GTSPP で使用される BTLNBR 変数を除く GTSPP のいずれ

かです。 
 
5.4 SDN集約 ODVコレクション (SDN Aggregated ODV Collection) 
Import > SeaDataNet Formats で作成されたデータコレクションは変数を自動的に集約し、Export > Data > SDN 

Aggregated ODV Collection で結果を新しいコレクションに書き込むことでさらに処理できます。 
 
集約を実行する前に ODV はまず http://vocab.nerc.ac.uk/collection/P35/current/から最新バージョンの P35

語彙をダウンロードします。P35 は寄与変数のリストと集約変数の優先単位を指定することによって多数の

集約変数を定義します。また ODV は ODV ウェブサイトから単位変換のリストの最新版をダウンロードしま

す。 インターネットに接続されていない場合 ODV はシステム上で利用可能なこれらのファイルの最新バー

ジョンを使用します。必要な単位変換は集計中に自動的に適用されます。P35 集約変数は SEADATANET 品

質フラグスキームを使用します。 

 

出力コレクション内の変数の順序は次の通りです： 

 ソースコレクションの主要変数、 

 ソースコレクションで寄与変数が見つかった P35 集約変数、 

 ソースコレクション内の P35 集約変数に寄与していない変数。 

 

http://odv.awi.de/fileadmin/user_upload/odv/misc/ODV_QualityFlagSets.pdf
http://vocab.nerc.ac.uk/collection/P35/current/
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ODV は P35 集約変数の値と品質フラグを計算するための二つのアルゴリズムを提供します：（a）利用可能

な最高品質の寄与値のみを使用する Best-of aggregation アルゴリズム、および（b）利用可能な全ての寄与値

を使用する Use-all アルゴリズムです。 

 

ODV では、使用されている元の変数の P01/P06 コードを含むサンプルごとの情報文字列を作成することも

できます。 この機能により出所情報が提供され、実際に計算に使用された元のデータを追跡することができ

ます。サンプルごとの情報文字列の作成と保存にはかなりのリソースが必要なので、詳細なバックトレーサ

ビリティが重要な場合にのみこの機能を使用してください。充分なストレージと長期処理時間に対する耐久

性をもっていないのであれば、数百万の測点や非常に多くの変数を含む大規模コレクションに情報文字列を

作成するのを防ぎます。 

 

P35 集約変数の値と品質フラグは次のようにして得られます： 
 
 一つの寄与変数のみにデータが含まれる場合 （only one contributing variable contains data）：値およ

び SDN 品質フラグを変更せずに使用します（Best of および Use-all アルゴリズムの両方で同じ手順）、 

 複数の寄与変数にデータが含まれている場合（more than one contributing variable contain data）：全

ての品質フラグを ODV スキームに対応付けし、最小（最高品質）および最大（最低品質）フラグ値

を決定します。その後で二つの集約アルゴリズムに対して異なる方法で処理します。 

（ａ）Best-of アルゴリズム：最小の ODV 品質フラグ値（最高の利用可能な品質；best-of）を有する寄与

値のみを使用します。 次に貢献度の最も高い値の中央値を計算します。最小の ODV 品質フラグを取り、

SEADATANET スキームに対応付けするか、あるいは、もし寄与値の全てのオリジナルフラグが同一であ

れば、共通のオリジナルフラグ値を使用します。 

（ｂ）Use-all アルゴリズム：全ての寄与値の中央値を計算します。対応付けされた ODV 品質フラグ値の

最大値を取り、SEADATANET スキームに再び対応付けします。 
 
ODV は P35 Aggregation Properties ダイアログを表示し、アルゴリズムの選択とサンプルごとの情報作成のオ

ン/オフの切り替えを許可します。 
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図 5-2：P35 Aggregation Propertiesダイアログ 

 

出力コレクションを開いて、Collection > Browse Info オプションを使用して未知の変換のリスト（存在する場

合）および構築された P35 集計変数とその寄与入力変数のリストを表示できます。 

 

寄与変数が未知の変換を必要とする場合、この入力変数は無視され、そのデータは集約に使用されません。 

変換に失敗した場合は reiner.schlitzer@awi.de に連絡して新しい変換を ODV 変換データベースに含めるよう

に依頼してください。 

 

5.5 SDN整合 ODVコレクション（SDN Harmonized ODV Collection） 
Import > SeaDataNet Formats で作成されたデータコレクションは自動的に変数を整合させ、Export > Data > 

SDN Harmonized ODV Collection で結果を新しいコレクションに書き込むことでさらに処理できます。整合化

は、同じ P01 コードを有する変数の集約と同様に、優先されるターゲット単位への変換を含みます。 単位変

換 係 数 と 、 整 合 化 さ れ て い る P01 コ ー ド の リ ス ト は 、 フ ァ イ ル 

include/import/sdn_contaminants_conversions.xml から読み込めます。整合された変数の名前、単位および説明

は P01 altLabel および prefLabel エントリを使って標準化されます。アスタリスク＊は整合された変数の変数

名として先頭に追加されます。 

 

たとえそれぞれの P01 コードが sdn_harmonization_settings.xml ファイルになくても、同じ P01 と P06 のコ

ード（同じ単位）を持つ複数の変数は単一変数に結合されます。結合された変数の名前、単位、および説明

は P01 altLabel および prefLavel エントリを使って標準化されます。結合された変数のラベルの先頭にはアス

タリスク＊が追加されます。 

 

整合リストまたは好ましいターゲット単位に変換できなかった単位に含まれない変数は、整合 ODV コレクシ

ョンにいまだ含まれています。整合化された変数の名前、単位、および説明は P01 altLabel および prefLabel

エントリを使って標準化されますが、値は変わらずに残ります。 

 

同じ P01 コードを持つ複数のソース変数を単一の整合変数に集約する場合、ODV は次の「最良」集約アル

ゴリズム：最小の ODV 品質フラグ値（最高品質；「最良」）の寄与値のみを使用し、「最良」寄与値の中央

値を計算して、SEADATANET スキームに戻って最小の ODV 品質フラグおよびマップを取得するか、または

寄与値の全てのオリジナルフラグが同一の場合は、共通のオリジナルフラグ値を使用します。 

 

mailto:reiner.schlitzer@awi.de
Suzuki Toru
わかりにくくてすみません。
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作成された整合化された変数のリストは、寄与している元の変数のリストと共に Collection > Browse Info オプ

ションを使用して閲覧できます。個々の整合された値のソース変数を明らかにする情報文字列は自動的に作

成されます。 

 

整合コレクション内の変数の順序は次のとおりです： 

 ソースコレクションの主要変数、 

 ソースコレクションで寄与変数が見つかった整合変数、ただし整合化された変数のラベルはアスタ

リスク*から始まることに注意、 

 整合ファイルで見つからなかったソースコレクションの整合化されなかった変数。 
 
5.6 データおよび格子場のクリップボードへのコピー（Clipboard Copy of Data and 

Gridded Field Values）  
データウィンドウの X, Y, Z データは、データ位置での格子化不適合および自動生成された格子上の格子化値

（格子化がオンの場合は後者の二つのみ）とともに、ウィンドウポップアップメニューの Extras > Clipboard 

Copy オプションを使用してクリップボードにコピーされます。マウスが特定のウィンドウ上にある間に Ctrl-

C を押すとショートカットできます。ODV はデフォルトでオリジナルの X と Y の値を出力しますが、ユーザ

ーはウィンドウの現在の投影によって生成された投影値も要求することができます。ODV がデータをクリッ

プボードにコピーしたら、クリップボードの内容をお気に入りのソフトウェアに貼り付けてさらに処理する

ことができます。マップウィンドウをクリップボードにコピーすると測点の位置やその他のメタデータを含

むリストが作成されます。 
 
5.7 等値面データのエクスポート (Exporting Isosurface Data) 
現在地図上に表示されている全ての測点の等値面データは Export > Isosurface Variables を選択し、ターゲット

ディレクトリと出力ファイル名を選択してエクスポートできます。出力ファイルは測点のメタデータを含み、

汎用 ODV スプレッドシートフォーマットに準拠しています。 

 

5.8 ウィンドウデータのエクスポート（Exporting Window Data）  

ODV メニューバーから Export > Window Data> Map or Window n を選択すると、ODV プロットウィンドウに

表示されている X, Y, Z のデータ値を ASCII ファイルにエクスポートできます。ターゲットディレクトリと

ファイル名を選択してください。あるウィンドウが gridding に切り替えられていたら、元のデータ値と共に、

データ位置において格子化に不適な、もしくは（自動生成された）格子点上における格子点値および「貧困

な評価エラー」のエクスポートを選ぶことができます。 

 

5.9 参照データセットのエクスポート（Exporting Reference Datasets） 
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ODV のメニューバーから Export > X, Y, Z Window Data as Reference を選択して現在のプロットウィンドウの元

のデータを別の ASCII ファイルに保存し、後でこれらのデータを reference datasets として使用できます。ID 

String フィールドに参照データを識別する説明テキストを入力して OK をクリックしてください。ODV はユ

ーザーの ODV ディレクトリにサブディレクトリ<documents>\ ODV\reference\<ID String>を作成し、全てのフ

ァイルをこのディレクトリに書き出します。ディレクトリが既に存在する場合、ODV は続行する前に現在の

内容を削除する許可を求めてきます。参照データは差分変数を定義するために ODV によって使用されます。 
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6 派生変数 (Derived Variables) 
 
コレクションファイルに保存されている基本データ変数に加えて、基本データ変数と同様に解析および可視

化に利用可能な多数の（一度定義された）派生変数を計算できます。派生変数は三種類あります： 

 海洋物理学および海洋化学で一般に使われるパラメータを含む組み込み派生変数。 

 任意の ODV コレクションで使用するためにファイルに格納したユーザー定義式のマクロファイル。 

 現在のコレクションに対してのみ、ユーザーがその場で(on-the-fly)定義した数式。 

 

派生変数を定義または削除するには Current Sample Window ポップアップメニューから Derived Variables オプ

ションを選択するか、メニューバーから View > Derived Variables を選択してください。マクロを追加するに

は Choices リストから Expressions, Derivatives, Integrals > Macro File の順に選択してください。ユーザー定義式

を追加するには Expressions, Derivatives, Integrals > Expression を選択してください。組み込み派生変数を追加

するには Choices リストで他の項目を選択してください。 
 
Load from View File ボタンをクリックして存在するビューファイルから派生変数を読み込むこともできます。

ビューファイルは現在開いているコレクションに属している必要があります。 

 

品質フラグ規約（Quality Flag Conventions） 
派生変数の品質フラグスキームは、入力変数に使用されるフラグスキームに依存します：(1) 全入力変数が

同じフラグスキームの場合、このスキームを派生変数に使用します；(2) 入力変数フラグスキームが異なる

場合、ODV 品質フラグスキームを派生変数に使用します。品質フラグの継承は次のようになります：(1) 全

入力値が同じフラグスキームの場合、結果としてこの品質フラグを使用します。入力値の品質フラグが異な

る場合、最大の ODV フラグ値が採用されて派生変数のフラグスキームに割り戻します；(2) 入力品質フラグ

は ODV スキームが割り当てられ、結果として最大 ODV フラグ値が採用されます。 

 

6.1 組み込み派生変数 (Built-in Derived Variables)  
ODV ソフトウェアには、ポテンシャル水温（温位）、ポテンシャル密度（任意の基準圧力に対する）、中立

密度、ブラントーバイサラ振動数(Brunt-Väisälä Frequency)、力学高度など、多くの海洋物理パラメータ

のアルゴリズムが組み込まれています。さらに海水中の二酸化炭素システムのさまざまなパラメータ、多く

のガス飽和濃度および分圧、そして海洋化学における他の多くの変数も、容易に選択可能な派生変数として

利用可能です。鉛直積分や微分と同様に二つの任意の変数の比のようないくつかの有用な数式もまた利用可

能です。 

Physical Properties（TEOS-10）派生変数グループ（バージョン 4.4.2 の新機能）は、以前の EOS-80 ベースの

変数を置き換え、20 を超える新しい変数を追加しました。下位互換および比較研究を可能にするために
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Physical Properties（EOS-80）派生変数グループはまだ維持されています。 通常は Physical Properties（TEOS-

10）グループからの派生変数を使用するべきです。 
 
利用可能な組み込み派生変数の完全なリストを以下に示します。これら全ての変数はユーザーによって要求

されます。測点データがメモリに読み込まれると、ODV は全ての要求された派生変数の値をその場で計算し

ます。要求された派生変数はコレクションファイルに保存されている基本変数と同様に使用および視覚化で

きます。 
 
組み込み派生変数を定義または削除するには Current Sample Window ポップアップメニューから Derived 

Variables オプションを選択してください。ODV は利用可能な定義済みの派生変数のリストを表示します。利

用可能な派生変数はテーマ別グループにまとめられて Choices リストに表示されます。 最近使用されたテー

マ別グループが最初に展開されます。他のグループはそれらの名前をクリックすると展開されます。 
 
特定の派生変数を追加するには、Choices リストでこのエントリを選択して（最初に変数が属するグループを

展開する必要があるかもしれませんが）Add を押してください。派生変数がポテンシャル水温（温位）やポ

テンシャル密度の基準圧力のような追加情報を必要とする場合、ODV は自動的にこの情報を要求します。多

くの派生変数も派生変数の計算に必要な入力変数(群)の識別を必要とします。このキー変数の識別は一度だ

け行う必要があり、関連付けは ODV によって記憶されることに注意してください。必要に応じて Collection 

> Identify Key Variables オプションを使用して、主要変数の関連付けを確認および変更します。主要変数の関

連付けが正しくなければ派生変数の計算値を間違える可能性があります。 
 
派生変数を削除するには Already Defined リストボックスでこの変数を選択して Delete を押すか、削除する項

目を単にダブルクリックしてください。他の派生変数への入力として要求される変数を削除すると、これら

の子変数も削除されることに注意してください。派生変数のパラメータまたは ODV マクロと数式を編集する

には（これらの特別な派生変数の詳細については下記を参照）、Already Defined リストボックスでそれぞれ

の変数を選択して Edit を押してください。 

表 6-1：組み込み派生変数のリスト 

Variable (変数) 注釈 

Carbon  (炭素) 

Alkalinity (アルカリ度) (任意の C 入力ペア)[μmol/kg] (詳細) 

CO*2 (任意の C 入力ペア) [μmol/kg] (詳細) 

CO3
2- (任意の C 入力ペア) [μmol/kg] (詳細) 

DIC (任意の C 入力ペア) [μmol/kg] (詳細) 

fCO2 (任意の C 入力ペア) [μAtm] (詳細) 
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HCO3- (任意の C 入力ペア) [μmol/kg] (詳細) 

OmegaA (任意の C 入力ペア) (詳細) 

OmegaC (任意の C 入力ペア) (詳細) 

pCO2 (任意の C入力ペア) [μAtm] (詳細) 

pH (任意の C 入力ペア) (詳細) 

Revelle Factor (訳注：大気から海洋への CO2 吸収能力の指標) 

(任意の C 入力ペア) 

(d fCO2 / d TCO2) / (fCO2 / TCO2). (詳

細) 

Expressions, Derivatives, Integrals (数式、微分、積分) 

Derivative (微分) 任意の変数(詳細) 

Derivative (二次微分) 任意の変数 

Expression (式) ユーザー定義式 

Integral (積分) 任意の変数(詳細) 

Macro File (マクロファイル) マクロファイルからのユーザー定義表現 

Ratio (比率) 任意の二つの変数 

Gases (ガス) 

AOU [μmol/kg] 

みかけの酸素消費量 AOU = Oxy(飽和

量)-Oxy(現場測定値), ここで Oxy(飽和

量)は，Weiss, Deep Sea Res., 17, 

721-735, 1970 のアルゴリズムを用い

たサンプルのポテンシャル水温および塩

分から計算される。 

CFC-11 Saturation (飽和度) [%] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985  

CFC-12 Saturation [%] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985  

CFC-10 Saturation [%] 
Bullister & Wisegarver, Deep Sea Res., 

45,1285-1302,1998 

CFC-113 Saturation [%] 
Bu & Warner, Deep Sea Res., 42,1151-

1161,1995  

CH4 Saturation [%] 
Wiesenburg & Guinasso, J. Chem. Eng.  

Data, 24,356-,1979  

Oxygen Saturation (酸素飽和度) [%] Weiss Deep Sea Res., 17, 721-735, 1970  

pCFC-11 [pptv] Warner & Weiss, Deep Sea Res., 
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32,1485-1497, 1985 

pCFC-12 [pptv] 
Warner & Weiss, Deep Sea Res., 

32,1485-1497, 1985  

pCFC-10 [pptv] 
Bullister & Wisegarver, Deep Sea Res., 

45,1285-1302,1998 

pCFC-113 [pptv] 
Bu & Warner, Deep Sea Res., 42,1151-

1161, 1995 

pCH4 [ppbv] 
Wiesenburg & Guinasso, J. Chem. Eng. 

Data, 24,356-,1979 

pSF6 [pptv] 
Bullister, Wisegarver & Menzia, DSR-I, 49 

(1), 175-187,2002  

SF6 Saturation [%] 
Bullister, Wisegarver & Menzia, DSR-I, 49 

(1), 175-187, 2002  

Metadata (メタデータ) 

Cruise ID 航海毎の固有 ID 

Latitude (緯度) 測点緯度から派生した十進角緯度 

Longitude (経度) 
測点経度から派生した十進角経度(現在の

地図領域に調整) 

Meta Variable Value (メタ変数値) メタ変数の数値 

Station Number (測点番号) Station ラベルから派生した番号 

Physical Properties (TEOS-10) 

Absolute Salinity SA（絶対塩分）[g/kg]  TEOS-101)  

Absolute Salinity at Freezing Point（氷結ポイント絶対塩分）               
[g / kg] 

TEOS-101)  

Adiabatic Lapse Rate Γ（断熱経過率）[mdegC/dbar]  TEOS-101)  

Brunt-Väisälä Frequency（ブ ラ ン ト ー バ イ サ ラ 振 動 数）
[cycl/h]  

(詳細)  

Cabbeling Coefficient CΘb （キャベリング係数） [10-6 K-2]  TEOS-101)  

Conservative Temperature Θ（保存温度）[degC]  TEOS-101)  

Depth from Pressure [m] TEOS-101)  

Dynamic Enthalpy（動的エンタルピー）[kJ/kg]  TEOS-101)  

Dynamic Height（力学高度）[dyn m]  TEOS-101, 3) （任意の基準圧力）  

Freezing Temperature Θf（凍結温度）[degC]  TEOS-101)  
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In situ Density Anomaly σ （現場密度偏差）[kg/m3]  
TEOS-101) （現場圧力、水温、塩分を使

用）  

In situ Temperature from Conservative Temperature（保存水温

からの現場水温）[degC]  

TEOS-101) （現場圧力と保存水温を使

用） 

Isentropic Compressibility κ（等エントロピー圧縮率）     [10-

10 Pa-1]  

TEOS-101)  

Latent Heat of Evaporation（蒸発潜熱）[kJ/kg]  TEOS-101)  

Latent Heat of Melting (融解潜熱) [kJ/kg]  TEOS-101)  

Neutral Density γn (中立密度) [kg/m3]  
Jackett & McDougall, J. Phys. Ocean., 

237-263, 1997 (他)  

Potential Density Anomaly σ（ポテンシャル密度偏差）[kg/m3]  TEOS-101) （任意の基準圧力参照）   

Potential Temperature θ（ポテンシャル水温）[degC]  TEOS-101) （任意の基準圧力参照）   

Potential Vorticity Q (ポテンシャル渦度) [10-12 m-1 s-1]  
潜在的な渦度（ブラント―バイサラ振動

数 Q = f / g * N2 から派生）  

Practical Salinity from Absolute Salinity（絶対塩分からの実用塩

分） 

TEOS-101)  

Practical Salinity from Conductivity（導電率からの実用塩分） TEOS-101)  

Preformed Salinity S*（予備成形塩分）[g/kg]  TEOS-101)  

Pressure from Depth [dbar]  TEOS-101)  

Reference Salinity SR （参照塩分）[g/kg]  TEOS-101)  

Saline Contraction Coefficient βΘ（生理食塩水収縮係数）    [10-

3 kg/g]  

TEOS-101)  

Sound Speed（音速）[m/s]  TEOS-101)  

Specific Enthalpy h（比エンタルピー）[kJ/kg]  TEOS-101)  

Specific Entropy η（比エントロピー）[J/(kg*K)] TEOS-101)  

Specific Heat Capacity Cp（比熱容量）[J/(kg degC)] 
TEOS-101) 

Specific Internal Energy u（比内部エネルギー）[kJ/kg]  TEOS-101) 

Specific Volume Anomaly（比容積偏差）[mm3/g] TEOS-101,2) 

Spiciness τ0 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Spiciness τ1 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Spiciness τ2 TEOS-101), McDougall and Krzysik, J. of 
Marine Research, 73, 141-152, 2015 

Stability Ratio Rρ（安定比） TEOS-101) 
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Thermal Expansion Coefficient αΘ（熱膨張率）[10-6 K-1] TEOS-101) 

Thermobaric Coefficient TΘb （熱圧係数）[10-12 K-1 Pa-1] TEOS-101) 

Turner Angle Tu （二重拡散対流に対する非粘性海水の局所安

定性） 

TEOS-101) 

Physical Properties (EOS80)  

Depth from Pressure (EOS80) [m] 
Saunders and Fofonoff, Deep-Sea 

Res., 23, 109-111, 1976 

Freezing Temperature (凍結温度）(EOS80) [degC] 

F. Millero, UNESCO Tech. Papers in 

the Marine Science, No.28, 29-35, 

1978  

In situ Density Anomaly（現場密度偏差） (EOS80)  [kg/m3] EOS80 

In situ Temperature (現場水温) (EOS80) [degC] EOS80 

Potential Density Anomaly  (ポテンシャル密度偏差) (EOS80)                
[kg/m3] 

EOS80 (任意の基準圧力) 

Potential Temperature (ポテンシャル水温) (EOS80) [degC]  
Bryden, Deep Sea Res., 20, 401-

408, 1973 (任意の基準圧力) 

Pressure from Depth (EOS80) [dbar] Saunders, J. Phys. Ocean., 1981  

Sound Speed （音速）(EOS80) [m/s]  
Fofonoff & Millard, UNESCO Tech. Pa. 

in Mar. Sci., No. 44, 53 pp, 1983  

Specific Heat Capacity Cp（比熱容量）(EOS80) [J/(kg degC)]  
F. Millero et al, J. Geoph. Res., 78, 

4499-4507, 1973  

Specific Volume Anomaly（比容積偏差）(EOS80) [mm3/g]  EOS80（任意の参照塩分および水温） 

Special 

Aggregated Variable（集約変数） (詳細) 

Converted Variable（変換済変数） (詳細) 

Data Error Value （データエラー値） 任意の変数の 1-σ データエラー値 

Difference from Reference Data （参照データとの差異） (詳細) 

Interpolated Variable （補間変数） 欠損データを補間値に置き換える 

Patches（パッチ） (詳細) 

Quality Flag Value（品質フラグ値） 変数の品質フラグ値 
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String ID（文字列 ID） 

任意の TEXT または INDEXED_TEXT メ

タまたはデータ変数の異なる文字列値に

対する整数 ID 値。 

Time （時間） 

Day of Month (station date) 
測点日付から派生した十進数表記の月内

通算日 4) 

Day of Month (time variable) 
時間変数から派生した十進数表記の月内

通算日 4） 

Day of Week (station date) 
測点日付から派生した十進数表記の曜日
4) 

Day of Week (time variable) 
時間変数から派生した十進数表記の曜日
4) 

Day of Year (station date) [days] 
測点日付から派生した十進数表記の年内

通算日 4) 

Day of Year (time variable) [days] 
時間変数から派生した十進数表記の年内

通算日 4) 

Day Time (station time) [hours] 
測点時刻から派生した十進数表記の日内

時間 

Day Time (time variable) [hours] 
時間変数から派生した十進数表記の日内

時間 

Month of Year (station date)  
測点日付から派生した十進数表記の年内

月 5) 

Month of Year (time variable) 
時間変数から派生した十進数表記の年内

月 5） 

Time (station date/time) 測点日時から派生した十進化時間 

Time (time variable) 時間変数から派生した十進化時間 

Year (station date) 測点日付から派生した整数年 

Year (time variable) 時間変数から派生した整数年 

 
1) IOC、SCOR and IAPSO, 2010:The international thermodynamic equation of seawater -  2010: Calculation and 

use of thermodynamic properties. Intergovernmental Oceanographic Commission, Manual and Guides No..56, 

UNESCO (English), 196 pp. 

2) TEOS-10 の比体積偏差は絶対塩分 SA = 35.16504 g/kg および conservative temperature Θ= 0°C を基準として計算される

ことに注意してください。これは実用塩分 SP = 35 psu および現場水温 t = 0°C を基準とした従来の定義とは異なります。 

深海では、値の相対差が 25％に達することがあります。 

3) TEOS-10 比体積偏差(上記 2
)参照)を用います。 

http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
http://www.teos-10.org/pubs/TEOS-10_Manual.pdf
Suzuki Toru
であってる？要確認

Suzuki Toru
要確認
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4) 昼間による端数日を含みます。 

5) 月の日と昼間による端数月を含みます。 

 

ブラント―バイサラ振動数（Brunt-Väisälä Frequency） 

ブラント―バイサラ振動数は次のように計算されます：与えられたプロファイルに対して、ODV は最初に一

連の標準層深度を設定し、観測された圧力、水温、塩分を投影します。次に、ブラント―バイサラ振動数が

標準層深度の間隔毎に（新しい TEOS-10 状態方程式 2010 から計算された鉛直密度勾配を使用して）計算

され、間隔の中間点に割り当てられます。最後に、中間点の Brunt-Väisälä 振動数値がプロファイルの元の

圧力（または深度）値に投影されます。値の投影は線形最小二乗補間を使用して行われます。ODV は N2 で

はなく N を計算することに注意してください。不安定な成層（負の値の平方根）の場合、絶対値の平方根が

とられ、負の符号が割り当てられます。したがって ODV における N の負の値は不安定な状態を示します。

ODV は計算を開始する前に（Good Coverage Criteria をチェックして）測点に十分な入力データが含まれ

ていることを確認します。データが不足している測点はスキップされます。 
 

海水中の二酸化炭素システムのパラメータ（Parameters of the carbon dioxide system in 

sea water） 
 
海水中の二酸化炭素システムの以下のパラメータは、派生変数として提供されています： 

1. アルカリ度 (ALK)、 

2. 溶存無機炭素 DIC、 

3. CO2 の逃散および分圧（fCO2 及び pCO2 ）、 

4. CO*2, CO32-, および HCO3-の濃度、 

5. pH（Total, SWS, 又は Free scale） 

6. Revelle または均一のバッファ、ファクタ 

7. カルサイトとアラゴナイトの飽和度 [CO32-]*[Ca2+]/Ksp を示す OmegaC と OmegaA 

 
これらの量は全て、次のいずれかの炭酸系入力データペアを使用して計算できます： 

1. ALK, DIC  
2. ALK, pH  
3. ALK, fCO2  
4. ALK, pCO2  
5. DIC, pH  
6. DIC, fCO2  
7. DIC, pCO2  
8. fCO2, pH  
9. pCO2, pH.  
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これらの炭酸系パラメータの一つを定義するには、Derived Variables ダイアログの Choices リストでそれぞれ

のエントリを選択して Add を押してください。図 6-1 の炭酸系パラメータ設定ダイアログが表示され、要求

された変数に対してさまざまな設定を定義できます。 
 
Equilibrium constants コンボボックスでは文献毎に異なる計算に使用する平衡定数を選択できます。Input ボ

ックスではデータ入力ペアと入力データが測定された条件を指定できます。Output ボックスでは要求された

変数を計算する出力条件を指定できます。要求された変数の種類および選択された Input variables に応じて、

いくつかのエントリは関連性がなく隠されています。 

 

以下の変数 pH、fCO2 または pCO2 のいずれかが選択された入力変数に含まれる場合、これらの変数が測定さ

れたときの圧力と水温を指定する必要があります。pH が入力変数の一つである場合は pH 値が報告される

pH スケールを指定する必要もあります。入力圧力の可能な選択肢は(1)In-situ pressure, (2)Select pressure 

variable および(3)Enter your pressure value here です。入力値が現場圧力である場合は(1)を選択し、データ変

数の一つが入力圧力値を含む場合は(2)を選択し（それぞれの変数は後で識別されます）、実験室の条件など、

測定が固定圧力で行われた場合は(3)を選択します。値を入力するには Enter your pressure value here テキス

トを選択して数値に置き換えます。 
 
入力水温には四つの選択肢があります：(1)In-situ temperature, (2)Potential temperature, （3）Select 

temperature variable および（4Enter your temperature value here で、選択と手順は上記の圧力と同じです。 
 
要求された派生変数が以下の pH、fCO2、pCO2 のいずれかである場合、これらの変数が計算される出力圧力と

水温条件を指定しなければなりません。要求された派生変数が pH の場合は出力 pH スケールを指定する必要

もあります。 

 

平衡定数 (Best Practices Handbook 2007) の推奨される選択は KF を除いて Dickson et al. (2007)に従ってい

ます：K1 と K2 は Luecker et al. (2007), K0 は Weiss (1974), KS は Dickson (1990), KF は Dickson and 

Riley (1979), KW は Millero (1995), K1p, K2p, K3p および KSi は Millero (1995) からのもので、カルサイト

（方解石）およびアラゴナイトの溶解度積 Ksp は Mucci（1983）からのものです。平衡定数の圧力依存性は

Millero (1995) によるものです。 Lewis and Wallace (1998) に要約されている様々な出版物の誤字が考慮

されています。 
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図 6-1：炭酸系パラメータ設定ダイアログ 

 

リン酸塩および/またはケイ酸塩のデータが利用できない場合、それらの濃度値はゼロと仮定されます。 

ODV は Dickson (1981) のアルカリ度の定義を使用して HS, S および NH 3 を除く全ての項目を扱います。pH

は反復ニュートン法を用いて計算されます。 
 
Lavigne et al. (2008)の SeaCarb バージョン 2.1.2 ソフトウェアと Matlab 版の CO2SYS v1.01 (Lewis 

and Wallace, 1998; マイアミ大学の Denis Pierrot によって Matlab に移植された) は同じサンプルデータ

で実行され、ODV による全ての炭酸系パラメータについて優れた一致が見られました。  

 
Dickson A. G.，Sabine C. L.. & Christian J. R., 2007. Guide to best practices for ocean CO2 measurements. PICES Special 

Publication 3:1-191.  （訳注：日本語訳版は https://www.nodc.noaa.gov/ocads/oceans/Handbook_2007.html より入手できる） 

Lavigne, H., A. Proye, J.-P. Gattuso., 2008.SeaCarb：Calculates parameters of the seawater carbonate system. R package 

version 2.1. http://www.obs-vlfr.fr/~gattuso/seacarb.php [Version: June/10/2009]. 

Lewis, E., and D. W. R. Wallace. 1998. Program developed for CO2 System Calculations. ORNL/CDIAC-105. Carbon Dioxide Information 

Analysis Center, Oak Ridge National Laboratory, U.S. Department of Energy. Oak Ridge, Tennessee. http://cdiac.ornl.gov/oceans/co2rprt.html. 

 

微分（Derivative） 

主要変数に関する微分を計算する変数を選択します（以下で A と指定します; 基本または定義済みの派生変

数を使用できます）。計算は三つのステップで進行します: (１)観測値Ａを主要変数の密集した間隔の標準値

のセットに補間し; （2）微分を標準の中間値で計算し; (3）微分値を元のサンプルの主要変数値に逆補間し

ます。ODV は計算を開始する前に（Good Coverage Criteria をチェックして）測点に十分な入力データが

含まれていることを確認します。データが不足している測点はスキップします。 

 

https://www.nodc.noaa.gov/ocads/oceans/Handbook_2007.html
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積分（Integral） 

主要変数に沿った積分を計算する変数を選択し（以下で A と指定します; 基本または定義済みの派生変数を

使用できます）、積分の開始一次変数値 z0 を指定します（デフォルト：0）。所定の測点の各サンプルに対

して、ODV は z0 からそれぞれの主要変数レベルまでの積分 A*dz を計算します。 
 
積分の単位は量 A の単位に主要変数の単位を掛けたものです。主要変数が深度であり、変数Ａが体積濃度単

位（例えば、１立方メートル当たりのモル数）を有する場合、計算された積分は 1 平方メートル当たりの現

存量に等しくなります。定義により z0 における積分値はゼロであることに注意してください。また ODV は

計算を開始する前に（Good Coverage Criteria をチェックすることによって）測点に十分な入力データが含

まれていることを確認します。データが不足している測点はスキップします。 

例（主要変数として深度を仮定）：海水の上部 500m の塩分含有量を求めるには、積分の変数として塩分を

選択し、開始値として 0 を使用します。次に 500m での鉛直積分値を（隣接点間を補間することによって）

調べるか、または SURFACE モードで等値面変数として depth=500 での積分を定義します。 
 
集約変数 (Aggregated Variable） 

集約派生変数は一つ以上の入力変数のデータ値を単一の変数に結合します。これは酸素のようなパラメータ

が異なる研究所で測定され、かつ異なる単位を使用して別々の元の酸素変数として報告されている場合に便

利です。集約派生変数は科学分析のためにさまざまな元の変数を（おそらく単位変換も含めて）単一の変数

に統合することを可能にします。集約変数値の計算は指定されたサンプルの入力変数の値を使用してサンプ

ルごとに行われます。全入力変数が同じ品質フラグスキームを使っている場合、集約派生変数もまた同じフ

ラグスキームを使用します。そうでない場合、集約派生変数は ODV 品質フラグを使用します。 

 

集約派生変数を定義するには、Special グループで Aggregated Variable を選択して Add を押してください。続

いて自動的に現れるダイアログで集約変数に寄与する全ての入力変数を選択し、そして新しい変数の名前と

単位を入力してください。 
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図 6-2：Aggregated Variableダイアログ 

 

その後 Aggregated Variable ダイアログが表示されるので（図 6-2 参照）、そこで集約変数のプロパティを微

調整してください。寄与する入力変数ごとに、入力変数の値を集約変数の単位に変換するために使用される

適切な単位変換を指定することが重要です。最初は全ての変換が Identity Transformation,すなわち「入力

値を変更せずに使用」に設定されています。入力変数の変換を定義するには Contributing Variables リストで

入力変数を選択して Conversion ボタンをクリックしてください。次に Conversion コンボボックスから変換の

一つを選択してください。目的の変換がリストに含まれていない場合は General Linear Transformation を選択

して独自の係数とオフセットを指定してください。 

 

単一の集計値が複数の入力値からどのように取得されるかを定義する三つの異なる集計モード：（1）

Exclusive, (2)Average, (3)Median があります。Exclusive 集計は指定された入力変数の順序で最初に使用可能な

データ値を使用します。一方 Average モードまたは Median モードでは特定のサンプルについて使用可能な全

ての入力値の平均値または中央値を計算します。 

 

入力変数を追加または削除するには Add ボタンと Delete ボタンを使用してください。選択した入力変数の変

換を変更するには Conversion をクリックしてください。デフォルトの変換である Identity Transformation では

入力値は変更されません。必要に応じて Top、Up、Down、Bottom ボタンを使用して入力変数の順序を変更

してください。Exclusive 集計（デフォルト）では入力変数の順序の中で最初に使用可能な値が使用されるた

め、入力変数の順序が重要になります。OK を押して集約変数の定義を完成させてください。 

 

一つ以上の入力変数が文字値の場合、集約変数もまた、全入力変数の文字値の結合で表される文字値になる

ことに注意してください。 
 



ODV User’s Guide 
 

 

変換された変数 (Converted Variable)  

変換された派生変数は、さまざまな単位である変数のデータを提供します。変換後の派生変数を定義するに

は、Special グループの Converted Variable を選択して Add を押してください。次に、変換する入力変数を選

択して新しい変数の名前と単位を入力し、使用する単位変換を指定してください。目的の変換がリストに含

まれていない場合は General Linear Transformation を選択して独自の係数とオフセットを指定してください。 

 

変換された派生変数は各々の入力変数の品質フラグスキームを使用することに注意してください。 

 

6.2 マクロ（Macros） 
特定のサンプルに対する新しい派生変数の値が、同じサンプルの他の変数値にのみ依存するという条件で、

組み込み派生変数のリストに含まれていない新しい派生変数を実装できます。新しいマクロを定義するには

ODV Macro Editor（下記参照）を使用して、マクロが依存する入力変数と値の計算に使用される代数式を指

定します。その後この情報をマクロファイルに保存します。 
 
現在のサンプルウィンドウのポップアップメニューから Derived Variables を選択して Choices リストから

Expressions, Derivatives, Integrals > Macro File を選択し、保存されているマクロのいずれかを選択します。そ

の後、マクロの計算に必要な入力変数を特定します。必要な変数の一つが利用できない場合マクロの設定を

中止するために Not Available を押します。 

 

6.2.1 マクロ編集（Macro Editor） 
Tools > Macro Editor を使用して Ocean Data View マクロファイルを編集または作成します。既存のマクロ

ファイルを選択するか新しいマクロ名を選択して以下の手順に従ってマクロを定義します。Save As を押して

マクロ名を指定してマクロをファイルに保存してください。 
 

マクロ変数 （Macro Variable） 

Label: マクロ変数のラベル名を入力。ギリシャ記号、(累乗の、べき)指数、(対数の)指標に関する書式制御シ

ーケンスが使用できます。 

Units: マクロ変数の単位を入力する。ギリシャ記号、(累乗の、べき)指数、(対数の)指標に関する書式制御シ

ーケンスが使用できます。 

Digits:現在のサンプルウィンドウにおいて値を表示する有効桁数を入力します。 

 

コメント (Comments)  
マクロ変数を説明する一行以上のコメント行を入力します。 
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入力変数 (Input Variables)  

マクロ変数に必要な入力変数を指定します。入力変数を追加するには、そのラベルと単位 New 欄に入力して

<<ボタンを押します。ギリシャ記号、(累乗の、べき)指数、または(対数の)指標の書式制御シーケンスを使

用できます。定義された入力変数を削除するには Defined リストボックスのエントリを選択して<<ボタンを

押してください。入力変数の数は制限されません。 

 

 
図 6-3：マクロエディタ・ダイアログ 

 

式 （Expression） 

Expression in Postfix Notation 欄内にマクロの評価時に実行される代数演算を指定します。式は非演算子が演算

子より先行するポストフィックス記法(後置記法; 逆ポーランド記法としても知られる)で記述する必要があり

ます。もしポストフィックス記法に慣れていなければ Enter Infix Expression ボタンをクリックしてからインフ

ィックス記法（中置記法）で式を入力してください。ODV はインフィックス記法の式を変換して Postfix 

Notation 欄に置きます。あるいは Tools > Infix-to-Postfix Converter オプション（ウィンドウズでのみ使用可
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能)は、Expression in Postfix Notation 欄内でインフィックス記法の数式からポストフィックス記法に変換する

ために使用できます。 
 
式は一行以上の非演算子と演算子の列で構成します。全てのエントリ(非演算子と演算子)は一文字以上のス

ペースで区切らなければなりません。非演算子には現在の測点の位置における緯度、経度、日付あるいは標

高といった現在の測点のメタデータと同様に、定数、入力変数の値、格納値、が使用できます(表 6-2 参照)。 

 

演算子には表 3 に記載されている代数演算子および論理演算子のいずれか一つを使用できます。演算子は必

要な入力値（単項、二項、および三項)の数によって異なりますが、=%n store 演算子を除いた全ての演算子

は正確に一つの結果値を生成します。 
 

マクロ式の評価は単純なスタックベースのスキームを使用して実装されます： 

1. 非演算子は表示されるとおりにスタックの先頭に追加されます。 

2. 演算子はその非演算子のスタックの先頭から取り出し、操作の結果をスタックの先頭に戻します。 

計算が成功したら、スタック上に残っている唯一のエレメントが最終結果です。 
 

表 6-2：ODV数式の非演算子 

非演算子 意味 

17.3 定数値 

#n 入力変数nの値(n=1、...;例:#1) 

%n 保存値nの値(n=0,...;例:%3) 

%x 現在の測点の緯度 

%y 現在の測点の緯度 

%t 現在の測点の日付時刻メタデータから計算した1900年からの十進化年 

%d 現在の測点の日付時刻メタデータから計算した通日 

%H 現在の測点位置での標高（海抜メートル；陸が正、海が負） 

 

表 6-3：ODV数式の演算子 

演算子 結果 注釈 

Unary:x （単項演算子） 

=%n - n (n=0,…番目の保存値 x。値を取得するには％n を使用。   

abs abs(x) 絶対値 

arccos arccos(x) 逆余弦関数（ラジアン）  
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arccot arccot(x) 逆余接関数 (ラジアン)  

arcsin arcsin(x) 逆正弦関数（ラジアン）  

arctan arctan(x) 逆正接関数（ラジアン）  

ceil ceil(x) x の切り上げ(x 以上の最小整数値) (ceil(-1.3)=-1; ceil(3.5)=4)  

cos cos(x) 余弦関数 ( x はラジアン)  

cot cot(x) 余接関数（ｘはラジアン）  

exp exp(x) 指数関数  

floor floor(x) x の切り捨て(x 以下の最小整数値) (floor(-1.3)=-2; floor(3.5)=3)  

int int(x) x の整数部(int(-1.3)=-1; int(3.5)=3)  

ln ln(x) 自然対数  

sin sin(x) 正弦関数  

sqrt sqrt(x) 平方根  

! !x 否定演算子(x の否定) (!(0)=1; !(1)=0)  

? 
有効値なら 1 

欠測値なら 0 

欠損値のテスト(ODV 5.0.1 以降)  

Binary: x y operator（二項演算子） 

+ x+y 和 

- x-y 差  

* x*y 積  

/ x/y 比  

** xy べき乗  

min min(x, y) 最小  

max max(x, y) 最大  

== 1 if x=y 
0 if x!=y 等値性テスト（等値性比較演算子） 

!= 1 if x!=y 
0 if x=y 不等値性テスト（等値性比較演算子） 

>= 1 if x>=y 
0 if x<y より大きいか等しいためのテスト（不等値性比較演算子）  

> 1 if x>y 
0 if x<=y より大きいかのためのテスト（不等値性比較演算子） 

<= 1 if x<=y 
0 if x>y 以下か等しいかのためのテスト（不等値性比較演算子） 

< 1 if x<y 
0 if x>=y より以下なのかのテスト（不等値性比較演算子） 

& 1 if x and y non-zero 
0 if x or y zero 論理積(AND)  

| 1 if x or y non-zero 
0 if x and y zero 論理和(OR)  
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Ternary: b x y operator （三項演算子） 

IFTE x if b is non-zero 
y else 

IF-THEN-ELSE ロジック  

 

基本的な算術演算には演算子+  -  * / **、平方根には sqrt、二つの非演算子の最小値と最大値には min

と max、自然対数と指数関数には ln と exp を使用します。 正弦、余弦、正接、余接には sin, cos, tan, 

cot（引数はラジアン）、逆正弦、逆余弦、逆正接、逆余接には arcsin, arccos, arctan, arccot（結果

はラジアン）、絶対値には abs、および引数の整数部にはそれぞれ int, floor, ceil があります。さらに、

いくつかの論理演算子と if-then-else 構造の IFTE 演算子があります。 

 

それぞれの入力変数の値を参照するには#1, #2 などの形式の用語を使用します。測点位置での標高（海抜メ

ートルで表し、陸地では正、海域では負）に%H という用語を使用し、観測時間には%t（測点の日付と時刻の

メタデータから計算される 1900 年以降の十進化年、例えば 1984 年 6 月 27 日の場合は%t= 84.4877）、

通日には%d（測点日のメタデータから計算されます）、（東）経度の %x、（北）緯度の %y がそれぞれあり

ます。 
 
計算の中間結果は演算子=%0, =%1 などを使用して内部変数%0, %1 などに格納できます。格納された値

は%0, %1 などと入力して後で計算に使用できます。この=%n 演算子はそれらの非演算子を消費することに注

意してください：例えば、それぞれの値はスタックから取り除かれます。 
 
非演算子と演算子は一文字以上のスペースで区切らなければなりません。 必要ならば次の行でマクロ式の定

義を続けることができます。 

表 6-4：数式の例 

後置記法式（逆ポーランド記法） 意味 
135 #1 * #2 + PO = 135 * PO4 + O2 (with: PO4 as #1 and O2 as #2)  

%t 80 - 17.6 / exp #1 * 
𝑐𝑐∙𝑒𝑒 (𝑡𝑡𝑡𝑡−1980)/17.6  (tritium decay correction to 1980; c as #1 (1980 年まで

のトリチウム減衰補正)) 

#1 ln ln(#1) (natural logarithm) /（自然対数） 

#1 ln 0.43429 *  log(#1) (base-10 logarithm) /（10 を底とする対数） 

0 #1 max  max(0, #1) (maximum value)  
#1 180 < #1 365 + #1 IFTE  if #1<180: (#1+365); else #1 (if-then-else expression)  

 

 

6.3 式 (Expressions) 
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派生変数式はマクロに似ています。それらは ODV マクロエディタで定義および編集することができ、それら

は同じ構文と演算子セットを使用します。式を設定するには現在のサンプルウィンドウのポップアップメニ

ューから Derived Variables を選択し、Choices リストから Expression を選択して Add を押してください。 

ODV はマクロエディタ・ダイアログに似たダイアログを表示します。ラベルフィールドと単位フィールドに

新しい変数のラベルとそれに対応する単位を入力します。次に新しい変数に必要な入力変数を選択してくだ

さい。例えば Choices リストで変数を選択して<<を押してください。最後に新しい数量について評価する式

を指定します。サポートされている演算子と一般的な構文ガイドラインについては Macro Editor の

Expression のパラグラフを参照してください。OK を押して新しい式の設定を終了します。 
 
現在のサンプルウィンドウのポップアップメニューから Derived Variables オプションを使用して ODV マクロ

と式を編集できます。次に Already Defined リストボックスでそれぞれの変数を選択して Edit を押してくださ

い。Edit Expression で名前を付けて Save As を押すと ODV マクロファイルに式を保存できます。 

 

 

図 6-4：式のダイアログの編集 

 
6.4 差分変数（Difference Variables） 
現在選択されている測点のプロパティ分布を以前に保存された参照データと比較し、プロパティの差を派生

変数として定義することで差分フィールドを作成できます。View > Derived Variables を選択するか、Alt + D
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を押して Special > Difference from Reference を選択してください。次に参照データディレクトリツリーのサブ

ディレクトリの中から使用したい一つの参照データセットの ExportID.txt ファイルを選択してください。

ODV はそのディレクトリから利用可能な参照データファイルのリストを表示します。Z 変数として差分フィ

ールドを生成し、かつ適切な X 変数および Y 変数を持つ.oal ファイルを選択してください（例えば、経度と

深度の断面を生成させる場合は参照データファイルの経度が X で深度が Y であることを確認します）。次に

現在のコレクション内の Z、X、および Y 変数を特定し（もし経度または緯度が必要な場合は Difference from 

Reference オプションを呼び出す前に派生変数としてそれらを定義します）差分変数の定義を完了してくださ

い。新しい変数の名前は Z 変数の名前と参照データセットの識別文字列で構成されています。一度定義する

と、どのデータプロットでも差分変数を使用できます。 

 

6.5 パッチ（Patches）  

現在画面に表示されているデータプロットの X/Y 空間に多角形を指定することで水隗パッチを定義できます。 

これを行うには、定義に使用したいデータプロット（例えばシータ/ S プロット）の上にマウスを移動し、マ

ウスの右ボタンをクリックします。ポップアップメニューから Extras > Define Patch を選択し（カーソルが十

字形に変わります）、節点の位置でマウスの左ボタンをクリックして多角形パッチの節点を定義します。点

を削除するには、マウスをそれぞれの点の近くに移動して右ボタンをクリックします。Enter キーを押すか、

マウスの左ボタンをダブルクリックして多角形の定義を終了してください。多角形は ODV によって自動的に

閉じられることに注意してください。その後 ODV はパッチ名（拡張子なし）の入力を求め、パッチ定義をコ

レクションディレクトリ内のファイルに書き出します。 

図 6-5：パッチを用いた水塊の範囲の特定 

 
一つのコレクションに対して一つ以上の水塊パッチを定義したら、それらを使用して派生変数 Patches を作

成して活性化することができます。View > Derived Variables を選択して Choices リストから Patches を選択し



Version 5.8.2 
 

 

 

てください。利用可能な水塊パッチ（上で説明したように定義済み）を一つ以上選択することで Patches 変

数をその内部に構成できます。終了したら OK を押してください。所定のサンプルのパッチ変数を評価するた

めに、ODV はサンプルが選択されたパッチ多角形の一つの内側にあるかどうかを判定し、（見つかった場合）

それぞれのパッチの番号をパッチ値として割り当てます。サンプルが全ての選択パッチの外側にある場合、

その値は欠測値に設定されます。 

 

他の全ての変数（基本変数または派生変数）と同様にデータウィンドウの任意の軸にパッチ変数を使用でき

ます。例えば、断面に沿った Z 変数として、または特定の水塊の空間的な広がりを表示するための等値面変

数として使用します（図 6-5 を参照）。 
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7 等値面変数 (Isosurface Variables)  
多くの場合、特定の時空間面または層上の変数の分布を計算して表示することが科学的に必要です。例えば、

一定の深度または圧力の層、等密度面、あるいは時系列データの場合は一定のタイムスライスです。ODV は

そのような分布を定義するための isosurface variables（等値面変数）を提供します。 定義により等値面変数

は測点ごとに正確に一つの値を持ちます。等値面変数の値は SURFACE スコープのデータウィンドウにプロ

ットできます。 

 

等値面変数は View > Isosurface Variables を使用するか Isosurface Data Window 上で右クリックして Isosurface 

Variables を選択して定義されます。ODV は Isosurface Variables ダイアログ（図 7-1）を表示するので、ここで

新しい等値面変数を定義、および既存のものの修正または削除してください。一つ以上の既存の等値面変数

を削除するには Already Defined リストでそれぞれのエントリを選択して Delete を押してください。 

 

新しい等値面変数を追加するには、まず New ボックス内に新しい変数を作成してから Add を押してください。

等値面変数を作成するには、（1）ある表面上に表示される変数（表示変数）、（2）表面を定義する変数

（表面変数）、（3）表面上の表面変数の値（表面変数値）の詳細が求められます。数値の表面変数値に加え

て first, last, minimum または maximum のキーワードを入力することもできます。この欄に数値を入力して表

面変数の数値を指定します。first および last キーワードの場合、ODV は主要変数の並び替え順に従って表

示変数の最初または最後の非欠測値を取得します。Minimum または maximum の場合、ODV は最初に表面変

数の最小値（最大値）でサンプルを決定し、次に与えられたサンプルの表示変数の値を使用します。 

 

図 7-1：等値面変数ダイアログボックス 

 

Already Defined ボックスで等値面変数が選択されている場合は S-Sync ボタンをクリックして同じ等値面を使

用するように他の全ての変数を同期させることができます（等値面の同期）。V-Sync ボタンをクリックして

他の全ての変数を同期させて同じ表示変数を使用することができます（変数同期）。 
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当然ながら、等値面変数の表示変数または表面変数として使用するには、まずポテンシャル密度や圧力など

の派生変数を定義する必要があります。等値面変数の総数は無制限です。現在の測点の等値面変数値は等値

面データウィンドウに表示されます。  
 
Salinity [psu] @ Depth [m] = 500 のような数値表面値を持つ等値面変数の計算は、等値面上で線形補間値を取

得するために利用可能なサンプル（Salinity）値を使用して実行されます。タイプ B（ボトルデータ）または

100 サンプル未満の測点では、測点の全てのデータを考慮して piece-wise linear regression (区分線形回

帰)を使用して補間します。タイプ C で 100 サンプル以上の測点では、線形補間は面の両側にある最も近い

二つのサンプルのみ使用します。 
 
補間を実行する前に ODV は表示変数（Salinity）のデータ範囲をチェックし、データが不足していると判断

された場合、補間は試行されず、この測点に対する等値面値は計算されません。データ不足の有意性を評価

するために使用される有効範囲基準は、オプション Collection > Good Coverage Criteria を使用して検査および

修正できます。 

 

測点の緯度経度と同様に、十進化時間や通日などの測点メタ情報は、常に自動で等値面値として提供されま

す。 

 

first、last、minimum、maximum キーワードを使用した等値面データの品質は、利用可能なデータの分布とデ

ータ内の顕著な極値の有無に大きく依存します。したがって、これらのキーワードは慎重に使用する必要が

あります。 
 
キーワード first または last は全ての測点の最初または最後のサンプルが同じ主要変数の値、または海水全体

にわたる範囲にある場合にのみ適用する必要があります。first または last を使用すると、表面または海底の

状態が正しく反映されます。最初と最後のサンプルの深度が測点間で大きく異なる場合、すなわち、ある測

点が海底まで伸びているのに対して他のサンプルが海中の一部しかカバーしていない場合は、これらのキー

ワードを使用すべきではありません。 
 
キーワード minimum または maximum は表面変数が顕著な最小(最大)値を示し、利用可能なデータによって

明らかに特徴が解決される領域でのみ使用するべきです。複数の最小(最大)値を持つ測点の場合、表面変数

の最小(最大)値を持つ測点が選択されます。一組の測点の場合、絶対最小(最大)値は異なる最小(最大)値の層

において得られることに注意して下さい。Isosurface Data Window 上で右クリックして Sample Filter > 

Customize Settings > Range の順に選択し、変数(例えば深度、圧力、または時間)の一つの範囲を指定すること

で、極値の検索をユーザー定義の間隔に制限する範囲サンプルフィルタを指定できます。 
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7.1 等値面変数描画（Drawing Isosurface Variables） 
等値面変数を定義したら、SURFACE スコープのデータウィンドウの Y、Y、Z 軸上でこれらの変数を使用で

きます。格子場を深度レベルでプロットする場合は、最も近い等深線が自動的にオーバーレイレイヤとして

使用されます。元のデータ点がプロットされている場合は灰色の海底地形図が背景として使用されます。 
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8 選択基準（Selection Criteria）  
8.1 測点フィルタ（Station Filter）  
測点マップの描画中に、ODV はコレクション内の各測点を検査し、現在の測点フィルタ設定が満たされてい

るかどうかを判定します。全てのテストに合格した測点のみが有効と見なされます。これらの測点だけがマ

ップ上に印づけられて、この測点の部分集合だけが以降の閲覧と可視化に使用されます。 

 

   
 

   
 

   
図 8-1：測点フィルタ・ダイアログ・ページ 
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図 8-2：測点フィルタ・ダイアログ・ページ（続き） 

 

測点図のコンテキストメニュー、Current Station Window ポップアップメニュー、またはメインメニュー

の View > Station Filter > Customize を使用して、測点フィルタ設定を変更できます。例えば Name/Range, 

Date/Time, Domain, Meta Data, Meta Data Quality, Availability, History または Invert のそれぞれのタブをクリッ

クして変更するカテゴリを選択し、関心のある項目を変更します。 

 

Name/Range タブでは、航海ラベル、測点ラベル範囲、測点タイプ、および内部測点 ID 番号の範囲によって

測点を選択できます。航海ラベルを選択するにはリストから特定の航海ラベルを選択するか、Cruise Label フ

ィールドの中に一つ以上の正規表現（ワイルドカード・パタン）を指定します。後者の場合、いずれかの正

規表現に一致する航海ラベルは全て有効と見なされます。航海ラベルに使用できる正規表現の例を表 8-1 に

まとめています。複数の航海ラベルを入力する場合は二本のバー“ || ”を使用してエントリを区切ります。 

 

例：OCE13 [34]  ||  A16N  ||  S05 * 

航海 OCE133 と OCE134 および航海 A16N，および S05 から始まる全ての航海を選択します。 
 

表 8-1：クルーズラベルの正規表現構文およびメタデータのワイルドカード表現 

文字・記号 意味 

任意の文字 
下記のものを除いて、任意の文字はそれ自身を表します。 

例：cは文字 cと一致します。 

? 
これは任意の一文字と一致します。 

例：SAVE_LEG？は SAVE_LEG1、SAVE_LEG9、SAVE_LEGa などに一致します。 

* 

これは 0 個以上の任意の文字と一致します。 

例：I01_*は I01_で始まるラベルに一致します; *06AQ*は中央に 06AQ があるラベル

に一致します。 

[...] 

角括弧([])内に示される文字列セット。文字クラスの範囲内では、範囲外のように

バックスラッシュは特別な意味を持ちません。ダッシュ（-）は文字の範囲を示すた

めに使用されます。キャレット（^）は最初の文字すなわち左角括弧の直後にある
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場合にその文字セットを否定します。 

例：I05 [EW]は I05E と I05W に一致します。LEG [0-2]は LEG0、LEG1、LEG2 に一致

します。SAVE_LEG [^3]は SAVE_LEG3 を除く全ての SAVE_LEG?航海に一致します。  

(empty) 空文字列に一致します。 

(!empty) 空ではない文字列に一致します。 

 
Date/Time タブでは、有効な時間間隔（Period）、有効なカレンダー間隔（Season）、および有効な日中の時

間範囲（Day Time）を指定できます。有効な測点は三基準の全てを満たす必要があります。Season および

Day Time（カレンダーおよび日中の）範囲は、連続した年または日にまたがることがあります。例えば

[Oct/20-Feb/03]または[21:09-04:15]は、受け入れ可能なカレンダーと日中の範囲です。 

 

Domain カテゴリでは、地図の矩形範囲をそれぞれの経度/緯度の値を指定して定義するか、Zoom ボタンを押

したズーミングによって矩形を定義できます。Polygon ボタンを押してからマウスで多角形の節点を入力する

と、多角形を有効なドメインとして定義できます。多角形は自動的に閉じます。 

 

Meta Data ページは数値メタ変数と文字列メタ変数を別々にカバーする二つの部分に分割されています。どち

らの場合も、最初に上部のコンボボックスから変数を選択してから、満たすべき数値範囲（数値メタ変数）

またはワイルドカード式（文字列メタ変数）を指定してください。 

 

数値範囲を指定する場合は、左に低値の境界、右の高値の境界を入力してください。指定した境界間のメタ

変数値を持つ測点だけが有効となります。もし許容値の範囲が低値（または高値）側に無限であれば、低値

（または高値）の境界は空白のままにしてください。あるメタ変数に関するデータを持たない測点を選択す

るには、低値の境界に文字列`(empty)’を入力して高値の境界を空白のままにしてください。 

 

ワイルドカード式は、上述したクルーズラベルの例のように、‘||’ で区切られた複数のエントリを持つことが

できます。エントリは OR 論理と組み合わせられ、例えばエントリのどれか一つに合致するメタ値が有効と

なります。`(empty)’または`(!empty)’文字は、空文字列または空ではない文字列に一致します。ワイルド

カード式の構文は表 8-1 にまとめられています。純粋な（ワイルドカード文字を含まない）テキストを入力

してメタ変数が INDEXED_TEXT 型の値を持つ場合、ODV は入力された文字列がコレクションに存在するか

どうかを示します。これにより特定の用語がコレクション内に存在するかどうかを素早く確認できます。 

 

Meta data Quality タブでは、データ品質フィルタを設定したいメタ変数を選択してから、許容したい品質フ

ラグを選択してください。Apply to all variables をクリックすると、選択した変数と同じ品質フラグスキーマ

を使用して全メタ変数に対して同じ品質フィルタを適用します。もし選択したメタ変数に対して全ての品質

フラグを許容したい場合は Relax this quality filter をクリックしてください。それから Apply to all variables を
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クリックすると、選択した変数と同じ品質フラグスキーマを使用して全メタ変数の全品質フィルタが緩和さ

れます。 

 

Availability ページでは必須変数として一つ以上のデータ変数を選択できます。測点は必須変数のデータが含

まれている場合のみ有効と見なされます。複数の必須変数は AND または OR 論理を使用して二つの方法で組

み合わせることができます。AND 論理では全ての必須変数のデータが存在しなければなりませんが、OR 論理

では一つの必須変数のデータだけで十分です。 

 

History ページｄは、測点の履歴記録にある日付、ユーザー、実行、および記録された説明情報に基づいて測

点を選択できます。User, Action, Description ワイルドカード仕様に一つ以上一致する指定した時間間隔の日付

時刻、ユーザー、行動および説明情報の履歴記録が含まれていれば、その測点は有効となります。履歴記録

によるフィルタリングは、他の基準より多くのコンピュータ的なコストがかかり、特に巨大なデータコレク

ションでは時間がかかることに注意してください。 

 

Invert タブでは測点の選択を反転できます。例えば Invert Selection ボックスをチェックすると、基準を満た

さない全ての測点が選択されます。 

 

有効測点フィルタ設定を含むページには、ページ名にアスタリスク(*)が追加されているので簡単に識別でき

ます。特定のページの選択基準を削除するには、それぞれのページタイトルをクリックして Relax Criteria, 

Map Domain または None Required ボタンを押してください。 
 
異なるページ上の選択基準は論理積(AND)を使用して組み合わせられることに注意してください。例えば測

点は、それが全ての測点フィルタ設定を満足する場合にのみ有効と見なさます。終了したら OK を押してくだ

さい。ODV は新しい選択基準を使用して測点図を再構築します。 

 

コツ：Availability ページで主要変数を除く全てのデータ変数を選んで論理 OR を選ぶと、主要変数を除くど

のデータがなくても測点を選別できます（空の測点）。Invert ページにおいて、Invert selection ボックスをチ

ェックしてください。Collection > Delete Station Subset オプションを使うとコレクションから空の測点を削除

できます。 
 

8.2 サンプルフィルタ（Sample Filter） 
ODV は等値面変数値の計算と同様に、（SURFACE ウィンドウを除く）各データウィンドウに関して個々の

サンプルフィルタを管理します。これらのフィルタはデータ値（範囲、ワイルドカードおよびポリゴンのフ

ィルタ処理）および/または品質フラグ値（品質フィルタ処理）に基づいてサンプルを受け入れたり拒否した

りします。品質フィルタは受け入れる品質フラグ値を指定します。範囲フィルタ（数値データ変数のみ）は

最小および最大の許容値を指定します。ワイルドカード・フィルタ（文字列データ変数のみ）は、それぞれ
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の文字列値と一致する必要がある一つ以上のワイルドカード仕様を指定します（詳細は下記を参照）。デー

タウィンドウのサンプルフィルタはユーザーが定義したフィルタ・ポリゴンも持っています。ポリゴン外の

全サンプル点はフィルタで取り除かれます。 
 
別々のサンプルフィルタを異なる非 SURFACE データウィンドウに適用することができます（下記参照）。

等値面変数値の計算中に適用される追加のサンプルフィルタがあります。どのような場合でも、指定された

サンプルは指定された全てのサンプルフィルタ設定を満たす場合にのみ有効と見なされます。有効なサンプ

ルのみが異なるデータウィンドウに表示され、有効なサンプルのみが等値面変数値の計算に使用されます。

Current Sample Window には常に全てのデータが表示され、サンプルフィルタは適用されません。 
 
非 SURFACE データウィンドウのサンプルフィルタを変更するには、ウィンドウ上で右クリックして Sample 

Filter サブメニューのオプション: Accept All Data、Reject Outliers そして Customize Settings から一つを選択し

てください。最初の二つのオプションは自動で使いやすくなっています。三番目のオプションでは、以下に

示す Sample Filter ダイアログのように全てのフィルタ設定を完全に制御できます。Isosurface Data Window

を右クリックしてオプションの一つを選択すると等値面変数の計算に使用されるサンプルフィルタ設定を変

更できます。 
 

     
図 8-3：サンプル・フィルタ・ダイアログ・ページ 

 

Sample Filter ダイアログを使用するときは、まず Quality や Rang など、それぞれのタブをクリックして変更

するカテゴリを選択して目的の項目を変更してください。 

 

Quality タブでデータ品質フィルタを設定する変数を選択してから、受け入れる品質フラグを選択してくださ

い。選択した変数と同じ品質フラグスキーマを使用して全ての変数に同じ品質フィルタを適用するには Apply 

to all variables をクリックしてください。選択した変数の全ての品質フラグを受け入れる場合は Relax this 
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quality filter をクリックしてください。そして選択した変数と同じ品質フラグスキーマを使用して全ての変数

の全ての品質フィルタを緩和する場合も Apply to all variables をクリックしてください。 

 

（一つ以上の変数に対して）指定した値の範囲内にある値を持つサンプルのみを表示したい場合は Range タ

ブのフィルタ設定を使用します。例えば上層の海中を調べていて深度 0〜500m のサンプルのみを見たい場

合は、深度変数を選択して Acceptable Range の下に希望の範囲を入力してください。一度に複数の変数に範

囲フィルタを指定できます。テキスト変数には、”N* || Gerad”のように一つ以上のワイルドカード表記を指

定できます。これにより変数のテキスト値が「N」で始まるか、または「Gerard」に等しいサンプルのみが選

択されます。 

 

新しい x/y フィルタ・ポリゴンを定義するか、既存のフィルタ・ポリゴンを削除するには Polygon タブを選

んでください。Define Polygon をクリックすると一時的にダイアログが消えて、マウスの左クリックでポリゴ

ンの節点を入力できます。Enter を押すとポリゴンが完成し、Esc を押すと取り消されます。 

 

オーバーレイデータウィンドウのサンプルフィルタを編集すると、オーバーレイウィンドウの変更されたサ

ンプルフィルタは自動的に親ウィンドウにも適用されます。 
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9 測点図（Station Map） 
9.1 マッププロパティー（Map Properties） 
測点図のプロパティはマップポップアップメニューの Properties オプションまたは View > Window Properties 

> Map より変更できます。これには、地図の領域と投影法、海底地形の表示、海岸線、および陸上地形、測

点のドットのスタイル、グラフィックスフォントサイズや軸のラベルの色とスタイルなどの一般的なプロパ

ティの変更が含まれます(図 9-1 と 9-3) 。 

 

図 9-1: マッププロパティダイアログの各ページ (1/3) 
 
一般 (General) 

General ページではマップで使用されるカラーパレット、マップウィンドウの背景色、基本フォントサイズと

フォントサイズ係数、および軸と軸注釈の色を定義できます。緯経線表示はオンまたはオフに切り替えるこ

とができます。 
 
表示スタイル（Display Style） 

Display Style ページでマップ内の測点マークの色とサイズを定義します。色に automatic を選択するとデータ

コレクション内の異なる航海に対して異なる色が発生します。ドットサイズを-1 にするとドットサイズは自

動的に定義されます。 

 

投影（Projection） 
Projection ページでは地図投影と投影極の経度と緯度（見る人の位置）を選択します。次の投影が現在利用可

能です:（1）Default Projection, （2）Orthographic (North Polar), （3）Orthographic (Equatorial), （4）

Orthographic (South Polar), （5）Orthographic (Oblique), （6）Mollweide. デフォルトの投影法は経度と緯度

方向が線形です。各々の正投影図法は半球形ですが、デフォルト図法およびモルワイデ図法は全球規模です。

全ての投影法でマウスまたはマップ Properties ダイアログの Domain ページを使用した小領域の定義でズーム
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インが可能です（下記参照）。Orthographic (Oblique)投影では、任意の経度/緯度の眼位（極）を指定して、

そこから全球を見ることができます。他の投影法では極の緯度は固定されており、極の経度のみを変更でき

ます。 
 
投影法(2)から(6)ではズーミングによる小領域の定義にコツが要ります。正確な結果が必要な場合はマップ

Properties ダイアログの Domain ページ（下記参照）を使用するか、一時的にデフォルトの投影法に切り替え

てからズーム（それによってサブ領域を定義）して最後に目的の地図投影法に切り替えてください。 

 

レイヤー (Layers)  

ODV には、中解像度または高解像度の海底地形および陸上地形の等値線、海岸線、湖沼、河川、および境界

のデータを含む多数のマップリソースパッケージ（Series（シリーズ）と呼びます）が付属しています。中解

像度の全球 GlobHR シリーズは、ODV ソフトウェアとともに自動的にインストールされます。他の利用可能

なマップリソースとインストール手順に関する情報は 2.12 章の Map Layer Series セクションを参照してくだ

さい。 
 
Layers ページで bathymetry-coastline-topography Series を選択し、異なった Layer Set カテゴリ内のレイヤー

を指定します。Draw color bar ボックスをチェックするかチェックを外して、マップのカラーバー描画のオン

またはオフを切り替えられます。 
 
ODV測点図で使用する Series を選択する方法は二つ：automatic または manual があります。 
 

  

図 9-2：Map Propertiesダイアログの各ページ (2/3) 

 

自動シリーズ選択（Automatic Series Selection） 

Automatic selection チェックボックスをチェックすると自動シリーズ選択に切り替わります。このモードで

ODV は自動的に与えられた地図領域で利用可能な最善のシリーズを決定して測点図にこのシリーズを使用し
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ます。地図領域が変更されたときはいつでも（例えばズーミング、またはマップポップアップメニューの

Full Domain または Global Map オプションを使用したとき）、ODV は新しいドメインに最適なインストール

済みシリーズを見つけて使用します。ODV はまた、所定の領域に適した海底地形と陸上地形レイヤーを自動

的に選択します。それぞれのチェックボックスをチェックするか外すことで ocean bathymetry, coastlines, land 

topography, lakes そして rivers と国の borders の描画のオンまたはオフを切り替えられます。 
 
自動シリーズ選択を有効にするには ODV Web サイトから入手可能な高解像度の bathymetry-coastline-

topography シリーズを一つ以上インストールする必要があります。他の利用可能なマップリソースとイン

ストール手順に関する情報は 2.12 章の Map Layer Series セクションを参照してください。 

 

独自の特注 Coastline-Bathymetry シリーズを作成し、それを自動シリーズ検索に含めたい場合はシリーズ

の領域と空間解像度に関する情報を含む設定ファイルを作成する必要があります。詳細については Preparing 

Custom Coastline and Bathymetry Files の章を参照してください。 
 
手動シリーズ選択 (Manual Series Selection) 

Automatic selection チェックボックスのチェックを外すと手動で bathymetry-coastline-topography シリー

ズを選択できます。また、個々のレイヤーセットを作成してそれらのグラフィカルな外観を指定することも

できます。このモードでは測点図のデザインを最大限にコントロールできます。 
 
Series コンボボックスをクリックしてインストールされているシリーズを選択することができます。一部のシ

リーズは地域版のため、それぞれのシリーズ領域に対して地図領域を手動で調整する必要があるかもしれま

せん。一つのシリーズを選択したら、さまざまな Layer Set カテゴリでレイヤーを定義できます（下記参照）。

地図が描画されるとレイヤーセット（およびセット内のレイヤー）は指定された順序で描画されます。 
 
選択されたレイヤーセット（例えば Ocean Bathymetry）に関する情報を取得するには Layer Set Info ボタンを

クリックしてください。選択したレイヤーセットのレイヤーを定義するには Compose ボタンをクリックして

ください。デフォルトレイヤーは全てのカテゴリに対して定義されています。結果の地図表示がニーズに合

っている場合はレイヤーセットを変更する必要はありません。 
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図 9-3：マップのレイヤー定義ダイアログ 

 
Compose ボタンを押すとレイヤー定義ダイアログ（図 9-3）が表示されます。Available リストでレイヤーを

選択して<<ボタンを押すとレイヤーを追加できます。Selected リストでレイヤーを選択して>>ボタンを押す

とレイヤーを削除できます。Line ボックスと Fill ボックスのプロパティに応じて、所定のレイヤーの塗りつ

ぶし、および／またはその輪郭を描くことができます。デフォルトの色設定は自動的に適切な色が選ばれる

(automatic)です(推奨)。それぞれのコンボボックスをクリックして、これらの設定を上書きして特定の色を

選択することができます。塗りつぶさない、および／または描きたくない場合は(none)を選択してください。

Selected リスト内の所定のレイヤーのプロパティをクリックすることで変更できます。そして Line と Fill で

設定を変更し、最後に<<をクリックして変更を実行します。 

 

領域（Domain） 

マップのプロパティダイアログの Domain ページで、東経と西経、南緯と北緯を与えて地図の範囲を指定で

きます。また Full Domain をクリックするとコレクション内の測点がまたがる全範囲の領域（ネイティブ領域）

を、Global Map をクリックすると全球領域を選択することもできます。 
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図 9-4：Map Propertiesダイアログの各ページ (3/3) 

 

注釈（Annotations） 

Annotations ページでは地図中で選択した測点（下記参照）に注釈を付けるかどうかを指定できます。選択し

た測点の測点ラベルを測点位置の横に描画する場合は Station labels を、注釈に航海ラベルも含める場合は

Cruise and station labels を選択してください。注釈が不要な場合は No annotations を選択してください。Pick 

List Editor を使用して測点の位置を基準にして注釈の位置を変更できることに注意してください（下記参照）。 

 

9.2 選択された測点（Picked Stations）  
測点図は選択された測点のリストを保持しています。選択された測点のデータは STATION データウィンド

ウに描画され、選択された測点もデータウィンドウと同じ色と記号を使用して測点図に印付けられます。

（例えば測点上を左クリックして）現在の測点にして+ (プラスキー)を押すと、その測点が選択リストに追

加されます。マウスの左ボタンで測点をダブルクリックしても測点を選択リストに追加できます。新しく追

加された選択された測点のデータが全ての STATION データウィンドウに追加され、それが測点図内にも印

づけられていることに注意してください。選択リストから測点を削除するには（例えば STATION データウ

ィンドウの一つのデータポイントをクリックして）現在の測点にして- (マイナスキー)を押します。 
 
マップポップアップメニューから Manage Pick List > Edit Pick List オプションを使用して選択リスト全体を編

集できます。Pick List Editor ダイアログで選択リスト内の全ての測点のプロパティとグラフィカル表示を編集

できます。リストの順序を変更したり、リストから個々の測点を削除したり、リストを完全に空にしたりす

ることもできます。 
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図 9-5：選択リストエディタ・ダイアログ 

 
現在のビューに選ばれた測点が含まれているのに STATION データウィンドウが表示されていない場合、選

択された測点は測点図内で測点記号の周りを黒い円で強調表示されます。STATION データウィンドウが作

成されるとすぐに選択された記号が再び表示されます。さらに、選択された測点の種類が`B’とは異なる場合、

最初は記号が割り当てられず、測点のサンプル間の線のみが強調表示されます。手動で記号タイプを定義す

ると、恒久的に使用する事が出来ます（ODV バージョン 4.2.0 から導入）。 
 
9.3 断面（Sections） 
SECTION データウィンドウを作図する前に、測点図で断面を定義する必要があります。 新しい断面を定義

するか、以前に定義した断面を使用するには、地図上で右クリックしてマップポップアップメニューを呼び

出します。新しい断面を定義する場合は Manage Section > Define Section を、以前に定義した断面を読み込む

場合は Manage Section > Load Section を選択してください。後者の場合「ファイルを開く」ダイアログから

（例えばそれをダブルクリックして）断面ファイルを選択してください。新しい断面を作成するとき ODV は

一時的に全面測点図に切り替わるので、断面の中心線を簡単に定義できます。マウスカーソルが十字線に変

わったときは、断面の中心線を定義する一連の点の入力を待っている状態です。 

 

十字線を目的の位置に移動してマウスの左ボタンをクリックして点を入力します。点を削除するにはマウス

を点の近くに移動してマウスの右ボタンをクリックします。一連の点を確定させる ENTER キーを押すか、マ

ウスの左ボタンをダブルクリックして最後の点を指定します。図 9-6 に示すように任意の航跡に沿ったかな

り複雑な断面を作成することができます。 
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                 図 9-6：GEOSECS西大西洋断面 
 

断面の中心を指定した後、ODV は断面帯に既定の幅を割り当て、既定の断面に沿った座標として開始点（最

初に入力した点）からの距離を選択します。断面の中心を指定すると自動的に表示される Section Properties

ダイアログ（図 9-7）で、これらおよび他の多くの断面プロパティを変更できます。Section Properties ダイ

アログは、マップポップアップメニューから Manage Section > Section Properties を選択するといつでも呼び出

せます。 
 
Section Properties ダイアログで、断面に沿う座標として Distance, Longitude, Latitude または Time の選択、断

面帯の幅の設定、水深値のソースの選択、海底地形断面の色の選択、および断面のタイトルを指定できます。 

 

図 9-7：Section Propertiesダイアログ 
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断面には海底地形の多角形を含めることができ、それはいくつかの方法で定義できます：（1）測点の水深メ

タデータを使用、（2）特別な netCDF ファイルで提供される全球または地域のグリッド海底地形データセッ

トを使用、または（3）.gob ファイルからの ODV POLYGON グラフィックスオブジェクトを使用します。格

子化海底地形データは View > Settings > Gridded Bathymetry > Resources オプション（macOS の場合は odv > 

Preferences > …）を使用してダウンロードおよびインストールできます。断面の海底地形多角形として.gob

ファイルの船舶測深データを使用した断面の例を図 9-8 に示します。 
 
注：断面プロットに表示される海底地形図について、プロットの Y 変数が Depth in the Water Column または

Pressure in the Water Column として識別されていることを確認してください。識別を検査および確認するには

Collection > Identify Key Variables オプションを使用してください。 

 

図 9-8：断面の海底地形の多角形として船舶測深データを使用した断面 

 

現在の断面図をファイルに保存するには Manage Section > Save Section As オプションを選択します。Manage 

Section > Load Section を選択して保存した断面図を後で読み込むことができます。断面を削除するには

Manage Section > Remove Section を選択してください。 
 
測点図内で印づけられている断面帯内の全ての測点はその断面に属しています。これら全ての測点のデータ

は SECTION データウィンドウにプロットされます。 

 

9.4 測点分布（Station Distributions） 
ポップアップメニューから Extras > Statistics を選択するか、マウスが地図上にあるときに F4（4 番のファン

クションキー）を押すと、測点図内の測点の空間的および時間的分布のプロットを作成できます。Map 

Statistics ダイアログが表示され、現在選択されている測点の時間または季節の分布を見ることができます

（それぞれ Time Histogram または Season Histogram ボタンを押します）。ヒストグラム(度数分布)は別々の
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ダイアログウィンドウに表示されます（図 9-9 を参照）。Save As を押して適切なファイルタイプを選択する

ことで、GIF、PNG、JPG、または TIFF イメージにグラフィックスを保存できます。 

 

     
図 9-9：マップ内の測点の時刻と季節のヒストグラムの例 

 

Map Statistics ダイアログ上の Heat Map を押すと小さなタイル内の測点数を使用して地図領域全体のデータ密

度を示すプロットが作成されます。この分布図は、特に非常に多数の測点と多数の繰り返しの測点が測点図

の同じ場所にプロットされている場合、密集した測点範囲のエリアの簡単な識別を可能にします。地図を拡

大して上記の手順を繰り返して、より高い空間分解能で測点密度情報を取得できます（図 9-10 を参照）。 
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図 9-10：異なるレベルの空間分解能を有する測点図および測点分布図の例 

 

9.5 経度符号と値の規約 （Longitude Sign and Value Conventions） 
  

1. ODV コレクションの経度メタデータは東経度[0° ―360°]で保存されています。 

2. Export > Data > ODV Spreadsheet File および Export > Meta Data オプションを使用して(1) [0°―

360°] または(2) [-180°―180°]の経度出力規約を選択できます。 

3. Export > Window Data および Extras > Clipboard Copy による測点図およびデータウィンドウマップか

らのデータのエクスポートでは、測点図またはデータウィンドウマップで現在使用されている経度

値を作成します（4 を参照）。 

4. 測点図またはデータウィンドウマップの経度メタデータの符号と値は、地図領域がグリニッジ子午

線をまたぐ(b)、もしくはまたがない(a)かに依存します： 

 (a) グリニッジ子午線が地図領域内にない、または東または西の境界線ではない、 

 (b) 領域内部にグリニッジ子午線。 
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(a)の場合、地図の経度は常に正で[0°―360°]の範囲です（値は東経度を表します）。（b)の場合

はグリニッジ子午線の東側の緯度は正（東経度）であるのに対し、グリニッジ子午線の西側の緯度

は負（西経度）です。いずれの場合も地図の経度は下図に示すように西から東に単調増加します。 

 

図 9-11：ODVマップにおける経度の規則 
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10 データウィンドウ（Data Windows） 
10.1 データウィンドウプロパティ（Data Window Properties） 

 
データウィンドウのプロパティは、それぞれのウィンドウを右クリックして Properties オプションを選択する

ことで変更できます。あるいは View > Window Properties > Window x を使用することもできます（ここで x はウ

ィンドウの番号です）。値の範囲やウィンドウの X, Y, Z 軸上の変数などウィンドウ設定の一部はデータウィ

ンドウのポップアップメニューの Set Ranges および X-, Y-, Z-Variable オプションを使用して変更することもで

きます。 

 

     
図 10-1：データウィンドウプロパティダイアログの各ページ (1/2) 

 

データウィンドウの Properties ダイアログは六つのページで構成されています（図 10-1 および 10-5 を参

照）。 

 

一般（General） 

General ページでは、データウィンドウ、データウィンドウの背景色、現在の測点の強調表示スタイル、基本

フォントサイズとフォントサイズ係数、軸の色と軸の注釈で使われているカラーパレットを定義できます。 

軸上の自動変数ラベルと同様に、格子線はオンまたはオフに切り替えることができます。自動軸タイトルを

オフにして独自の注釈グラフィックスオブジェクトを作成すると、軸上のテキストをカスタマイズすること

ができます。 

 

データ（Data）  

Data ページでは、データウィンドウの範囲、X, Y, Z の変数、および様々な軸のプロパティを定義できます。

通常の軸の方向は、X の場合は左から右へ、Y の場合は下から上へ、Z の場合はカラーバー内の下から上に向

かって値は増加します。例えば、海洋深度値を上向きに減少させるためにそれぞれの Reverse range ボックス

をチェックして、一つ以上の軸の方向を反転させることができます。X, Y, Z 軸のプロパティを変更するには
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X-Axis Settings, Y-Axis Settings または Color bar Settings をクリックしてください。軸のプロパティダイアログ

（図 10-2）が表示され、それぞれの軸の値の範囲、軸に沿った線形、対数、または引き伸ばした投影図、ラ

ベル付きおよびラベルなしの目盛りの間隔、ラベル付き軸の位置を指定できます。目盛りの間隔を

(automatic) に設定すると、ODV は自動的に印の場所と頻度を決定します。Position エントリでは、軸の位置

（左または右、下または上）の選択、またはそれぞれの軸のラベルを完全にオフにすることができます。 

 

注：軸上で十進数の時間変数を検出した場合、ODV は特別なラベル付けの方法を適用します。この場合ユー

ザーはラベルの間隔を変更できません。 

図 10-2: Axis Properties ダイアログ 

 
ODV は次の X 軸と Y 軸の投影をサポートします：（1）線形（デフォルト）、（2）対数、（3）左（底）延

伸部、（4）左（底）延伸部（強）、（5）中央延伸部、（6）中央延伸部（強）、（7）右（頂）延伸部分、

（8）右（頂）延伸部分（強）。以下は、対数軸と引き伸ばされた上部 Y 軸の使用を示す例の図です。断面

図の上層の分解能が向上していることに注意してください。 
 
表示スタイル（Display Style） 

Display Style ページでは、それぞれの項目をクリックすることで ODV の二つの基本的なプロットタイプ、

Original data と Gridded field を切り替えることができます。 

 

Original data の場合、測定位置におけるカラードット、サイズドット、数値または矢符を得るために Colored 

Dots, Sized Dots, Numbers または Arrows の表示タイプを選択できます。さらに，各 X, Y, Z 変数の品質フラグ

値に応じたカラードットを生成する SCATTER および SECTION プロットにおいて、Colored Dots (X Quality), 

Colored Dots (Y Quality), Colored Dots (Z Quality)を選択できます。これらのプロットタイプはデータの品質管理

の特に有用です。 

Symbol size の下の二つのフィールド内の数値で、ドットのサイズと色、またはフォントのサイズと色を指定

してください。選択された色は、Z 変数を除いた SECTION、SCATTER、SURFACE の各データウィンドウ
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でのみ有効です。Z 変数を持つデータウィンドウでは、ドットの色（またはサイズ）は Z 値によって決まり

ます。STATION ウィンドウでは選択された測点ごとに色が異なります。これらの色は自動的に割り当てら

れますが、ユーザーはいつでも変更できます。 Line width エントリは STATION データウィンドウでのみ有

効です。 

 

 

  
図 10-3：対数表示および Y軸の上部を伸張した表示例 

 

Sized Dots の場合、ドットの最大サイズは指定された Symbol size の 10 倍となり、塗りつぶしの色は Symbol 

color によって与えられ、ボーダーの色とボーダーの幅は、それぞれデータマークの色とライン幅のエントリ

から引き継がれます。最大 Z 範囲値を表すサンプルドットがデータウィンドウの左下隅にプロットされます。

データウィンドウの Set Ranges オプションを使用して、Z 範囲の最大値を調整できます。サンプルドットと

それに関連する注釈は他の位置にドラッグすることができ、新しい位置はビューファイルに記憶されます。 
 
Arrows を選択すると Arrow Properties ダイアログ（図 10-4）が表示され、矢符の x, y 成分を与える変数、

矢符のスケール、線幅、矢符の色を選択できます。Color (automatic)を選択すると矢符の色は矢符の位置に

ある Z 変数の値によって決まります。もし(automatic)色を使用する場合は Z 変数が定義されていることを確

認してください。Arrow Properties ダイアログを再度呼び出して矢符の設定を変更するには Original data の

下の Arrows エントリをクリックします。 

 

サンプル位置に色付きの点を表示する代わりに、Gridded field をクリックして、Z 変数を持つどのデータウィ

ンドウにおいても（鉛直断面に沿った、あるいは等値面上のプロパティ分布が例）格子化プロパティフィー

ルドを作成することができます。まず利用可能な格子化手法である Quick gridding, Weighted-average gridding, 

DIVA gridding から一つを選択します。次に X 軸と Y 軸のそれぞれに適切な平均化長さスケールを指定してく

ださい。長さスケールの値は全軸範囲のパーミル（千分率）で、大きい値ほど平滑化されます。データ内の

構造の保存と滑らかさの間で許容できる妥協点が得られるまで、さまざまな長さスケールの値の使用を試み

るべきでしょう。Automatic scale lengths チェックボックスをチェックすると、ODV はデータ分布を分析して

グリッド長スケールを自動的に選択します。 
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断面ウィンドウにおいて、ODV は等密度線のように成分の等値線を配置する高度な格子化手順である

Isopycnic gridding を提供します。この機能は中立密度 γn またはポテンシャル密度派生変数が定義され、かつ

DIVA による格子化が使用されている場合に利用できます。詳しくは下記を参照してください。 

 

格子化フィールドは、もし不適切に実行された場合、データの表現が不正確になる可能性があります。 
 
全てのＯＤＶ格子化手法は、所定の格子点(x, y）におけるあらゆる推定値に対して無次元の quality value を割

り当てます。Quality value は、推定に使用される全てのデータポイントの推定ポイントからの（それぞれの

平均化スケール長の単位で測定された）距離に基づいています。通常、約 3 より大きい Quality Value は、

最も近い測定が推定ポイントから 2 長さスケールより離れていることを示し、問題があると考えられます。

Hide bad estimate ボックスをチェックして適切な Quality limit 値を指定することで、それに等しいまたは大き

な値の不適当な推定を非表示にできます。 
 

図 10-4：矢符プロパティダイアログ 
 
Do color shading がチェックされている場合、格子化フィールドは ODV によってカラーシェーディングされ

ます。Draw marks がチェックされていて、ドットに対して適切なサイズと色が指定されている場合、実際の

データポイントの位置がプロット内で印づけられます。プロパティフィールドの等値線（下記参照）および

カラーシェーディングは、全ての格子化モードでサポートされています。 
 

図 10-5: データウィンドウのプロパティダイアログの各ページ (2/2) 

Suzuki Toru
本文はupperですが，ソフトウェアではbottomになっているので，誤植と思われます。

Suzuki Toru
誤植でしょう。
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等高線（Contours）  

データウィンドウプロパティの Contours ページではプロットの等値線を定義できます。このページは

Gridded field が表示スタイルとして選択されている場合にのみ有効です（上記参照）。等値線の自動選択を指

定するには Auto-create ボタンをクリックしてください。等値線のセットを手動で追加するには New グルー

プで Start, Increment, End の各 Z 値を指定してください。適切な線とラベルのプロパティを選択して<<ボタン

を押すと等値線のセットが Already Defined リストに追加されます。必要ならば異なる Start, Increment, End の

値と、場合によっては異なるラインとラベルのプロパティでこの手順を繰り返します。既存の等値線のプロ

パティを変更するには Already Defined リストで選択して New グループのプロパティを変更し、<<ボタンを押

して変更を確定させます。 
 
所定の Z 値 z に対応した等値線の描画に加えて、Fill の下から自動またはユーザーが指定した色を使ってｚ

より大きい Z 値で定義された領域を塗りつぶすことができます。図 10-6b は、全ての等高線に対して Fill の

下の(automatic)を使用して作成されています。 
 

 

図 10-6：（a）連続的に塗りつぶしたフィールドと（b）等高線で塗りつぶしたフィールドの比較 
 
カラーマップ（Color Mapping） 

Color Mapping ページでは、Z 変数値とそれに関連付けられた色との間のマッピングを操作できます。このペ

ージは Z 変数を含むデータウィンドウ（例えばカラー断面または等値面上のカラー分布）に対してのみ有効

です。Auto Adjust ボタンを押すと、Z 値の分布に基づいて自動的に作成される、おそらく非線形のマッピン

グが確立されます。Linear Mapping ボタンを押すとデフォルトの線形カラーマッピングに戻ります。最高の

色解像度を得るために Z 値に対する Median（中線）トラックバーを動かし、Nonlinearity（非線形）トラ

ックバーを使用して非線形性を高めることによって、カスタマイズされたカラーマッピングを確立できます。 

 

DIVA設定 (DIVA Settings)  
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DIVA 設定ページでは、DIVA 格子化アルゴリズムを制御するパラメータを操作できます。詳細については

DIVA 格子化手法の説明を参照してください。データウィンドウが DIVA 格子化を使用していない場合、こ

のページは無効になります。 
 
10.2 ズーミングと自動計測 (Zooming and Automatic Scaling)  
マウスをウィンドウ上に移動させて、マウスの右ボタンをクリックしてデータウィンドウのポップアップメ

ニューを表示して Full Range または Zoom を選択することで、データプロットの変数の範囲を変更できます。

Full Range の場合、現在のウィンドウの X 範囲と Y 範囲は、このウィンドウにプロットされた全てのデータ

値に対応するように調整されます。キャンバスポップアップメニューで Full Range（All）を使用すると画面

上の全てのデータプロットを一回の操作で自動スケールできます。 

 

Zoom を選択すると現在のウィンドウの周りに赤いズームフレームが表示されます。このズームフレームを操

作するには、マウスをその端、四隅、または内側に移動させて、マウスの左ボタンを押して端、四隅、また

はフレーム全体を目的の位置までドラッグします。下/左および上/右の隅の x/y 座標はステータスバーの中

央部分に表示されます。ズームフレームの現在の設定を受け入れ、それに応じて変数範囲を調整するには、

マウスの左ボタンをダブルクリックするか、ENTER を押してください。ズーム操作を中止して元の変数範囲

を維持したい場合は Esc キーを押すか、マウスの右ボタンをクリックしてください。 

 

前の段落で説明した通常のズーム手順に加えて、追加のズーム方法(quick-zoom)があり、それは多くの状況で

簡単かつ素早く使えます。マウスがデータウィンドウまたはマップ上にあるときに Ctrl キー（Macintosh シ

ステムでは cmd キー）を押したまま、かつマウスの左ボタンを押したままマウスを動かしてズームボックス

を開きます。マウスの左ボタンを離すとズームボックス設定の quick-zoom したウィンドウに適用されます。 
 
変更はズーミングされたウィンドウに適用されます。範囲の同期がオンになっている場合（View > Settings > 

Windows ダイアログページ、macOS の場合は odv > Preferences > Windows を参照）、修正された変数の一つ

を使用して新しい範囲が他のウィンドウにも適用されます。 
 

 
10.3 Zズーミング (Z-Zooming)  
カラーバー付きの全てのデータウィンドウでは、カラーバーにズーミング（Z ズーミング）して Z 変数の範

囲を変更できます。Z ズーミングを起動するには、そのデータウィンドウの上にマウスを移動し、マウスの

右ボタンをクリックしてデータウィンドウのポップアップメニューを表示します。Z Zoom を選択すると、そ

れぞれのウィンドウのカラーバーの周りに赤いズームフレームが描画されます。上で述べたように、このズ

ームフレームを操作してドラッグしてください。ズームフレームの現在の設定を受け入れて、それに応じて

Z 変数の範囲を調整するにはマウスの左ボタンをダブルクリックするか Enter キーを押します。ズーム操作
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を中止して元の Z 変数の範囲を維持したい場合は ESC キーを押すかマウスの右ボタンをクリックしてくださ

い。 

 

変更はズーミングされたウィンドウに適用されます。範囲の同期がオンになっている場合（View > Settings > 

Windows ダイアログページ、macOS の場合は odv > Preferences > Windows を参照）、修正された変数の一つ

を使用して新しい範囲が他のウィンドウにも適用されます。 

 
10.4 ウィンドウレイアウトの変更（Changing Window Layout） 
測点図の位置や形状と同様に、データウィンドウの数、位置および形状はメインメニューの View > Layout、

キャンバスポップアップメニューの Window Layout オプションまたはキャンバス、マップ、およびデータウ

ィンドウのコンテキストメニューの Layout サブメニューオプションから容易に変更できます。ショートカッ

トして Layout サブメニューを素早く呼び出すには、各ウィンドウ上にマウスを動かしてから右クリックと同

時に Ctrl キーを押してください。 

 

マップまたはデータウィンドウを移動またはサイズ変更するには Move/Resize を選択してください。それぞ

れのウィンドウの周りに赤いズームフレームが表示されます。このズームフレームを移動および／またはサ

イズ変更するには、マウスを四隅、端、または内側に移動し、マウスの左ボタンを押したままマウスを動か

します。ウィンドウの新しいサイズと位置を確定させるにはマウスの左ボタンをダブルクリックするか Enter

キーを押してください。ウィンドウ位置を変更せずに Move/Resize 操作を中止するには Esc キーを押します。

オーバーレイウィンドウ（下記参照）の移動またはサイズ変更時には、それに応じてアンダーレイ親ウィン

ドウも移動またはサイズ変更されます。 

 

既存のウィンドウの一つにマウスを移動して右クリックして Create New Window または Create Overlay 

Window オプションを選択すると新しいウィンドウを作成できます。どちらの場合も新しいウィンドウの初

期プロパティは既存のものから導入されます。Create New Window を使用する場合、新しいウィンドウは

ODV グラフィックスキャンバスの中央に配置されるので、上述の Move/Resize オプションを使用して配置お

よびサイズ変更してください。 

 

Create Overlay Window を使用するとオーバーレイウィンドウのいくつかの属性は自動的に設定され、新しい

ウィンドウは親ウィンドウ上に適切に揃います。このウィンドウを右クリックして Properties オプションを

選択すると、既存または新しいウィンドウの属性を変更できます。ウィンドウの X 軸、Y 軸、Z 軸について

新しい変数を選択するには Properties ダイアログの Data ページを選択し、各軸のコンボボックスで適切な変

数を選択します。デフォルトでは変数値は右方向および上方向に増加します。逆方向にしたい場合（例えば

プロファイルの深さ）、それぞれの Reverse range ボックスをチェックしてください。OK を押すと新しい属

性が確定されます。マップまたはデータウィンドウの属性はいつでも変更できます。 

Suzuki Toru
とっても分かり難い文ですが，実際にODVで捜査してみると言いたいことは理解できます。
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上述したようなレイアウトの手動変更に加えて、View > Layout > Layout Templates を介して広範囲な定義済み

のウィンドウレイアウトも実現できます。 

 

オーバーレイウィンドウ上で右クリックするとオーバーレイウィンドウのコンテキストメニューが表示され

ますので、アンダーレイ親ウィンドウのコンテキストメニューを表示するには右 Alt キーを押しながらクリ

ックしてください。 

 

10.5 グラフィックス出力（Graphics Output） 

GIF, PNG, JPG および Tiff ファイル（Files GIF, PNG, JPG and Tiff Files） 

キャンバス全体、個々のデータウィンドウまたはマップは、キャンバスポップアップメニューから Save 

Canvas As、データウィンドウまたはマップポップアップメニューから Save Plot As または Save Map As を選択

し、それぞれのファイルタイプを選ぶことによって gif、png、jpg、または tiff ファイルに保存することがで

きます。これらのオプションはショートカットキーでも呼び出すことができます：（1）マウスがキャンバス

領域上にあるときに Ctrl-S を押すと ODV グラフィックスキャンバスが保存され、（2）マウスをマップまた

はデータウィンドウ上に置いて Ctrl-S を押すとそれぞれのデータプロットが保存されます。ODV はファイ

ル保存ダイアログを表示し、適切な出力ファイルの種類（GIF（*.gif）、PNG（*.png）、JPG（* .jpg）または

TIFF（* .tif））を選択できます。デフォルトの出力ファイル名は現在のビューの名前から派生することに注

意してください。必要に応じて他の名前や保存先を選択できます。ODV は出力画像の解像度を定義できます。

達成可能な最大解像度はシステムで利用可能なメモリによって制限されることに注意してください。 

 

10.6 データ統計（Data Statistics） 
ウィンドウを右クリックして Extras > Statistics を選択するか、マウスがウィンドウ上にあるときに F4 を押す

と、そのデータウィンドウに表示されているデータの統計情報を取得できます。ウィンドウの統計ページが

表示され（図 10-7 を参照）、それぞれのウィンドウの X, Y, (もし存在するなら)Z の各変数の平均、標準偏

差、標準誤差、データ点数、最小値と最大値が表示されます。平均値、標準偏差、標準誤差、データ点数は

現在表示されているデータのみに基づいていますが、最小値と最大値は使用可能な全データに関する値であ

ることに注意してください。 

各 Histogram ボタンを押すと X, Y, (もし存在するなら)Z データの分布ヒストグラムが得られます。ヒストグ

ラムの例を以下に示します。ヒストグラムは現在表示されているデータのみに基づいています。Heat Map ボ

タンを押すと X/Y 空間でのデータ分布のプロットが得られます。全てのヒストグラムと分布図は GIF、PNG、

JPG、または TIFF イメージで保存できます。 
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図 10-7：北東太平洋における深さ方向の酸素を示す SCATTERデータウィンドウ(左)およびその統計概要ダ

イアログボックス(右) 

 

  
図 10-8：酸素のデータ分布ヒストグラム(左)および図 10-7に示されるデータの酸素/深度データ分布(右) 

 

親データウィンドウが現在 Weighted-average または DIVA gridding を使用している場合は Gridding Misfits ボ

タンが有効になります。このボタンを押すと現在の格子化処理の推定値とデータの差を示すプロットが表示

されます（図 10-9 参照；訳注：原文では図 10-10 となっているが間違いと思われる）。 
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図 10-9：データ位置における推定値とデータとの差を示すプロットの例 

 

ウィンドウ上でマウスを右クリックして Statistics > Curve Fitting を選ぶと、そのウィンドウの曲線近似ダイア

ログが表れます（図 10-10 参照；訳注：原文で図 10-8 となっているのは間違いと思われる）。ODV では

（1）最小二乗直線、（2）区分最小二乗直線、および（3）移動平均曲線の三種類の曲線でデータを近似で

きます。Fitted Curves グループの一番上のコンボボックスから、これらの曲線タイプの一つを選択できます。

次に、あてはめる方向を選択します（図 10-7 の例では、深度を関数とする酸素、例えば X(Y)が必要です）。

曲線タイプ（2）と（3）では、曲線を評価する点の数を指定することもできます（デフォルトは 30；より滑

らかな曲線にするにはより大きい値を選択してください）。移動平均曲線（タイプ 3）の場合は平均の長さ

スケール（括弧内の変数の軸範囲のパーミル（千分率）あたり、例えば図 10-7 の Y=深度）を指定できます。

平均の長さスケールが大きいと滑らかになり、小さければデータ内の構造がより多く保存されます。曲線を

作成して結果を右側のボックスに表示するには Construct Curve を押してください。これらの結果は

（Clipboard Copy を押して）クリップボードにコピーしてから、外部使用のための他の文書またはアプリケー

ションに貼り付けることができます。 
 

 
図 10-10：曲線近似ダイアログ 

（訳注：原文では図 10-8 となっているが間違いと思われる） 
 

Suzuki Toru
組版処理できない場合はこう書くことになっています（原文が間違い）。
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Show Curve を押して作成した曲線をデータウィンドウに追加することもできます。曲線はポリライン（折れ

線）グラフィックスオブジェクトとして追加されることに注意してください。オブジェクトを右クリックし

て Properties を選択することで、いつでもオブジェクトのプロパティの編集や変更、またはオブジェクトを

削除できます。 
 
10.7 等密度線（Isopycnals）  
データプロットポップアップメニューの Extras > Isopycnals オプションを選択して T/S データプロットに等密

度線を追加できます。Isopycnal Properties ダイアログで等密度線の基準圧力とそのグラフィカルプロパティ

を指定してください。draw isopycnals チェックボックスをチェックする／チェックを外すと等密度線を描画

します／描画しません。 
 
Extras > Isopycnals オプションは次の二種類の T/S プロットに対してのみ有効です： 

1. Practical Salinity キー変数として識別されている基本塩分変数が X 軸上に、ODV 派生変数 Potential 

Temperature が Y 軸上にあります。 

2. 派生変数 Absolute Salinity が X 軸上にあり、派生変数 Conservative Temperature が Y 軸上にあります。 

Extras > Isopycnals オプションは無効で、等密度線は他の全ての場合には使用できません。 
 
10.8 フィールドチェックを使用した範囲外値の検出（Finding Outliers using Field 

Checks） 
Weighted-average または DIVA gridding を使用した SECTION または SCATTER データウィンドウでは Extras 

> Find Outliers（Field Check）オプションを使用して Z 変数データの範囲外値を識別および編集ができます。 
 
範囲外値出力ファイルの名前と位置を指定した後、ODV はデータ位置（フィールド値）で Z 値の推定を開始

し、estimate-minus-data の差（不適合）と不適合標準偏差を計算します。不適合標準偏差の 1.5 倍を超えて

フィールド値から外れているデータ値は範囲外値と見なされフラグが立てられます。この手順は直前にフラ

グが立てられたデータポイントを除外して三回まで繰り返されます。 次に識別された範囲外値のリストを見

て、関連するＺ変数値を調べて編集することができます。 

 

範囲外値を識別するためのこの方法は、疑わしいデータの割合が比較的小さく、データウィンドウの選択さ

れた格子化した長さスケールがデータに見られる典型的な長さスケールに対応している場合に最も効果的で、

格子化フィールドでは正しく表現されない可能性がある急勾配の領域では注意が必要です。そのような領域

で不適合値が大きいと、データ値自体に問題があるというよりは、推定されたフィールド値が正しくないこ

とを反映している可能性があります。効率上の理由から、データウィンドウ自体が DIVA gridding を使用して

いる場合でもフィールドチェックには Weighted-average gridding が使用されます。 

  

Toru Suzuki
文中とソフトウェアではHeat Mapになっていますが，図は前版のX/Y Distributionのままです。入れ替え忘れたものと思われます。
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11 グラフィックスオブジェクト（Graphics Objects）  
キャンバス、マップ、または任意のデータウィンドウにテキスト注釈、記号、線、およびその他の幾何学的

オブジェクトを追加できます。ESRI シェープファイルで提供される地勢データを測点図に追加できます。以

下のグラフィックスオブジェクトがサポートされています：（1）テキスト注釈、（2）直線、（3）長方形

と正方形、（4）楕円と円、（5）連続直線（直線セグメントまたはベジエ平滑化）、（6）塗りつぶしポリ

ゴン（直線セグメントまたはベジエ平滑化）、（7）記号、（8）記号セット、（9）凡例、（10）ファイル

からのさまざまなオブジェクトタイプ。これらのオブジェクトの詳細な説明は以下の通りです。 

 

グラフィックスオブジェクトは、そのオブジェクトが作成されたキャンバス、マップ、または特定のデータ

ウィンドウの所有になります。キャンバス、マップ、またはデータウィンドウの全てのグラフィックスオブ

ジェクトは、それぞれの親ウィンドウが描画されるたびに描画されます。グラフィックスオブジェクトの座

標は、親ウィンドウまたはキャンバスの座標システムで指定されます。キャンバス座標は左下隅から右また

は上に向かって cm（センチメートル）です。 
 
オブジェクトの初期の所有権と座標システムは、作成を始めたウィンドウから派生します（下記参照）。グ

ラフィックスオブジェクトの他のほとんどのプロパティと同様に、所有権と座標システムはいつでも編集お

よび変更できます。デフォルトではグラフィックスオブジェクトは親ウィンドウに貼り付けられます。ウィ

ンドウのビューポートの外側にオブジェクトを作成する場合は、必ずオブジェクトの Properties ダイアログ

ボックスの Clip to window ボックスのチェックを外してください（下記参照）。 

 

グラフィックスオブジェクトは現在のビューに属し、ビューファイルに保存されます。 
 
作成 (Creation)  

自動的に作成される凡例を除いて、マップまたはデータウィンドウポップアップメニューから Extras > Add 

Graphics Object > ...  [”...”は目的のオブジェクトタイプを示す]を選択して、他のグラフィックスオブジェクト

を作成および追加できます。またはキャンバスポップアップメニューから Add Graphics Object > ...を選択しま

す。最初の作成後、オブジェクトのさまざまなプロパティを定義するためのダイアログボックスが表示され

ます。これらのプロパティは後でいつでも再度変更できます（下記の Edit を参照）。グラフィックスオブジ

ェクトは、作成を始めたウィンドウ（またはキャンバス）の所有になり、グラフィックスオブジェクトの座

標はそれぞれのウィンドウ座標システムにあります。結果としてウィンドウの全てのオブジェクトはそれぞ

れのウィンドウが移動またはサイズ変更されたときに自動的に追従します。 

 

グラフィックスオブジェクトは、グラフィックスオブジェクトコンテキストメニューの Copy Object オプショ

ンまたはグラフィックスオブジェクト管理ダイアログの Copy ボタンを使用して、既存のオブジェクトのコピ
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ーとして作成することもできます（下記参照）。既存のグラフィックスオブジェクトをエクスポートするこ

とによって、以前に作成された ODV.gob ファイルからグラフィックスオブジェクトを読み込むこともできま

す。断面プロットの海底地形ポリゴン、格子化フィールドを表示するデータウィンドウの等値線、オリジナ

ルのデータを表示するデータウィンドウの色付きデータ点、または測点図の測点選択ポリゴンなど、その他

のウィンドウオブジェクトも.gob ファイルに書き込まれます。これらの書き込まれたオブジェクトは全て後

で読み込んでグラフィックスオブジェクトとしてキャンバス、マップ、または任意のデータウィンドウに追

加することができます。 
 
編集・削除 (Edit and Delete)  

特定のオブジェクトのプロパティは、その上にマウスを移動して（記号セットの場合はいずれかの記号の上

にマウスを移動して）、マウスの右ボタンをクリックしてポップアップメニューから Properties を選択する

と変更できます。軸ラベル、ユニット矢符ボックス、凡例などの一部のグラフィックスオブジェクトは自動

的に作成および削除されます（自動グラフィックスオブジェクト）。これらのオブジェクトは手動で編集ま

たは削除することはできません（自動軸タイトルはウィンドウの Properties ダイアログの General ページでオ

ン/オフを切り替えられます）。 
 
（オブジェクトごとに異なる）ダイアログボックスが表示されるので、プロパティを簡単かつ迅速に変更で

きます。グラフィックスオブジェクトは親ウィンドウに貼り付けられ（window ボックスの Clip をオンにす

る）、ウィンドウのデータが描画される前に描画されます（Pre-data plot ボックスをチェックする）。オブ

ジェクトを削除するには、マウスをオブジェクトの上に移動してマウスの右ボタンをクリックし、Delete 

Object を選択してください。 
 
ドラッグ (Dragging)  

グラフィックスオブジェクトの Allow dragging が設定されている場合は、オブジェクトを別の場所にドラッ

グするだけでオブジェクトの位置を変更できます。オブジェクトをドラッグするには、その上にマウスを移

動し、マウスの左ボタンをクリックしたままマウスを動かします。デフォルトでは、ドラッグは実際のデー

タ値にリンクされている記号セットを除く全てのグラフィックスオブジェクトに対して最初はオンになって

います。オブジェクトの Properties ダイアログを使用して Allow dragging 属性をいつでも変更できます（上

記参照）。 

 

グラフィックスオブジェクトの管理 (Managing Graphics Objects) 

それぞれの Extras > Manage Graphics Objects オプションを使用して、キャンバス、マップ、または任意のデー

タウィンドウのグラフィックスオブジェクトを管理できます。これにはオブジェクトのプロパティの変更

（編集）、エクスポート、コピー、削除、またはオブジェクトの描画順序の変更が含まれます。 
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11.1 注釈（Annotations） 
キャンバス、マップ、またはデータウィンドウポップアップメニューから (Extras >) Add Graphics Object > 

Annotation を選択して注釈を追加できます。十字カーソルが表示されますので、注釈を表示する場所に移動

して、マウスの左ボタンをクリックしてください。作成を始めたウィンドウがそれぞれのオブジェクトを所

有します。注釈を追加（または編集）するときは、注釈テキストの位置、向き（度、反時計回り）、フォン

トサイズ（ポイント(pt)）、色、および配置パラメータを設定できます。注釈は枠を持つことができ、テキ

ストを描画する前に注釈矩形を塗りつぶすことができます。これら全てのアイテムに異なる色を選ぶことが

できます。ODV の注釈では、さまざまなフォーマット制御シーケンスと自動テキスト置換機能を使用できま

す。 
 
全てのグラフィックスオブジェクトと同様に、マウスカーソルをその上に移動し、マウスの左ボタンを押し

たままマウスを動かすことで注釈を別の位置にドラッグできます。注釈を編集するには、注釈の上にマウス

を移動してマウスの右ボタンをクリックし、ポップアップメニューから Properties を選択してください。注

釈（全ての注釈）を削除するにはポップアップメニューから Delete Object (Delete All Objects)を選択してくだ

さい。 
 
データプロットウィンドウの軸ラベルは自動注釈として実装されています。それらはプロットウィンドウが

描画されるときに自動的に作成され、それぞれのデータプロットウィンドウが削除されるときに削除されま

す。自動軸タイトルを編集または削除することはできません。軸ラベルの変更を恒久的にするには自動軸タ

イトルをオフにし（ウィンドウの Properties ダイアログの General ページを参照）、キャンバスポップアップ

メニューから Extras > Add Graphics Object > Annotation を選択して手動で水平および垂直方向の注釈を作成し

てください。 

 

11.2 直線、連続直線とポリゴン（Lines, Polylines and Polygons）  
マップ、データウィンドウ、またはキャンバスポップアップメニューから (Extras >) Add Graphics Object > 

Line, ... > Polyline or ... > Polygon を選択して、直線、連続直線、ポリゴンをマップ、データウィンドウ、または

キャンバスに追加します。三つの場合の全てにおいてカーソルが十字に変わりますので、オブジェクトの節

点を指定して先に進む必要があります。Line グラフィックスオブジェクトの場合は始点と終点を定義する必

要があります。十字カーソルを線の始点に移動してマウスの左ボタンをクリックし、終点に移動してもう一

度左ボタンをクリックしてください。連続直線またはポリゴングラフィックスオブジェクトの場合、最大

1000 個の節点を定義できます。ポリゴンは ODV によって自動的に閉じられることに注意してください。点

を削除したい場合は十字カーソルを点の近くに移動してマウスの右ボタンをクリックしてください。Enter キ

ーを押すとポリゴンまたは連続直線の点の定義が終了します。 
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線、連続直線、またはポリゴンの節点を指定すると、ODV は、色、幅、（連続直）線（の種類、およびポリ

ゴンの塗りつぶしの色を定義できるプロパティダイアログを表示します（Line と Polyline では無視されま

す；ポリゴンの塗りつぶしを避けるためには塗りつぶしの色に（none）を選択します）。連続直線とポリゴ

ンは Bezier smoothing ボックスをチェックすると線を滑らかにすることができます。 
 
線、連続直線、ポリゴンの始点や終点には、矢尻、塗りつぶされた、または塗りつぶされていない点やバー

などの特殊記号を付けることができます。そのような記号を選択するとプロパティダイアログを介してそれ

らのサイズを指定できます。 

 

11.3 矩形と楕円 (Rectangles and Ellipses)  
マップ、データプロット、キャンバスに矩形(正方形)と楕円(円)を追加するには、マップ、データプロット、

キャンバスポップアップメニューから(Extras >) Add Graphics Object, …> Rectangle, … > Ellipse を選んでくださ

い。新しい矩形または楕円の境界ボックスを示す赤いズーム矩形が現れます。ズーム矩形は移動およびサイ

ズの変更ができます。設定を確定させるには ENTER を、オブジェクトの作成を中止するには ESC を押してく

ださい。ダイアログボックスが現れますので、矩形または楕円のプロパティを定義してください(詳細は線と

ポリゴン(Lines and Polygons)を参照してください)。 

 

11.4 記号 （Symbols） 
記号(点、正方形、ダイヤモンド、三角形、逆三角形、星、×、プラス)をマップ、データウィンドウ、キャン

バスに追加するには、マップ、 データウィンドウ、キャンバスポップアップメニューから(Extras >) Add 

Graphics Object > Symbol を選んでください。マウスカーソルが十字形になりますので、記号を表示させたい

場所に移動させてマウスの左ボタンをクリックしてください。Symbol Properties ダイアログボックスが現れ

たら、それぞれの記号のプロパティを設定してください。 

 

11.5 記号セットと凡例 (Symbol Sets and Legends) 
選択したデータ点に記号(記号セット)を割り当てて、データウィンドウ中のデータの点のサブセットやマッ

プ中の測点のサブセットを強調することができます。データウィンドウやマップに記号セットを作成するに

は、そのウィンドウ上にマウスを動かして Extras > Add Graphics Object > Symbol Set を選んでください。

Symbol Set Selection ダイアログボックスが現れたらデータ点のサブセットを選択してください(一つ以上の航

海ラベルを Cruises リストの中から、測点を Stations リストの中から、および/または個々のサンプルを

Samples リストの中から指定してください)。Selected リストに選んだデータ点を追加するには<<ボタンを押

してください。全ての希望する点が選択されてから OK を押すと Symbol Set Selection Properties ダイアログが

現れますので、記号と線の特性を定義してください。記号セットが持つ説明文(凡例)はそれぞれのウィンド

ウの凡例に自動的に追加されます(Add to legends ボックスをチェックしてください)。他のグラフィックスオ
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ブジェクトとは異なり、記号セットは選択されたデータ点に関連付けられているのでドラッグできません。

記号セット上にマウスを動かして右ボタンをクリックし、Properties を選択すると、いつでも記号セットの全

プロパティを変更することができます。 

 

図 11-1：特定の測点のデータを強調表示するために記号セットおよび凡例を使用した SCATTERプロットの

例 
 
データウィンドウまたはマップに記号セットが含まれている場合で、かつ Add to legends オプションがオンの

場合、このウィンドウに現れている全ての記号セットの記号と凡例の説明文を含んだ凡例ボックスが自動的

に表示されます。凡例セットは別の場所にドラッグでき、それらのプロパティ(凡例ボックスの大きさは説明

文のフォントサイズの変更に応じて修正されます)はいつでも修正できます(マウスを凡例セットに移動させ

て右ボタンをクリックし、Properties を選んでください)。 
 

11.6 ファイルからのグラフィックスオブジェクト（Graphics Objects from Files） 
ODV は.cdt ファイルからの海底地形、海岸線または地形の等深線、.gob ファイルからのグラフィックスオブ

ジェクト、および ESRI .shp シェープファイルからの地勢の読み込みをサポートしています。マップ、デー

タウィンドウ、またはキャンバスポップアップメニューから(Extras >) Add Graphics Object from File > [type] 選

んでグラフィックスオブジェクトを追加できます。ODV は現在、次のタイプ：（1）Graphics Object File 

(*.gob)、（2）CDT File (*.cdt)、および（3）Shapefile (*.shp) をサポートしています。全ての場合において「フ

ァイルを開く」ダイアログが表示され、グラフィックスオブジェクトを読み込むファイルを選択できます。

cdt ファイルと shp ファイルはマップにのみ追加できます。 

 

シェープファイルを開くとファイル内のオブジェクトの種類と数をユーザーに通知します。そして ODV では、

色、線の種類、幅などのグラフィックスプロパティを指定できます。これらのプロパティはシェープファイ
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ル内の全てのオブジェクトに適用されますが、後で Manage Graphic Objects オプションを使用して変更できま

す（下記参照）。 
 
シェープファイルに付随する.prj 投影ファイルがある場合、ODV は必要に応じて投影情報を使用して地理座

標を WGS84 に変換します。.prj 投影ファイルが見つからない場合、ODV は全ての地理座標が WGS84 であ

り、-180 から+360 および -90 から+ 90 度の範囲内にあると見なします。ODV は現在、シェープファイ

ルのポイント、マルチポイント、ライン、マルチライン、ポリゴン、マルチポリゴンをサポートしています。

ポリゴンの場合は外側の輪だけが描かれます。非常に大きなシェープファイルの描画は遅くなることがあり

ます。 

 

11.7 グラフィックスオブジェクトの管理（Managing Graphics Objects） 
各領域を右クリックして Manage Graphics Objects または Extras > Manage Graphics Objects を選択すると、キャ

ンバス、マップ、またはデータウィンドウの全てのグラフィックスオブジェクトの完全なリストを取得でき

ます。 

図 11-2：Graphics Objectsダイアログ 

 
Graphics Objects ダイアログ（図 11-2）が表示され、個々のオブジェクト、オブジェクトのサブグループ、ま

たはオブジェクトのリスト全体を選択できます。一つ以上のオブジェクトを選択した場合は Delete を押して

選択した全てのオブジェクトを削除するか、Export を押して後で再利用するために選択した全てのオブジェ

クトを.gob または.shp ファイルにエクスポートできます。一つのオブジェクトだけを選択した場合は、その

オブジェクトをコピーするか（Copy を押す）、またはそのオブジェクトのプロパティを変更することもでき

ます（Edit を押す）。描画順序を変更して、オブジェクトを最前面（Foreground または Up）または後面

（Background または Down）に近づけることもできます。 
 
複数のオブジェクトをシェープファイルにエクスポートする場合、ODV は選択されたセット内の全てのオブ

ジェクトタイプに対して個別のファイルを作成します。最初のものを除く全ての作成されたシェープファイ

ルに対して、ODV は自動的にオブジェクトタイプを記述しているファイル名文字列に追加します（例：

_points、_polygons、または_lines）。エクスポートされたオブジェクトの少なくとも一つが記号セットの場合、
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全ての記号と記号セットはマルチポイントジオメトリを持つシェープファイルに書き込まれます。エクスポ

ートされたオブジェクトの少なくとも一つがポリゴンの場合、全ての線とポリゴンはポリゴンとしてシェー

プファイルに書き込まれます。 
 
現在のシェープファイルのエクスポートの実行にはいくつかの制限があります：（a）CDT ファイルオブジ

ェクトと注釈は未だシェープファイルにエクスポートできません；（b）投影情報.prj ファイルは書き出され

ません（全ての地理座標は WGS84 と見なされます）；（c）記号セットを除いて属性.dbf ファイルは書き出

されません（記号セットの場合、凡例文字列は属性 Name で書き出されます）；（d）全てのオブジェクトは

最初のレイヤーだけが書き出され、マルチレイヤーはサポートされていません。 
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12 コレクションの操作（Working with Collections） 
 
12.1 コレクションのコピー、パッケージング、名前の変更、削除  （Copying, 

Packaging, Renaming and Deleting Collections） 
Collection > Copy を使用して現在開いているコレクションのコピーを作成し、Collection > Move/Rename を使

用して現在開いているコレクションの名前を変更 (あるいは移動も)できます。Collection> Delete を使用して

現在開いているコレクションを削除できます。古い ODVGENERIC コレクションを削除する場合はコレクシ

ョンのビューおよびセクションファイルを手動で削除する必要があります。 
 
Collection > Create Snapshot オプションを使用して、コレクションを zip ファイルにパッケージ化できます。 

これは、コレクションのバックアップコピーを作成するときや、コレクションを友人と共有するときに便利

です。パッケージ化によってソースコレクションは変更されません。 

 

12.2 並び替えと圧縮（Sorting and Condensing） 
コレクション内の測点が航海順に並べられている場合、ODV の測点検索および選択アルゴリズムは最も効率

的に機能します。したがって多数の測点のインポート、置換、マージ、または削除した後は、コレクション

を並び替えて圧縮することをお勧めします。Collection > Sort and Condense を選択して並び替えと圧縮の手順

を呼び出します。 

 

12.3 測点の削除（Deleting Stations） 
ODV のメインメニューから Collection > Delete Station Subset を選択すると現在選択されている測点をコレク

ションから削除できます。現在の測点のみを削除するには Collection > Delete Current Station を選択します。

コレクションディスクファイル内で削除された測点のデータスペースは、コレクションを並べ替えて圧縮す

るまで解放されません。 
 
12.4 コレクションプロパティの変更（Changing Collection Properties） 
重要な注意：このセクションで説明されている操作を行う前に Collection > Create Snapshot オプションを使用

して現在のコレクションのバックアップコピーを作成してください。 
 
ODVGENERIC および ODVCF5 コレクションは Collection > Properties > Convert to ODVCF6 オプションを使用

して新しい ODVCF6 コレクション形式に変換できます。 
 
開いている ODVCF6 コレクションのプロパティは Collection > Properties オプションを使用して変更できます。 

General, Meta Variables, Data Variables の三つのサブオプションがあります。General オプションではデータフ

ィールド（GeneralField、Ocean、Atmosphere、Land、IceSheet、SeaIce、Sediment）、データタイプ
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（GeneralType、Pro-files、Trajectories、TimeSeries）、およびデータの並び替えに使用される主要変数

を定義できます。データフィールドとタイプのエントリは現在使用されていません。ただし将来の ODV バー

ジョンではデータフィールドに応じてさまざまな派生変数のセットが提供されるか、データタイプに応じて

さまざまなデフォルトの作図スタイルが適用される可能性があります。 
 
Meta Variables と Data Variables オプションはメタデータとデータ変数セットの修正を可能にします。これに

は新しい変数の追加、既存の変数の削除、変数の並べ替え、データタイプ、バイト長、変数の品質フラグに

使用される品質フラグスキーマなどの変数のプロパティの変更が含まれます。最初の 12 個のメタ変数は必

須で、削除したり並べ替えたりすることはできません。 
 
コレクションのデータフィールド、データタイプ、または変数のラベル、単位、小数点以下の桁数の変更な

どの一部の修正は、コレクションの設定または変数ファイルに新しいエントリを記録することで対処できる

単純な変更です。変数の追加または削除、コレクションの主要変数の変更、または変数のデータタイプまた

は品質フラグスキーマの変更は、コレクションのメタデータとデータファイルの完全な書き換えを必要とす

る重大な変更です。 

 
コレクションの書き換えが発生すると、元のコレクションが ODVCF5 または ODVGENERIC であっても、新し

いコレクションは常に新しい ODVCF6 コレクション形式（ .odv コレクション）を使用します。新しい

ODVCF6 コレクション形式には ODV 4.6.0 以上が必要です。 
 
12.5 キー変数の関連付け（Key Variable Associations） 
多くの派生変数は、派生変数の計算に必要な入力変数の識別を必要とします。キー変数の識別は、派生変数

の最初の定義中に行われ、選択された変数はコレクションの設定ファイルに記録されます。後で派生変数が

再度要求された場合は、記録されているキー変数情報が使用され、ユーザーに再度要求が出されることはあ

りません。 

Collection > Identify Key Variables を使用して現在のキー変数の関連付けを調べて変更できます。Identify Key 

Variables ダイアログが現れると、左側にキー変数のリスト、右側にデータ変数のリストが表示されます。関

連する項目はアスタリスク（*）で印付けられています。リストのいずれかでそのような項目をクリックする

と ODV は他のリストに関連項目を表示します。Undo 押すと関連付けを解除できます。Undo All を押すと全

ての関連付けが解除されて全てのキー変数が未定義のままになります。 
 
二つのリストで関連項目を選択して Associate を押すと関連付けが確立されます。データ変数のリストに含ま

れていないキー変数リスト内の項目は Not Available ボタンを押すことによって使用不可としてマークされま

す。このような項目はキー変数リスト内ではマイナス記号（-）で印付けられています。 
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重要な注意：キー変数の関連付けに失敗すると、影響を受ける派生変数の値が間違い、かつ意味のないもの

になる可能性があります。例えばキー変数 Practical Salinity [psu]が誤ってデータ変数 Oxygen [μmolkg-1]に関連

付けられていたとします。これは Practical Salinity [psu]を入力変数として要求する全ての派生変数（例えばポ

テンシャル水温、ポテンシャル密度など）が、塩分の代わりに酸素値を使用するため、誤った値を返す原因

になります。疑わしい派生変数の値を受け取ったときには、先ず Collection > Identify Key Variables オプション

を使用してキー変数の関連付けの有効性の検証をチェックするべきです。 
 

 
図 12-1：Identify Key Variablesダイアログ 

 

12.6 有効範囲の基準（Good Coverage Criteria） 
標準層への内挿やさまざまな派生変数の計算など、一部の ODV 操作では sufficient（十分な）入力データが

利用可能であることが必要です。例えば、力学高度の計算には水温と塩分のデータの完全なプロファイルが

必要です。また、データポイント間のギャップが大きすぎてもいけません。Collection > Good Coverage 

Criteria を使用して、所定の変数のデータが十分であること考慮するために満たさなければならない基準を指

定できます。これらの基準は特定の操作によって必要な全ての変数に適用されます。一つ以上の必須変数が

テストに失敗した場合、それぞれの操作は実行されません。 
 
許容ギャップの仕様は二つの項の最小値であり、一つは主要変数値 Z（プロファイルデータコレクションの

場合は深さまたは圧力）に依存し、もう一つは第二定数項です。大きなデータギャップを許容する場合は、

両方の行の最初のフィールドに大きな値を入力してください。 

 

12.7 コレクション情報の閲覧（Browsing Collection Information） 

コレクション情報（Collection Info） 
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全てのコレクションには、そのコレクション内のデータに関するフリーテキストの説明があります。この情

報はコレクションの情報ファイルに保存されています。Collection > Browse Info File を選択すると現在開いて

いるコレクションの情報ファイルを表示または編集できます。 
 
航海目録（Cruise Inventory） 

Collection > Browse Inventory を選択すると現在開いているコレクションの航海目録表を閲覧できます。以下の

情報：航海 ID、測点数、サンプル数、測点 ID、経度と緯度の範囲および期間が航海毎に提供されます。別

のウィンドウは所定の航海のデータを含む変数のリストを表示します。 

 

コレクションログファイル（Collection Logfile） 

コレクションの内容を変更する全ての操作（作成、データのインポート、測点の削除など）はコレクション

ログファイルに記録されます。メタデータやデータの編集は測点の履歴（ODVCF6）またはコレクションロ

グファイル（ODVCF5 と ODGENERIC）に記録されます。Current Station Window の測点 ID の見出しの上に

マウスを置くと測点の履歴が表示されます。コレクションログファイルは Collection > Browse Log File オプシ

ョンを使用して表示できます。 
 
12.8 変数のプロパティ（Properties of Variables） 
現在の測点または現在のサンプルリストウィンドウを右クリックして Properties オプションを選択するとメ

タ変数とデータ変数のプロパティを変更できます。変数のリストから変更したいものを選択して Edit を押し

てください。選択した変数のプロパティダイアログで変数ラベル、単位、コメントの文字列を編集できます。

現在の測点またはサンプルウィンドウに値を表示するために使用される桁数を変更することもできます。 

 

12.9 データの編集（Editing Data） 
現在の測点のメタデータとデータ値、およびそれらに関連付けられている品質フラグを編集し、変更した値

をディスク上のコレクションデータファイルに保存できます。 
 
測点メタデータ （Station Metadata） 

現在の測点のメタデータを修正するには、現在の測点リストウィンドウを右クリックして Edit > Metadata を

選択してください。現在の測点のメタデータを示す Edit Station Metadata ダイアログが表示されます。個々の

エントリを編集するには、それぞれの値フィールドをダブルクリックしてください。特定の品質フラグを変

更するには、そのフィールドをクリックしてから Change Quality Flag ボタンをクリックして新しい品質フラ

グを選択してください。 

 
Edit Station Metadata ダイアログで OK をクリックすると新しいメタデータがコレクションファイルに書き込

まれます。変更を破棄して現在の測点のメタデータを変更しない場合は Cancel を押してください。OK が押
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されて、編集された変数が値タイプ INDEXED_TEXT を持つならば、あなたは現在のインスタンスのみ、ま

たは前の文字列の全ての発生を修正するオプションを持っています。Modify all instances を選択すると、テキ

スト内の間違いを修正したり、コレクション内の航海ラベルなどの項目を一回の編集操作で全体を修正した

りできます。 

 
編集操作は測点の履歴（ODVCF6）またはコレクションログファイル（ODVCF5 と ODVGENERIC）に記録

されます。Current Station Window の測点 ID の見出しの上にマウスを置くと測点の履歴が表示されます。コ

レクションログファイルは Collection > Browse Log File オプションを使用して表示できます。 

 

図 12-2：Edit Station Metadataダイアログ 

 

測点データ （Station Data） 

現在の測点の所定の変数のデータを修正するには、現在のサンプルリストウィンドウ内の特定の変数を右ク

リックして Edit Data を選択してください。現在の測点の全てのサンプルに対する変数のデータ値と品質フラ

グを示す Edit Data ダイアログが表示されます。現在のサンプル（初期選択）またはユーザー定義のサンプル

サブセットのデータ値と品質フラグを変更できます。マウスを左クリックしながら標準の拡張選択キーCtrl

と Shift を押してデータリストのサンプルサブセットを定義してください。Select All をクリックして全てのサ

ンプルを選択するか Invert Selection を押して現在の選択を反転させてください。 
 
単一のデータ項目を選択した場合は Change Value をクリックして新しい数値を入力することによってその値

を変更できます。データリストで複数のサンプルを選択した場合 Change Value ボタンは無効になります。

Delete Value(s）ボタンを押すと選択した全てのサンプルのデータ値が削除されます。元のデータ値は永久に

失われるので、このボタンは慎重に使用してください。 
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警告：Change Value オプションを使って主要変数の値（深さ、圧力、時間など）を編集するのは危険であり、

予期せぬ影響が生じる可能性があることに注意してください。具体的には、主要変数の値の変更は現在の測

点内のサンプルの順序に影響を与え、編集中のサンプルはプロファイル（または時系列）内で上下に移動し

て、編集後にサンプル ID が変わる可能性があります。これが発生した場合、編集後の Current Sample 

Window には編集されたサンプルは表示されなくなりますが、並べ替え後に編集されたサンプルの場所を持っ

ているサンプルはこれにはあてはまりません。 
 
サンプル値の編集と削除は、どうしても必要なときにだけ行ってください。 通常は実際のデータ値を変更せ

ずに、選択したサンプルのデータ品質フラグを変更するべきです。これは、Change Quality Flag(s）ボタンを

クリックして利用可能なフラグのリストから新しい品質フラグを選択することによって行われます。OK を押

すとディスクへの変更が保存され、Cancel を押すと編集セッションが中止されて測点データは元の形式のま

まになります。 
 
品質フラグの値を使用してデータをフィルタリングできます。編集操作は測点の履歴（ODVCF6）またはコ

レクションログファイル（ODVCF5 と ODVGENERIC）に記録されます。Current Station Window の測点 ID

の見出しの上にマウスを置くと測点の履歴が表示されます。コレクションログファイルは Collection > Browse 

Log File オプションを使用して表示できます。 
 
現在の測点の所定のサンプルのデータを修正するには現在のサンプルリストウィンドウを右クリックして

Edit Sample Data を選択してください。現在のサンプルの全てのデータ変数のデータ値と品質フラグを示す

Edit Sample Data ダイアログが表示されます。特定の変数のデータ値または品質フラグを変更するには、その

変数をクリックしてから Change Value, Delete Value, または Change Quality Flag ボタンをクリックします。 
 
サンプルリストウィンドウを右クリックしてオプション Delete Current Sample を選択すると、現在のサンプ

ル（全てのデータ変数の全てのデータ値を含む）を削除できます。あるいはサンプルリストウィンドウを右

クリックしてオプション Add New Sample を選択すると新しいサンプルを追加することもできます。新しいサ

ンプルの主要変数値を入力して OK を押してください。 
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図 12-3：データ編集ダイアログ(所定の変数の全てのサンプル値) 

 

図 12-4：Edit Sample Data ダイアログ(所定のサンプルの全ての変数値) 

 

品質フラグ値（Quality Flag Values） 

上記の方法に加えて、Current Sample ウィンドウで変数を右クリックし、Assign Quality Flags サブメニュー: 
(1) Current Sample, (2) All Samples of Current Station, (3) All Samples in Window n, (4) All Samples of Valid Stations,  
(5) All Samples in Collection.のいずれかのオプションを使用して、所定の変数のデータの品質フラグ値を変更

することもできます。 
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品質フラグの変更が適用されるサンプルのセットは選択したオプションによって異なり、現在のサンプルの

み（オプション 1）からコレクション内の全ての測点の全てのサンプル（5）までの範囲です。オプション 3

では、現在のデータウィンドウ n に表示されている変数のデータに新しい品質フラグを割り当てることがで

きます。オプション 4 と 5 では、現在マップに表示されている全ての測点の全てのサンプル（有効な測点）

またはコレクション内の全ての測点の全てのサンプルに新しい QF 値を適用します。 
オプション 3 から 5 は潜在的に非常に大きなサンプルのセットを変更するため、変更を加える前にユーザー

が確認する必要があります。 

 
サブメニューオプションの一つを選択した後に ODV は Assign Quality Flags ダイアログを表示します（図 12-

5）。このダイアログでは、割り当てる新しい品質フラグ値を選択し、このフラグを現在の値に関係なく全て

のサンプルに割り当てるか、特定の QF 値のみに等しい（または等しくない）サンプルに割り当てるかを指

定します。この操作は、測点の履歴（ODVCF6）またはコレクションログファイル（ODVCF5 と

ODVGENERIC）に記録されます。Current Station Window の測点 ID の見出しの上にマウスを置くと、測点の

履歴が表示されます。現在マップに表示されている全ての測点の履歴レコードは Export > Station History オプ

ションを使用してテキストファイルにエクスポートできます。コレクションログファイルは Collection > 

Browse Log File オプションを使用して表示できます。 

 

図 12-5：品質フラグの割り当てダイアログ 

 

12.10 パスワードプロテクション（Password Protection） 
ODVCF6 コレクションは Collection > Properties > Change Password オプションを使用してパスワードで保護で

きます。Change Collection Password ダイアログで現在のパスワードを入力し（コレクションが現在パスワー

ドで保護されていない場合は空白のままにします）、新しいパスワードを二回入力します。現在保護されて
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いるコレクションのパスワード保護を解除するには、古いパスワードを入力して New Password と New 

Password (repeated) を空白のままにします。 
 
パスワードで保護されたコレクションを開くと ODV はユーザーにパスワードの入力を求めます。入力したパ

スワードが正しくないとアクセスは拒否されます。コレクションのパスワードは安全な場所に保管してくだ

さい。パスワードを紛失するとデータコレクションにアクセスできなくなります。 

  

Suzuki Toru
原文もよくわかりません。
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13 NetCDFファイルの操作 (Working with NetCDF Files) 
NetCDF はソフトウェアライブラリのセットで、配列指向の科学データの作成、アクセス、および共有をサ

ポートする自己記述型でマシンに依存しないデータフォーマットです。NetCDF は気候研究やその他の地球

科学の分野で広く使用されています。多くの重要なデータセットとモデル出力ファイルは netCDF フォーマ

ットで配布されています。 

 

NetCDF ファイルは以下のプロパティを持っています： 

 Self-Describing. （自己記述型） netCDF ファイルは、そのファイルに含まれているデータについて

の情報を含みます。 

 Architecture-independent. （アーキテクチャ非依存）NetCDF ファイルは、異なる方法で保存されて

いる整数、文字、および浮動小数点数であっても、どのコンピュータからでもアクセスできる形式

で表されます（訳注：原文には書いていませんが、（CPU の違いによる）ビックエンディアン、リ

トルエンディアンを意識することなくアクセス可能、ということだと思われます）。 

 Direct-access. (直接アクセス)  大きなデータセットの小さなサブセットには、最初に全てのデータを

読み込まなくても、効率的にアクセスできます。 

 Appendable. (追記可能) データセットをコピーしたり、その構造を再定義したりすることなく、デ

ータを一次元で netCDF ファイルに追加することができます。NetCDF ファイルの構造は変更する

ことができますが、これによってデータセットがコピーされることがあります。 

 Sharable. (共有可能) 一人の作成者と複数の利用者が同じ netCDF ファイルに同時にアクセスする

ことができます。 

 

NetCDF データモデルは非常に一般的であり、netCDF ファイルの構造と内容はかなり異なります。NetCDF

データセットの交換と共有を容易にして促進するために、いくつかの規約が定義されています。 

二つの規約（CF と COARDS; 詳細な仕様については https://cfconventions.org/を参照）が気候研究者や

モデラーによって広く使用されており、多くのデータセットが CF/COARDS 準拠の netCDF ファイルとして

利用可能です。そのようなデータセットの例は、http://www.cdc.noaa.gov/PublicData/または

https://www.ncei.noaa.gov/thredds/catalog.html からダウンロードできます。NetCDF の詳細は netCDF の

Web ページ http://www.unidata.ucar.edu/packages/netcdf/ を参照してください。 
  

13.1 NetCDF サポート（NetCDF Support）  
ODV は CF/COARDS に準拠したファイルを含むものの、これに限定されない広範囲な netCDF ファイルを

開くことができます。これらのファイルはローカルファイルシステムまたはリモート OPeNDAP サーバーに

存在します。一旦 netCDF ファイルが正常に開かれると、ODV はあたかもデータが ODV データコレクショ

ンに保存されているかのようにファイル内のデータをユーザーに示します。ODV はクリック可能な測点図を

https://cfconventions.org/
http://www.cdc.noaa.gov/PublicData/
https://www.ncei.noaa.gov/thredds/catalog.html
http://www.unidata.ucar.edu/packages/netcdf/


ODV User’s Guide 
 

 

作成し、ODV コレクションに関してはほとんどのタイプのグラフィックス出力をサポートしています。ODV

は netCDF ファイルを読み取り専用モードで開くので、これらのファイルが変更されることは決してありま

せん。書き込み許可を求めるオプションは有効とならずにグレー表示となります。NetCDF ファイルはプラ

ットフォームに依存せず、サポートされている全てのプラットフォームで同じファイルを使用できます。 
 
通常 netCDF ファイルの中の所定の変数 S のデータは一次元または多次元配列として保存されています。時

空間変数の次元のセットには三つの空間座標 X, Y, Z と時間座標 T が含まれます。これらの次元をＳ(Ｔ, Ｚ, 

Ｙ, Ｘ)として順序付けることは規約であり、例えばＸは最も速く、Ｔは最も遅く変化する次元になります。

地球科学データの場合、X と Y は経度と緯度を表し、Z は海洋の深さや気圧、大気中の高度、堆積物や氷床

コアの深さなどの鉛直座標です。NetCDF ファイルが複数の X, Y, Z, T 座標系を含むことは可能です。例え

ばモデル出力の netCDF ファイルには、グリッドインターフェイスで定義された速度データだけでなく、モ

デルグリッドの中心で定義されたデータ（トレーサー濃度など）を含めるのが一般的です。ODV は一度に一

つの X, Y, Z, T 座標系しか扱うことができないため、対応する次元は netCDF セットアップ中に選択する必

要があります（下記参照）。 
 
NetCDF ファイルを開くときの ODV ユーザーの主な課題は、空間と時間の次元を正しく識別し、複数の座標

系で状況を把握して、適切な主要変数を選択することです。例えば主要変数として Z を選択すると netCDF

ファイルは全ての(X, Y）位置に nT 個の測点を持つ鉛直プロファイルデータベースに変換されます。この場

合の測点の総数は nT * nY *nX です。ここで nK は次元 K の長さです。あるいは T を主要変数として選択した場

合、netCDF ファイルのデータは時系列として解釈されます。この場合（X, Y, Z）ポイントごとに一つの測

点（時系列）となり、測点の総数は nZ * nY * nX です。 
 
最高レベルのユーザーコントロールを提供するために、ODV は netCDF ファイルが初めて開かれたときに

netCDF セットアップウィザードを表示します。この四ページのダイアログのさまざまなコントロールは自

動的に定義された設定で初期化されます。多くの場合、ユーザーは Next を押して設定を確認し、最後に

Finish を押すだけで済みます。これらの設定は ODV によって記憶され、ファイルを再度開いたときにセット

アップウィザードは表示されません。以下の方法で ODV にセットアップウィザードを表示させることができ

ます：（1）（例えば File > Open オプションで）netCDF ファイルを開き、（例えば File > Recent Files オプシ

ョンで）同じ netCDF ファイルを再度開く、または（2）netCDF ファイルが開いている間に Collection > 

Properties > NetCDF Setup を使用します。 
 
ローカルファイルシステム上の netCDF ファイル（拡張子は .nc または .cdf である必要があります）を開く

には、ODV アイコンまたはウィンドウにファイルをドロップするか、File > Open を選択して標準のファイル

選択ダイアログでファイルを選択します。NetCDF ファイルを開く前であれば File > Recent Files オプション

を使ってファイルにアクセスすることもできます。さらに、ODV をコマンドラインから起動し、netCDF フ

ァイル名をコマンドライン引数として指定することもできます。 
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リモートの OPeNDAP サーバー上の netCDF ファイルを開くには File > Open Remote オプションを使用して

netCDF フ ァ イ ル へ の URL を 入 力 し て く だ さ い （ 例 ：

http://test.opendap.org/dap/data/nc/coads_climatology2.nc）。 

 

ODV は netCDF ファイルを開き、ファイルに含まれる次元と変数に関する情報を取得します。ODV はまた、

全てのグローバル属性と変数の全ての属性を取得し、この情報を ncdump –h < file>が生成する形式と同じ形式

で ASCII ファイルに書き出します。このファイルはセットアップウィザードの最初のページにある View 

NetCDF Header ボタン（下記参照）をクリックするか、Collection > Browse Info オプションを使用していつで

も表示できます。 
 
13.2 NetCDF セットアップ（NetCDF Setup） 
netCDF ファイルが分析されると、ODV は必要な情報を集めるための四ページのウィザードを表示します。 

 

NetCDF次元の選択（Selecting NetCDF dimensions）  

セットアップウィザードの最初のページ（図 13-1）にはファイルに含まれている次元のリストが表示されま

す。最初に全ての次元が選択されます。ただし複数の X, Y, Z, T 座標系で、これらの系の一つのみが選択され

ている場合を除きます。所定の次元の選択に対して、これらの次元で定義された netCDF 変数のセットは、

Corresponding netCDF variables リストに表示されます。NetCDF dimensions リストで選択されていない次元に

依存する netCDF ファイル内の他の変数は Corresponding netCDF variables として表示されません。対応する

次元を選択しない限り、これらの変数は使用できません。拡張選択テクニック（Ctrl キーまたは Shift キーを

押しながらマウスの左ボタンをクリック）を使用して、使用する必要がある全ての次元を選択してください。

共通の次元 X（経度）、Y（緯度）、Z（深度/高さ）、および T（時間）に複数の座標が指定されている場合

は、必ず各方向に一つのみを選択してください。 
 
NetCDF ファイルのヘッダー情報を（ncdump-h と同様に）表示するには View NetCDF Header ボタンを押して

ください。ユーザーがファイルの構造と内容に慣れていないなら、これは常にされるべきです。 

http://test.opendap.org/dap/data/nc/coads_climatology2.nc
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図 13-1:netCDFセットアップウィザード(手順 1/4) 

 

メタデータ情報の指定（Specifying metadata information）  

セットアップウィザードの二ページ目（図 13-2）で、経度、緯度、データの日時などのメタデータを提供す

る netCDF 変数を識別する必要があります。多くの場合、ODV はそれぞれの変数を自動的に識別して関連付

けることができます。このような自動的に関連付けられたメタ変数はアスタリスク(*)で印付けられます。 
 
場合によっては自動設定を変更して手動で netCDF ファイル（NetCDF variables リスト）の変数と ODV メタ

変数（Meta variables リスト）の間の関連付けを確立する必要があります。 

 

NetCDF 変数とメタ変数の間の（一対一の）関連付けを確立するには NetCDF variables リストの中の netCDF

変数と Meta variables リストの中のメタ変数を選択して Associate を押してください。NetCDF メタ変数と

ODV メタ変数（通常 netCDF 時間変数に必要）の間の変換を確立するには上記のように二つの変数を選択し

てから Convert を押してください。コンボボックスから利用可能な変換オプションの一つを選択して OK を押

してください。General Linear Transformation では倍率とオフセット（位置・距離）を指定してください。 
 
多くの netCDF ファイルは、特定の開始日からの日数または時間数で与えられる相対時間を使用します。こ

の情報を活用して日と時間のメタ情報を取得することができます。これを行うには NetCDF variables リスト

で相対時間を、Meta variables リストで Year を選択してから Convert を押してください。ODV は自動的に変

換を確立しようとします。うまく行かなかった場合、ODV は手動での適切な変換アルゴリズム選択を促しま

す。ODV は基準日がグレゴリオ暦に基づいている事に注意してください。ODV 日付値はグレゴリオ暦の日

付です。 
 
メタ変数（例えば航海など）のデフォルト値は Meta variables リストで選択して Set Default を押すことで変

更できます。 
 
メタ変数 Cruise, Station, Type は ODV によって自動的に設定されるので手動で設定する必要はありません。

NetCDF ファイルに日付と時刻の情報が含まれていない場合、Year, Month, Day, Hour, Minute, Second のメタ変
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数は関連付けられていないままかもしれません。しかしながらウィザードの次のページに進む前に Longitude 

と Latitude のメタ変数は常に関連付けられていなければなりません。 

図 13-2：netCDFセットアップウィザード(手順 2/4) 
 
主要変数の選択 (Selecting the primary variable)  

セットアップウィザードの三ページ目（図 13-3）で主要変数を選択します。この変数は ODV コレクション

で主要変数の役割を果たし、データが鉛直プロファイルまたは時系列として解釈されるかどうかを決定しま

す。例えば Depth または他の鉛直次元が主要変数として使用される場合、測点は鉛直プロファイルを表示し

ます。 Time 変数を使用する場合、測点は時系列を表示します。Year メタ変数がウィザードの二ページ目で

定義された場合は Use decimal date/time 項目が有効になり、測点ヘッダーから派生した十進化時間変数

（units=YEARS）を主要変数として使用できます（時系列では日付/時刻メタ情報は時系列の開始を参照し、

それらは一定値です。） 
 
NetCDF ファイルには層の正確な値を明示する変数（例えば深度=0m または深度＝1000ｍ、など）を指定

しない、水平格子上のデータ値（例えば大気―海洋境界面を横切るフラックス、または特定深度層での濃度）

が頻繁に含まれています。そのような場合は Use dummy variable 項目を選択してください。 

図 13-3：netCDFセットアップウィザード(手順 3/4) 
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次元の部分設定（Subsetting dimensions） 

大規模な netCDF データセットを扱うときは、データアクセスを関心のある範囲と深さ、または時間範囲に

制限すると便利です。デフォルトで ODV は測点の総数が 300,000 を超えないように経度と緯度の範囲の増

分値（ストライド）を調整します。 
 
手動で任意の座標変数をサブセット化することもマップにズームインして範囲を絞り込むこともできます。

特定の範囲をサブセット化するには NetCDF dimensions リストで対応する項目を選択して Subset Dimension ボ

タンを押してください。ODV にはそれぞれの座標値のリストが表示され、この座標の開始インデックス、増

分、終了インデックスを指定できます。新しいインデックスセットを受け入れるには OK を押してください。

サブセット化する全ての範囲に対してこの手順を繰り返します。 

 

関心のあるサブ領域を定義するには Zoom into Map ボタンをクリックしてから赤いズームボックスを目的の

範囲にサイズを変更または移動して Enter ボタンを押すか、マウスの左ボタンをダブルクリックして選択し

てください。ズーム操作を中止するには ESC キーを押すかマウスを右クリックしてください。 

 

図 13-4：netCDFセットアップウィザード(手順 4/4) 

 

NetCDF ファイルの探索（Exploring the netCDF file） 

NetCDF セットアップウィザードの四つのステップ全てが完了すると ODV は測点図を描き、ネイティブの

ODV データコレクションに使用しているのと同じ方法で netCDF ファイル内のデータを調べることができま

す。ODV は netCDF ファイルを読み取り専用のデータセットとして扱い、これらのファイルには書き込めま

せん。したがってデータ書き込みアクセスを必要とする全てのオプションが無効になります。これには全て

のデータインポートオプション、メタデータとデータオプションの編集、およびほとんどのコレクション操

作オプションも含まれます。 
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ODV は netCDF セットアップの設定をビューファイルに保存し、次回 netCDF ファイルを開いたときにこれ

らの設定を使用します。すでに開いている netCDF ファイルに新しい設定を適用したい場合は、File > Recent 

Files オプションを使って netCDF ファイルをもう一度開きます。 

 

NetCDF リモートアクセス（Remote netCDF access）  

リモートの netCDF ファイルで作業するときのデータアクセス速度は、インターネット接続の帯域幅と、発

行されたデータ要求の種類に依存します。主要変数の長さが大きい場合（上記参照）、（例えば地図をクリ

ックすることが引き金となる）個々の測点データを取得するには、かなり時間がかかります。これは、例え

ば netCDF ファイルが数千の圧力または深度値のプロファイルデータ（例えば CTD データ）、または数千

の記録時間を有する時系列データ（例えば流速計データ）を含む場合に起こります。そのような場合は不要

なデータ検索を引き起こさないように、意図せずに測点図をクリックしないようにしてください。 

 

リモートの netCDF ファイルで作業する場合、ODV SECTION ウィンドウのデータを読み込むには非常に時

間がかかります。したがってそのような場合、セクションを定義および管理するためのオプションは無効に

なります。NetCDF セットアップウィザードの四ページ目で緯度（経度）範囲を部分設定化し、一つの値だ

けを選択することで東西（または子午線）断面に沿って分布を表示することができます。Collection > 

Properties > NetCDF Setup を選択するといつでもセットアップウィザードに入ることができます。次に派生変

数 Metadata > Longitude（Metadata > Latitude）を定義して X 上の派生経度（緯度）変数、Y 上の鉛直座標、Z

として表示する変数を使用して SCATTER ウィンドウを確立してください。 
 
数値データに加えて ODV 4.7.4 以降では netCDF ファイルからテキスト変数のデータを抽出して Current 

Sample Window にテキストを表示します。Current Sample Window にはさらに多くの変数が表示されており、

変数の名前と順序は以前のバージョンの ODV とは異なります。変数の順序は次のとおりです：主要変数、ア

ルファベット順の数値変数リスト、アルファベット順のテキスト変数リスト。ODV 変数名はファイル内の

netCDF 変数名で、units エントリは units 属性から取られます。全ての ODV 変数は netCDF 変数の

long_name, comment および convention 属性の連結で構築されたコメント文字列を持ちます。ODV は Current 

Sample Window 内の変数の上にマウスを移動するとコメントを含む ODV 変数の詳細を表示します。 
 
変数名の一部として_QC 接尾辞を含む netCDF 変数は自動的に品質フラグ変数として扱われ、それらの値は

親変数の品質フラグとして ODV が使用します。変数名の一部として_SD, _STD または_ERROR 接尾辞を含む

netCDF 変数は自動的に親変数のデータエラー変数として扱われます。 
 
注：ODV 5.6.3 以前を使用して netCDF ファイル用に作成されたビューは、ODV 5.6.3 で導入された変数

の数と順序の違いのため ODV 5.6.4 以降では正しく表示されないでしょう。この問題遭遇したら、等値面変

数を再定義してデータウィンドウの X, Y, Z 軸に変数を再割り当てしてください。 
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14 ツール（Tools） 
14.1 地衡流（Geostrophic Flows） 
Tools > Geostrophic Flows オプションを使用して現在の断面に垂直な地衡流を計算し視覚化することができま

す。結果を受け取る.odv 出力コレクションの名前を指定し、深度、等密度またはその他の等値面を選択して

参照レイヤーを定義します。デフォルトで出力コレクションは親コレクションディレクトリのサブディレク

トリ GeoVel に書き込まれます。このサブディレクトリは、まだ作成されていない場合は自動的に作成されま

す。 ODV は計算を開始し、測点ペアの結果と地衡流速度を上記で指定された.odv コレクションに出力しま

す。 

 

完了したら計算のログファイルを表示して、測点ペアと地衡流速度データを含む新しく作成されたコレクシ

ョンを開きます。ズームして適切な地図領域を定義し、F11 キーを押して断面レイアウトに切り替えてくだ

さい。それから一つ以上のプロットウィンドウの Z 変数として Geostr. Vel. [cm/s], Geostr. Vel. (north comp.) 

[cm/s] そして/または Geostr. Vel. (east comp.) [cm/s] を定義します。与えられた測点ペア A-> B:alpha の測点ラ

ベルは、そのペアで使用されている測点の元の測点番号 A と B、および正の Geostr. Vel.フロー値 (alpha=0:東

向き;  alpha=90:北向き; 等)の方向 alpha で構成されています。メタ変数 Distance は二つの測点間の距離を km

で表したものです。 

 

地衡流速度は二つの各層観測点間の力学高度の差から導き出されます。計算は二段階で行われます：（１）

最初に二つの測点のデータが区分線形最小二乗法によって一組の標準層にマッピングされます。（2）次に両

方の測点について標準層での力学高度が計算され、標準層での測点ペアの地衡流速度が力学高度の差から得

られます。ODV はコレクション内の全ての変数の平均値（ペア平均）も計算します。ペア平均と地衡流速度

は、どちらも二つの測点間の中間点におけるもので、ODV はそれらの値を二つの測点間の中間点に位置する

virtual ペア測点の出力.odv コレクションに書き出します。ペア測点の測点ラベルには関連する元の測点の測

点ラベルが含まれています。 
 
地衡流速度は、赤道付近または疎な（密でない）各層観測の測点では計算されません。結果はデータエラー

の影響を非常に受けやすいため Tools > Geostrophic Flows オプションを呼び出す前に、セクションの水温と塩

分データを慎重に品質管理することが不可欠です。続行する一つの方法は Edit Data オプションを使用して疑

わしいデータに Questionable または Bad フラグを付与し、適切なサンプルフィルタ設定を適用して Good お

よび Unknown データのみを受け入れることです。また適切な測点フィルタ設定を適用することで特定の遠征

調査の測点のみが計算に含まれ、断面を横断する他の航海の測点が除外されているか確認してください。海

水（柱）の一部だけを覆っている測点は排除し、海面から海底までの完全なプロファイルのみ使用してくだ

さい。 
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14.2 二次元推定（2D Estimation） 
Weighted-average または DIVA 格子化法を使用するデータウィンドウでは、それぞれのデータウィンドウのポ

ップアップメニューから Extras > 2D Estimation オプションを選択して、任意のユーザー指定の X-Y 点におけ

る Z 値の推定を実行できます。ユーザー指定の X-Y 位置での推定 Z 値は、画面に表示されているウィンドウ

の格子化フィールドの生成にも使用されているものと同じパラメータ設定を使用して、ウィンドウの現在の

格子化法を適用することによって得られます。 
 
格子化フィールドの場合、ユーザー指定の X-Y 位置での結果は格子平均長さスケールの大きさによって異な

ります：スケールが大きいと滑らかなフィールドになりますが、スケールが小さいとデータ内の小規模な現

象が維持されます。また、長さスケールは現在の X と Y の範囲のパーミル（千分率）で指定されることにも

注意してください。ズームインまたはズームアウトして軸範囲を変更すると平均長さスケール値も変わるた

め 2D Estimation の結果にも影響します。データプロットの Properties ダイアログを使用してデータウィンド

ウに表示された分布が満たされるまで長さスケールを調整してください。それから Extras > 2D Estimation オ

プションを呼び出してください。 

 

ODV は、推定が要求される点の X-Y 座標を求めます。これらの座標は等間隔な X-Y グリッドを対話的に，

または任意の間隔の点を含むファイル（以降，「入力ファイル」と呼びます）を選んで指定できます。この

ファイルは 2D Estimation オプションを呼び出す前に準備する必要があります。適切な列ラベルを含むオプシ

ョンのヘッダー行と、一行につき TAB で区切られた一組の X-Y 座標ペアを持つ無制限の追加行を含む、通常

の ASCII フォーマットでなければなりません。デフォルトでは、ODV はコレクションのディレクトリから入

力ファイルを検索しますので、入力ファイルをそこに配置すると選択プロセスが簡単になります。 
 
入力ファイル内の各Ｘ-Ｙ点について、ODV はＺ値を推定し、推定値をそれぞれのＸ座標およびＹ座標とと

もにコレクションのディレクトリ内の ASCII 出力ファイルに書き出します出力ファイルの各行には、一つの

推定点の X, Y, Z 値が含まれます。空の Z 値は、特定の X-Y 点がどのデータ点からも遠く離れていて信頼で

きる推定が実行できなかったことを示しています。ウィンドウ領域の外側またはウィンドウの品質制限を超

える領域（プロットの白い部分）の Z 値もまた空として残ります。 
 
14.3 三次元推定（3D Estimation） 
Tools > 3D Estimation を選択して、任意の地理的位置における基本変数または派生変数の値を推定できます。 

ODV は Z 変数の推定値を求める対象となる地点の経度、緯度、および深度の値を含む ASCII ファイルを求

めます。この 3D 点定義ファイルは Tools > 3D Estimation オプションを呼び出す前に準備する必要があります。 

ポイント定義ファイルを作成するときは、一行につき一つずつポイントを入力し、十進角の経度、緯度、お

よび深度の値の順で並べます。各値は一つ以上のスペースで区切ります。ODV は推定を実行する変数を選択

させ、推定に使用する x, y, z の平均長さスケールを指定させます。経度と緯度の長さスケールは現在のマッ

プ範囲のパーミル（千分率）で、深さの長さスケールの単位はメートルです。平均長さスケールの値を大き
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くすると滑らかな推定値になります。3D Estimation では現在地図に表示されている全ての測点における全て

の元のデータ点が使用されます。所定のデータ点が特定のターゲット位置で推定に影響する重みは、データ

点とターゲット点間の距離に反比例します。出力ファイルには入力ファイルで指定された全ての経度、緯度、

および深度点に対して一行の結果が含まれています。各行には以下に示す意味を持つ六つの数値: x, y, z, v, d, 

n が含まれます： 

x, y, z      （入力ファイルで指定された）経度、緯度、深度 

v      推定値 

d      推定点からの平均データ x, y, z 位置の正規化距離（平均長さスケールの単位） 

n      使用されたデータ点の数 
 
注：Tools > 3D Estimation オプションは Depth in Water Column [m] および／または Pressure in Water Column 

[db]のキー変数が識別されている場合にのみ有効になります。必要に応じてそのような関連付けを確立するに

はオプション Collection > Identify Key Variables を使用してください。 
 
14.4 ボックス平均 (Box Averaging) 
ODV を使用して所定の経度－緯度－深度ボックス内の基本変数または派生変数の平均と標準偏差を計算でき

ます。現在マップに表示されている測点のみが考慮され、要求されたボックス内の測点とデータ点のみが実

際に平均と標準偏差に使用されます。Box Averaging オプションを呼び出す前に、適切な測点選択基準を指定

して、さまざまな測点サブセット、年、月、または季節の平均を取得できます。ボックス平均を呼び出すに

はメインメニューから Tools > Box Averaging を選択します。ODV は出力が生成されるボックスのジオメトリ

情報を含む ASCII ボックス定義ファイルを要求します。その後 ODV は基本変数と派生変数のリストを表示

するので、平均化手順に対して一つ以上の変数を選択してください。 ボ ッ ク

ス定義ファイルは Box Averaging オプションを呼び出す前に準備する 必 要 が

あります。 
 
ボックス定義ファイルのフォーマットは次のとおりです： 

 通常の ASCII で、一行につき一つのボックスを

定義した、六つの数字（一つ以上のスペースで

区切られたもの） 

 数字の意味（図を参照）：lon lat dep（ボックス

の中心）Δlon Δlat Δdep（ボックスのサイズ）。 

経度と緯度は十進角で、深さはメートル。 
 
ボックス定義ファイルを指定すると ODV は作業を開始します。平均化している間 ODV はデータの異常値を

チェックし、平均から標準偏差の三倍以内のデータのみを使用します。出力はボックス定義ファイルのディ
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レクトリに書き込まれます。出力ファイル名は、ボックス定義ファイル名、処理される変数のラベル、およ

び拡張子.est で構成されています。 

 

平均化する時は、ボックスの各方向の境界で最大加重値の 1/e に減少するように、個々のデータ値はボック

スの中心からの距離に応じて加重されます。 
 
.est 出力ファイルの形式は次のとおりです： 

 通常の ASCII、ボックス定義ファイルの一行につき一行の出力、TAB で区切られた 10 個の値 

 値の意味：lon lat dep（ボックス定義ファイルと同じ）𝑙𝑙𝑙𝑙𝑙𝑙   𝑙𝑙𝑙𝑙𝑙𝑙  𝑑𝑑𝑑𝑑𝑑𝑑  𝑣𝑣𝑣𝑣𝑣𝑣  σ  nu  nr 
 
𝑙𝑙𝑙𝑙𝑙𝑙  𝑙𝑙𝑙𝑙𝑙𝑙 𝑑𝑑𝑑𝑑𝑑𝑑  𝑣𝑣𝑣𝑣𝑣𝑣 は使用されたデータの平均経度、緯度、深度および変数値、σ は変数値の標準偏差、nu は使

用されたデータ点数、および nr は棄却されたデータ点数です。データ点の値と平均𝑣𝑣𝑣𝑣𝑣𝑣との差が標準偏差 σ

の三倍を超えた場合、そのデータ点は棄却されます。平均𝑣𝑣𝑣𝑣𝑣𝑣の誤差は次のように計算できることに注意して

ください。 

𝜎𝜎𝑚𝑚 = 𝜎𝜎/�𝑛𝑛𝑢𝑢 
 

もしボックス内にデータ点が見つからなければ𝑣𝑣𝑣𝑣𝑣𝑣は-1.e10 に設定されます。データ点が一つしか見つから

なければ σ は 1.e10 に設定されます。 
 
また、所定のボックスに使用される個々のデータ値は全て#<box-number>_<var-name>.dat という形式の名前

の ASCII ファイルに出力されます。ここで<box-number>はそれぞれのボックス番号を表し（例えばボック

ス定義ファイルの行番号など）、<var-name>は平均が計算された変数名を表します。.dat ファイル中の値の

意味は次のとおりです：サンプル ID、経度、緯度、深度、十進化年、年内通算日、値、加重、使用/棄却フ

ラグ。.dat ファイルは後続のボックス平均要求によって上書きされることに注意してください。要求された

平均の総数が 5000 を超えると.dat ファイルは書き出されません。 
 
注意：Tools > Box Averaging オプションは Depth in Water Column [m]キー変数が識別されている場合にのみ有

効になります。必要に応じて Collection > Identify Key Variables オプションを使用して関連付けを確立してくだ

さい。 

 

14.5 異常値の検出（Finding Outliers） 
Tools > Find Outliers > Range Check を選択すると、ユーザーが指定した値の範囲内または範囲外のデータ値を

持つサンプルに関して現在選択されている測点をスキャンできます。あるいは Tools > Find Outliers > Spike 

Check を選択すると、スパイクに関して現在選択されている測点をスキャンすることもできます。いずれも変

数の一覧からスキャンする変数を選択して Sample Range にチェックの摘要を指定してください。範囲チェッ

クの場合は値の範囲の値を指定し Action の下から指定した範囲内もしくは範囲外の値を検索するか選択して
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ください。OK を押すとスキャンが開始されます。ODV は見つかった異常値の数を報告し、異常値のリスト

を表示します。 

 

ODV では異常値サンプルのデータ値および／または品質フラグを調べたり変更したりすることもできます。

Inspect and Edit Outliers をチェックすると、ODV は全ての識別された異常値にアクセスし、それぞれの値を

削除したり、値に関連付けられた品質フラグを変更したりできます。Apply to All を押すと ODV は選択され

た操作を全ての異常値に適用します。それ以外の場合、ユーザーは個々の異常値に対するアクションが促さ

れます。現在編集されている異常値はデータプロットに印付けられていることに注意してください。 
 
14.6 重複測点の検出および処理（Finding and Processing Duplicate Stations） 
重要：以下に記述する重複測点の特定および削除処理は元に戻すことのできない変更をコレクションに実行

します。意図しないデータの喪失を避けるために，この処理を呼び出す前に Collection > Create Snapshot オプ

ションを使用してコレクションのバックアップコピーを作成してください。 
 
Tools > Find Duplicate Stations を選択すると、現在有効な測点セット（地図に表示されている測点）で、同一

またはほぼ同一の位置および時間の測点（重複測点）をスキャンできます。 

 

Duplication Station Identification ダイアログ上で、占有時間と地理的位置の最大許容差を指定し，重複と

見なすための二測点間で一致するメタ変数を選択してください。出力ファイルに含める追加のメタ変数を選

ぶこともできます。 

 
図 14-1: Duplication Station Identification ダイアログ 
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ODV は重複検索を実行し、検出された重複測点グループに関する情報をファイルに書き出します。次の情報

が測点毎に提供されます：（1）測点 ID、（2）航海ラベル、（3）測点ラベル、（4）測点タイプ、（5）日

付時刻、（6）経度、（7）緯度、 （8）サンプル数、（9）最深サンプル、（10）基本変数に関する 2 から

nVar までの可用性指標（例えば 7 はサンプルの 70〜79％がその変数に関するデータを含んでいることを示

しています）。 
 
Duplication Station Processing ダイアログ（図 14-2）上に、ODV は検出されたグループと重複測点の数を報

告します。Duplicate station list および Process duplicate stations はそれぞれのボックスをチェックすると閲覧

できます。重複測点を処理する時には次のオプションを選べます：(a)より多くのデータを持つ測点を残して

他は削除する、(b)最初の測点を残して他は削除する、(c)二番目の測点を残して他は削除する、(d)全測点を

一つに統合する。 

 

オプション(d)で重複測点グループを処理する場合は最多データ値を含む測点を残し、もしそれより高品質で

あるか，あるいは対象測点に値が存在しなければ、他の測点からのデータが残った測点に統合されます。こ

のオプションは重複測点の削除によるデータ喪失を最小限にします。 
 

  

図 14-2：Duplicate Station Processingダイアログ 

 

14.7 海洋計算機（Ocean Calculator） 
ODV では Tools > Ocean Calculator オプションを呼び出して海洋物理および海洋化学に関する 40 以上の一般

的に使用される変数の計算およびプロットが可能です。Ocean Calculator ダイアログ（図 14-3）では、先ず

Variables リストから計算したい変数を選択します。次に Input values に入力値を入力し、最後に Evaluate ボ

タンを押すと Result 欄で指定した入力による変数値を受け取れます。 
 
三つから成る start : increment : end を指定して一つ以上の入力変数に対する入力値のセットの計算を要求でき

ます。例えば Temperature 入力値に-2：1：35 を指定すると、-2〜35℃間で 1℃毎の入力温度に対する選択さ

れた変数が繰り返し計算されます。複数入力が指定されている場合、ユーザーが選んだ他のソフトウェアを

使用してさらに処理または作図ができるようにするために ODV は全ての入力変数値と計算結果をクリップボ

ードにコピーします。 

https://www.sangyo-honyaku.jp/dictionaries
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図 14-3：Ocean Calculatorツール 

 

一つまたは二つの入力変数に複数の入力値がある場合、ODV は図 14-4 および図 14-5 に示すように 1D 曲

線または 2D 等値図を自動的に作成します。 
 

     
図 14-4：複数の入力値を持つ一つの入力変数の曲線プロット 
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図 14-5：複数の入力値を持つ二つの入力変数の等値線図 

 
Settings ボタンを押して計算機の設定を変更できます。Calculator Settings ダイアログ（図 14-6）では、海水

（柱）の鉛直座標（Pressure [dbar]または Depth [m]）、デフォルトの塩分入力変数（Practical Salinity [psu]ま

たは Absolute Salinity [g/kg]）、平衡定数のセット、海水中の炭酸パラメータの計算に使用される炭酸データ

入力ペアおよび pH スケール（入力と出力）を指定できます。ODV はユーザー設定と Ocean Calculator を呼

び出す間の最後の入力値を記憶します。Ocean Calculator が開いている間も ODV を使い続けることができま

す。 
 
多くの関数は入力として元々absolute salinity を要求することに注意してください。Practical salinity が入力変

数として選択されると ODV は入力された実用塩分値を絶対塩分値に自動的に変換し、変換された絶対塩分値

を使用してネイティブ関数を呼び出します。実用塩分から絶対塩分への変換は地理的位置によって異なりま

す。したがって実用塩分欄に加えて経度と緯度の入力欄も利用可能です。いくつかの関数は塩分入力設定に

関係なく一種類の塩分入力に対してのみ利用可能です。絶対塩分が入力として必要とされるものの実用塩分

データのみが利用可能である場合、最初のステップで Absolute Salinity SA [g/kg]関数を使用して実用塩分から

絶対塩分に変換します。あるいは実用塩分が入力として要求されるものの絶対塩分データのみが利用可能で

ある場合、二つの塩分タイプの間で変換するために Practical Salinity from Absolute Salinity [psu] 関数を使用し

ます。 

 

図 14-6：Calculator Settingsダイアログ 
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15 雑録（Miscellanea） 
15.1 ドラッグ＆ドロップ（Drag-and-Drop） 
サポートされているほとんどのプラットフォームでは、ODV でサポートされているファイルを ODV ウィン

ドウまたはアイコンにドラッグ＆ドロップができます。ドロップされたファイルの拡張子に応じて ODV は次

のことを行います： 

.odv または.var：現在のコレクションまたは netCDF ファイルを閉じて、ドロップされたコレクション

を開きます。 
 

.nc または.cdf：現在のコレクションまたは netCDF ファイルを閉じて、ドロップされた netCDF ファ

イルを開きます。 
 

.txt（ODV スプレッドシートファイル）：現在開いているコレクションにデータを読み込むか、開いて

いるコレクションがない場合は.txt ファイルと同じ名前の新しいコレクションを作成し、新しく作成

したコレクションにデータをインポートします。 
 
ODV でサポートされているファイル名もコマンドライン引数として使用できます。次のように入力して任意

の端末ウィンドウから ODV を起動します：odv [ファイル名[.拡張子]] 。ファイル名には、絶対パス名また

は ODV を起動したディレクトリからの相対パス名を使用することに注意してください。相対パス名を使用す

る場合“.”と“..”は使用できません。コマンドライン引数を使用して、 

1. ODV を起動して既存のコレクションを開く：ファイル名にはコレクション名を使用します。 拡張

子を省略するとデフォルトの.odv が使用されます。 

2. 新しいコレクションを作成してデータをインポートする：ファイル名にはインポートするデータフ

ァイルの名前（ODV のインポートタイプの一つ、例えば.o4x や.txt でなければなりません）を使

用します。この場合は拡張子を入力する必要があります。ODV は読み込みファイルのあるディレク

トリに新しいコレクションを作成してファイルからデータをインポートします。データ変数はデー

タファイルの情報から決定されます。 

 

15.2 ODVコマンドファイル（ODV Command Files） 
コレクションを開く、特定のビューファイルを読み込む、グラフィックスまたはデータ出力ファイルを作成

するなど、頻繁に使用する操作のコマンドは ODV コマンドファイルに保存できます。ODV コマンドファイ

ルは File > Execute Command File オプションまたは” -x cmd_file “コマンドラインオプションを使用していつで

も（バッチモードで）実行できます。ODV コマンドファイルのデフォルトの拡張子は.cmd です。デフォルト

の置き場所はユーザーのドキュメントディレクトリ内のディレクトリ ODV/cmd_files です。まだ存在していな

い場合はディレクトリ cmd_files を作成してコマンドファイルをこのディレクトリに配置します。 
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以下のコマンドが ODV コマンドファイルで現在サポートされています。プラットフォームに依存しないよう

にするために ODV コマンドファイルに表示される全てのファイル名にはスラッシュ”/”をパス区切り文字と

して使用する必要があります。set_base_directory コマンドを使用して base directory 定義すると、それ以降の

全ての相対ファイル名は base directory に対する相対パスと見なされます。base directory が定義されておらず、

コレクションまたは netCDF ファイルが開かれている場合、相対ファイル名はコレクションまたは netCDF

ディレクトリを基準にした相対パスと見なされます。複数の引数は、set_var コマンドを除きカンマ“,”で区切

る必要があります。set_var コマンドの場合は変数名と値の間の区切り文字として“=”を使用します。一部のコ

マンドで使用されるウィンドウインデックスパラメータ iw は、グラフィックスキャンバスの場合は-1、マッ

プの場合は 0、データウィンドウの場合は正の整数値になります。ODV コマンドファイルの行は 255 文字を

超えてはいけません。コメント文字＃の右側にあるものは全てコメントと見なされて実行されません。 

 

注意：delete または import コマンドを含むコマンドファイルはデータコレクションを変更して意図しない効

果をもたらします。そのようなコマンドファイルを実行する前に Collection > Create Snapshot を介してコレク

ションのバックアップを作成しておいてください。 
 
create_annotation（注釈の作成）      iw, x, y, orientation, textAlign, “text” 

正の x 軸から反時計回りに orientation 度方向沿いの（ウィンドウ iw 座標系の）位置 x, y にウィンドウ iw のテキスト注釈 text
を作成します。textAlign は(x, y）に対するテキストの配置を決定します：中央＿中央 0、中央_上 1、中央_下 2、右_上 3、右_

下 4、左_上 5、左_下 6、右_中央 7、左_中央 8。iw と textAlign は整数、x, y, orientation は浮動小数点数です。注釈テキストは“”
文字で囲む必要があります。 

例：create_annotation -1, 10., 8., 30., 0, “Some Text” 

 

create_collection（コレクションの作成）      collection, collection_type 

collection_type 型のメタデータおよびデータ変数のテンプレートセットを使用して collection コレクションを作成します。
Collection_type は次のいずれかです：ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASBOTTLE, MEDATLASCTD, 
MEDATLASTIMESERIES, MEDATLASPROFILES, MEDATLASSEDIMENTTRAP, WORLDOCEANDATABASE. 
注：collection が既に存在する場合は新しいバージョンが作成される前に既存のバージョンが削除されます。 
例：create_collection c:/data/ARGO_Atlantic.odv, ARGOPROFILES 

 

delete_collection（コレクションの削除）      collection 
現在開いている collection コレクションを削除します。 Collection 引数は前の open_collection の呼び出しで使用されたものと同じ

でなければなりません。 

例：delete_collection c:/data/ARGO_Atlantic.odv 

 

delete_stations_matching（同一測点の削除）      metavarLabel1, metavarLabel2, … 
現在開いているコレクション内で一つ以上のメタ変数 metavarLabel1, metavarLabel2 などに関して指定した値に一致する全ての測

点を削除します。一致させる値は後に続く行から delete_stations_end 行までの間で指定します。もし metavarLabel1, metavarLabel2

などの全てのメタ変数値が指定行の一つの値に一致すると、その測点は一致とみなされます。論理 AND は所定の指定行上にあり、

論理 OR は行間にあります。指定値はタブで区切ります。結果の概要はログファイル<path>.log に書き出されます。ここで<path>

はディレクトリおよびこのコマンドを含むコマンドファイルのファイル名を表します。 

例：delete_stations_matching “LOCAL_CDI_ID”, “EDMO_CODE” 
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    77AR1993_11 H71 545 
    Delete_stations_end 

 

export_data（データのエクスポート）      data_file 

export_data（データのエクスポート）      data_file, var_ids, derived_var_ids, extended_metavar_ids, quality_flag_export,  

    error_export, info_export, history_export, compact_export, do_zip 
現在の測点を data_file ファイルにエクスポートします。エクスポートフォーマットは data_file 拡張子に依存します：(1).txt - 汎

用 ODV スプレッドシート、(2).odv - ODV コレクション、(3).nc – netCDF4. 

 

var_ids, derived_var_ids, extended_metavar_ids は、エクスポートされる基本データ変数、派生変数、拡張メタ変数の varIds を定義し

ます。これらの varIds は、角括弧に囲まれた varId の空白区切りのリスト：[vgroup1 vgroup2 ...]で指定します。vgroups は以下

の値を持つことができます：’:’ (全変数), ‘m:n’ (m から n までの varIds を持つ変数で、m, :, n の間に空白はありません), ‘m’ 

(varId m を持つ変数)。[]は空リストを表します。 

 

ODV アプリケーションウィンドウの右側にあるリストウィンドウの中にある各変数の上にマウスを置くことで、メタおよびデー

タ変数の varIds を回復できることに注意してください。 

 

残り全ての引数は 1 か 0 の整数値です。これらの引数は、データ品質フラグ、（もしあれば）データエラー値、データ情報値、

（もしあれば）履歴レコードをエクスポートするか(値が 1 の場合)、しないか（値が 0 の場合）を制御します。compact_export は、

メタデータが測点の最初のサンプルに対してのみエクスポートするか(1), 全てのサンプルに対してか(0)を制御します。この引数

はスプレッドシートエクスポートに関してのみ効果があります。エクスポートしたデータは、もし do_zip が 1 ならば zip ファイル

に保存されます。 

 

上述の最初の export_data 版を使う場合は、次のデフォルト引数が適用されます： 

[:], [], [:], 1, 1, 1, 1, 1, 0 
 

例：export_data c:/out/odv_data.txt 

    export_data c:/out/odv_data.nc, [1:5 20:21], [32001], [], 1, 1, 0, 0, 0, 0 
    export_data c:/out/odv_data.odv, [:], [:], [], 1, 1, 1, 1, 0, 1 

 

export_graphics （グラフィックスのエクスポート）      iw, graphics_file, dpi [,width, height, drawing_style, 

      transparent_background ] 
dpi ドット/インチの解像度で graphics_file ファイルにウィンドウ iw のグラフィックスを保存します。Graphics_file 拡張
子.eps, .gif, .png または.jpg を使うとそれぞれ PostScript, GIF, PNG または JPEG 形式で出力します。 
 
Width, height, drawing_style および transparent_background 引数はオプションです。 
 
Width と height を与えるときは出力イメージのピクセル幅と高さを指定してください。両方の既定値は-1 で、この場合のイメージ
サイズは選択された dpi 解像度だけで決まります。 
 
Drawing_style 引数は NORMAL（既定値）または PURE となります。データ表示の出力は必要だがフレーム、カラーバーまたは軸
ラベルは不要な場合には PURE を指定してください。 
 
Transparent_background 引数は、イメージ形式が tiff で drawing_style が PURE なら 1（真）が既定値となります。それ以外では
transparent_background は 0（偽）です。Jpg イメージでは背景を透明にできないことに注意してください。 
例：export_graphics –1, c:/output/odv_graph.eps, 300 

    export_graphics 1, GeoTIFF_example.tif, 300, -1, -1, PURE, 1 
 

import_data（データの読み込み）      file_spec, import_type 
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インポートルート import_type を使用して file_spec を満たす全てのファイルからデータを読み込みます。データは現在開かれてい

るコレクションに、または現在開かれているコレクションが無ければ一つ以上のターゲットコレクションが自動的に作成され、そ

れに読み込まれます。Import_type は次のいずれかです：ARGOPROFILES, ARGOTRAJECTORIES, GTSPP, MEDATLASPROFILES, 

MEDATLASTIMESERIES, MEDATLASSEDIMENTTRAP, MEOPPROFILES, SPREADSHEET, WORLDOCEANDATABASE. File_spec は、単一のイ

ンポートファイルのパス名、ワイルドカード・ファイルの指定、またはインポートするファイルのパス名を含む.lst リストファイ

ルのパス名です。File_spec は絶対パス名または以前に set_base_directory コマンドで指定した base directory からの相対パスでなけ

ればなりません。.lst リストファイルのエントリは絶対パス名でなければなりません。 
例：import_data c:/data/*.nc, ARGOPROFILES 

 

load_view（ビューの読み込み）      view_file 

ビューファイル view_file を読み込みます。View_file は.xview ファイルまたは.cfg ファイルです。load_view は後方互換性のために

サポートされている load_cfg と同等です。$FullScreenMap$, $OnePickWin$, $TwoPickWin$, $SixPickWin$, $OneScatterWin$, 

$TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, $TwoSectionWin$, $ThreeSectionWin$, $FiveSectionWin$, $SixSectionWin$, 

$OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, $FiveIsoSurfaceWin$, $EightIsoSurfaceWin$, $ElevenI-soSurfaceWin$, 

$FiveMixedWin$, $FromFileWin$または$OneIsoSurfaceOneScatterWin$をテンプレートビューの一つを読み込むのに使用します。 
例：load_view c:/views/abc.xview  

 
open_collection（コレクションを開く）      collection[, view_file] 

コレクション collection を開き、ビューview_file を読み込みます。View_file 引数はオプションです。$Full-ScreenMap$, $OnePickWin$, 

$TwoPickWin$, $SixPickWin$, $OneScatterWin$, $TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, $TwoSectionWin$, 

$ThreeSectionWin$, $FiveSectionWin$, $Six-SectionWin$, $OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, $ThreeIsoSurfaceWin$, 

$FiveIsoSurfaceWin$, $EightIsoSurfaceWin$, $ElevenIsoSurfaceWin$, $FiveMixedWin$, $FromFileWin$または 

$OneIsoSurfaceOneScatterWin$をテンプレートビューの一つを読み込むのに使用します。  
注：パスワードで保護されたコレクションを ODV コマンドファイルで開いて使用することはできません。 
例：open_collection c:/ewoce/WoceBtl.odv 

open_collection c:/ewoce/WoceBtl.odv, $FullScreenMap$ 
 

open_data_file（データファイルを開く）      data_file 

Data_file ファイルのデータを使用してコレクションを作成して開きます。Data_file は汎用 ODV スプレッドシートフォーマットに

準拠し、拡張子が.txt である必要があります。新しいコレクションはデータファイルのあるディレクトリに作成され、その名前は

データファイルのベース名です。この名前とパスを持つ既存のコレクションはユーザーに許可を求めることなく削除されます。 

例：open data_file c：/ewoce/WoceData.txt 

 

open_netcdf（netCDFを開く）      netcdf_file_path[, nc_setup_name, view_name] 

NetCDF の nc_setup_name セットアップと view_name ビューを使用して netcdf_file_path 上の netCDF ファイルを開きます。

Netcdf_file_path および view_name 引数はオプションです。ビューview_file を読み込みます。View_file 引数はオプションです。$Full-

ScreenMap$, $OnePickWin$, $TwoPickWin$, $SixPickWin$, $OneScatterWin$, $TwoScatterWin$, $SixScatterWin$, $OneSectionWin$, 

$TwoSectionWin$, $ThreeSectionWin$, $FiveSectionWin$, $SixSectionWin$, $OneIsoSurfaceWin$, $TwoIsoSurfaceWin$, 

$ThreeIsoSurfaceWin$, $FiveIsoSurfaceWin$, $EightIsoSurfaceWin$, $ElevenIsoSurfaceWin$, $FiveMixedWin$, $FromFileWin$または 

$OneIsoSurfaceOneScatterWin$をテンプレートビューの一つを読み込むのに使用します。  
例：open_netcdf IMOS_ACORN_V_201301month_CDF_FV01_1-hour-avg.nc, default, arrows 

open_netcdf http://test.opendap.org/dap/data/nc/coads_climatology2.nc, default, Default 
 

 

quit（終了） 

http://test.opendap.org/dap/data/nc/coads_climatology2.nc
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ODV を終了します。 

例：quit 

 

save_view（ビューの保存）      view_file 

現在のビューを view_file ファイルに保存します。View_file の拡張子は.xview でなければなりません。 
例：save_view c:/cfg_files/abc.xview 

 

set_annotation_style（注釈のスタイルの設定）      ptSize, textColor, bckgrdColor, frameColor, frameWidth 

Create_anotation に続いて作成されたテキスト注釈のスタイルを設定します。ptSize はポイント単位のフォントサイズ、textColor は

テキストの色、bckgrdColor はテキスト境界ボックスの背景色、frameColor はテキスト境界ボックスの枠の色、frameWidth はテキ

スト境界ボックスを囲む枠の幅です。全ての色は現在のカラーパレットのインデックス値として指定されています。背景ボックス

または背景フレームが描画されないようにするには bckgrdColor または frameColor あるいはその両方に-1 を指定します。注：

set_annotation_style の全ての引数は整数です。デフォルト値は 16, 0, -1, -1, 0 です。これはボックスまたはフレームなしで

16 ポイントの黒いテキストを生成します。 

例：set_annotation_style 24、8、7、0、1 

 

set_axis_full_ranges（全範囲軸の設定）      iw 

データウィンドウ iw（1 から始まるウィンドウインデックス）または全てのデータウィンドウ（iw = -1）の x, y, z 軸範囲を全範囲

に設定します。iw=0 の場合、マップ領域を現在有効な測点をカバーする領域に設定します。 

例：set_axis_full_ranges -1 

set_axis_full_ranges 0 
 

set_axis_range（軸範囲の設定）       iw, axis, v0, v1 

ウィンドウ iw（-1 と 0 は不可）の軸 axis（可能な値：x, y または z）の範囲値を v0（左/下）と v1（右/上）に設定します。v0 と v1

が指定されていない場合は全てのウィンドウデータで有効な軸が全範囲になります。 
例：set_axis_range 1, x, 34, 37 

set_axis_range 1, y, ,  

 
set_base_directory（ベースディレクトリの設定）     base_directory 

ベースディレクトリを定義します。全ての後続のファイル名は全て絶対パス名または base_directory からの相対名と見なされます。 
例：set_base_directory c:/ewoce/data 

 
set_var（変数の設定）     var_name = string 

変数 var_name の値を string に設定します。以降の行の変数は％var_name％として使用できます。 

例：set_var OUTDIR = c:/tmp 

export_data %OUTDIR%/A15_OXYGEN.txt  

 
以下は、コレクションを開いてビューを読み込み、注釈を追加し、キャンバス全体とデータウィンドウ 1 に
二つの画像ファイルをそれぞれ書き込み、現在選択されている測点のデータを ODV スプレッドシートファイ
ルに出力して、最後に ODV が終了する ODV コマンドファイルの例です。  
 
set_var   OUTDIR = c:/tmp 
set_base_directory  c:/data/eWOCE/data/whp/bottle 
set_annotation_style  18, 0, 7, 0, 1 
open_collection  WoceBtl.odv 
load_view   atlanticSections/A15_OXYGEN.xview 
create_annotation  1, -13.18,65.83,0, 6, "Test"  
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export_graphics  -1, %OUTDIR%/A15_OXYGEN.png, 100  
export_graphics  1, %OUTDIR%/A15_OXYGEN_1.png, 200  
export_data   %OUTDIR%/A15_OXYGEN.txt  
quit  
 

15.3 カラーパレット (Color Palettes)  
ODV スタイルのカラーパレットは 177 色を定義します（図 15-1 参照）。 
 0-15: 基本色 
 16-31: グレースケール 
 32-144: カラー陰影に使用されるメインパレット 
 145-160: 地図の海底地形および大陸に使用される色 
 161-176: 地図の陸上地形に使用される色 
 

図 15-1：ODVデフォルトカラー・パレット 

 

ODV には、さまざまなレインボーパレット、単色または二色パレット（BlueOnly、BlueRed など）、およ

びさまざまなグレースケールパレットが付属しています。さらに ODV にはさまざまな種類の色覚異常の影響

を受けている人々の知覚改善が向上する Viridis パレット（Anton Velo 氏の好意による）も含まれています。 
 

図 15-2：Viridisカラーパレット 

 
ウィンドウを右クリックして Properties オプションを選択し、General ページの Palette コンボボックスから

使用可能なパレットファイルの一つを選択することで、マップまたはデータウィンドウの別のカラーパレッ

トを選択できます。ODV は新しいパレットを使用してマップまたはデータウィンドウを再描画します。 
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Windows では PalEdt.exe アプリケーションを使用して既存のパレットを変更したり新しいパレットを作成し

たりできます。PalEdt.exe は Tools > Palette Editor を選択して ODV から呼び出すことができます。 
 
15.4 アニメーション（Animations） 
ODV では、それぞれのウィンドウを右クリックして Extras > Animation を選択し、Metadata Time, Metadata 
Time of Year, Variable Range, Isosurface のいずれかのサブオプションを選択することで、マップあるいはあら
ゆるデータウィンドウのアニメーション GIF を作成できます。その後の手順は以下の通りです。 
 
（1）Metadata Time: 
開始日 t0、間隔ステップ tStep（日数）、間隔幅 tWidth（日数）、生成するフレーム数 n、および間隔タイプ
を指定してください。その後 ODV は n 時間間隔を構成し、Date/Time > Period 測点フィルタ設定にはそれぞ
れの開始日と終了日を使用します。 
 
選択した間隔タイプに応じて間隔 i（i = 0、…、n-1）の開始日と終了日は次のように定義されます: 
 
間隔のタイプ（Interval Type） 間隔 i の開始日(Start of interval i) 間隔 i の終了日(End of Interval i) 

Zero Width (幅なし) 𝑡𝑡0  + 𝑖𝑖 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 𝑡𝑡0  + 𝑖𝑖 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 

Fixed Width (固定幅) 𝑡𝑡0  + 𝑖𝑖 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 𝑡𝑡0  + 𝑖𝑖 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 + 𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡ℎ 
Fixed Start (開始日固定) 𝑡𝑡0   𝑡𝑡0  + (𝑖𝑖 + 1) ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 
Fived End (終了日固定) 𝑡𝑡0  + 𝑖𝑖 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 𝑡𝑡0  + 𝑛𝑛 ·  𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡𝑡 
 
そのような時間間隔ごとに、それぞれの時間ウィンドウ内にメタデータ日付を持つこれらの測点のみを含む
マップが再構築されます。アニメーションがデータウィンドウの場合、このデータウィンドウも現在選択さ
れている測点セットからのデータのみを使用して再描画されます。現在のマップまたはデータウィンドウが
アニメーションファイルに追加されます。 
 
 (2) Metadata Time of Year: 
開始月日 t0, 間隔ステップ tStep（日数）、間隔幅 tWidth（日数）、生成するフレーム数 n、および間隔タイ
プを指定してください。次に ODV は n 時間間隔を構成し、Date/Time > Season 測点フィルタ設定にはそれぞ
れの開始日と終了日を使用します。選択した間隔タイプに応じて間隔 i の開始日と終了日（i = 0、…、n-1）は
上の表のように定義されます。 
 
そのような時間間隔ごとに、それぞれの時間枠にメタデータの月と日がある測点のみを含めて、マップが再
構築されます。データコレクションに複数年の期間からの測点が含まれている場合は、一年以上のデータが
使用されることがあります。アニメーションがデータウィンドウの場合、このデータウィンドウも現在選択
されている測点セットからのデータのみを使用して再描画されます。 現在のマップまたはデータウィンドウ
がアニメーションファイルに追加されます。 
 
 (3) Variable Range:  
このオプションは等値面以外のデータウィンドウでのみ使用できます。有効な変数を選択し、開始値 v0, 間隔
ステップ tStep、間隔幅 vWidth、生成するフレーム数 n、および間隔タイプを指定してください。ODV は有
効な変数に対して n 個の間隔を作成し、選択された変数のサンプルフィルタ設定にはそれぞれの開始値と終
了値を使用します。 
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選択した区間タイプに応じて、区間 i の開始値と終了値（i = 0、…、n-1）は次のように定義されます。 
 
間隔のタイプ（Interval Type） 間隔 i の開始日(Start of interval i) 間隔 i の終了日(End of Interval i) 

Zero Width (幅なし) 𝑣𝑣0  + 𝑖𝑖 ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0  + 𝑖𝑖 ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 

Fixed Width (固定幅) 𝑣𝑣0  + 𝑖𝑖 ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0  + 𝑖𝑖 ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 + 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣ℎ 
Fixed Start (開始日固定) 𝑣𝑣0   𝑣𝑣0  + (𝑖𝑖 + 1) ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 
Fived End (終了日固定) 𝑣𝑣0  + 𝑖𝑖 ·  𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 𝑣𝑣0  + 𝑛𝑛 · 𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣𝑣 

 
そのような間隔ごとに、それぞれの変数値の間隔からのデータのみを含めて、データウィンドウが再描画さ

れます。現在のデータウィンドウのスナップショットがアニメーションファイルに追加されます。 
 
 (4) Isosurface :  
このオプションは等値面データウィンドウだけに使用できます。開始値 s0, 間隔ステップ ds, および生成する

フレーム数 n を選択します。ODV は n 個の等値面値を作成し、そのような値ごとにデータウィンドウを再構

築します。現在のデータウィンドウのスナップショットがアニメーションファイルに追加されます。 
 
全てのアニメーションに対して、ODV は現在のアニメーション間隔を示すアニメーションバーを描画します。
アニメーションバーはそれぞれのウィンドウの下の中央にあります。 
 
15.5 海底地形の地名辞典（Gazetteer of Undersea Features） 
ODV は海山、海嶺、破砕帯、トラフ、海盆などの海底地形を識別するために使用できます。地名辞典オプシ
ョンを呼び出すには、マップのポップアップメニューから Extras > Gazetteer を選択すると地名辞典
（gazetteer）ダイアログボックスが表示され、特定のデータベースを選択したり、地形の選択基準や ODV
が描く地名記号のサイズや色を指定したりできます。Switch On ボタンを押すと（または地名辞典の設定を変
更した場合は Update）、選択した地名辞典データベースから情報が読み込まれ、地図上の地形の位置に記号
が表示されます。マウスを地形記号の近くに移動すると地形の名前を表示するポップアップウィンドウが表
示されます。地形記号をオフにするには地名辞典（gazetteer）ダイアログボックスを再度表示して Switch 
Off ボタンを押してください。 
 
ODV 配布パッケージではいくつかの地名辞典を提供しています：（1）国際水路局(International Hydrographic 
Bureau（IHB）)の GazetteerGEBCO.gzt、（2）米国国防測量庁（US Defense Mapping Agency）の Gazet-teerBGN.gzt，  
（3）WHP_Sections.gzt（WOCE 海洋観測プログラム（WOCE Hydrographic Programme）で実施された観測断面
の集大成）。地名辞典ダイアログボックスを使用して地形タイプおよび／または地名の部分文字列を指定す
ることで地名サブセットを選択できます。名前とタイプの選択は大文字と小文字を区別しないことに注意し
てください。地形の名前（またはその名前の一部）がわかっていてその場所を特定する場合は地名辞典の地
形選択を使用します（地形記号を表示するには地図を全球で開く必要がある場合があります）。地名辞典の
設定は設定ファイルに保存されません。最初にコレクションを開くときは常に地名辞典オプションはオフに
なっています。 
 
地名辞典ファイルは編集および拡張することができます。独自の新しい地名辞典データベースを作成するこ
ともできます。ODV で私家版地名辞典を使用する場合、ファイルの拡張子は.gzt で、ODV 地名辞典ディレ
クトリ（<home>\odv_local\gazetteers、ここで<home>はホーム・ディレクトリを表す）に配置され、以下の
仕様を満たしている必要があります： 
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ファイルの最初の行は％GZT01:で始まり、その後にファイル名が続くこと。 
 
それから、％で始まり、任意のコメントを含む 7 行があること。 
 
次の行は、Feature;Type;No;East-Longitude;North-Latitude;North-Latitude;で、 その後に空白
行が一行あること。 
 
ファイルの残りの部分には実際のアイテム定義が含まれていること。各地形は別々の行にリストされ

ていること。 
 
地形の名前、その種類、経度/緯度の点数、経度/緯度のエントリはセミコロン「;」で区切ります。 経度は東
経（0-360 または-180-180）で指定します。 経度/緯度の点数は最大 1500、行の長さは最大 200,000 文
字です。 
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16 付録（Appendix） 
16.1マウス動作とショートカットキー (Mouse Actions and Shortcut Keys) 
マウス動作とショートカットキーの概要は別文書（訳注：日本語訳版では以下に記載します）を参照するか、

Help > Shortcut Key Summary から閲覧できます。 

 

ODV / ODVオンラインのマウス操作およびショートカットキー (2024/02/02版) 
Reiner Schlitzer, Alfred Wegener Institute, Bremerhaven, GERMANY (Reiner.Schlitzer@awi.de) 

ODV および ODV オンラインは広範囲なデータ解析および可視化を提供する対話的ユーザーインターフェー

スを備えています。マウス、トラックパッド、キーボードを使って同じように両者のインターフェースを操

作できます。以下はメニューをクリックすることなく頻繁に使用する機能を直接作動させるマウス動作およ

びショートカットキーの概要です。陰影部は ODV オンラインでは無効です。 

 

マウス操作 

キー / マウスキー 対象 (Object) 応答 (Action) 

Windows macOS   

L-Click L-Click 
マップ、データ

ウィンドウ 

最も近い測点を現在の測点として、または最も

近いサンプルを現在のサンプル（および親測点

を現在の測点）として選択します。 

R—Click R-Click 

キャンバス、マ

ップ、データウ

ィンドウ、グラ

フィクスオブジ

ェクト、データ

リスト・ウィン

ドウ 

要素のコンテキストメニューを呼び出します。 

Shift+L-Click ⇧+L-Click 
マップ、データ

ウィンドウ 

最も近い測点を現在の測点として、または最も

近いサンプルを現在のサンプルとして選択しま

す。 同じ位置に複数の測点またはサンプルが

あれば、それらの測点またはサンプルのリスト

から選択できます。 

L-DbleClick L-DbleClick マップ 

最も近い測点をpick listに追加し、この測点の

データをSTATION データウィンドウに追加し

ます。 

https://odv.awi.de/fileadmin/user_upload/odv/docs/ODV_shortcut_keys.pdf
Suzuki Toru
原文ではvcになってますが，v0が正しいと思われます。
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ショートカットキー 

キー 応答 (Action) 

Windows macOS  

測点およびサンプルの選択 

Enter, Return Enter, Return 現在の測点を pick list に追加し、この測点のデータを STATION

データウィンドウ（があればそれ）に追加します。 ウィンドウ

レイアウトモードでは、現在のレイアウトを確定させて通常モー

ドに戻ります。 

# # 内部測点 ID により新しい現在の測点を 

. . 永続的受入番号により新しい現在の測点を選択します。 

→ → 次の測点を現在の測点として選択します。 

← ← 前の測点を現在の測点として選択します。 

HOME  最初のサンプルを現在のサンプルとして選択します。 

↓ ↓ 次のサンプルを現在のサンプルとして選択します。 

↑ ↑ 前のサンプルを現在のサンプルとして選択します。 

END  最後のサンプルを現在のサンプルとして選択します。 

L-Drag L-Drag 

グラフィクスオ

ブジェクト、キ

ャンバス、マッ

プ、データウィ

ンドウ 

（ドラッギングが可能であれば）グラフィクス

オブジェクトをドラッグします。（スクロール

バーがあれば）キャンバスをドラッグします。 

Ctrl+L-Drag ⌘+L-Drag 
マップ、データ

ウィンドウ 

地図をクイック・ズームします。 

データウィンドウをクイック・ズームします。 

Ctrl+R-Click ⌘+R-Click 

キャンバス、マ

ップ、データウ

ィンドウ 

要素の Layout サブメニューを呼び出します。 

Shift+R-Click ⇧+R-Click 
マップ、データ

ウィンドウ 

マップまたはデータウィンドウの Extras サブ

メニューを呼び出します。 

Alt+R-Click ⌥+R-Click 
オーバーレイウ

ィンドウ 

アンダーレイ親データウィンドウのコンテキス

トメニューを呼び出します。 

Alt+Shift+R-

Click 
⌥+⇧+R-Click 

オーバーレイウ

ィンドウ 

アンダーレイ親データウィンドウの Extras サ

ブメニューを呼び出します。 

Ctrl+Wheel ⌘+Wheel 
マップ、データ

ウィンドウ 

マウス位置をズームインまたはズームアウトし

ます。 
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PgDn  現在のサンプルを下げます（前進させます）。 

PgUp  現在のサンプルを上げます（後退させます）。 

レイアウトの変更 

F5 F5 1) キャンバス全体またはマウスがあるウィンドウを再描画します。 

F8 F8 1) 全画面マップ・レイアウトに切り替わります。 

F9 F9 1) 六つの STATION ウィンドウレイアウトに切り替わります。 

F10 F10 1) 二つの SCATTER ウィンドウレイアウトに切り替わります。 

F11 F11 1) 三つの SECTION ウィンドウレイアウトに切り替わります。 

F12 F12 1) 一つの SURFACE ウィンドウレイアウトに切り替わります。 

Ctrl+R ⌘+R マウスがあるウィンドウを移動またはサイズ変更します。 

Ctrl+A ⌘+A マウスがあるウィンドウに注釈を追加します。 

Del, Backspace Backspace 

マウスが指しているグラフィックスオブジェクトを削除します。

グラフィックスオブジェクト上にない場合は pick list から現在の

測点を削除し、STATION データウィンドウ（があればそこ）か

らこの測点のデータを削除します。 

ビューの変更 

Alt+D ⌥+D 派生変数の定義を許可します。 

Alt+P 
⌥+P マウスがあるウィンドウまたはグラフィックスオブジェクトの属

性変更を許可します。 
Alt+S ⌥+S 測点フィルタを変更します。 

Ctrl++ ⌘++ マウス位置をズームインします。 

Ctrl+- ⌘+- マウス位置をズームアウトします。 

Ctrl+F ⌘+F 
マウス上のウィンドウ（または全データウィンドウ）の X, Y, Z

範囲を変更します。 

Ctrl+V ⌘+V リソースからビュー設定を読み込みます。 

Shift+S ⇧+S マウス上のウィンドウのサンプルフィルタを変更します。 

ビュー変更の取り消し／やり直し 

Ctrl+Z ⌘+Z 最後のビュー変更を取り消します。 

Ctrl+Y ⌘+Y 最後のビュー変更をやり直します。 

Alt+Z ⌥+Z 全てのビュー変更を取り消します。 

データおよびメタデータの編集 

Shift+E ⇧+E マウス位置に依存したメタデータおよびサンプルデータの編集 

出力の生成 ／ ヘルプ表示 

Ctrl+C ⌘+C マウス上のウィンドウのデータをクリップボードにコピー、また
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はグラフィクスオブジェクト上にあればそのオブジェクトのコピ

ーを生成します。 

Ctrl+S ⌘+S 
マウス上のウィンドウ（またはキャンパス全体）を画像ファイル 

(gif, png, jpg, tiff または PostScript)として保存します。 

F1 ⌘+? ODV ヘルプ文書を表示します。 

F4 F44 マウス上のウィンドウのデータ統計を表示します。 

アプリケーション動作の変更 

 ⌘+, 一般設定ダイアログを表示します。 

Ctrl+N ⌘+N 
新規 ODV コレクションを生成します。現在開いているコレクシ

ョンは自動的に閉じます。 

Ctrl+O ⌘+O 
ODV コレクション、netCDF ファイル、またはサポートされて

いる ASCII データファイルを開きます。 

Ctrl+F4  現在のコレクションまたは netCDF ファイルを閉じます。 

Alt+F4 ⌘+Q ODV を終了します。 

ESC  （操作がサポートされていれば）現在の操作を中止します。 
1）macOS システムでは fn キーを押しながらファンクションキーを押してください。Mac システム環境設定のキーボード・タブで「標

準ファンクションキーとして F1、F2 など全てのキーを使う」をチェックした場合、fn キーは必要ありません。 

 
ズーミングおよび Z ズーミング 

マップ、データウィンドウ、またはデータウィンドウのカラーバーをズームするとき、ODV は一時的にズー

ムまたは Z ズームモードに移行します。 

操作（Action）  対象（Object）  応答（Response）  

L-Drag ズーム矩形の境界および四隅 ズーム矩形のサイズを変更します。 

L-DbleClick or 

ENTER 
どこでも 現在の設定を確定させてズームを終了します。 

R-Click or ESC どこでも 変更を破棄してズームを中止します。 
 

ポイント取得モード (GetPoints Mode) 

断面、線、多角形、またはグラフィクスオブジェクトを定義するとき、ODV はマウス左ボタンのクリックに

よって一つ以上の x/y 座標を入力する GetPoints モードに一時的に移行します。GetPoints モード時のカーソ

ルは「+」に変わります。 

操作（Action）  対象（Object）  応答（Response）  

   

L-Click キャンバス、マップ、データウ

ィンドウ 

現在のポイントをリストに加えます。 
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R-Click キャンバス、マップ、データウ

ィンドウ 

リストから最も近いポイントを削除します。 

   

ENTER どこでも 現在の設定を確定させて GetPoints を終了します。 

   

ESC どこでも GetPoints を中止します。 
 

16.2 品質フラグスキーム (Quality Flag Schemes) 
ODV は海洋学のコミュニティで現在使用されているほとんどの品質フラグスキームをサポートしています。

これらのスキームのいずれか一つを所定のメタデータまたはデータ変数の品質フラグに符号化するため使用

することができます。サポートされているスキームの概要、品質フラグコードの一覧とその意味、およびス

キーム間のコードマッピングについては、表 16-1 および ODV_Quality_Flag_Sets.pdf ファイルを参照してくだ

さい。 
 

表 16-1：ODVでサポートされている品質フラグスキーム。異なるスキーム間の品質フラグ値と値マッピン

グの完全なリストについては、ODV_Quality_Flag_Sets.pdfファイルを参照してください。 

SchemaID  Comment  

ARGO Argo quality codes. (Argo 品質コード) 参照: Argo data management, ユーザーマニュア

ル, Version 2.1, https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-

manual.pdf (訳注：http://www.usgodae.org/argo/argo-dm-user-manual.pdf で

はたどり着きません) 

BODC BODC quality codes. (BODC 品質コード) 参照: 

http://www.bodc.ac.uk/data/codes_and_formats/request_format/ （訳注：リ

ンク先がありません） 

ESEAS European Sea Level Service quality codes. (European Sea Level Service 品質コード) 参照: 

www.eseas.org/eseas-ri/deliv-erables/d1.2/ESEAS_QC_29032005.doc （訳注：time out

になり接続できません） 

GTSPP GTSPP quality codes. (GTSPP 品質コード) 参照: http://www.meds-sdmm.dfo-

mpo.gc.ca/meds/Data-bases/OCEAN/GTSPPcodes_e.htm（訳注：リンク先がありませ

ん） 

IODE IODE data quality flags. (IODE データ品質フラグ) 参照: 
http://www.iode.org/index.php?op-
tion=com_oe&task=viewDocumentRecord&docID=10762 

OCEANSITES OceanSITES quality flags. (OceanSITES 品質フラグ) 参照: 
http://www.oceansites.org/docs/oceans-ites_user_manual_version1.2.doc 

https://odv.awi.de/fileadmin/user_upload/odv/docs/ODV_quality_flag_sets.pdf
https://odv.awi.de/fileadmin/user_upload/odv/docs/ODV_quality_flag_sets.pdf
https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-manual.pdf
https://nrlgodae1.nrlmry.navy.mil/argo/argo-dm-user-manual.pdf
http://www.bodc.ac.uk/data/codes_and_formats/request_format/
http://www.iode.org/index.php?op-tion=com_oe&task=viewDocumentRecord&docID=10762
http://www.iode.org/index.php?op-tion=com_oe&task=viewDocumentRecord&docID=10762
http://www.oceansites.org/docs/oceans-ites_user_manual_version1.2.doc


ODV User’s Guide 
 

 

ODV ODV generic quality flags. (ODV 一般品質フラグ) 参照: ODV User’s Guide, 
http://odv.awi.de/en/docu-mentation/ 

QARTOD Qartod 品質フラグ quality flags. (Qartod 品質フラグ) 参照: 
https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-
Manual_Final_version1.1.pdf 

PANGAEA PANGAEA generic quality flags. (Qartod 品質フラグ) 参照: 
http://wiki.pangaea.de/wiki/Quality_flag 

SEADATANET SeaDataNet quality codes. (SeaDataNet 品質コード) 参照: 

http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order

=entrykey&all=yes 

SMHI Swedish Meteorological and Hydrographic Institute quality codes. (Swedish 

Meteorological and Hydrographic Institute 品質コード)  

WOCEBOTTLE WOCE bottle value quality codes. (WOCE ボトル値品質コード) 参照: 
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOCECTD WOCE CTD value quality codes. (WOCE CTD 値品質コード) 参照: 
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOCESAMPLE WOCE WHP quality flags for the water bottle itself. (WOCE WHP 採水ボトル自身の品質フ

ラグ) 参照: http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf  

WOD World Ocean Database individual observed level quality codes. (World Ocean Database

個々の観測レベル品質コード) 参照: 
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

WODSTATION World Ocean Database entire station quality flags. (World Ocean Database 測点全体の品

質フラグ) 参照: ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

 

16.3 汎用ＯＤＶスプレッドシートフォーマット（Generic ODV Spreadsheet Format）  
汎用 ODV スプレッドシートフォーマットは、データ作成者とデータユーザーの間でデータを交換するための

推奨フォーマットです。汎用スプレッドシートフォーマットは ODV コレクションへのデータの自動インポー

トが可能で、ユーザーの操作は不要です。ODV はコレクションからデータをエクスポートするときにも汎用

スプレッドシートフォーマットを使用します。出力されたデータセットはファイル内のデータを編集および

変更した後に、同じまたは別のコレクションに簡単に再インポートできます。開いているコレクションから

汎用スプレッドシートファイルへのデータのエクスポートは Export > ODV Spreadsheet オプションを使って行

います。 
 
汎用 ODV スプレッドシートファイルは ASCII エンコーディングを使用しており、推奨されるファイル拡張

子は.txt です。測点のメタデータとデータは別々の列に表示されます。メタデータとデータの列は任意の順序

で並べることができます。全てのメタデータおよびデータ列にはオプションの品質フラグ列があります。品

質フラグ列は、それが属するメタデータまたはデータ列の後のどこにでも表示できます。品質フラグ値はサ

ポートされている品質フラグスキームのいずれかになります（表 16-1 を参照）。ファイル内の列の総数は

http://odv.awi.de/en/docu-mentation/
https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-Manual_Final_version1.1.pdf
https://cdn.ioos.noaa.gov/media/2017/12/QARTOD-Data-Flags-Manual_Final_version1.1.pdf
http://wiki.pangaea.de/wiki/Quality_flag
http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order=entrykey&all=yes
http://seadatanet.maris2.nl/v_bodc_vocab/browse_export.asp?l=L201&order=entrykey&all=yes
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
http://cchdo.ucsd.edu/WHP_Exchange_Description.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf
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無制限です。ファイル内のコメント以外の行（下記参照）は全て同じ列数を持たなければなりません。個々

の列は TAB またはセミコロンで区切ります。 
 
通常、ODV スプレッドシートファイルは多くの航海からの多くの測点のデータを保持しています。ファイル

内の行数、および個々の行の長さは無制限です。汎用 ODV スプレッドシートファイルには（1）コメント行、

（2）列ラベル行、（3）データ行の三種類の行があります。 
 

16.3.1 コメント行（Comment Lines） 
コメント行は、行の最初の二文字として二つのスラッシュ//で始まり、自由形式の任意のテキストを含むこ

とができます。コメント行は原則としてファイル内のどこにでも置くことができますが、最も一般的にはフ

ァイルの先頭に配置され、データの説明、発信者に関する情報、またはファイルに含まれる変数の定義を含

みます。コメント行はオプションです。 
 
コメント行は ODV または他のソフトウェアによって利用される可能性のある構造化された情報を伝えるため

に使用されることがあります。例は、公式のパラメータ辞書内の変数定義への参照を含む SeaDataNet プロ

ジェクトで使用される//SDN_parameter_mapping ブロック、または特定の属性名の値を含む ODV で定義され

た//<attribute_name>行です。現在定義されている属性名は表 16-2 にまとめられています。//<History>を除

く全ての構造化コメント行は列ラベル行と最初のデータ行の前のファイルの先頭になければなりません。

//<History>のコメント行には与えられた測点の履歴情報が含まれています。それらは、それらが属する測点

の最後のデータ行の後かつ次の測点の最初のデータ行の前に現れます。 
 
//<MetaVariable>および//<DataVariable>コメント行にはファイル内のメタデータおよびデータ変数の仕様が

含まれています。これらの行はオプションです。もしあれば、値は以下のタグに関して与えられます：label, 

value_type, qf_schema, significant_digits, および comment. //<MetaVariable>コメント行にも var_type タグを含め

ることができます。//<DataVariable>コメント行には is_primary_variable タグも含めることができます。label

タグ以外の全てのタグはオプションです。タグ値は二重引用符で囲む必要があります。label 値はファイル内

の列ラベルの一つの名前および単位の部分と一致している必要があり、value_type は BYTE、SIGNED_BYTE, 

SHORT, UNSIGNED_SHORT, INSIGNED_INTEGER FLOAT, DOUBLE, TEXT:nn (nn はテキストのバイ

ト長) または INDEXED_TEXT のいずれかでなければなりません。qf_schema は ARGO, BODC, ESEAS, 

GTSPP, IODE, OCEANSITES, ODV, QARTOD, PANGEA, SEADATANET, SMHI, WOCEBOTTLE, 

WOCECTD, WOCESAMPLE, WOD または WODSTATION のいずれかでなければなりません。key_variable

は ”Depth in Water Column [m]”, “Pressure in Water Column [db]”, “Temperature [degC]”, 

“Practical Salinity [psu]”または Collection>Identify Key Variables で得られる Identify Key Variables ダイアログ

の Key Variables リストのラベルの中の一つでなければなりません。 
 

Suzuki Toru
Time out
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Var_type タ グ が //<MetaVariable> コ メ ン ト 行 に 存 在 す る 場 合 、 値 は METABASIC, METACRUISE, 

METASTATION, METATYPE, METALONGITUDE, METALATITUDE, METADAY, METAMINUTE, 

METAMONTH, METAHOUR, METAYEAR, METASECOND, METABOTDEPTH, METALOCALCDIID, 

METAEDMOCODE,  METASENSORDEPTH, METADURATION, METAEXTRACRUISEINFO, 

METAORIGCRUISE,  METAORIGSTATION, METAINVESTIGATOR, METAGTSPPDATATYPE, 

METACOMMENTSLINK,  METACRUISEREPORTLINK, METAREFERENCE, METASDNINSTRUMENTINFO

のいずれかでなければなりません。is_primary_variable は主要データ変数の場合は”T”、その他全ての変数の

場合は”F”に設定されます。//<MetaVariable>および//<DataVariable>コメント行の例を以下の表に示します。

Export > Data > ODV Spreadsheet File で作成された全ての ODV スプレッドシートファイルには、全てのメタ

データとデータ変数のためのそのような行が含まれています。 
 

表 16-2：ODVでサポートされているコメント行の属性名のまとめ 
Attribute Name  Possible Values  
File information 
Creator ファイルの作成者を指定するフリーテキスト。 

例：//<Creator>rschlitz@GSYSP168</Creator> 
CreateTime ISO 8601 拡張フォーマットでのファイル作成時刻。 

例：//<CreateTime>2008-05-16T09:53:45.2</CreateTime> 
Encoding ファイルで使用されているエンコーディング。有効なエントリは UTF-8, ISO-

8859-1, latin 1, windows-1258, MacRoman, macintosh です。注：もしこ

の行が無ければ ODV はエンドユーザのコンピュータ・ロケールで定義された

コーデックを使用します。 

例：//<Encoding>UTF-8</Encoding> 
MissingValueIndicators ファイル内の欠損値インジケータのリスト。複数のエントリはスペースで区切

ります。 
例：//<MissingValueIndicators>-9 -99.9 -9999</MissingValueIndicators> 

Software ファイルの作成に使用されたソフトウェア。 

例：//<Software>Ocean Data View - Version 4.7.7</Software> 
Source ソースコレクションの絶対パス。 

例：//<Source>C:/eWOCE/data/whp/bottle/WoceBtl</Source> 
SourceLastModified ISO 8601 拡張フォーマットでのソースコレクションの最終更新日時。 

例：//<SourceLastModified>2003-11-11T19:53:45.2</SourceLastModified> 

Version ファイルのバージョン。 

例：//<Version>ODV Spreadsheet V4.6</Version> 
Data information 
DataField ファイル内のデータフィールドの説明。 有効なエントリは次の通り：

Suzuki Toru
リンク先がありません。
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GeneralField, Ocean, Atmosphere, Land, IceSheet, SeaIce, Sediment 

例：//<DataField>Ocean</DataField> 
DataType ファイル内のデータの種類の説明。 有効なエントリ：GeneralType, Profiles, 

TimeSeries, Trajectories 

例：//<DataType>Profiles</DataType> 
Description 自由テキストによるデータコレクションの説明。 

例：//<Description>Data from the South Atlantic Ventilation Experiment 

(1987-1989)</Description> 
History 指定された測点の履歴記録。 履歴記録は測点の最後のデータ行の後に配置する

必要があります。 

例：//<History>2015-10-09T09:28:18 xxx@yyy IMPORT (ADD) from 

D:/data/ARK-XXVII-1_cnv_seabird/d003-01.cnv (last modified: 
2015-10-08T13:21:45; byte size: 524146427 MD5: 
9c567f786c781d78865ecb589afd2bd8)</History> 

Metadata- and data variable information 
MetaVariable ファイルに含まれるメタ変数の説明（上記の詳細を参照）。 

例：//<MetaVariable>label="Cruise Report" 

value_type="INDEXED_TEXT" qf_schema="ODV" significant_digits="0" 
comment=""</MetaVariable> 

DataVariable ファイルに含まれるデータ変数の説明（上記の詳細を参照）。 

例：//<DataVariable>label="SALNTY [pss-78]" value_type="FLOAT" 

qf_schema="ODV" significant_digits="3" is_primary_variable="F" 
com-ment="Practical salinity from bottle sample"</DataVariable> 

 

16.3.2 列ラベル（Column Labels） 
列のラベルを含む一行は必須です。この列ラベル行は常に存在していて、データ行の前に置かれていて、か

つファイルの最初のコメント以外の行である必要があります。 

 

汎用 ODV スプレッドシートファイルは、全ての必須メタ変数の列を提供し（表 3-3 を参照）、列ラベルと

して次のラベルを使用する必要があります：Cruise, Station, Type. サポートされている日付/時刻形式の一つ、

Longitude[degree_east], Latitude[degrees_north], Bot. Depth [m]. 経度と緯度の値は十進角で指定する必要があり

ます。推奨される日付/時刻形式は ISO 8601 で、これは日付と時刻を yyyy-mm-ddThh:mm:ss.sss として一列

にまとめたものです。 
 
経度と緯度の値は、全てのスペックが一つ以上のスペースで区切られて一列に表示されていれば、度、分、

秒（秒はオプション）として代わりに指定することもできます。サポートされているフォーマットには“32 

18 23.1 N”, ”32 18.756 N”, ”32° 18' 23.1'' N”, または”32°18'23.1''N”があります。 度数(°)を使用すると

Latin 1 以外のファイルエンコードで問題が発生する可能性があることに注意してください。経度と緯度を度、
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分、秒で指定する場合は列ヘッダーに Latitude [deg min]と Longitude [deg min]を使用する必要があります。十

進角の経度と緯度のラベル Lon（°E）と Lat（°N）は推奨されませんが、下位互換性のために引き続きサポー

トされています。 
 
注：以下に説明するメタデータ列およびデータ列のラベル修飾子は非推奨です。代わりにメタデータとデー

タ変数のプロパティを指定するために//<MetaVariable>と//<DataVariable>のコメント行を使用してください

（上記参照）。 

 

メタデータ列ラベル（Metadata column labels） 

メタデータラベルには、が指定された値型およびバイト長のメタ変数を表す 
:METAVAR:<valueType>:<valueBytes> 

形式の修飾子があります。valueType は次のいずれかです：BYTE, SIGNED_BYTE, SHORT, UNSIGNED_SHORT, 

INTEGER, UNSIGNED_INTEGER, FLOAT, DOUBLE, TEXT または INDEXED_TEXT. valueBytes は値ごとのバイト数

を表し valueType=TEXT の場合にのみ指定する必要があります。valueBytes 値は、テキストフィールドに格納

される最大文字数を表します（デフォルトの長さ：21 バイト）。文字の一つは文字列の終了に使用され、実

際のメタデータテキストには使用できないことに注意してください。例えば 21 バイトの TEXT フィールド

には最大 20 文字のメタデータテキストを格納できます。INDEXED_TEXT 変数は任意の長さの文字列を格納

できます。文字列が長くて可変長の場合、または同じ文字列が何度も使用される場合は、この値型を使用す

る必要があります。 

例： Longitude[degree_east]:METAVAR:DOUBLE 

Citation:METAVAR:TEXT:81 

URL:METAVAR:INDEXED_TEXT 
 
注：修飾子は、スプレッドシートファイルがコレクション作成用のテンプレートとして使用されている場合、

例えばファイルを ODV にドロップする、File > Open でファイルを開く、または File > New で新規コレクショ

ンを作成するときにファイルをテンプレートとして選択する場合にのみ使用されます。既存のコレクション

にファイルを読み込んでも効果はありません。 
 
データ列ラベル（Data column labels） 

データ変数ラベルには、Depth [m]のように角括弧[]で囲まれた単位指定を含める必要があります。単位のな

い変数は[] units の部分（例：Species Count）を含むべきではありません。 
 
データ変数ラベルは、次の形式の修飾子を持つことができます。 

:PRIMARYVAR:<valueType>:<valueBytes>:<SchemaID> 
 
ここでは、valueType は次のいずれかになります：BYTE, SIGNED_BYTE, SHORT, UNSIGNED_SHORT, 

INTEGER, UNSIGNED_INTEGER, FLOAT, DOUBLE, TEXT, または INDEXED_TEXT. valueBytes 値ごとの
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バイト数を表し、valueType=TEXT の場合、または SchemaID エントリが存在する場合にのみ指定する必要が

あります。TEXT の場合、valueBytes 値はテキストフィールドに格納される最大文字数を表します（デフォル

トの長さ：21 バイト）。文字の一つは文字列の終了に使用され、実際のデータテキストには使用できないこ

とに注意してください。例えば、21 バイトの TEXT フィールドには、最大 20 文字のメタデータテキストを

格納できます。INDEXED_TEXT 変数は任意の長さの文字列を格納できます。文字列が長くて可変長の場合、

または同じ文字列が何度も使用される場合は、この値型を使用する必要があります。 
 
SchemaID は次のいずれかです：ARGO, BODC, ESEAS, GTSPP, IODE, OCEANSITES, ODV, QARTOD, 

PANGAEA, SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, WOCESAMPLE, WOD, ま た は 

WODSTATION. 変数に関連する品質フラグ列（下記参照）がある場合は、品質フラグ列の SchemaID が優先

されます。 
 
この列が主要変数であることを示すために：PRIMARYVAR 修飾子を使用できるのは、1 つの列ラベルだけで

す。 
 
例： Depth[m]:PRIMARYVAR:DOUBLE 

Sample Number:SHORT 

Salinity[psu] 

Phosphate[~$m~#mol/kg]:FLOAT:4:WOCEBOTTLE 

Sediment Type:INDEXED_TEXT:4:SEADATANET 
 
注：スプレッドシートファイルがコレクション作成用のテンプレートとして使用されている場合、例えばフ

ァイルを ODV にドロップする、File > Open でファイルを開く、または File > New で新しいコレクションを

作成するときにファイルをテンプレートとして選択する場合にのみ使用されます。既存のコレクションにフ

ァイルを読み込んでも効果はありません。 
 
データ列は、関連する品質フラグ、データエラー、およびデータ情報列を持つことができます。これらの補

助列は通常、それらが属するデータ列の直後に続きます。 
 
品質フラグ列ラベル（Quality flag column labels） 

品質フラグの列ラベルは、それらが属するメタデータまたはデータ変数、および使用されている特定の品質

フラグスキームを自動的に識別できるように、次の命名規則に従う必要があります。 
 
汎用 ODV スプレッドシート品質フラグラベルは、次のいずれかの形式で指定できます： 

 QV<Text>:<SchemaID>:<ParentColumnLabel> 
 QV<Text>:<SchemaID>:STATION 
 QV<Text>:<SchemaID>:SAMPLE 
 QF 
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<Text>は任意のオプションの文字列、<SchemaID>はサポートされている品質フラグスキーマ識別子の一つで

（表 16-1 を参照）、<ParentColumnLabel>は品質フラグ列が属する変数の列ラベルです。品質フラグラベル

の<Text>, <SchemaID>および<ParentColumnLabel>の部分はオプションです。<SchemaID>項目がない場合は、

品質フラグ値は汎用 ODV 品質フラグであると見なされます。<ParentColumnLabel>部分がない場合は、品質

フラグは品質フラグ列の前の変数に属していると見なされます。<Text>項目が存在する場合は区切り文字`:’

を含めることはできません。<Text>は ODV によって評価または使用されないことにも注意してください。こ

の項目は、この機能を必要とするアプリケーション（例えば、QV1、QV2 など）に固有の列ラベルを与える

ためにのみ含まれています。 
 
<SchemaID> は ARGO, BODC, ESEAS, GTSPP, IODE, OCEANSITES, ODV, QARTOD, PANGEA, 

SEADATANET, SMHI, WOCEBOTTLE, WOCECTD, WOCESAMPLE, WODまたはWODSTATIONのいずれ

かの一つです。品質フラグスキーマの詳細については表16-1を参照してください。 
 
個々のデータ値の品質フラグ値に加えて、ODV は測点全体の一般的な品質測面を記述する測点全体品質フラ

グ（特定の測点に対する単一のフラグ、例えば WOCE 測点全体フラグ）を、そのサンプルに対して行われる

全ての測定の品質に影響を与える可能性があるサンプリング装置に関する問題を示すために使用されるサン

プル品質フラグと同様にサポートします（サンプルごとに一つのフラグ）。全ての測点およびサンプル品質

フラグは列ラベルの<ParentColumnLabel>部分に STATION または SAMPLE という語で示されます。 
 
品質フラグラベルの QV 構文は ODV バージョン 3 以前では認識されません。ODV3 と互換性を保つには品

質フラグ列のラベルとして QF を使用する必要があります。そのような場合、品質フラグ値は汎用 ODV フラ

グであり、それらは品質フラグ列の前の変数に属していると想定されます。 

 

表 16-3：品質フラグの列ラベルの例 

品質フラグ列ラベル  コメント  
QV or QF  左側で最も近いデータ変数の汎用 ODV 品質フラグ。 
QV:SEADATANET  左側で最も近いデータ変数の SeaDataNet 品質フラグ。 

QV:ARGO:Nitrate（硝酸塩） 
[umol/kg]  

ラベル Nitrate [umol/kg]の変数に対するアルゴ品質フラグ。 

QV:ODV:Nitrate [umol/kg]  
or  
QV::Nitrate [umol/kg]  

ラベル Nitrate [umol/kg]の変数に対する汎用 ODV 品質フラグ。 

QV:WOCESAMPLE:SAMPLE  WOCESAMPLE サンプラー品質フラグ。 
QV:WODSTATION:STATION  WODSTATION 測点全体の品質フラグ。 
QV::STATION  測点全体の汎用 ODV 品質フラグ。 
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データエラー列ラベル（Data error column labels）  

全てのデータ列は、それぞれのデータ値の 1-σ または 2-σ不確実性を含む関連データエラー列を持つことが

できます。データエラー列ラベルは、それらが属するデータ変数を自動的に識別できるようにするために、

次の命名規則に従う必要があります： 
 STANDARD_DEV<Text><::ParentColumnLabel>  (for 1-σ uncertainties) 
 2STANDARD_DEV<Text><::ParcentColumnLabel> (for 2-σ uncertainties) 

 
<Text>は任意のオプションの文字列で、<ParentColumnLabel>はデータエラー列が属する変数の列ラベルです。

<Text>と<ParentColumn-Label>の部分はオプションです。 <ParentColumnLabel>部分がない場合は、データエ

ラーはデータエラー列の前のデータ変数に属していると見なされます。<Text>項目が存在する場合は、区切

り文字`:’を含めることはできません。<Text>は ODV によって評価または使用されないことにも注意してく

だ さ い 。 こ の 項 目 は 、 こ の 機 能 を 必 要 と す る ア プ リ ケ ー シ ョ ン （ 例 え ば STANDARD_DEV1, 

STANDARD_DEV2 など）に固有の列ラベルを与えるためにのみ含まれています。 

 

注意：読み込み中に 2-σデータエラーは自動的に 1-σデータエラーに変換されます。ODV コレクションのデ

ータエラーは常に 1-σデータエラーとなります。 

 

表 16-4：データエラー列のラベル例 

データエラー列ラベル コメント 

STANDARD_DEV  左側で最も近いデータ変数の 1-σデータエラー。 

STANDARD_DEV::Nitrate [umol/kg]  ラベル Nitrate [umol/kg]の変数に関する 1-σデータエラー。 

2STANDARD_DEV 左側で最も近いデータ変数の 2-σデータエラー。 

2STANDARD_DEV::Nitrate [umol/kg] ラベル Nitrate [umol/kg]の変数に関する 2-σデータエラー。 

 

データ情報列ラベル（Data info column labels） 

全てのデータ列にはそれぞれのデータ値の情報文書への情報テキストまたは URL を含む関連データ情報列を

含めることができます。データ情報列ラベルは、それらが属するデータ変数を自動的に識別できるようにす

るために、次の命名規則に従う必要があります： 
 INFOS<Text><::ParentColumnLabel>  

 
<Text>は任意のオプションの文字列で、品質フラグラベルの<ParentColumnLabel>部分はオプションです。

<ParentColumnLabel>部分がない場合、データ情報はデータ情報列の前のデータ変数に属していると見なされ

ます。<Text>項目が存在する場合は区切り文字`:’を含めることはできません。<Text>は ODV によって評価

または使用されないことにも注意してください。この項目は、この機能を必要とするアプリケーション（例

えば INFOS1, INFOS2 など）に固有の列ラベルを与えるためにのみ含まれています。 
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表 16-5：データ情報列ラベルの例 

データ情報列ラベル コメント 
INFOS  左側で最も近いデータ変数のデータに関する情報。 
INFOS::Nitrate [umol/kg]  ラベル Nitrate [umol/kg]の変数に関するデータ情報。 
 

重要な注意：列ラベルにはスプレッドシートファイルで使用されている列区切り文字を含めないでください。 

 

16.3.3 データ列 (Data Lines) 
列ラベル行に続くコメント以外の行は全てデータ行と見なされます。全てのデータ行は列ラベル行と同じ列

数を持たなければなりません。各データ行には一つのサンプルのメタデータとデータが含まれています。所

定の測点の全てのサンプルは連続順でなければなりませんが並び替えられている必要はありません。欠測値

は空欄、-1.e10 値、または na（使用不可 (not available）)や NaN（数字ではない (not a number）)
のようなテキスト指示子によって示されることがあります。ファイル内の欠損値インジケータとして-9 や-

9999 などの特殊な値が使用されている場合は、全てのデータ行より前のファイルの先頭近くにおいて

//<MissingValueIndicators>-9 -9999</MissingValueIndicators>形式の属性行で特殊な値を指定する必

要があります。 
 
測点ラベルは測点メタ変数の長さに制限されています（デフォルト：20 文字）。測点ラベルに番号を使用す

ると内部ソートおよび選択機能が強化されるので推奨されます。 
 
測点タイプ Type は単一の文字列です。サンプル数が約 250 未満の測点には B（ボトル採水データなど）を、

サンプル数が 250 を超える測点には C（CTD、XBT など）を使用してください。Type に*を指定すると

ODV が選択します。Bot. Depth の値が使用できない時はこのフィールドを空欄のままにしてください。 
 
測点のメタデータは所定の測点の最初の行に指定する必要があります。測点の残りの行のメタデータフィー

ルドはファイルサイズを縮小するために空のままになることがあります（コンパクトスプレッドシート形

式）。汎用 ODV スプレッドシートファイルは通常、多くの航海からの多くの測点のデータを保存します。次

の測点の最初のサンプルのメタデータとデータは前の測点の最後のサンプルの直後に続きます。測点間に区

切り線はありません。 
 
数値は小数点を示すためにピリオド`.’またはカンマ`,’を使用できます（例えば 2,57 と 2.57 は両方とも有

効な入力です）。入力が二重引用符で囲まれている場合それらは処理の前に自動的に削除されます。 
 
TEXT 型のデータ変数は文字エンコーディングごとに一バイトを使用します。テキスト値が ASCII 文字セッ

ト（コード 0〜126）に厳密に制限されている場合 ODV コレクションはプラットフォームおよび国に依存し

ません。非 ASCII 文字の使用は同じプラットフォーム上の同じ地域内では正常に機能しますが、非 ASCII 文

字は異なるプラットフォームまたは異なる地域では正しく表示されない可能性があります。データコレクシ
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ョンがプラットフォームに依存しないようにするために ASCII のみのテキストを常に使用する必要がありま

す。 
 
テキスト型データ変数の値ごとに格納できる最大バイト数（バイト長）は固定されており、コレクションの

作成時に指定する必要があります。実際に要求されたバイト長はテキスト終了のための追加の 1 バイトを含

まなければなりません。例えばテキスト変数が 40 文字のテキストを格納する場合は 41 バイト必要です。テ

キスト変数のバイト長は 2 より小さくすることはできず、それ以外は任意です。5001 などの大きなバイト

長を選択すると長いテキストに対応できますが、個々のテキスト値は全て指定されたバイト数を占めるので

コレクションファイルも大きくなります。特定のテキスト値が Web サイトの DOI または URL を表す場合、

ODV はその値をクリックすることを許可し、Web ブラウザで DOI または URL を開きます。大量のテキス

トを直接使用する代わりに URL または DOI を使用することを検討してください。 

 

16.4 ODV スプレッドシートでサポートされている日付と時間形式（Supported Date 

and Time Formats in ODV Spreadsheet Files） 
 
ODV は単一列の ISO 8601 日付/時刻フォーマットをサポートしています。これは ODV のインポートおよび

エクスポートファイルで推奨される日付/時刻フォーマットです。さらに ODV は科学界で一般的に使用され

ている多くのカスタムファイルフォーマットの一つで提供されるデータの簡単なインポートを可能にするた

めに、他のさまざまな日付および時刻フォーマットもサポートします。これには日、月、年の値の順序が異

なる場合や、個々の列に日、月、年、時、および分のデータがある場合のような、多くの日付／時刻の仕様

が含まれています。 
 
表 16-6 の列ラベルの使用は ODV による自動日付/時刻識別を可能にするために強く推奨されます（小文字、

大文字、または大/小文字混合）。ODV スプレッドシート出力ファイルのデフォルトの日付/時刻フォーマッ

トは ISO 8601 です。 

 

表 16-6：サポートされている日付フォーマット（列ラベルは大文字、小文字、または大/小文字混合） 

列ラベル  コメント 

yyyy-mm-dd hh:mm 
または 
yyyy-mm-ddThh:mm 
または 
yyyy-mm-ddThh:mm:ss.sss  

ISO8601。ODV 推奨の日付/時刻フォーマット。 日付と時刻を一つの列

にまとめます。 

例: Feb/23/2006 10:23h は 2006-02-23 10:23 または 2006-02-

23T10:23 となります。  
Time [xxx since yyyy-mm-dd]  指定された参照日 yyyy-mm-dd 以降の xxx（日数または年数）の単位の十進

数値としての日時。 

例: Jan/02/2012 12h は Time [days since 2012-01-01] = 1.5 とな
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ります。 
mon/day/yr  
または  
mm/dd/yyyy  

日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 02/23/2006 となります。 

dd/mm/yyyy  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 23/02/2006 となります。 
yyyy/mm/dd  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 2006/02/23 となります。 
mmddyyyy  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 は 02232006 となります。 
ddmmyyyy  日付は、一列に、時間は別に提供されます。 

例：Feb/23/2006 は 23022006 となります。 
yyyymmdd  日付は一列に、時間は別に提供されます。 

例：Feb/23/2006 10:23h は 20060223 10:23 となります。 
year  
month  
day  

個々の列の日付情報（任意の順序） 時間は別に提供されます。 

例：Feb/23/2006 は 2006 02 23 となります。  
 

表 16-7：サポートされている時間フォーマット（列ラベルは大文字、小文字、または大/小文字混合） 

列ラベル  コメント  
hh:mm  時刻は一列で 日付は別に提供されます。 

例：10:23h は 10:23 となります。 

hhmm  時刻は一列で 日付は別に提供されます。 

例：10:23h は 1023 となります。  
hour  
minute  

個々の列の時間情報（任意の順序）。日付は別に提供されます。 

例：10:23h は 10 23 となります。 

 

16.5 注釈内の制御シーケンスと機能  (Control Sequences and Functions in 

Annotations) 
 

表 16-8：ODV 注釈内のフォーマット制御シーケンス 

制御シーケンス 動作 
~$ Symbol フォント（ギリシャ文字）に切り替えます。 
~# 通常のテキストフォントに切り替えます。 
~% パーミル（千分率）記号（‰）を生成します。 
~^ 次の文字を上付き文字として描きます。 
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~_ 次の文字を下付き文字として描きます。 
&#<code>; Unicode 文字<code>を生成します。<code>は十進数（例：169）または

16 進数（例：x00A9）のコードです。 

例：“~$S~＃CO~_ 2 [~$ m~＃mol/kg]”は“ΣCO2 [μmol/kg]”を生成します。“&#x00A9; No Name”を選

択すると、“© No Name”が生成されます。 

 

 

 
図 16-1：ギリシャ語の記号とラテン語の等価語 

 

表 16-9：ODVの注釈で利用可能な自動関数 

機能 置換テキスト 
=collection() 現在のコレクションのフルパス 
=collectionName() 現在のコレクションの名前（拡張子を除く） 
=collectionStationCount() 現在のコレクション内の測点数 
=date() 現在の日付 
=section() 現在のセクション（section）ファイルのフルパス 
=software() ODV ソフトウェア名およびバージョン 
=time() 現在の時刻 
=user() ユーザー名とホスト名 
=validStationCount() 現在測点マップに表示されている測点の数 
=view() 現在のビューファイルのフルパス 
=viewName() 現在のビューファイルの名前（拡張子を除く） 

 

16.6 格子化手法（Gridding Methods） 
ODV では、次の三つの方法：Quick gridding, Weighted-average gridding, DIVA gridding のいずれかを使用して、

不規則な間隔で配置されたオリジナルデータを等間隔または不等間隔の矩形格子（等値線およびグラフィッ

クス表示または格子点値の出力）に投影できます。 
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Quick gridding は速度に最適化された加重平均アルゴリズムで、利用可能なデータに対して一回のループだけ

で全格子点の推定値を計算します。Quick gridding は、他のアルゴリズムでは時間がかかりすぎる場合、例え

ば数百万のデータポイントを含む場合にのみ使用してください。Weighted-average gridding は、より洗練さ

れた加重平均アルゴリズムを使用しており、データ範囲が広く均一である場合には良好な結果が得られます。

Weighted-average gridding はデフォルトの格子化手法です。DIVA gridding は他の方法よりも高度ですが計算

コストは高くなります。DIVA 格子化手法は、出版物や Web ページの最終的なグラフを作成するときには常

に使用してください。注：Isopycnic gridding 機能は DIVA 格子化手法が有効な場合にのみ使用可能です。 
 

16.6.1 加重平均格子化（Weighted-Average Gridding） 
等間隔の矩形格子が使用される Quick gridding とは対照的に、ODV は加重平均または DIVA 格子化が要求さ

れる場合、可変解像度の矩形格子を構築して使用します。この場合、データ密度に応じて X 方向と Y 方向の

格子間隔が変わります。高データ密度を有する領域では高解像度（小さなグリッド間隔）となり、一方で疎

なサンプリングの領域では低解像度の粗い格子が使用されます。海洋観測断面では、データ範囲が通常良好

な上層および境界流域では空間分解能が高く、データ範囲が疎な外洋地域や深層部では粗い分解能の格子と

なります。 

 

格子の構築後、成分の推定値𝑐𝑐𝑖𝑖 = ∑ 𝛼𝛼𝑖𝑖𝑑𝑑𝑖𝑖𝑖𝑖 /∑ 𝛼𝛼𝑖𝑖𝑖𝑖 は、単純な加重平均スキームを使用して全ての格子点(+)で計

算されます。効率上の理由から、格子点からごく近傍のデータ値 di のみが合計の対象となります（下図を参

照）。データと格子点との間の距離が増すにつれて、重み αi は指数関数的に減少します：𝛼𝛼𝑖𝑖 = 𝑒𝑒−𝑟𝑟，ここ

で r =  (∆ 𝑥𝑥 ∕ 𝐿𝐿𝑥𝑥  )² +(∆ 𝑦𝑦 ∕ 𝐿𝐿𝑦𝑦)² ，Lx および Ly はそれぞれＸ方向およびＹ方向にそれぞれ分けた平均の長

さスケール を表します。 

 

図 16-2：格子点（+）でのデータ値（赤い記号）の加重平均。詳細は本文を参照してください。 

 

平均化された長さスケールは領域によって異なり、局所的な格子間隔に比例します。すわなち、小さい平均

長さスケールは小さい格子間隔を有する区域（例えば海洋上層、または境界流領域などの高分解能格子）に

おいて使用され、一方で大きい格子間隔を有する範囲においては大きい平均長さスケールが自動的に適用さ
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れます。空間的に変化する長さスケールのこのアプローチは、データ範囲が密な領域における小規模の特徴

を分解することを可能にし、同時にデータ範囲が疎な他の領域においては滑らかで安定した場を提供します。

Display Options ダイアログでユーザーが指定した長さスケール Lx0 と Ly0 は、それぞれの軸範囲のパーミル

（千分率）あたりで計測され、データカ範囲が最も小さい領域（最も粗いグリッド）を表します。加重平均

アルゴリズムの ODV 実装は、数千のデータポイントを持つフィールドであっても、数秒以内のフィールド推

定を可能にするために速度に関して非常に最適化されています。 
 
全ての格子点について推定値が得られると、そのフィールドはスクリーン上に表示するために陰影付けおよ

び等値線化ルーチンに渡されます。 

 

16.6.2 DIVA 格子化（DIVA Gridding） 
DIVA はリエージュ大学（http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA）で開発された格子化ソフト

ウェアで、ODV に組み込まれている加重平均法よりも優れた点がいくつかあります。DIVA を使用すると最

適補間（OI）に匹敵する最適な方法でデータを分析および補間することができます。OI とは異なり、DIVA

は海岸線と海底地形の特徴も考慮に入れて、推定が行われる領域を構造化して細分化します。計算は特定の

グリッド領域に適応した有限要素メッシュで実行されます。 

 

有限要素メッシュの生成、解析パラメータの最適化、格子化領域の計算に必要な DIVA ツールは ODV インス

トールパッケージに含まれています。DIVA gridding オプションは Properties > Display Style ダイアログ（Z 変

数を持つデータウィンドウ）においてデフォルトで使用可能です。このオプションを選択し、適切な X と Y

の相関長スケールを指定するか、Automatic scale lengths チェックボックスをチェックして DIVA 格子化を有

効にしてください。ODV は DIVA の操作に必要な全てのファイルを自動的に（作業ディレクトリ

<user>/diva/work/ yyyy-mm-ddThh-mm-ss に；ここで<user>は ODV ユーザーディレクトリを、yyyy-mm-

ddThh-mm -ss は個々の ODV インスタンスの起動日付時刻を表します）作成し、DIVA メッシュ生成および領

域推定ステップを実行し、ODV による領域のグラフィカル表示のために DIVA 出力を読み取ります。 
 
他の格子化アルゴリズムと同様に、推定領域の滑らかさはデータウィンドウの Properties ダイアログの

Display Style ページで X と Y の長さスケールを調整することによって制御されます。目盛りの長さの値はそ

れぞれの軸範囲のパーミル（千分率）あたりで、大きい値は滑らかな領域になります。データ S/N 比や格子

化領域の設定方法（下記の Domain Separation を参照）などの他の DIVA パラメータは、データウィンドウの

Properties ダイアログの DIVA 設定ページからアクセスできます。ODV がシャットダウンされると、DIVA

作業ディレクトリとその全ての内容が削除されることに注意してください。 
 
DIVA の専門家は DIVA 設定ファイル<user> /diva/diva.settings を編集して追加の DIVA パラメータを調整で

きます。 

http://modb.oce.ulg.ac.be/mediawiki/index.php/DIVA
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Non-negativity Constraint 
Quick gridding または weighted-averaging gridding などの加重平均法では、常に最小データ値と最大データ値

の間の区間にある推定値が生成されるので、これらの推定値は観測値の範囲を超えることはありません。

DIVA 格子化法はこの点で異なり、データ範囲を超える格子領域値を生成することがあります。特別な場合

として、全てのデータ値が正（またはゼロ）で負にならない領域を期待している場合でも、X/Y 範囲の一部

の領域で負の格子値が発生する可能性があります。負でないことが保証されている変数（例えば化学トレー

サの濃度）を格子化し、DIVA が負の濃度の領域を生成するような場合は、そのような非現実的な値を防ぐ

ために DIVA 設定ページの「負のグリッド値の回避」チェックボックスをチェックしてください。  
 
Domain Separation 
DIVA 格子化は、一般的に疎で不均一なデータ範囲の場合（図 16-3 を参照）、および陸地、海嶺または他の

海底地形の障壁（図 16-4 を参照）によって全く異なるプロパティ値を持つ小地域に分離されている場合に、

Quick gridding または Weighted-aver-age gridding よりも優れた結果をもたらします。一方、Quick gridding や

Weighted-average gridding で使われる加重平均スキームは、障壁を越えて誤った情報を伝えてしいますが、

これは DIVA 格子化では発生しません。 
 
DIVA 範囲分離機能は二種類のデータウィンドウで有効になります：（1）Y 軸に Depth または Pressure があ

り、断面の海底地形が表示されている断面プロット、（2）X 軸と Y 軸にそれぞれ経度と緯度を持ち、Z 変数

としてコレクション変数または等値面変数を持つデータウィンドウ（マップ）。Z 等値面変数の面変数は

Depth または Pressure in Water Column 変数でなければならないことに注意してください（キー変数の関連付

けを参照）。 
 
（1）断面図では、範囲の分離に断面海底地形多角形を使用するか、範囲の分離を使用せずに X/Y ウィンド

ウ範囲全体を単一の範囲として扱うかを選択できます（図 10-5 の DIVA 設定ページを参照）。 
 

 
図 16-3：不均一なデータ範囲を持つフィールドに対する（a）加重平均と（b）DIVA格子化法の比較。 
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（2）マップ内の範囲分離は、格子化海底地形データおよび閾値水深値に基づいています。指定された閾値水

深よりも浅い水深の地域は全てバリアと見なされます。ODV では標準格子上の標高データと閾値水深を含む

適切な海底地形ファイルを選択できます（図 10-5 の DIVA 設定ページを参照）。デフォルトで ODV は

6’×6’でサブサンプリングされたグローバル GEBCO 等深線（ディレクトリの GEBCO1.nc ファイル）を使用し

ます。これは海盆規模または全球地図領域に対して十分な解像度を提供します（図 16-3 および 16-4）。非

常に小さな領域では、デフォルトの等深線ファイルの 6’x6’の解像度では信頼性の高い陸域バリア検出には粗

すぎるため、カスタム等深線ファイルをユーザーが用意する必要があります。新しい 0.5’解像度の

GEBCO_08 海底地形の地域サブセットを含むファイルは、リクエストに応じて配信できます。 
 
カスタム等深線ファイルは netCDF フォーマットでなければならず、それらは<install>/include/GEBCO1.nc と

同じ論理構造を持ち、<install>/include に記録されなければなりません（<install>はあなたの ODV インスト

ールディレクトリを表します）。DIVA にカスタム等深線ファイルを使用するには、ウィンドウの Properties

ダイアログの Domain Selection > Map on the DIVA Settings ページの Domain Selection > Map でファイルを選択

します。 
 
選択した等深線ファイルで特定の領域での解像度が不十分な場合、ODV は領域の分離を自動的にオフにしま

す。 
 
閾値水深には、特定の水深値またはキーワード(automatic)を入力できます。(automtic)が使用され、Z 変数が

Depth または Pressure 等値面で定義された等値面変数である場合、等値面の深度（または圧力）が、閾値水

深として使用されます。このような場合、ODV は深度（または圧力）変数を識別できる必要があります。オ

プション Collection > Identify Key Variables を使用してキー変数 Depth in Water Column [m] （または Pressure in 

Water Column [db])が Depth（または Pressure)変数に関連付けられていることを確認してください。等値面変

数がキーワード first を使用して定義されている場合（例えば XXX @ Depth [m] = first）、1m の自動閾値水深

が使用されます。 
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図 16-4：分離された海域の（a）加重平均と（b）DIVA格子化法の比較。加重平均格子化法のケース（a）

におけるカリブ海の太平洋の値の影響に注意してください。 
 

DIVA の実行時間は他のグリッド方法よりも多少長くなりますが、出版品質の図のために DIVA 格子化の使

用を常に考えるべきです。 

 

System requirements and troubleshooting: DIVAパッケージを正しく動作させるには、最低2GBのRAMを搭載し

たコンピュータが必要です。DIVAを実行してプロットウィンドウが白のままになっている場合は、他のアプ

リケーションを閉じてメモリを解放してからもう一度やり直してみてください。 
 

16.6.3等密度格子化 （Isopycnic Gridding） 
海洋における海水や成分の移動は一定密度の表面（等密度線）に沿って最も効果的であり、直交座標に沿っ

て等密度線が急勾配な領域（フロント領域）で相応しくなく、かつ観測データの大きな誤表示につながる可

能性があります。 
 
例として図 16-5 に 30°N 付近のガルフストリーム地域の東西断面に沿った硝酸塩データを示します。（a）

のオリジナルデータでは σ0=27.725 の等密度線に沿った顕著な硝酸塩極大層が明らかであり、これはこの海

域の沿岸近くで約 300m の深さから沖合では約 1000m まで深くなっています。デカルト格子（ｂ）では、

等密度の全深度範囲にわたって連続硝酸塩極大層を再現することができず、特に約５００ｍ深では沿岸およ

び沖合において低硝酸塩水の影響によって小さすぎる推定値を導き出しています。対照的に等密度格子化で

はこの影響を受けずに、より現実的な分布を生成しています（c）。 
 
等密度格子化は強い潮流や前線がある地域など、等密度線の勾配が急な海域では常に使用する必要があるで

しょう。 

 

 
図 16-5：（a）ガルフストリーム地域の元の硝酸塩データおよび（b）デカルト座標と（c）等密度格子の比

較 
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ウィンドウの Properties ダイアログの Display Style ページにある Isopycnic gridding ボックスをチェックして、

等密度格子化をセクション単位で要求できます（図 10-1 を参照）。このオプションは、中立密度 γn または

ポテンシャル密度派生変数が定義されていて、かつ DIVA 格子化が使用されている場合にのみ有効です。ま

た、中性密度 γn は一部の海域（例えば北極）では利用できないことに注意してください。そのような場合は

代わりにポテンシャル密度変数を使用してください。 
 
海洋観測データが最高品質でない場合 Isopycnic gridding は質の悪い結果を生む可能性があります。このオプ

ションは品質管理されたデータセットにのみ使用し、適切なサンプル品質フィルタを適用してデータの外れ

値を確実に除外してください。等密度格子化に使用される密度変数（定義されている場合はγn、そうでない

場合は最初に定義されたポテンシャル密度偏差変数）の値が深さとともに厳密に単調増加することも重要で

す（基準圧力からかけ離れたポテンシャル密度変数はこの要求を妨げるかもしれません）。常に中立密度γn

を使用することをお勧めします；ただし北極圏では γn は定義されないので σ0 を使用してください。 

 

16.7 ODVディレクトリ構造（ODV Directory Structure） 
ODV のデフォルトのインストールディレクトリは、Windows の場合は c:¥Program Files¥Ocean Data View

（mp）、macOS の場合は/Applications/ODV、Linux および UNIX の場合は/usr/local/ odv です（以降では

<install>と表記）。macOS, Linux では次のパス指定でバックスラッシュ(訳注：日本語キーボードでは円記

号(\))をスラッシュ(/)に置き換えてください。インストールディレクトリには特定の目的に必要なファイル

を含むさまざまなサブディレクトリがあります。マクロファイル、パレットファイル、サンプルデータコレ

クションなど、ユーザーによって変更される可能性のあるインストールファイルはユーザーのドキュメント

ディレクトリの下のサブディレクトリ ODV にインストールされます（以降では<user>と表記）。 

 

下記はODVによって使用されるディレクトリのリストです： 
 
<install>\bin_w64   Windowsプラットフォームの場合 

<install>\bin_macx  macOSプラットフォームの場合 

<install>\bin_linux-i386  Linux i386プラットフォームの場合 
 
<install>\coast\GlobHR 

全球の中解像度海岸線および海底地形ファイル 
 
<install>\doc 

ODV HTMLヘルプファイル（ODV Webページから入手可能なPDFバージョン） 
 
<install>\include 

ＯＤＶインクルードファイルのデフォルトディレクトリ（例えばGEBCO1全球海底地形）。特定の

ファイルを含むサブディレクトリがいくつかあることに注意してください。 
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<install>\include\atmhist 

各種微量ガスの大気中濃度の変移 
 
<install>\samples 

ODVサンプルファイルのディレクトリ。これらのファイルをデータ読み込みまたはマクロファイル

のテンプレートとして使用します。 
 
<user>\cmd_files 

ODVコマンドファイル（.cmd） 
 
<user>\data 

ODVデータコレクションのベースディレクトリ。ODVデータコレクションは原則として読み書き可

能（ハードディスク、メモリースティックなど）または読み取り専用（DVD、CD-ROMなど）の記

憶媒体上のどこにでも置くことができますが、全てのコレクションをこのディレクトリの下に管理

することをお勧めします。全てのコレクションはそれ自身のサブディレクトリに格納してください。 
 
<user>\diva 

DIVA作業ディレクトリ（DIVAが使用されている場合にのみ存在） 
 
<user>\export 

Export > Window Dataでエクスポートしたデータセットのベースディレクトリ 
 
<user>\gazetteers 

ODV地名辞典データベースファイル 
 
<user>\macros 
 ODVマクロファイル（.mac） 
 
<user>\palettes 

ODVパレットファイル（.pal） 
 
<user>\reference 

Export > Window Data as Reference を通してエクスポートした参照データセットのベースディレクト

リ 

 


	1 概要（General Overview）
	1.1 使いやすさ（Ease of Use）
	1.2 高密度データフォーマット（Dense Data Format）
	1.3 拡張性 (Extensibility)
	1.4 派生変数（Derived Variables）
	1.5 プロットの種類 (Plot Types)
	1.6 ウィンドウスコープ（Window Scopes）
	1.6.1 STATIONスコープ（STATION Scope）
	1.6.2 SCATTERスコープ（SCATTER Scope）
	1.6.3 SECTIONスコープ（SECTION Scope）
	1.6.4 SURFACEスコープ（SURFACE Scope）

	1.7 グラフィックスの出力（Graphics Output）
	1.8 データ統計（Data Statistics）
	1.9 推定と平均化（Estimation and Averaging）
	1.10 NetCDF サポート（NetCDF Support）

	2 ファースト・ステップ（First Steps）
	2.1 Ocean Data Viewのインストール（Installing Ocean Data View）
	2.2 Ocean Data Viewの起動（Running Ocean Data View）
	2.3 ヘルプの取得（Getting Help）
	2.4 アプリケーションウィンドウ（Application Window）
	2.5 メニューバー（Menu Bar）
	2.6 ビューバー（Views Bar）
	2.7 メタデータとデータリスト・ウィンドウ（Metadata and Data List Windows）
	2.8 グラフィックスキャンバス（Graphics Canvas）
	2.9 ポップアップメニュー（Popup Menus）
	2.10 ステータスバー（Status Bar）
	2.11 現在の測点とサンプル（Current Station and Sample）
	2.12 マップおよびデータウィンドウの描画（Map and Data Window Drawing）
	2.13 設定（Settings）

	3　ODVコレクション（ODV Collections）
	3.1 データモデル（Data Model）
	3.1.1 メタ変数（Meta-Variables）
	3.1.2 データ変数（Data Variables）

	3.2 コレクションタイプの例（Example Collection Types）
	3.2.1 プロファイルデータ（Profile Data）
	3.2.2 時系列データ (Time Series Data)
	3.2.3 軌跡データ（Trajectory Data）

	3.3 コレクションの作成（Creating Collections）
	3.3.1 テンプレートとしてファイルを使用（Using a File as Template）
	3.3.2 マニュアル入力（Manual Entry）
	3.3.3 既定テンプレートの使用（Using a Pre-defined Template）

	3.4 コレクションファイル（Collection Files）
	3.4.1 ODVCF6 and ODVCF5
	3.4.2 ODVGENERIC

	3.5 プラットフォーム非依存（Platform Independence）

	4 データのインポート（Importing Data）
	4.1 ODV スプレッドシートファイル（ODV Spreadsheet Files）
	4.2 SDNスプレッドシートおよびnetCDFファイル（SDN Spreadsheet and netCDF Files）
	4.3 World Ocean Databaseデータ（World Ocean Database Data）
	4.4 Argoフロートデータ（Argo Float Data）
	4.5 CORA水温・塩分データ（CORA Temperature and Salinity Data）
	4.6 GTSPP – (全球水温・塩分プロファイルプログラム/Global Temperature-Salinity Profile Program）
	4.7 GOSUD – (全球海洋表層航走データ/Global Temperature-Salinity Underway Data)
	4.8 WOCE海洋観測データ (WOCE Hydrographic Data)
	4.9 Medatlasフォーマット・データ（Medatlas Format Data）
	4.10 MEOP 海洋哺乳類データ（MEOP Marine Mammals Data）
	4.11 Sea-Bird CNV ファイル（Sea-Bird CNV Files）
	4.12 Associate Meta-variablesダイアログ（Associate Meta-variables Dialog）
	4.13 インポートオプションダイアログ （Import Options Dialog）
	4.14 ファイルリストの生成（Generating File Lists）

	5 データのエクスポート（Exporting Data）
	5.1 スプレッドシートファイル（Spreadsheet Files）
	5.2 NetCDFファイル　(NetCDF Files)
	5.3 WHP 交換フォーマットでのエクスポート (WHP Exchange Format Export)
	5.4 SDN集約ODVコレクション (SDN Aggregated ODV Collection)
	5.5 SDN整合ODVコレクション（SDN Harmonized ODV Collection）
	5.6データおよび格子場のクリップボードへのコピー（Clipboard Copy of Data and Gridded Field Values）
	5.7 等値面データのエクスポート (Exporting Isosurface Data)
	5.8 ウィンドウデータのエクスポート（Exporting Window Data）
	5.9 参照データセットのエクスポート（Exporting Reference Datasets）

	6 派生変数 (Derived Variables)
	6.1 組み込み派生変数 (Built-in Derived Variables)
	6.2 マクロ（Macros）
	6.2.1 マクロ編集（Macro Editor）

	6.3 式 (Expressions)
	6.4 差分変数（Difference Variables）
	6.5 パッチ（Patches）

	7 等値面変数 (Isosurface Variables)
	7.1 等値面変数描画（Drawing Isosurface Variables）

	8 選択基準（Selection Criteria）
	8.1 測点フィルタ（Station Filter）
	8.2 サンプルフィルタ（Sample Filter）

	9 測点図（Station Map）
	9.1 マッププロパティー（Map Properties）
	9.2 選択された測点（Picked Stations）
	9.3 断面（Sections）
	9.4 測点分布（Station Distributions）
	9.5 経度符号と値の規約 （Longitude Sign and Value Conventions）

	10 データウィンドウ（Data Windows）
	10.1 データウィンドウプロパティ（Data Window Properties）
	10.2 ズーミングと自動計測　(Zooming and Automatic Scaling)
	10.3 Zズーミング (Z-Zooming)
	10.4 ウィンドウレイアウトの変更（Changing Window Layout）
	10.5 グラフィックス出力（Graphics Output）
	ポストスクリプトファイル (PostScript Files)
	画面全体または個々のデータウィンドウまたはマップのEncapsulated PostScript.epsファイルを作成するには、キャンバスまたはそれぞれのデータウィンドウまたはマップ上で右クリックしてSave Canvas As、Save Plot AsまたはSave Map Asを選択してください（もしくはマウスがキャンバス、データウィンドウ、またはマップ上にあるときにはCtrl-Sを押してもできます）。ファイルタイプでPostScript（* .eps）を選択し、出力ファイルの名前と保存先を指...
	10.6 データ統計（Data Statistics）
	10.7 等密度線（Isopycnals）
	10.8 フィールドチェックを使用した範囲外値の検出（Finding Outliers using Field Checks）

	11 グラフィックスオブジェクト（Graphics Objects）
	11.1 注釈（Annotations）
	11.2 直線、連続直線とポリゴン（Lines, Polylines and Polygons）
	11.3 矩形と楕円 (Rectangles and Ellipses)
	11.4 記号 （Symbols）
	11.5 記号セットと凡例 (Symbol Sets and Legends)
	11.6 ファイルからのグラフィックスオブジェクト（Graphics Objects from Files）
	11.7 グラフィックスオブジェクトの管理（Managing Graphics Objects）

	12 コレクションの操作（Working with Collections）
	12.1 コレクションのコピー、パッケージング、名前の変更、削除　（Copying, Packaging, Renaming and Deleting Collections）
	12.2 並び替えと圧縮（Sorting and Condensing）
	12.3 測点の削除（Deleting Stations）
	12.4 コレクションプロパティの変更（Changing Collection Properties）
	12.5 キー変数の関連付け（Key Variable Associations）
	12.6 有効範囲の基準（Good Coverage Criteria）
	12.7 コレクション情報の閲覧（Browsing Collection Information）
	12.8 変数のプロパティ（Properties of Variables）
	12.9 データの編集（Editing Data）
	12.10 パスワードプロテクション（Password Protection）

	13 NetCDFファイルの操作 (Working with NetCDF Files)
	13.1 NetCDF サポート（NetCDF Support）
	13.2 NetCDF セットアップ（NetCDF Setup）

	14 ツール（Tools）
	14.1 地衡流（Geostrophic Flows）
	14.2 二次元推定（2D Estimation）
	14.3 三次元推定（3D Estimation）
	14.4 ボックス平均 (Box Averaging)
	14.5 異常値の検出（Finding Outliers）
	14.6 重複測点の検出および処理（Finding and Processing Duplicate Stations）
	14.7 海洋計算機（Ocean Calculator）

	15 雑録（Miscellanea）
	15.1 ドラッグ＆ドロップ（Drag-and-Drop）
	15.2 ODVコマンドファイル（ODV Command Files）
	15.3 カラーパレット (Color Palettes)
	15.4 アニメーション（Animations）
	15.5 海底地形の地名辞典（Gazetteer of Undersea Features）

	16 付録（Appendix）
	16.1マウス動作とショートカットキー (Mouse Actions and Shortcut Keys)
	16.2 品質フラグスキーム (Quality Flag Schemes)
	16.3 汎用ＯＤＶスプレッドシートフォーマット（Generic ODV Spreadsheet Format）
	16.3.1 コメント行（Comment Lines）
	16.3.2 列ラベル（Column Labels）
	16.3.3 データ列 (Data Lines)

	16.4 ODVスプレッドシートでサポートされている日付と時間形式（Supported Date and Time Formats in ODV Spreadsheet Files）
	16.5 注釈内の制御シーケンスと機能 (Control Sequences and Functions in Annotations)
	16.6 格子化手法（Gridding Methods）
	16.6.1 加重平均格子化（Weighted-Average Gridding）
	16.6.2 DIVA 格子化（DIVA Gridding）
	16.6.3等密度格子化 （Isopycnic Gridding）

	16.7 ODVディレクトリ構造（ODV Directory Structure）


